Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Bosnian/Croatian/Slovenian letters
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Languages
View previous topic :: View next topic  
Author Message
castra
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2003
Posts: 86

PostPosted: Mon Sep 15, 2003 3:46 pm    Post subject: Bosnian/Croatian/Slovenian letters Reply with quote

Hi
Was asking the same question to gentoo users that can speak/read
bosnian/croatian/slovenian but didn't get any answer and I hope I'll get
one koz am writing in english now :)

Here my problem: I can write and use bosnian/croatian/slovenian letter
like : č枚đ but when I open documents that where writen in one of these
languages I get question marks ( or some odd letters ) instead of these
letters ( see above ).
Any ideas why and how to fix this ?

Thanks
Back to top
View user's profile Send private message
steveb
Advocate
Advocate


Joined: 18 Sep 2002
Posts: 4564

PostPosted: Mon Sep 15, 2003 4:02 pm    Post subject: Reply with quote

hi castra

i can speak/read in bosnian/croatian/serbian/sloenian, but to be honest, i never use my native mother language to write ;)

anyway... where do you write those letters? openoffice.org? email client? browser? etc?

maybe you need to set the language setting to that specific language or maybe you need to use an application wich is able to write and display unicode fonts?

cheers

SteveB (znam! to nije bas naso ime, ali moje pravo ime je Stevan, ali svi me zovu Steve)
Back to top
View user's profile Send private message
my_nick
n00b
n00b


Joined: 07 Jul 2003
Posts: 28
Location: Slovenia

PostPosted: Mon Sep 15, 2003 5:00 pm    Post subject: Reply with quote

Try to change the encoding
ISO 8859-2
CP-1250
UTF-8 (I think)

I think one of these should work :)
Back to top
View user's profile Send private message
castra
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2003
Posts: 86

PostPosted: Mon Sep 15, 2003 5:58 pm    Post subject: Reply with quote

To my_nick:
Change encoding ?? Where... cos changing in KDE control center
didn't help and in apps that I use. Tryed with "bs" in /etc/cr.conf and
no go ! Damn ... Same for XF86config !

To steveB:
Tryed with Kwrite "nope" but as I said when I save docs all those
letters are again changed to question marks or some very odd signs.
Email client are complaining too...if I use these letters I get msg that says:
Some letters could not be saved and if you save them you'll gona lose them.
Thunderbird is the name of the email client! No problems with browser though ! Any other suggestions
Back to top
View user's profile Send private message
norvalk
n00b
n00b


Joined: 21 Feb 2003
Posts: 49
Location: Ljubljana, Slovenia

PostPosted: Fri Sep 19, 2003 11:46 am    Post subject: Reply with quote

if you can read slovenian, maybe you could try this (whole topic):

https://forums.gentoo.org/viewtopic.php?t=50416

or direct link (to my post):

https://forums.gentoo.org/viewtopic.php?t=50416&start=7

cheers
Back to top
View user's profile Send private message
castra
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2003
Posts: 86

PostPosted: Sat Sep 20, 2003 8:04 am    Post subject: Reply with quote

I can understand slovenian ..no problem...
I did all that was explaind on that link but still in kde I cant save
text writen in my language. Does it have to do with that I installed
KDE while I had ( KEYMAP="no-latin1" and CONSOLEFONT="lat0-16" )in rc.conf?? Damn ...this is pis... me off ! :evil:
Back to top
View user's profile Send private message
norvalk
n00b
n00b


Joined: 21 Feb 2003
Posts: 49
Location: Ljubljana, Slovenia

PostPosted: Sat Sep 20, 2003 12:35 pm    Post subject: Reply with quote

damn indeed! i can imagine myself being in the same situation... and being pis*** off about it as well! :wink:

ok - let's try to eliminate this annoyance throuh step-by-step procedure...

first - if i got this environmental variables stuff right - "KEYMAP=" and "CONSOLEFONT=" in /etc/rc.config don't affect x11 in any way. they are both terminal console settings only.

so, this leaves us with setting right the /etc/profile and the /etc/X11/XF86Config. to my knowledge these should be only ones concerning x11 (font) localisation.

could you paste both of them here?

also, which fonts are you using in kde - mine works fine with bistream vera sans (part of media-fonts/ttf-bitstream-vera package) and ms arial (part of media-fonts/corefonts package) font families. which version of xfree are you using - i remember having similar problems (but with keyboard) with one of pre 4.3 versions...
Back to top
View user's profile Send private message
norvalk
n00b
n00b


Joined: 21 Feb 2003
Posts: 49
Location: Ljubljana, Slovenia

PostPosted: Sat Sep 20, 2003 12:43 pm    Post subject: Reply with quote

oh, and...

ps: as already stated, i don't beleive that this problem you are experiencing has anything to do with "wrong" settings in /etc/rc.config while emerging kde.

pps: as a side note, i'm using nls USE flag in my /etc/make.conf - what's in yours?

ppps: maybe you are using /etc/env.d/02language, which could conflict with settings in /etc/profile?
Back to top
View user's profile Send private message
castra
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2003
Posts: 86

PostPosted: Sun Sep 21, 2003 11:02 am    Post subject: Reply with quote

I USE="X -gtk kde cups alsa qt tcpd pam ssl "

Second not using /etc/env.d/02language and think there is no conflic between them.

/etc/X11/XF86Config
Quote:
Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "si"
#Option "XkbLayout" "no"


/etc/profile
Quote:
# /etc/profile:
# $Header: /home/cvsroot/gentoo-src/rc-scripts/etc/profile,v 1.15 2002/11/18 19:39:22 azarah Exp $

if [ -e "/etc/profile.env" ]
then
source /etc/profile.env
fi

#077 would be more secure, but 022 is generally quite realistic
umask 022

if [ `/usr/bin/whoami` = 'root' ]
then
if [ "$SHELL" = '/bin/bash' ] || [ "$SHELL" = '/bin/sh' ]
then
export PS1='\[\033[01;31m\]\h \[\033[01;34m\]\W \$ \[\033[00m\]'
fi
export PATH="/bin:/sbin:/usr/bin:/usr/sbin:${ROOTPATH}"
else
if [ "$SHELL" = '/bin/bash' ] || [ "$SHELL" = '/bin/sh' ]
then
export PS1='\[\033[01;32m\]\u@\h \[\033[01;34m\]\W \$ \[\033[00m\]'
fi
export PATH="/bin:/usr/bin:${PATH}"
fi
unset ROOTPATH

if [ -z "$INPUTRC" -a ! -f "$HOME/.inputrc" ]; then
export INPUTRC="/etc/inputrc"
fi

export ROOT_USES_LANG="en_US"
#export LANGUAGE="sl_SI"
export LANG="sl_SI"
#export LC_ALL="sl_SI"
export LC_CTYPE="sl_SI"


And am using verdana fonts

But the real thing that blowes my mind is that I can use
native letters in console, but again if I use nano NO WAY .... :roll:
Back to top
View user's profile Send private message
norvalk
n00b
n00b


Joined: 21 Feb 2003
Posts: 49
Location: Ljubljana, Slovenia

PostPosted: Mon Sep 22, 2003 11:21 am    Post subject: Reply with quote

i'll dive more into this tomorrow, after exams...

... just to let you know that i am not ignoring you or something. :wink:

ps: in the meantime, could you also post your version of xfree?
Back to top
View user's profile Send private message
norvalk
n00b
n00b


Joined: 21 Feb 2003
Posts: 49
Location: Ljubljana, Slovenia

PostPosted: Mon Sep 22, 2003 11:34 am    Post subject: Reply with quote

just a though - could it be a kernel thing?

try compiling (as modules) codepage 437/852, windows 1250 support, nls utf8 and (most importantly?) nls iso 8859-2 & 1 - all of which you'll find under file systems | native language support...

set utf8 as default nls option.

from what you say, it seems like characters get lost at a time of saving, which could be an issue with underlying file system - or am i totaly off base here (please, somebody correct me!)?
Back to top
View user's profile Send private message
castra
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2003
Posts: 86

PostPosted: Mon Sep 22, 2003 2:05 pm    Post subject: Reply with quote

I didn't choose native language support at all ....all though norwegan works
just fine ( I speak that language too :lol: ) with out it.
Xfree is 4.3.0-r2 version

And there is no hurry ....we have ( at least I have ) time..

Thanks for the help and tips so far !
Back to top
View user's profile Send private message
norvalk
n00b
n00b


Joined: 21 Feb 2003
Posts: 49
Location: Ljubljana, Slovenia

PostPosted: Tue Oct 21, 2003 10:25 am    Post subject: Reply with quote

aw! i almost forgot about this thread completely - castra im very sorry! please do accept my apology! :oops:

did you suceed in your quest to get ce letters working?
Back to top
View user's profile Send private message
castra
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2003
Posts: 86

PostPosted: Thu Oct 30, 2003 2:45 pm    Post subject: Reply with quote

I lost every hope ....lol just kidding...

Nope same problem...am gona add stuff in kernel today and let you know
how that went. ( been busy )

Thanks for remmebring

PS
I hope that you passed exames ;)
Back to top
View user's profile Send private message
castra
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2003
Posts: 86

PostPosted: Wed Dec 31, 2003 6:46 pm    Post subject: Reply with quote

Its has been a while since I promissed to write what happend.
Well here it is. NO WAY. It just don't work. Why ? I have no idea why !
I can use "our" letters in consol but the minute I change to nano or what
ever text editor I get eather ????? or some other ODD letters.
I even switched to 2.6 kernel in hope that this would be fixed but NO.
I can use our letters in browser but thats it.
Thanks

Castra using:
kernel 2.6 stable
fluxbox as window manager
nano as main text editor
Back to top
View user's profile Send private message
norvalk
n00b
n00b


Joined: 21 Feb 2003
Posts: 49
Location: Ljubljana, Slovenia

PostPosted: Fri Feb 06, 2004 2:30 am    Post subject: Reply with quote

please try adding "nls" as your USE flag in /etc/make.conf and re-emerging nano.

also (as an additional mesure), try complinig your kernel with nls support as suggested in one of my previous posts.
Back to top
View user's profile Send private message
castra
Tux's lil' helper
Tux's lil' helper


Joined: 12 Aug 2003
Posts: 86

PostPosted: Fri Feb 06, 2004 12:09 pm    Post subject: Reply with quote

Hello again....

I switched back to 2.4.24 coz 2.6 had some wierd alsa issues...

I added nls to my make.conf and Iæm gona paste what I have in kernel regarding nativ language support
Quote:

# Native Language Support
#
CONFIG_NLS_DEFAULT="iso8859-1"
CONFIG_NLS_CODEPAGE_437=y
CONFIG_NLS_CODEPAGE_737=y
# CONFIG_NLS_CODEPAGE_775 is not set
# CONFIG_NLS_CODEPAGE_850 is not set
CONFIG_NLS_CODEPAGE_852=y
# CONFIG_NLS_CODEPAGE_855 is not set
# CONFIG_NLS_CODEPAGE_857 is not set
# CONFIG_NLS_CODEPAGE_860 is not set
# CONFIG_NLS_CODEPAGE_861 is not set
# CONFIG_NLS_CODEPAGE_862 is not set
# CONFIG_NLS_CODEPAGE_863 is not set
# CONFIG_NLS_CODEPAGE_864 is not set
CONFIG_NLS_CODEPAGE_865=y
# CONFIG_NLS_CODEPAGE_866 is not set
# CONFIG_NLS_CODEPAGE_869 is not set
# CONFIG_NLS_CODEPAGE_936 is not set
# CONFIG_NLS_CODEPAGE_950 is not set
# CONFIG_NLS_CODEPAGE_932 is not set
# CONFIG_NLS_CODEPAGE_949 is not set
# CONFIG_NLS_CODEPAGE_874 is not set
# CONFIG_NLS_ISO8859_8 is not set
CONFIG_NLS_CODEPAGE_1250=y
# CONFIG_NLS_CODEPAGE_1251 is not set
CONFIG_NLS_ISO8859_1=y
CONFIG_NLS_ISO8859_2=y
# CONFIG_NLS_ISO8859_3 is not set
# CONFIG_NLS_ISO8859_4 is not set
# CONFIG_NLS_ISO8859_5 is not set
# CONFIG_NLS_ISO8859_6 is not set
# CONFIG_NLS_ISO8859_7 is not set
# CONFIG_NLS_ISO8859_9 is not set
# CONFIG_NLS_ISO8859_13 is not set
# CONFIG_NLS_ISO8859_14 is not set
# CONFIG_NLS_ISO8859_15 is not set
# CONFIG_NLS_KOI8_R is not set
# CONFIG_NLS_KOI8_U is not set
CONFIG_NLS_UTF8=y


Also xfree regarding keyboard ( maybe set in a wrong way )
Quote:

Option "XkbRules" "xfree86"
# These are the default XKB settings for XFree86
# Option "XkbRules" "xfree86"
# Option "XkbModel" "pc101"
# Option "XkbLayout" "us"
# Option "XkbVariant" ""
# Option "XkbOptions" ""

# Option "XkbDisable"

Option "XkbModel" "pc105"
#Option "XkbLayout" "no"
Option "XkbLayout" "si"



Thanks for taking interest in that problem !
Back to top
View user's profile Send private message
Tuxx
n00b
n00b


Joined: 17 Mar 2004
Posts: 13

PostPosted: Mon Mar 22, 2004 3:25 pm    Post subject: Reply with quote

Budale jedne koji kurac svi engleski pricate !
Back to top
View user's profile Send private message
brankob
Apprentice
Apprentice


Joined: 29 Apr 2004
Posts: 183

PostPosted: Wed May 26, 2004 2:20 am    Post subject: Reply with quote

Yeah, it works for me !

Thanks a bunch !

Well, just one more question from me:

howo does one accomplish having two keyboards (like slovenian and us) and switching between them in XFce4 ?

While KDE has option for this, i can set up both keyboards in gnome-control, but I can't switch between them...
Back to top
View user's profile Send private message
shoki
n00b
n00b


Joined: 01 Nov 2004
Posts: 12
Location: Stubièke Toplice, Croatia

PostPosted: Thu Nov 04, 2004 2:22 pm    Post subject: Reply with quote

KDE Control Center -> Regional & Accessibility -> Keyboard Layout.
Here you activate keyboard layouts, customize Switching Policy.
You can switch layouts in tray.
Back to top
View user's profile Send private message
shoki
n00b
n00b


Joined: 01 Nov 2004
Posts: 12
Location: Stubièke Toplice, Croatia

PostPosted: Thu Nov 04, 2004 2:30 pm    Post subject: Reply with quote

englesk ise prièa zato što smo na stranom forumu.
Kad si u Rimu, ponašaj se kao rimljanin.

A i zato da drugi shvate kak se mijenjaju fontovi. Naèin je isti.
Back to top
View user's profile Send private message
Tomcater
n00b
n00b


Joined: 05 Nov 2004
Posts: 2
Location: Slovenia

PostPosted: Fri Nov 05, 2004 9:05 am    Post subject: Slovenian Character setting Reply with quote

Start Gentoo Linux
and type this:

nano -w /etc/rc.conf

Change language to this:

lat2-16

This will work only in console viewing. For KDE you must have scrypt installed for slovenian language characters.
_________________
Don't worry ... Be Happy
Back to top
View user's profile Send private message
Davitelj
n00b
n00b


Joined: 23 Jan 2004
Posts: 13
Location: Beograd

PostPosted: Fri Nov 05, 2004 11:11 am    Post subject: Reply with quote

shoki wrote:
englesk ise prièa zato što smo na stranom forumu.
Kad si u Rimu, ponašaj se kao rimljanin.


Si fueris Romae, Romano vivito more,
Si fueris alibi, vivito sicut ibi....

ako se dobro secam:)
_________________
Nemanja Jakovljevic
www.jakovljevic.net
+381(64)1782230
Back to top
View user's profile Send private message
pingufunkybeat
l33t
l33t


Joined: 01 Dec 2004
Posts: 610

PostPosted: Wed Dec 01, 2004 1:02 pm    Post subject: Reply with quote

The console programs aren't all able to deal with central European characters. But KWrite should work all right (just tested), IF you set the encoding to ISO-8859-2 before you save it and after you load it again.

KDE in general should deal with our characters without any problems, and that has been my experience from the early 1.9alpha days.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Languages All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum