Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
SUCKING install OF frgl200 radeon 8500 and audigy worked fin
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
doyouba
n00b
n00b


Joined: 26 Jun 2002
Posts: 4

PostPosted: Wed Jun 26, 2002 9:14 am    Post subject: SUCKING install OF frgl200 radeon 8500 and audigy worked fin Reply with quote

hello Gentoo World
:lol:
to install Gentoo correctly===2week
to install my sound card ( audigy)====2week
and now i want to install my video card (radeon 8500)
please help me

if is not possible to install the frgl200 for ati radeon 8500
can you tell me how to install the normal driver (radeon.o)
because when i run xf86config i can t see this video card on th data base

so :wink: if someone can help us


Au secours


Last edited by doyouba on Fri Jun 28, 2002 10:00 am; edited 1 time in total
Back to top
View user's profile Send private message
fmalabre
Guru
Guru


Joined: 19 Jun 2002
Posts: 376
Location: Chicago

PostPosted: Thu Jun 27, 2002 8:19 pm    Post subject: Reply with quote

Indeed, the card is not in the db, but just choose another ATI, and that will do the trick, they use the same driver.
Thus, you will have only 2D.
If you want to use the 3D, you need to wait the end of the year (Q4) when drivers will be included in XFree86.
Meanwhile, I heard people making it work with FireGL drivers, or ou can try the drivers from Accelerated X, but those are not free, but they work great.
Back to top
View user's profile Send private message
klieber
Administrator
Administrator


Joined: 17 Apr 2002
Posts: 3657
Location: San Francisco, CA

PostPosted: Fri Jun 28, 2002 12:58 am    Post subject: Reply with quote

Semi-OT, but I know some other users have been struggling with getting their audigys to work correctly in Gentoo. Could you post a brief description of how you got yours working? (kernel config, any special hoops you had to jump through, etc.)

--kurt
_________________
The problem with political jokes is that they get elected
Back to top
View user's profile Send private message
doyouba
n00b
n00b


Joined: 26 Jun 2002
Posts: 4

PostPosted: Fri Jun 28, 2002 9:55 am    Post subject: how i do to make work my audigy Reply with quote

AUDIGY
1-- the first time i make a make menuconfig i put emu10k1 driver as module
2-- then i emerge emu10k1-audigy
3-- edit modules.autoload and put "emu10k1"

THAT ALL

NOBODY KNOW HOW TO WITCH LIBRARY I NEED TO INSTALL
FOR THE FIREGL200 DRIVER?
Back to top
View user's profile Send private message
zaphf
n00b
n00b


Joined: 29 Jun 2002
Posts: 3

PostPosted: Sat Jun 29, 2002 1:05 am    Post subject: Additional Modifications needed Reply with quote

Having just installed Gentoo I havn't had time to look into submitting a proper bug report, but for those following the above instructions for the audigy will need to alter a script that seems to run when the module loads.


Code:


*** /usr/sbin/audigy-script.old   2002-06-28 14:29:43.000000000 -0500
--- /usr/sbin/audigy-script   2002-06-28 14:03:28.000000000 -0500
***************
*** 63,71 ****
  # example "-M /dev/mixer1"
  MIXERDEV=""
 
! DSPMGR=$BASE_PATH/bin/emu-dspmgr $DSPDEV $MIXERDEV
 
! CONFIG=$BASE_PATH/bin/emu-config $DSPDEV $MIXERDEV
 
  DRIVER_VERSION=` $DSPMGR  -q`
   
--- 63,71 ----
  # example "-M /dev/mixer1"
  MIXERDEV=""
 
! DSPMGR=$BASE_PATH/sbin/emu-dspmgr $DSPDEV $MIXERDEV
 
! CONFIG=$BASE_PATH/sbin/emu-config $DSPDEV $MIXERDEV
 
  DRIVER_VERSION=` $DSPMGR  -q`
Back to top
View user's profile Send private message
Forge
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2002
Posts: 125
Location: KOP, PA, USA

PostPosted: Fri Jul 26, 2002 2:31 pm    Post subject: Reply with quote

I managed to get Audigy emu10k1 into my kernel, non-module. I can't recall exactly which of the 20 things I tried got things working, though, but I'll make notes next time I have to upgrade kernels.
Back to top
View user's profile Send private message
Forge
Tux's lil' helper
Tux's lil' helper


Joined: 20 Jun 2002
Posts: 125
Location: KOP, PA, USA

PostPosted: Fri Jul 26, 2002 2:32 pm    Post subject: Reply with quote

Better: I'll unpack a vanilla 2.4.19-rc1 and do a diff before I upgrade. :)

BTW, I've had fglr200 working just fine on Gentoo, wasn't hard at all. Gave me regular lockups in Tribes2 and Q3A, though, so I went back to my GF4.
Back to top
View user's profile Send private message
syadnom
Guru
Guru


Joined: 09 May 2002
Posts: 531

PostPosted: Mon Jul 29, 2002 10:48 pm    Post subject: when will: Reply with quote

someone make an ebuild for the fireGL drivers that work ono 8500s?

i have read that some people are getting this to work, and the 8500 is a fairly popular card so it would be well worth it to have an interim driver that is usable until next year when "official" 8500 drivers come out.
Back to top
View user's profile Send private message
TripKnot
Apprentice
Apprentice


Joined: 29 May 2002
Posts: 213

PostPosted: Mon Jul 29, 2002 11:36 pm    Post subject: Reply with quote

Wish it could be done but you have to register with ati before you can download the drivers which cause some problems. Also kernel changes need to be made(agpgart as module). But, like you ask, it would be nice. The good thing however is that installing these drivers manually is rather painless. Not much harder than setting up grub.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum