Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Dificuldade para abilitar algumas flags USE
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
rodrigopmatias
n00b
n00b


Joined: 02 May 2004
Posts: 21
Location: Palmas - Tocantins - Brasil

PostPosted: Thu Dec 11, 2008 10:56 pm    Post subject: Dificuldade para abilitar algumas flags USE Reply with quote

Pessoa nao consegui encontrar informações de como abilitar algumas flags USE que estão entre parentese, como devo proceder veja o exemplo, gostaria de abilitar o plugin para firefox do JAVA quando executo o comando:

Code:
 # emerge -pv =dev-java/sun-jre-bin-1.6.0.11

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS   ] dev-java/java-config-1.3.7-r1  0 kB
[ebuild     U ] dev-java/sun-jre-bin-1.6.0.11 [1.6.0.10] USE="X alsa (-nsplugin) -odbc" 71,101 kB

Total: 2 packages (1 upgrade, 1 in new slot), Size of downloads: 71,101 kB


Pensei comigo:

Code:
 # USE="(nsplugin)" emerge -pv =dev-java/sun-jre-bin-1.6.0.11

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS   ] dev-java/java-config-1.3.7-r1  0 kB
[ebuild     U ] dev-java/sun-jre-bin-1.6.0.11 [1.6.0.10] USE="X alsa (-nsplugin) -odbc" 71,101 kB

Total: 2 packages (1 upgrade, 1 in new slot), Size of downloads: 71,101 kB


Espero nao esta sendo repetitivo.
_________________
Gnu/Linux Gentoo current - Kernel 2.6.30
Back to top
View user's profile Send private message
baldeante
Guru
Guru


Joined: 17 Jan 2004
Posts: 498
Location: Caldas da Rainha, Portugal

PostPosted: Fri Dec 12, 2008 9:10 pm    Post subject: Re: Dificuldade para abilitar algumas flags USE Reply with quote

rodrigopmatias wrote:
Pessoa nao consegui encontrar informações de como abilitar algumas flags USE que estão entre parentese, como devo proceder veja o exemplo, gostaria de abilitar o plugin para firefox do JAVA quando executo o comando:

Code:
 # emerge -pv =dev-java/sun-jre-bin-1.6.0.11

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS   ] dev-java/java-config-1.3.7-r1  0 kB
[ebuild     U ] dev-java/sun-jre-bin-1.6.0.11 [1.6.0.10] USE="X alsa (-nsplugin) -odbc" 71,101 kB

Total: 2 packages (1 upgrade, 1 in new slot), Size of downloads: 71,101 kB


Pensei comigo:

Code:
 # USE="(nsplugin)" emerge -pv =dev-java/sun-jre-bin-1.6.0.11

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  NS   ] dev-java/java-config-1.3.7-r1  0 kB
[ebuild     U ] dev-java/sun-jre-bin-1.6.0.11 [1.6.0.10] USE="X alsa (-nsplugin) -odbc" 71,101 kB

Total: 2 packages (1 upgrade, 1 in new slot), Size of downloads: 71,101 kB


Espero nao esta sendo repetitivo.


Esperimenta :
Code:

USE=nsplugin emerge -pv =dev-java/sun-jre-bin-1.6.0.11


Ou adiciona "nsplugin" a variável USE no ficheiro /etc/make.conf podes também adicionar "java" para teres suporte java em todos os pacotes que possam tirar partido ou utilizar java seguido dos dois comandos que se seguem :

Code:
emerge system -uD --newuse
emerge world -uD --newuse


Para actualizar todo o sistema com as novas flags ...
_________________
Never Quit, Never Get Mad, Get Even
Back to top
View user's profile Send private message
rodrigopmatias
n00b
n00b


Joined: 02 May 2004
Posts: 21
Location: Palmas - Tocantins - Brasil

PostPosted: Sat Dec 13, 2008 12:44 am    Post subject: Reply with quote

Ja tentei fazer da forma que é proposto para colocar o valor da variavel USE e desta forma também, mas mesmo assim nao consegui, acredito que seja uma funcionalidade que existia e nao existe mais. Ninguem parece que passou por isto, veja que a variável esta marcada por '(' e ')'
_________________
Gnu/Linux Gentoo current - Kernel 2.6.30
Back to top
View user's profile Send private message
baldeante
Guru
Guru


Joined: 17 Jan 2004
Posts: 498
Location: Caldas da Rainha, Portugal

PostPosted: Sat Dec 13, 2008 4:37 pm    Post subject: Reply with quote

rodrigopmatias wrote:
Ja tentei fazer da forma que é proposto para colocar o valor da variavel USE e desta forma também, mas mesmo assim nao consegui, acredito que seja uma funcionalidade que existia e nao existe mais. Ninguem parece que passou por isto, veja que a variável esta marcada por '(' e ')'


Tanto quanto sei deveria funcionar ...

A minha variavel USE do make.conf :

Code:
CPU="fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 mmx fxsr sse up"
SYSTEM="apm dga hal aoss hardened userlocales glibc-omitfp cups mdnsresponder-compat"
GENERAL="x86 samba java bzip2 symlink spell libedit zlib unicode fbcon slang"
FILESUPPORT="jpeg gif tiff png pdf xml xml2 mp3 mad"
MEDIAUSE="openal alsa real gstreamer a52 vidix wma wmf asf win32codecs aac xvid wxwindows"
XUSE="nvidia truetype type1 X new-login xorg xv opengl xcomposite"
KDEUSE="-kde -arts -qt -qt3 -qt4"
GNOMEUSE="gtk cairo glitz -gnome -avahi"
INTERNET="firefox nsplugin moznopango xulrunner"
NOTUSE="-ipv6 -eds -gtk2 -gpm -real"
USE="${CPU} ${SYSTEM} ${GENERAL} ${FILESUPPORT} ${MEDIAUSE} ${XUSE} ${KDEUSE} ${GNOMEUSE} ${INTERNET} ${NOTUSE}"


Note-se que eu não utilizo o Gnome e sim o Fluxbox ...

O que acontece se tentar recompilar o firefox e java :
Code:


These are the packages that would be merged, in order:

Calculating dependencies   ... done!
[ebuild  N    ] sys-libs/libstdc++-v3-3.3.6  USE="nls nptl -build (-multilib)" 23,411 kB
[ebuild  N    ] virtual/libstdc++-3.3  0 kB
[ebuild  N    ] dev-java/sun-jre-bin-1.6.0.07  USE="X alsa nsplugin -odbc" 76,675 kB

Total: 3 packages (3 new), Size of downloads: 100,086 kB

These are the packages that would be merged, in order:

Calculating dependencies   ... done!
[ebuild   R   ] www-client/mozilla-firefox-2.0.0.18  USE="java moznopango -bindist -debug -filepicker -gnome -iceweasel -ipv6 -mozdevelop -restrict-javascript -xforms -xinerama -xprint" LINGUAS="en pt -af -ar -be -bg -ca -cs -da -de -el -en_GB -en_US -es -es_AR -es_ES -eu -fi -fr -fy -fy_NL -ga -ga_IE -gu -gu_IN -he -hu -it -ja -ka -ko -ku -lt -mk -mn -nb -nb_NO -nl -nn -nn_NO -pa -pa_IN -pl -pt_BR -pt_PT -ro -ru -sk -sl -sv -sv_SE -tr -uk -zh -zh_CN -zh_TW" 39,529 kB

Total: 1 package (1 reinstall), Size of downloads: 39,529 kB


Não tenho directamente o pacote java que indicas instalado mas tenho suporte pois consigo abrir sites com java "www.cm-obidos.pt" por exemplo tem os menus em java e eu consigo abri-lo sem problemas ...

Acho que quando instalei java instalei um pacote alternativo mas não me lembro qual ... vou ver se consigo ver o que tenho instalado e digo qualquer coisa ...

Howto Java em Gentoo
https://gentooexperimental.org/svn/java/axxo-overlay/README/docs/java-user.html
_________________
Never Quit, Never Get Mad, Get Even
Back to top
View user's profile Send private message
baldeante
Guru
Guru


Joined: 17 Jan 2004
Posts: 498
Location: Caldas da Rainha, Portugal

PostPosted: Sat Dec 13, 2008 9:47 pm    Post subject: Reply with quote

Boas,

Tenho instalado o pacote virtual/jre-1.5.0 e virtual/jdk-1.5.0

Segundo o equery esta é a lista de pacotes que dele dependem onde esta incluido o firefox :

Code:
app-office/openoffice-3.0.0
dev-db/hsqldb-1.8.0.10
dev-java/bcel-5.2
dev-java/bsf-2.3.0-r5
dev-java/gjdoc-0.7.8
dev-java/jakarta-regexp-1.3-r4
dev-java/javacup-0.10k-r1
dev-java/libreadline-java-0.8.0-r2
dev-java/rhino-1.5.5-r4
dev-java/servletapi-2.3-r3
dev-java/tomcat-servlet-api-4.1.36
dev-java/xalan-2.7.0-r5
dev-java/xalan-serializer-2.7.0
dev-java/xerces-2.9.1
dev-java/xml-commons-external-1.3.04
dev-java/xml-commons-resolver-1.2
net-dns/libidn-1.5-r1
net-libs/xulrunner-1.8.1.18-r1
net-print/cups-1.3.9-r1
sys-libs/db-4.3.29-r2
sys-libs/db-4.5.20_p2-r1
www-client/mozilla-firefox-2.0.0.18
www-client/seamonkey-1.1.13

_________________
Never Quit, Never Get Mad, Get Even
Back to top
View user's profile Send private message
rodrigopmatias
n00b
n00b


Joined: 02 May 2004
Posts: 21
Location: Palmas - Tocantins - Brasil

PostPosted: Mon Dec 15, 2008 2:17 pm    Post subject: Reply with quote

Só um detalhe estou utilizando Arch AMD64 em um NACONA, mas resolvi parcialmente o problema instalei emul-linux-x86-firefox acho que e este ebuild nao tenho certeza estou no meu trabalho, mas assim o firefox consegui adquirir o nsplugin, acredito que quando o flag esta quando esta entre parentese. (-nsplugin) como alguns falarão aqui, tem que funcionar liberando no USE mas isto nao aconteceu, só para adicionar um detalhe, eu utilizei um make.conf que já havia utilizado em um sistema x86 mas claro modificando as variaveis para o NACONA (EMT64). Mas desde já fico grato com todos que me ajudarão e assim que conseguir resolver o problema estarei postando aqui no forum.
_________________
Gnu/Linux Gentoo current - Kernel 2.6.30
Back to top
View user's profile Send private message
Sodki
Guru
Guru


Joined: 11 Aug 2003
Posts: 418
Location: London, U.K. & Lisbon, Portugal

PostPosted: Tue Dec 30, 2008 1:39 pm    Post subject: Reply with quote

A USE flag estar entre parêntesis significa que ela não pode ser usada. Essa USE flag está masked no profile, mesmo.

Retirado de http://en.gentoo-wiki.com/wiki/HOWTO_Use_Portage_Correctly :

Quote:
Parentheses () around a USE flag indicate that it is currently masked by your profile. This is usually because the USE flag can not be supported on the given platform (for example, the win32codecs on amd64 with non-binary packages) or is irrelevant; for example, sse is available on all amd64 CPU's, so there's no point being able to disable it in a 64-bit environment.
Back to top
View user's profile Send private message
elissoncosta
n00b
n00b


Joined: 22 Jan 2009
Posts: 24
Location: Brasil

PostPosted: Thu Jan 22, 2009 1:25 pm    Post subject: Reply with quote

Rodrigo,

É possivel habilitar a flag (nsplugin), entretanto deve-se estar ciente de que ela foi masked por motivos de segurança ou algum bug.

Simplesmente comente a flag 'nsplugin' no arquivo "/usr/portage/profiles/base/use.mask".

Vale a pena lembrar que este arquivo pode ser substituído a cada sync, então é necessário que verifique-o com frequência.

--
Elisson Costa
elissoncosta@security.homelinux.org
Back to top
View user's profile Send private message
Sodki
Guru
Guru


Joined: 11 Aug 2003
Posts: 418
Location: London, U.K. & Lisbon, Portugal

PostPosted: Mon Jan 26, 2009 11:32 pm    Post subject: Reply with quote

elissoncosta wrote:
É possivel habilitar a flag (nsplugin), entretanto deve-se estar ciente de que ela foi masked por motivos de segurança ou algum bug.

Simplesmente comente a flag 'nsplugin' no arquivo "/usr/portage/profiles/base/use.mask".

Vale a pena lembrar que este arquivo pode ser substituído a cada sync, então é necessário que verifique-o com frequência.

O melhor mesmo é criar o ficheiro /etc/portage/profile/package.use.mask com o seguinte conteúdo

Code:
dev-java/sun-jre-bin -nsplugin


Esta solução não é afectada pelo sync, logo funciona sempre.
Back to top
View user's profile Send private message
elissoncosta
n00b
n00b


Joined: 22 Jan 2009
Posts: 24
Location: Brasil

PostPosted: Mon Feb 23, 2009 7:32 pm    Post subject: Reply with quote

Sodki wrote:
elissoncosta wrote:
É possivel habilitar a flag (nsplugin), entretanto deve-se estar ciente de que ela foi masked por motivos de segurança ou algum bug.

Simplesmente comente a flag 'nsplugin' no arquivo "/usr/portage/profiles/base/use.mask".

Vale a pena lembrar que este arquivo pode ser substituído a cada sync, então é necessário que verifique-o com frequência.

O melhor mesmo é criar o ficheiro /etc/portage/profile/package.use.mask com o seguinte conteúdo

Code:
dev-java/sun-jre-bin -nsplugin


Esta solução não é afectada pelo sync, logo funciona sempre.

.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum