Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Xorg - Clavier] Pb touches (Résolu)
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4  Next  
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
_Seth_
Guru
Guru


Joined: 15 Sep 2004
Posts: 539
Location: encore paumé dans un labo ;)

PostPosted: Mon Jun 30, 2008 11:00 am    Post subject: Reply with quote

Salut,
J'ai le même problème, il me semble. Pour le résoudre je change le layout (fr <->us) ou je recharge la disposition du clavier (pc 105) avec l'utilitaire de gestion de clavier kde. C'est moche et frustant mais je n'ai pas trouvé l'origine du problème.
_________________
no tears to cry, no feelings left
the species has amused itself to death
amused itself to death
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Mon Jun 30, 2008 11:02 am    Post subject: Reply with quote

T'as pensé à relancer HAL après l'ajout du FDI ? :)
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Mon Jun 30, 2008 11:34 am    Post subject: Reply with quote

oui, avec /etc/init.d/hald restart
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
Mickael
Advocate
Advocate


Joined: 05 Sep 2005
Posts: 2383
Location: ~Belfort! - France - EU

PostPosted: Mon Jun 30, 2008 11:39 am    Post subject: Reply with quote

Bon l'approche de Xavier fonctionne. Je viens de me rendre compte que dans mon package.use j'avais un -evdev sur xorg-server et lors de ma tentative de passer en full hal, j'avais en même temps la variable evdev danc mon make.conf. Est-ce possible que cela est foiré mon passage sous hal.

Bon pour l'instant je reste en full xorg, et je verrai lorsque cela sera un peu plus clair. Rédaction de thèse pour l'instant je me contenterai de cela. Si vous avez des pistes je retenterai dans la semaine.

Merci.
Micka, qui n'est plus énervé et donc ne met plus de jurons dans ses postes :)
_________________
À LIRE : COMMENT POSTER ET OBTENIR DE L'AIDE ?
Qui suis-je ? Bon j'ai relu, comme d'habitude, je suis bon a rien le vendredi
Qui suis-je ? Je ne serai jamais modo
Back to top
View user's profile Send private message
_Seth_
Guru
Guru


Joined: 15 Sep 2004
Posts: 539
Location: encore paumé dans un labo ;)

PostPosted: Mon Jun 30, 2008 3:47 pm    Post subject: Reply with quote

Bonne rédaction ;)
_________________
no tears to cry, no feelings left
the species has amused itself to death
amused itself to death
Back to top
View user's profile Send private message
Nicomero
n00b
n00b


Joined: 06 Feb 2007
Posts: 16

PostPosted: Thu Aug 21, 2008 12:11 pm    Post subject: Reply with quote

Bonjour a tous,

Je ressort ce sujet car j ai aussi des problemes suite a ma derniere maj : le fichier /etc/hal/fdi/policy/10-keymap.fdi n est pas pris en compte. J ai pourtant bien suivis les explications donnees, a savoir :
-INPUT_DEVICE="evdev" dans /etc/make.conf
-sections Input Device commentees dans /etc/X11/xorg.conf
-copie de diverses fichiers /etc/hal/fdi/policy/10-keymap.fdi

A chaque fois, X utilise un driver clavier et mouse par defaut et un layout us.

GentooUser@Clubic wrote:
Je crois savoir ou est mon problème, en effet j'ai pas viré les drivers keyboard et mouse, merci.


En quoi cela consiste ? :oops: Est-ce de commenter les sections Input Device du xorg.conf ?

Sinon j utilise xorg-server-1.3.0.0-r6, xf86-input-evdev-1.1.5-r2, enfin la brache stable quoi...

Voila, j ai besoin de votre aide.... Merci [/quote]
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 500

PostPosted: Thu Aug 21, 2008 12:33 pm    Post subject: Reply with quote

J'ai eu un problème avec ça il y a quelque temps... mon fichier /etc/hal/..../10policy.fdi n'était pas pris en compte...

J'ai finalement changé le fichier :
Code:
/usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi
directement...

C'est pas très propre et ça va sauter à la prochaine mise à jour de hal, mais en attendant, ça marche chez moi ...

Sinon, tu peux toujours récupérer un clavier avec un layout fr en lançant:
Code:
setxkbmap -model evdev -layout fr
Back to top
View user's profile Send private message
Nicomero
n00b
n00b


Joined: 06 Feb 2007
Posts: 16

PostPosted: Thu Aug 21, 2008 1:55 pm    Post subject: Reply with quote

Merci de ta réponse.

J'ai modifié directement le fichier que tu m'a indiqué dans /usr/share/hal/fdi/policy/10osvendor/10-keymap.fdi, malheureusement ça ne change rien. Je peux mettre n'importe quoi en fichier fdi, on dirait qu'i n'est jamais pris en compte. C'est pourquoi j'ai un doute su d'eventuels drivers à supprimer, mais je ne sais pas où...

Sinon utiliser la commande :
Code:
setxkbmap -model evdev -layout fr

fonctionne mais ce n'est vraiment que du dépannage, il y a aussi le touchpad à faire fonctionner et toutes les touches du clavier ne fonctionnent pas (comme les flèches par exemple :/).

Voici la fin de /var/log/Xorg.0.log :
Code:
(WW) <default pointer>: No Device specified, looking for one...
(II) <default pointer>: Setting Device option to "/dev/input/mice"
(--) <default pointer>: Device: "/dev/input/mice"
(==) <default pointer>: Protocol: "Auto"
(**) Option "CorePointer"
(**) <default pointer>: Core Pointer
(==) <default pointer>: Emulate3Buttons, Emulate3Timeout: 50
(**) <default pointer>: ZAxisMapping: buttons 4 and 5
(**) <default pointer>: Buttons: 9
(**) <default pointer>: Sensitivity: 1
(**) Option "CoreKeyboard"
(**) <default keyboard>: Core Keyboard
(**) Option "Protocol" "standard"
(**) <default keyboard>: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XkbRules" "xorg"
(**) <default keyboard>: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) <default keyboard>: XkbModel: "pc105"
(**) Option "XkbLayout" "us"
(**) <default keyboard>: XkbLayout: "us"
(**) Option "CustomKeycodes" "off"
(**) <default keyboard>: CustomKeycodes disabled
(II) XINPUT: Adding extended input device "<default keyboard>" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "<default pointer>" (type: MOUSE)
(--) <default pointer>: PnP-detected protocol: "ExplorerPS/2"
(II) <default pointer>: ps2EnableDataReporting: succeeded
(**) RADEON(0): RADEONSaveScreen(2)
(II) 3rd Button detected: disabling emulate3Button


Voilà merci de ton aide. Je n'est rien contre le progrès, donc configurer les claviers et souris par hal dans X ne me dérange pas, sauf que je n'y arrive pô :/
Back to top
View user's profile Send private message
tmasscool
Apprentice
Apprentice


Joined: 27 Jul 2005
Posts: 151

PostPosted: Thu Aug 21, 2008 4:30 pm    Post subject: Reply with quote

Bonjour, petite question en rapport avec ce sujet ...

Voilà, j'utilise un portable auquel je connectes parfois un clavier USB dont le layout n'est pas le même que celui intégré au portable (respectivement FR et BE).

Comment dois-je rédiger le fichier fdi pour que celà fonctionne. J'aimerais enlever les sections InputDevice de mon xorg.conf, vu que de toutes façons elles vont devenir obsolètes.
Code:
Section "InputDevice"
    Identifier     "Keyboard0"
    Driver         "evdev"
    Option         "Device"     "/dev/input/by-path/platform-i8042-serio-0-event-kbd"
    Option         "XkbLayout"  "fr"
EndSection

Section "InputDevice"
    Identifier     "Keyboard1"
    Driver         "evdev"
    Option         "Device"     "/dev/input/by-id/usb-MOSART_Semi._Wireless_Keyboard___Mouse-event-kbd"
    Option         "XkbLayout"  "be"
EndSection
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Sun Sep 07, 2008 3:29 pm    Post subject: Reply with quote

Je remonte un coup le topic pour informer que depuis xorg-server 1.5, on peut maintenant passer des options aux drivers dans la config hal, ce qui permet entre autres (dans mon cas) de configurer synaptics sans besoin du xorg.conf :)
Chez moi ça donne donc ça du coup :
/etc/hal/fdi/policy/10-x11-input.fdi:
<?xml version="1.0" encoding="UTF-8"?>
<deviceinfo version="0.2">
  <device>
    <!-- Keyboard configuration -->
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>
    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.x11_driver" type="string">evdev</merge>
      <merge key="input.xkb.layout" type="string">us</merge>
      <merge key="input.xkb.variant" type="string">altgr-intl</merge>
      <append key="input.xkb.options" type="strlist">compose:menu</append>
    </match>
    <!-- Synaptics configuration -->
    <match key="info.capabilities" contains="input.touchpad">
      <match key="info.product" contains="Synaptics TouchPad">
        <merge key="input.x11_driver" type="string">synaptics</merge>
        <merge key="input.x11_options.SHMConfig" type="string">on</merge>
        <merge key="input.x11_options.VertScrollDelta" type="string">20</merge>
        <merge key="input.x11_options.HorizScrollDelta" type="string">20</merge>
        <merge key="input.x11_options.UpDownScrolling" type="string">1</merge>
        <merge key="input.x11_options.LeftRightScrolling" type="string">1</merge>
        <merge key="input.x11_options.TapButton1" type="string">1</merge>
        <merge key="input.x11_options.RTCornerButton" type="string">2</merge>
        <merge key="input.x11_options.RBCornerButton" type="string">3</merge>
      </match>
    </match>
  </device>
</deviceinfo>

Et je n'ai plus du tout de xorg.conf maintenant, tout fonctionne nickel avec hal uniquement. ;)
En espérant que ça intéresse du monde... :)
Back to top
View user's profile Send private message
RickyLoad
Tux's lil' helper
Tux's lil' helper


Joined: 29 Dec 2006
Posts: 148
Location: Rennes

PostPosted: Mon Sep 08, 2008 1:18 am    Post subject: Reply with quote

Salut
Bon je viens de faire une big de mise a jour et hal me fais des misères :(
Tout d'abord il m'a créé un fichier /etc/hal/fdi/policy/10-x11-input.fdi
bien que sous ma version précédente j'avais déjà un /etc/hal/fdi/policy/10-keymap.fdi qui lui fonctionnait très bien !
Je me suis donc empressé de coller le contenu du 1e dans le /etc/hal/fdi/policy/10-x11-input.fdi , et la erreur ==> Clavier fou
Je vous colle le contenu des deux

/etc/hal/fdi/policy/10-keymap.fdi
Code:

<?xml version="1.0" encoding="ISO-8859-1"?>
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">xorg</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.x11_driver" type="string">kbd</merge>
      <merge key="input.xkb.layout" type="string">fr</merge>
      <merge key="input.xkb.variant" type="string">,winkeys</merge>
      <merge key="input.xkb.options" type="string">grp:toggle,grp_led:scroll</merge>
    </match>
  </device>
</deviceinfo>


le /etc/hal/fdi/policy/10-x11-input.fdi
Code:

<?xml version="1.0" encoding="utf-8"?>
<deviceinfo version="0.2">
 <device>
   <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
   </match>
   <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">xorg</merge>
      <merge key="input.xkb.layout" type="string">fr</merge>
      <merge key="input.xkb.model" type="string">evdev</merge>
      <merge key="input.x11_driver" type="string">evdev</merge>
      <merge key="input.xkb.options" type="strlist">grp:toggle</merge>
      <append key="input.xkb.options" type="strlist">grp_led:scroll</append>
      <merge key="input.xkb.variant" type="string">,winkeys</merge>
   </match>
 </device>
</deviceinfo>


Voilà tout marche si ce n'est que je n'ai pas de 3e niveau dans mon clavier :((
Pour retrouver toutes les fonctions je suis obligé de passer par un ==> setxkbmap -model evdev -layout fr
je suis aussi passé sous xorg-server 1.5 en même tps !
Merci pour votre aide

edit: j'ai virer le /etc/hal/fdi/policy/10-keymap.fdi vu que l'autre a été créé et qu'il marche "presque "
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Mon Sep 08, 2008 8:22 am    Post subject: Reply with quote

Heu, le nom du fichier importe peu, il ne défini que l'ordre dans lequel ils sont lu dans un même répertoire, donc tu pouvais très bien garder le premier, surtout s'il fonctionnait ;p

Pour le input.xkb.options, chez moi il n'est pas pris en compte non plus, et j'ai pas trouvé pourquoi pour le moment... La même conf sur ma Debian SID fonctionne très bien pourtant. Donc je fais un setxkbmap sous Gentoo pour activer le Compose.

Sinon t'as vérifié avec hal-device que tout était bien pris en compte comme il faut ?
Back to top
View user's profile Send private message
RickyLoad
Tux's lil' helper
Tux's lil' helper


Joined: 29 Dec 2006
Posts: 148
Location: Rennes

PostPosted: Mon Sep 08, 2008 2:23 pm    Post subject: Reply with quote

Code:

tu pouvais très bien garder le premier, surtout s'il fonctionnait ;p


ben a priori l'en voulait pas , mais vu qu'il m'en a créé un autre c'est peu être pour çà :)

Code:

Pour le input.xkb.options, chez moi il n'est pas pris en compte non plus, et j'ai pas trouvé pourquoi pour le moment... La même conf sur ma Debian SID fonctionne très bien pourtant. Donc je fais un setxkbmap sous Gentoo


Bon ben je vais faire comme toi en attendant que çà s'arrange avec une prochaine mise a jour peu être
Merci pour ces éclaircissements geekounet
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Fri Nov 21, 2008 3:23 am    Post subject: Reply with quote

Je remonte ce post, car j'ai toujours besoin de passer la commande setxkbmap pour que mon clavier fonctionne correctement, je ne sais pas si entretemps quelqu'un à trouvé une solution.
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8043
Location: ~Brussels - Belgique

PostPosted: Fri Nov 21, 2008 7:52 am    Post subject: Reply with quote

Tu as mis ta config via HAL ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
RickyLoad
Tux's lil' helper
Tux's lil' helper


Joined: 29 Dec 2006
Posts: 148
Location: Rennes

PostPosted: Sat Nov 22, 2008 2:58 am    Post subject: Reply with quote

Salut

titoucha wrote:
Je remonte ce post, car j'ai toujours besoin de passer la commande setxkbmap pour que mon clavier fonctionne correctement, je ne sais pas si entretemps quelqu'un à trouvé une solution.


Même chose , si y'en a qui ont trouvé une solution je suis preneur également
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Sat Nov 22, 2008 5:00 am    Post subject: Reply with quote

XavierMiller wrote:
Tu as mis ta config via HAL ?


Ben j'ai tellement modifier le config que plus rien ne fonctionne, il faut que je remettes tout en place et ensuite je recommencerais.
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
psychoteur
n00b
n00b


Joined: 26 Jul 2006
Posts: 34

PostPosted: Thu Nov 27, 2008 1:53 pm    Post subject: Reply with quote

Est-ce que quelqu'un pourrait expliquer le pourquoi du comment de ce fichier xml ?
J'ai un inspiron 6400 et j'ai du passer par gnome pour avoir les touches correctement configurées.
Malheureusement dans gdm, c'est toujours pas bon et pour cause puisque la configuration ne semble pas être lue ou est ignorée.

D'après mes fouilles, c'est un peu plus compliqué que ça, parce qu'il y a plusieurs modèles de clavier.
Et pourtant ici, je vois xkb.model evdev ... ce qui n'a pas de sens.
En logique pour moi, qui ai un insprion xkb.model inspiron et xkb.input.driver evdev
Mais il y a aussi le problème du vendor, car ni mon pad n'a les fonctionnalités désirées, ni mon clavier sauf via gnome-settings.

Si on a une translation du fichier xorg, on devrait avoir xkb.model>inspiron<
xkbdriver<evdev>
xkb.laytout<ch>
xkb.variant<fr>
xkb.options<lv3:ralt_switch<

En fait, ce qui m'embête surtout c'est mon pad sans la fonction glide pour les ascenseurs.
Dans gdm, c'est moi embêtant du moment que je me rappelle de taper à l'aveugle en clavier US.
Back to top
View user's profile Send private message
psychoteur
n00b
n00b


Joined: 26 Jul 2006
Posts: 34

PostPosted: Thu Nov 27, 2008 2:43 pm    Post subject: Reply with quote

Bah encore plus bizarre, je viens de recompiler en supprimant "keyboard et mouse"
J'ai été revoir ma config dans Gnome et ce n'était plus à clavier evdev mais à pc105.
J'ai rechangé pour inspiron 64** et mon layout, etc.
Ai rebooté, mon gdm est juste mais toujours pas le touchpad.
Visiblement, il faut retirer impérativement keyboard pour que la lecture du fichier fdi se fasse.

lshal | grep input.x11 montre qu'il lit la configuration.
Maintenant, il faut que je trouve la bonne pour mon touchpad.

Rectification, il s'avère qu'en fait, j'avais mis dans xorg d'ignorer la configuration hal. C'est toujours pas bon, retour à la case départ.
Quels sont les droits pour les fichies *.fdi ... simple lecture, non ?
Back to top
View user's profile Send private message
d2_racing
Bodhisattva
Bodhisattva


Joined: 25 Apr 2005
Posts: 13047
Location: Ste-Foy,Canada

PostPosted: Wed Dec 31, 2008 3:42 am    Post subject: Reply with quote

Vous avez raison, j'ai parlé avec un Dev et c'est bien le bon fichier : /etc/hal/fdi/policy/10-x11-input.fdi

http://sources.gentoo.org/viewcvs.py/gentoo-x86/sys-apps/hal/hal-0.5.11-r1.ebuild?rev=1.15&view=markup

Il y a plein de monde qui prenne celui-ci : /etc/hal/fdi/policy/10-keymap.fdi

Mais c'est pas le bon.
Back to top
View user's profile Send private message
titoucha
Advocate
Advocate


Joined: 21 Jul 2005
Posts: 2374
Location: Genève

PostPosted: Wed Dec 31, 2008 8:06 am    Post subject: Reply with quote

Ha bon j'ai le keymaps pour le clavier et le input pour la souris et ça marche 8O

PS: depuis le passage de xorg à la version 1.5.3 je n'ai plus de problèmes tout fonctionne.
_________________
Assurez-vous que le titre de votre message soit conforme aux conventions de ce forum (paragraphe 3/3 : Comment poster sur le forum ??)
Back to top
View user's profile Send private message
geekounet
Bodhisattva
Bodhisattva


Joined: 11 Oct 2004
Posts: 3772
Location: Wellington, Aotearoa

PostPosted: Wed Dec 31, 2008 8:19 am    Post subject: Reply with quote

d2_racing wrote:
Vous avez raison, j'ai parlé avec un Dev et c'est bien le bon fichier : /etc/hal/fdi/policy/10-x11-input.fdi

http://sources.gentoo.org/viewcvs.py/gentoo-x86/sys-apps/hal/hal-0.5.11-r1.ebuild?rev=1.15&view=markup

Il y a plein de monde qui prenne celui-ci : /etc/hal/fdi/policy/10-keymap.fdi

Mais c'est pas le bon.

Heu, en gros osef du nom du fichier... ils sont d'abord lu dans l'ordre alphabétique dans /usr/share/hal/fdi/, puis dans l'ordre alphabétique dans /etc/hal/fdi/, le nom n'a aucune importance, à part pour déterminer l'ordre si t'y places plusieurs fichiers ;p
Back to top
View user's profile Send private message
ppg
Apprentice
Apprentice


Joined: 05 Oct 2008
Posts: 178
Location: Toulouse

PostPosted: Wed Dec 31, 2008 10:03 am    Post subject: Reply with quote

d2_racing wrote:
Vous avez raison, j'ai parlé avec un Dev et c'est bien le bon fichier : /etc/hal/fdi/policy/10-x11-input.fdi

http://sources.gentoo.org/viewcvs.py/gentoo-x86/sys-apps/hal/hal-0.5.11-r1.ebuild?rev=1.15&view=markup

Il y a plein de monde qui prenne celui-ci : /etc/hal/fdi/policy/10-keymap.fdi

Mais c'est pas le bon.


Tiens c'est marrant parce que j'ai pris le mauvais fichier et ça marche quand même, mais s'ils sont lu dans l'ordre alphabtique ça s'explique :

Code:

furet@woodstock ~ $ cat /etc/hal/fdi/policy/10-x11-input.fdi
furet@woodstock ~ $

furet@woodstock ~ $ cat /etc/hal/fdi/policy/10-keymap.fdi
<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<deviceinfo version="0.2">
  <device>
    <match key="info.capabilities" contains="input.keymap">
      <append key="info.callouts.add" type="strlist">hal-setup-keymap</append>
    </match>

    <match key="info.capabilities" contains="input.keys">
      <merge key="input.xkb.rules" type="string">base</merge>

      <!-- If we're using Linux, we use evdev by default (falling back to
           keyboard otherwise). -->
      <merge key="input.xkb.model" type="string">keyboard</merge>
      <match key="/org/freedesktop/Hal/devices/computer:system.kernel.name"
             string="Linux">
        <merge key="input.xkb.model" type="string">evdev</merge>
      </match>

      <merge key="input.xkb.layout" type="string">fr</merge>
      <merge key="input.xkb.variant" type="string">oss</merge>
    </match>
  </device>
</deviceinfo>


Normalement il y a juste les 2 lignes à compléter :
Code:

      <merge key="input.xkb.layout" type="string">fr</merge>
      <merge key="input.xkb.variant" type="string">oss</merge>

Le reste faut pas y toucher.

Sinon le seul truc que j'ai eu à changer dans mon xorg.conf c'était de supprimer le RgbPath, les sections InputDevice pour keyboard0 et mouse0 sont ignorée.
Back to top
View user's profile Send private message
_Seth_
Guru
Guru


Joined: 15 Sep 2004
Posts: 539
Location: encore paumé dans un labo ;)

PostPosted: Thu Mar 05, 2009 3:07 am    Post subject: Reply with quote

bon, je suis comme mickael : je rédige ma thèse et je n'ai pas de altgr ... c'est chiant (noter qu'au moins mes flèches marchent).
le setxkbmap -model evdev -layout fr n'y change rien. je peux redémarrer X ou hal, rien n'y fait. J'ai essayé les différents *.fdi proposé dans ce thread sans succès.

NB : QT m'indique qu'il ne connait pas la touche altgr et voila ce que me renvoie xev quand je presse altgr
Code:
KeyPress event, serial 34, synthetic NO, window 0x1800001,
    root 0x92, subw 0x0, time 1139044, (93,26), root:(98,980),
    state 0x10, keycode 108 (keysym 0xfe08, ISO_Next_Group), same_screen YES,
    XLookupString gives 0 bytes:
    XmbLookupString gives 0 bytes:
    XFilterEvent returns: False


Est ce qu'il existe un moyen pour retrouver ma touche alt gr ? et accessoirement le pipe, le backquote, le backslash et le dièse ?
_________________
no tears to cry, no feelings left
the species has amused itself to death
amused itself to death
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8043
Location: ~Brussels - Belgique

PostPosted: Thu Mar 05, 2009 7:51 am    Post subject: Reply with quote

en attendant, ctrl+alt ne fait pas altgr ? (altgr, c'est une abherration...)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Goto page Previous  1, 2, 3, 4  Next
Page 3 of 4

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum