Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[wifi] mise en place connexion wifi + wap
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
lcrprod
n00b
n00b


Joined: 07 Sep 2004
Posts: 30

PostPosted: Fri Nov 07, 2008 2:09 pm    Post subject: [wifi] mise en place connexion wifi + wap Reply with quote

Bonjour,

J'ai cherché partout mais je n'arrive pas a configurer correctement mon wifi.

knetworkmanager ne veut pas s'installer. comme je veut absolument avoir la connexion wifi en fonctionnement et en connexion principale.;


j'ai mis en place wpa_supplicant, je l'ai configuré pour allez sur mon wifi, j'ai accroché mon reseau et j'ai lancé manuellement un dhcpcd wlan0 pour avoir mon ip.


Ce qu'il me manque c'est de finaliser ceci pour que la connexion ce fasse automaitiquement au boot sans aucune manip de ma part.


j'ai rien trouver sur les forum....

je regelerais mon probléme de de knetwork aprés.

Coridalement.
Back to top
View user's profile Send private message
YetiBarBar
Guru
Guru


Joined: 23 Dec 2005
Posts: 494

PostPosted: Fri Nov 07, 2008 2:35 pm    Post subject: Reply with quote

Pour schématiser ce que tu as à faire pour celà:

1/ Remplir le fichier /etc/conf.d/net (en prenant exemple sur /etc/conf.d/net.exemple que tu enregistre en /etc/conf.d/net après modification)
2/ Créer un lien symbolique de /etc/init.d/net.wlan0 (ou tout autre nom de ton périphérique, sur une de mes machines net.ath0...) vers /etc/init.d/net.lo, j'insiste sur le fait que ça doit être un lien symbolique et non une copie sous peine de problèmes lors de (rares) update du baselayout... Pour réaliser ce lien, tu devra utiliser la commande ln
3/ Ajouter net.wlan0 à tes runlevel à l'aide de la commande:
Code:
rc-update add net.wlan0 default


Enfin, pour plus de raffinement, tu peux sauter la dernière étape et "jouer" avec ifplugd, qui est surtout utile sur un laptop
Back to top
View user's profile Send private message
lcrprod
n00b
n00b


Joined: 07 Sep 2004
Posts: 30

PostPosted: Fri Nov 07, 2008 3:13 pm    Post subject: Reply with quote

Bonjour,

et merci pour la réponse rapide.

j'ai fait tout ce que tu m'a dis. j'ai ensuite rebooter mon poste et depuis impossible d'accrocher mon wifi.

j'ai systématiquement le message suivant:

Quote:

/etc/init.d/net.wlan0 start
* Starting wlan0
* Starting wpa_supplicant on wlan0 ...
Unsupported driver 'iwl3945'.

/lib/rcscripts/sh/rc-daemon.sh: line 231: 11500 Segmentation fault /sbin/start-stop-daemon '--start' '--exec' '/sbin/wpa_supplicant' '--pidfile' '/var/run/wpa_supplicant-wlan0.pid' '--' '-Diwl3945' '-c/etc/wpa_supplicant/wpa_supplicant.conf' '-W' '-W' '-B' '-iwlan0' '-P/var/run/wpa_supplicant-wlan0.pid' [ !! ]


voici mon wpa_supplicant.conf

Quote:

# This is a network block that connects to any unsecured access point.
# We give it a low priority so any defined blocks are preferred.
#network={
# key_mgmt=NONE
# priority=-9999999
#}

ctrl_interface=/var/run/wpa_supplicant

ctrl_interface_group=0
ap_scan=1

network={
ssid="ma ssid"
psk="ma clef"
proto=WPA2
key_mgmt=WPA-PSK
pairwise=CCMP
group=CCMP
priority=5
}



je n'y comprend plus rien. il ya quelque minutes cela marchais. Maitenant wpa_supplicant me dis qu'il ne supporte pas mon drivers.

j'ai comme verison de noyaux :
Quote:


uname -r
2.6.25-gentoo-r8


La gentoo est fraichement installé.
Back to top
View user's profile Send private message
lcrprod
n00b
n00b


Joined: 07 Sep 2004
Posts: 30

PostPosted: Fri Nov 14, 2008 8:59 pm    Post subject: Reply with quote

j'ai enfin réussi a mettre en place ma connexion wifi mais c'est trop galére.

je voudrait trouver une solution plus simple si quelqu'un pourrais m'aider.

voila comment cela foncionne chez moi.

je lance NetworkManager a la main ( je ne me souviens plus de la commande pour l'activer au boot).

ensuite je lance wpa_gui, je ressaisi ma clef wap et je clique sur connecter dans l'interface.

j'ai mon fichier /etc/wpa_supplicant/wpa_supplicant.conf de bien configurer.

j'aimerais aussi pouvoir enlever le lancement de ipw3945 au démmarage car j'avais fais mes premiers essais avec.

Cordialement.

Christophe
Back to top
View user's profile Send private message
tmasscool
Apprentice
Apprentice


Joined: 27 Jul 2005
Posts: 151

PostPosted: Fri Nov 14, 2008 11:26 pm    Post subject: Reply with quote

Alors : le driver pour les iwl3945 c'est wext pour wpa_supplicant, pas iwl3945

Dans /etc/wpa_supplicant/wpa_supplicant.conf
Code:

network={
ssid="ma ssid"
proto=RSN
key_mgmt=WPA-PSK
psk="ma clef"
pairwise=CCMP
group=CCMP
priority=5
}
 


Et dans /etc/conf.d/net
Code:

modules_wlan0="wpa_supplicant"
wpa_supplicant_wlan0="-Dwext"
config_wlan0="dhcp"


ça devrait fonctionner automagically au boot ainsi...
Back to top
View user's profile Send private message
lcrprod
n00b
n00b


Joined: 07 Sep 2004
Posts: 30

PostPosted: Sat Nov 15, 2008 4:00 pm    Post subject: Reply with quote

et bien non cela ne fonctionne pas chez moi.

j'ai ceci dans le fichier net

Quote:

# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d. To create a more complete configuration,
# please review /etc/conf.d/net.example and save your configuration
# in /etc/conf.d/net (this file :]!).
#modules=("wpa_supplicant")
#wpa_supplicant_wlan0="-Diwl3945"
#wpa_supplicant_wlan0="-Dwext"
#wpa_timeout_wlan0=60
#config_wlan0=("dhcp")
#essid_wlan0="any"


dns_domain_lo="theforce"
config_eth0="dhcp"
dhcp_eth0="release"

modules_wlan0="wpa_supplicant"
#wpa_supplicant_wlan0="-Dwext"
wpa_supplicant_wlan0="-W -Dwext -iwlan0 -c /etc/wpa_supplicant/wpa_supplicant.conf -dd"
config_wlan0="dhcp"
dhcpcd_wlan0="-t 20"


et ceci dans wpa_supplicant.conf.

Quote:

# This is a network block that connects to any unsecured access point.
# We give it a low priority so any defined blocks are preferred.
#network={
# key_mgmt=NONE
# priority=-9999999
#}

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=wheel

ap_scan=1
fast_reauth=1

network={
ssid="myssid"
psk=maclef
proto=WPA
# proto=RSN
key_mgmt=WPA-PSK
pairwise=CCMP
group=CCMP
priority=0
}



j'y comprend plus rien du tout car aprés le reboot j'ai plus de wifi et impossible de le réactivé avec ces P..... de fichiers de configuration et NetworkManager de lancer
Back to top
View user's profile Send private message
tmasscool
Apprentice
Apprentice


Joined: 27 Jul 2005
Posts: 151

PostPosted: Sun Nov 16, 2008 12:09 am    Post subject: Reply with quote

Perso je n'utilise pas NetworkManager, car sous gentoo, ça fonctionne pas trop bien. De plus lorsque j'ai essayé d'utiliser ça par le passé, NetworkManager et wpa_supplicant au démarrage ne faisaient pas bon ménage...

le -iwlan0 est superflu ainsi que que le -c /etc/wpa_supplicant/wpa_supplicant.conf dans la ligne wpa_supplicant_wlan0...

Donc essaie sans le NetworkManager et enlève le timeout pour le dhcp de l'interface wlan0. 20s ça peut être insuffisant pour une interface WiFi pour obtenir une adresse IP via DHCP et de toute façon le service est démarré en background, donc ça ne poses pas de ralentissement au démarrage....

Sinon les instructions détaillées pour la configuration du Wireless sont ici : Wireless guide
Back to top
View user's profile Send private message
lcrprod
n00b
n00b


Joined: 07 Sep 2004
Posts: 30

PostPosted: Sun Nov 16, 2008 7:57 pm    Post subject: Reply with quote

j'ai unmerge NetworkManager et knetworkmanager.
j'ai ensuite modifié les fichiers comme suit et restarter mon net.wlan0 ( lien symbolique sur net.lo)

voici mes dernieres modif:

wpa_supplicant.conf

Quote:

# This is a network block that connects to any unsecured access point.
# We give it a low priority so any defined blocks are preferred.
#network={
# key_mgmt=NONE
# priority=-9999999
#}

ctrl_interface=/var/run/wpa_supplicant
ctrl_interface_group=0

ap_scan=1
fast_reauth=1

network={
ssid="mysssid"
psk=wpa key hexa
proto=WPA

key_mgmt=WPA-PSK
pairwise=CCMP
group=CCMP
priority=0
}




et le fichier net

Quote:

# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d. To create a more complete configuration,
# please review /etc/conf.d/net.example and save your configuration
# in /etc/conf.d/net (this file :]!).

modules_wlan0="wpa_supplicant"
wpa_supplicant_wlan0="-Dwext"
config_wlan0="dhcp"


résultat de ifconfig

Quote:

eth0 Link encap:Ethernet HWaddr ADDRESS_MAC
inet addr:192.168.1.20 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::21d:9ff:febe:cd28/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:22604 errors:0 dropped:0 overruns:0 frame:0
TX packets:29755 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:13395387 (12.7 MiB) TX bytes:8066046 (7.6 MiB)
Interrupt:17

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:12 errors:0 dropped:0 overruns:0 frame:0
TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:600 (600.0 B) TX bytes:600 (600.0 B)

wlan0 Link encap:Ethernet HWaddr ADDRESS_MAC
UP BROADCAST MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

wmaster0 Link encap:UNSPEC HWaddr 00-1C-BF-90-3D-25-65-74-00-00-00-00-00-00-00-00
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)



mon iwlist scan

Quote:

lo Interface doesn't support scanning.

eth0 Interface doesn't support scanning.

wmaster0 Interface doesn't support scanning.

wlan0 Scan completed :
Cell 01 - Address: ADDRESS_MAC
ESSID:"myssid"
Mode:Master
Channel:11
Frequency:2.462 GHz (Channel 11)
Quality=90/100 Signal level=-41 dBm Noise level=-127 dBm
Encryption key:on
IE: WPA Version 1
Group Cipher : TKIP
Pairwise Ciphers (2) : CCMP TKIP
Authentication Suites (1) : PSK
Bit Rates:1 Mb/s; 2 Mb/s; 5.5 Mb/s; 11 Mb/s; 18 Mb/s
24 Mb/s; 36 Mb/s; 54 Mb/s; 6 Mb/s; 9 Mb/s
12 Mb/s; 48 Mb/s
Extra:tsf=000000cb93fcbdf1




lsmod |grep 3945

Quote:

ipw3945 104224 0
iwl3945 162548 0
mac80211 132368 1 iwl3945
ieee80211 39368 1 ipw3945
firmware_class 17280 4 ipw3945,iwl3945,qla2xxx,pcmcia


je supprime le module ipw3945 mais rien ne change. D'ailleurs je ne comprend pas pourquoi ce module ce charge en mémoire.


Malgré ceci ma connexion wifi ne fonctionne pas.

je désespère vraiment.
Back to top
View user's profile Send private message
tmasscool
Apprentice
Apprentice


Joined: 27 Jul 2005
Posts: 151

PostPosted: Sat Nov 22, 2008 11:54 pm    Post subject: Reply with quote

lcrprod wrote:

Quote:

ipw3945 104224 0
iwl3945 162548 0
mac80211 132368 1 iwl3945
ieee80211 39368 1 ipw3945
firmware_class 17280 4 ipw3945,iwl3945,qla2xxx,pcmcia

je supprime le module ipw3945 mais rien ne change. D'ailleurs je ne comprend pas pourquoi ce module ce charge en mémoire.


Malgré ceci ma connexion wifi ne fonctionne pas.

je désespère vraiment.

Désinstalles ipw3945 : emerge -C ipw3945
Il y a probablement conflit avec iwlwifi...
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum