Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[dev-lang/php-5.2.6-r7] echec de compilation ... (résolu)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index French
View previous topic :: View next topic  
Author Message
regis_couraud
n00b
n00b


Joined: 03 Nov 2006
Posts: 7

PostPosted: Sat Oct 18, 2008 1:19 am    Post subject: [dev-lang/php-5.2.6-r7] echec de compilation ... (résolu) Reply with quote

Bonsoir,

Je suis en train de m'arracher les cheveux à cause d'une mise à jour qui ne se déroule pas correctement :(

Je ne comprends pas pourquoi il n'est pas content. Malgré de nombreux tests, je sèche complètement.
Voila l'erreur sur laquelle il s'arrête :

Configuring SAPI modules
checking for AOLserver support... no
checking for Apache 1.x module support via DSO through APXS... no
checking for Apache 1.x module support... no
checking whether to enable Apache charset compatibility option... no
checking for Apache 2.0 filter-module support via DSO through APXS... no
checking for Apache 2.0 handler-module support via DSO through APXS... configure: error: You have enabled Apache 2 support while your server is Apache 1.3. Please use the appropiate switch --with-apxs (without the 2)
*
* ERROR: dev-lang/php-5.2.6-r7 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 4377: Called src_compile_normal
* environment, line 4500: Called php5_2-sapi_src_compile
* environment, line 3415: Called die
* The specific snippet of code:
* ./configure --prefix=${destdir} --host=${CHOST} --mandir=${destdir}/man --infodir=${destdir}/info --sysconfdir=/etc --cache-file=./config.cache ${my_conf} ${EXTRA_ECONF} || die "configure failed";
* The die message:
* configure failed
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/dev-lang/php-5.2.6-r7/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-lang/php-5.2.6-r7/temp/environment'.
*

* Messages for package dev-lang/php-5.2.6-r7:

*
* ERROR: dev-lang/php-5.2.6-r7 failed.
* Call stack:
* ebuild.sh, line 49: Called src_compile
* environment, line 4377: Called src_compile_normal
* environment, line 4500: Called php5_2-sapi_src_compile
* environment, line 3415: Called die
* The specific snippet of code:
* ./configure --prefix=${destdir} --host=${CHOST} --mandir=${destdir}/man --infodir=${destdir}/info --sysconfdir=/etc --cache-file=./config.cache ${my_conf} ${EXTRA_ECONF} || die "configure failed";
* The die message:
* configure failed
*
* If you need support, post the topmost build error, and the call stack if relevant.
* A complete build log is located at '/var/tmp/portage/dev-lang/php-5.2.6-r7/temp/build.log'.
* The ebuild environment file is located at '/var/tmp/portage/dev-lang/php-5.2.6-r7/temp/environment'.

Pour info

[ebuild U ] dev-lang/php-5.2.6-r7 [5.2.6-r6] USE="apache2 berkdb cli crypt ctype exif gd gdbm iconv imap ipv6 ldap mysql mysqli ncurses nls pcre readline reflection session simplexml spl sqlite ssl truetype unicode xml zlib -adabas -bcmath -birdstep -bzip2 -calendar -cdb -cgi -cjk -concurrentmodphp -curl -curlwrappers -db2 -dbase -dbmaker -debug -discard-path -doc -empress -empress-bcs -esoob -fastbuild -fdftk -filter -firebird -flatfile -force-cgi-redirect -frontbase -ftp -gd-external -gmp -hash -inifile -interbase -iodbc (-java-external) -json -kerberos -kolab -ldap-sasl -libedit -mcve -mhash -msql -mssql -oci8 -oci8-instant-client -odbc -pcntl -pdo -pic -posix -postgres -qdbm -recode -sapdb -sharedext -sharedmem -snmp -soap -sockets -solid -spell -suhosin -sybase -sybase-ct -sysvipc -threads -tidy -tokenizer -wddx -xmlreader -xmlrpc -xmlwriter -xpm -xsl -yaz -zip -zip-external"

[ebuild R ] www-servers/apache-2.2.9-r1 USE="ldap ssl -debug -doc (-selinux) -sni -static -suexec -threads" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias -asis -auth_digest -authn_dbd -cern_meta -charset_lite -dbd -dumpio -ident -imagemap -log_forensic -proxy -proxy_ajp -proxy_balancer -proxy_connect -proxy_ftp -proxy_http -substitute -version" APACHE2_MPMS="-event -itk -peruser -prefork -worker" 4,828 kB

Si vous avez plus d'idée que moi je suis preneur :)
Merci d'avance


Last edited by regis_couraud on Sat Oct 18, 2008 12:20 pm; edited 1 time in total
Back to top
View user's profile Send private message
galerkin
Tux's lil' helper
Tux's lil' helper


Joined: 04 Mar 2006
Posts: 115
Location: /dev/toulouse

PostPosted: Sat Oct 18, 2008 10:34 am    Post subject: Reply with quote

Salut,

Essaie de faire ce qu'il t'indique:

il faut enlever le use apache2 pour la compilation de ton ebuild!

Code:

echo "dev-lang/php -apache2" >> /etc/portage/package.use


et essaie de relancer la compil
Back to top
View user's profile Send private message
regis_couraud
n00b
n00b


Joined: 03 Nov 2006
Posts: 7

PostPosted: Sat Oct 18, 2008 10:56 am    Post subject: Reply with quote

Salut,

Effectivement si j'enlève l'option apache2 ça compile, mais du coup je n'ai plu php qui fonctionne avec apache2 :(
Back to top
View user's profile Send private message
netfab
Veteran
Veteran


Joined: 03 Mar 2005
Posts: 1685
Location: 127.0.0.1

PostPosted: Sat Oct 18, 2008 11:00 am    Post subject: Reply with quote

Réinstalle apache, quelque chose ne va pas, le ./configure de php détecte apache 1.3.
Par curiosité, que donne :
Code:

# ls -l /usr/sbin/apxs2
Back to top
View user's profile Send private message
regis_couraud
n00b
n00b


Joined: 03 Nov 2006
Posts: 7

PostPosted: Sat Oct 18, 2008 12:19 pm    Post subject: Reply with quote

Merci. En fait, je suis un gros boulet. Il y'a quelque temps, j'avais modifié le code source d'apache (include/ap_release.h /AP_SERVER_BASEPRODUCT) afin de changer la version du serveur.

Je ne sait pas pourquois mais apparement php ce base sur ces données.

Tous est rentré dans l'ordre depuis que j'ai recompilé apache sans modifier le code source.

Maintenant j'avais deux options devant moi si je voulais continuer à modifier la version d'apache.

1) Je remodifie le source d'apache après avoir compilé php
Mais ça va vite être chiant à la prochaine mise à jour.

2) Installer www-apache/mod_security

C'est cette option que j'ai choisie.

Désolé pour le bruit, et il faut que je pense à me rappeler de ne plus faire mes mises à jour la nuit
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index French All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum