Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Portage acting strange
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
pmatos
Veteran
Veteran


Joined: 06 Jun 2003
Posts: 1220
Location: Cambridge, UK

PostPosted: Mon Sep 15, 2003 2:31 pm    Post subject: Portage acting strange Reply with quote

Hi all,

Isn't this strange?

Code:
euler root # emerge -up world
 
These are the packages that I would merge, in order:
 
Calculating world dependencies ...done!
 
euler root # emerge -up mplayer
 
These are the packages that I would merge, in order:
 
Calculating dependencies ...done!
[ebuild     U ] media-sound/xmms-1.2.8-r2 [1.2.7-r20]
[ebuild     U ] media-libs/xvid-0.9.2-r1 [0.9.1]
[ebuild     U ] media-video/mplayer-1.0_pre1 [0.90-r1]


Shouldn't these updates be reported when I typed
Code:
emerge -up world
?

What's going on?

Best regards
Back to top
View user's profile Send private message
db_404
Guru
Guru


Joined: 05 Dec 2002
Posts: 336

PostPosted: Mon Sep 15, 2003 4:18 pm    Post subject: Reply with quote

What does:
Code:
emerge -u --deep -p world

give?

That might be the 'problem' - I don't think portage lists updates
to dependencies unless you specify --deep.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum