Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Accesso internet adsl (eth1)
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
ficofico
Tux's lil' helper
Tux's lil' helper


Joined: 25 Apr 2008
Posts: 120

PostPosted: Mon Sep 22, 2008 6:44 pm    Post subject: Accesso internet adsl (eth1) Reply with quote

Ragazzi aiutatemi perche' non ce la faccio piu', non so perche' ma non riesco ad avere un accesso ad internet con la nuova installazione di gentoo, basata su baselayout 2

vi posto un po' di informazioni, ho fatto innemerevoli prove ma niente

rc.log
http://pastebin.com/m6b854fbf

rc-update show
http://pastebin.com/d440acabe

/etc/conf.d/net
http://pastebin.com/d627d0076

( con questo file ho accesso ad internet sulla gentoo amd64 sullo stesso pc)

/etc/rc.conf
http://pastebin.com/m6e53a839



Questo invece e' l'rc-update show della gentoo amd64 funzionante

rc-update show
http://pastebin.com/m7b9a085


Chiedo lumi, grazie....
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Mon Sep 22, 2008 6:48 pm    Post subject: Reply with quote

ifconfig -a mostra l'interfaccia eth0?
prova con !net.eth0
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
ficofico
Tux's lil' helper
Tux's lil' helper


Joined: 25 Apr 2008
Posts: 120

PostPosted: Mon Sep 22, 2008 7:39 pm    Post subject: Reply with quote

questo e' quello che mostra la gentoo amd64 con web funzionante

Code:
tux fico # ifconfig -a
eth1      Link encap:Ethernet  HWaddr 00:01:29:D5:B1:F0
          inet6 addr: fe80::201:29ff:fed5:b1f0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:13404 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12963 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:12733240 (12.1 Mb)  TX bytes:3058730 (2.9 Mb)
          Interrupt:18

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:4 errors:0 dropped:0 overruns:0 frame:0
          TX packets:4 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:240 (240.0 b)  TX bytes:240 (240.0 b)

ppp0      Link encap:Point-to-Point Protocol
          inet addr:87.8.1.155  P-t-P:192.168.100.1  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:13244 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12863 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:12378565 (11.8 Mb)  TX bytes:2717668 (2.5 Mb)


Questo e' quello che succede in ambiente chroot se do il comando

tux / # !net.eth0
net.eth0
bash: net.eth0: command not found
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Tue Sep 23, 2008 6:05 am    Post subject: Reply with quote

dopo esserti fatto un backup, cancella il file un backup di /etc/udev/rules/70-persistent-net.rules . poi riavvia e facci sapere.

p.s.: se non hai 70, avrai 71 ...
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
ficofico
Tux's lil' helper
Tux's lil' helper


Joined: 25 Apr 2008
Posts: 120

PostPosted: Tue Sep 23, 2008 5:31 pm    Post subject: Reply with quote

Cancellato il file ma niente

http://pastebin.com/m14c13e06
Back to top
View user's profile Send private message
nikko96
Apprentice
Apprentice


Joined: 22 Jul 2005
Posts: 229
Location: Pulcinella's Country

PostPosted: Tue Sep 23, 2008 6:11 pm    Post subject: Reply with quote

ficofico wrote:


................. cut .............

Questo e' quello che succede in ambiente chroot se do il comando

tux / # !net.eth0
net.eth0
bash: net.eth0: command not found

:?:

Hai provato a cambiare eth1 in eth0 in /etc/conf.d/net
link_ppp0="eth1" -----------> link_ppp0="eth0"
_________________
My system: cpu Intel core 2 duo e6750,mb asus p5n-e sli,scheda grafica nvidia GeForce 9600 GT,kernel 2.6.31-gentoo-r6
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Tue Sep 23, 2008 6:12 pm    Post subject: Reply with quote

ficofico wrote:
tux / # !net.eth0
net.eth0
bash: net.eth0: command not found
:evil: mettere !net.eth0 nella variabile RC_PLUG_SERVICES del file /etc/conf.d/rc o meglio ancora RC_POLU_SERVICES="net.lo !net.*"

in ogni caso nel tirare a indovinare ci ha azzecato cloc3 secondo me e per qualche strana ragione ti ritrovi sempre con eth1 al posto di eth0 quindi potresti pensare di azzerare le regole di udev.

Vista la tendenza ad eseguire senza riflettere ti faccio la nota della lavandaia:
con qfile /etc/udev/rules.d/* verificare i pacchetti proprietari delle regole
spostare il contenuto di /etc/udev/rules.d in una cartella di backup
emerge -1 per i pacchetti di cui sopra
etc-update/dispatchconf e riavviare.
Nota che prima di aver almeno lanciato emerge -1 udev non ti devi riazzardare a riavviare per nessun motivo.
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
ficofico
Tux's lil' helper
Tux's lil' helper


Joined: 25 Apr 2008
Posts: 120

PostPosted: Tue Sep 23, 2008 6:28 pm    Post subject: Reply with quote

Quote:
mettere !net.eth0 nella variabile RC_PLUG_SERVICES del file /etc/conf.d/rc o meglio ancora RC_POLU_SERVICES="net.lo !net.*"


Quote:
Hai provato a cambiare eth1 in eth0 in /etc/conf.d/net
link_ppp0="eth1" -----------> link_ppp0="eth0"


provato ma niente


Quote:
Vista la tendenza ad eseguire senza riflettere ti faccio la nota della lavandaia:
con qfile /etc/udev/rules.d/* verificare i pacchetti proprietari delle regole
spostare il contenuto di /etc/udev/rules.d in una cartella di backup
emerge -1 per i pacchetti di cui sopra
etc-update/dispatchconf e riavviare.
Nota che prima di aver almeno lanciato emerge -1 udev non ti devi riazzardare a riavviare per nessun motivo.


Non e' vero che eseguo sempre senza riflettere, e' che probabilmente tu ti sarai imbattuto in questi problemi circa 10 anni fa', mentre io sono solo 4 mesi che uso linux in generale, cmq grazie , ogni risposta di aiuto e' sempre ben accetta.
Back to top
View user's profile Send private message
ficofico
Tux's lil' helper
Tux's lil' helper


Joined: 25 Apr 2008
Posts: 120

PostPosted: Tue Sep 23, 2008 6:33 pm    Post subject: Reply with quote

non so cosa significhi ma mi fa' paura

gentoo amd64

tux fico # qfile /etc/udev/rules.d/*
media-libs/libnjb (/etc/udev/rules.d/80-libnjb.rules)
media-libs/libmtp (/etc/udev/rules.d/65-mtp.rules)
app-emulation/virtualbox-modules (/etc/udev/rules.d/60-virtualbox.rules)
media-gfx/sane-backends (/etc/udev/rules.d/70-libsane.rules)
sys-fs/udev (/etc/udev/rules.d/50-udev-default.rules)
sys-fs/udev (/etc/udev/rules.d/60-persistent-input.rules)
sys-fs/udev (/etc/udev/rules.d/60-persistent-storage-tape.rules)
sys-fs/udev (/etc/udev/rules.d/60-persistent-storage.rules)
sys-fs/udev (/etc/udev/rules.d/80-drivers.rules)
sys-fs/udev (/etc/udev/rules.d/95-udev-late.rules)
sys-fs/udev (/etc/udev/rules.d/60-cdrom_id.rules)
sys-fs/udev (/etc/udev/rules.d/61-persistent-storage-edd.rules)
sys-fs/udev (/etc/udev/rules.d/75-cd-aliases-generator.rules)
sys-fs/udev (/etc/udev/rules.d/75-persistent-net-generator.rules)
sys-fs/udev (/etc/udev/rules.d/30-kernel-compat.rules)
sys-fs/udev (/etc/udev/rules.d/40-gentoo.rules)
sys-fs/udev (/etc/udev/rules.d/40-video.rules)
sys-fs/udev (/etc/udev/rules.d/65-permissions.rules)
sys-fs/udev (/etc/udev/rules.d/90-network.rules)
sys-fs/udev (/etc/udev/rules.d/40-alsa.rules)
sys-fs/device-mapper (/etc/udev/rules.d/64-device-mapper.rules)
sys-apps/hal (/etc/udev/rules.d/90-hal.rules)




gentoo i686 in chroot

tux rules.d # dir
70-persistent-cd.rules 70-persistent-net.rules
tux rules.d # qfile /etc/udev/rules.d/*
tux rules.d #
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Tue Sep 23, 2008 7:52 pm    Post subject: Reply with quote

emerge -1 udev
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
ficofico
Tux's lil' helper
Tux's lil' helper


Joined: 25 Apr 2008
Posts: 120

PostPosted: Wed Sep 24, 2008 12:34 pm    Post subject: Reply with quote

No niente, ho installato anche udev ma se do'

qfile /etc/udev/rules.d/*

non ottengo nessuna risposta
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum