Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Risolto] Rendere persistente nomi dischi prima di udev
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
flocchini
Veteran
Veteran


Joined: 17 May 2003
Posts: 1124
Location: Milano, Italy

PostPosted: Sun May 18, 2008 1:01 am    Post subject: [Risolto] Rendere persistente nomi dischi prima di udev Reply with quote

Ho una mobo intel DP35DP sul mio serverino casalingo: controller sata ich9r e un pata marvell, funzionanti perfettamente con i rispettivi moduli. Il problema e' che al boot mi rileva SEMPRE prima i dischi SATA (tutti) e poi i PATA. Avendo il disco di sistema su controller PATA e' seccante, vuol dire che se aggiungo un SATA il pata di sistema mi cambia device, con annessi sbattimenti in grub prima e in fstab poi. La via di udev non mi sembra percorribile visto che il problema e' prima, la cosa bella poi e' che nel bios ho forzato l'ordine dei dischi secondo il mio criterio (ossia il PATA di sistema come primo disco) ma linux sembra fregarsene, ostinandosi a vedere prima i sata. Idee e soluzioni? :?: (no, mettere sata come modulo e' un workaround, non una soluzione :p)
_________________
~~ Per amore della rosa si sopportano le spine... ~~


Last edited by flocchini on Thu May 22, 2008 10:19 am; edited 1 time in total
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4665
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sun May 18, 2008 6:22 am    Post subject: Reply with quote

indirizzare le partizioni con le uuid?
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
TwoMinds
Tux's lil' helper
Tux's lil' helper


Joined: 14 Jul 2004
Posts: 146
Location: Italy

PostPosted: Sun May 18, 2008 6:24 am    Post subject: Reply with quote

...ciao... ho avuto lo stesso noioso problema per un sistema di storage con pata e sata e raid... ho optato per label + genkernel --disklabel initrd...
Back to top
View user's profile Send private message
flocchini
Veteran
Veteran


Joined: 17 May 2003
Posts: 1124
Location: Milano, Italy

PostPosted: Sun May 18, 2008 11:33 pm    Post subject: Reply with quote

cloc3 wrote:
indirizzare le partizioni con le uuid?


ecco, che anche grub leggesse le uuid mi era sfuggito, sembra una buona soluizione, testero' :)

@twominds: mi sembra macchinoso, la tengo come soluzione di scorta, tnx cmq
_________________
~~ Per amore della rosa si sopportano le spine... ~~
Back to top
View user's profile Send private message
flocchini
Veteran
Veteran


Joined: 17 May 2003
Posts: 1124
Location: Milano, Italy

PostPosted: Thu May 22, 2008 10:19 am    Post subject: Reply with quote

orpo, funziona davvero ;)
_________________
~~ Per amore della rosa si sopportano le spine... ~~
Back to top
View user's profile Send private message
elegos
n00b
n00b


Joined: 11 Sep 2004
Posts: 51
Location: Milano, Italy

PostPosted: Mon May 26, 2008 12:52 pm    Post subject: Reply with quote

Ciao flocchini!

Credo di avere un problema molto simile al tuo...
Ho usato genkernel, quindi utilizzo initramfs per poi passare al kernel.

Questa è la lista dei miei device per UUID:
Code:
drwxr-xr-x 2 root root 140 May 26  2008 .
drwxr-xr-x 6 root root 120 May 26  2008 ..
lrwxrwxrwx 1 root root  10 May 26  2008 2C88743C8874071C -> ../../sda2
lrwxrwxrwx 1 root root  10 May 26  2008 2b8b67b6-7cde-4ad9-ae22-ef9933d952a4 -> ../../sda6
lrwxrwxrwx 1 root root  10 May 26  2008 300fcc30-9d97-48fa-9a53-591f4e09e46a -> ../../sda4
lrwxrwxrwx 1 root root  10 May 26  2008 3db5ba52-3de9-486e-8e68-6a9c995bd9ac -> ../../sda5
lrwxrwxrwx 1 root root  10 May 26  2008 593F3C5D05388D2D -> ../../sda1


la ROOT è in /dev/sda5

il mio grub è così configurato:
Code:
title           Gentoo 2008.0 beta 2
root            (hd0,4)
kernel          /boot/kernel-genkernel-x86_64-2.6.24-gentoo-r8 root=/dev/ram0 init=/linuxrc ramdisk=8192 real_root=UUID=3db5ba52-3de9-486e-8e68-6a9c995bd9ac udev
initrd          /boot/initramfs-genkernel-x86_64-2.6.24-gentoo-r8


Eppure continua a rispondermi
Code:
>> Activating mdev
ls: : No such file or directory
>> Determining root device...
/init: /init: 453: blkid: not found
!! Could not find the root block device: UUID=3db5ba52-3de9-486e-8e68-6a9c995bd9ac is not a valid root device

Ho un portatile HP DV9570EL, non saprei proprio dirti come è collegato l'HD (anche se 9 su 10 è in SATA).

Potresti aiutarmi?
Grazie :)
Back to top
View user's profile Send private message
Lioben
Tux's lil' helper
Tux's lil' helper


Joined: 02 Mar 2008
Posts: 148

PostPosted: Mon May 26, 2008 1:22 pm    Post subject: Reply with quote

Mentre mi ripreparo ad installare di nuovo tutto da 0 ................mi accodo pure io con il solito identico problema di elegos.............il mio è un hardisk SATA pero'.
_________________
Il destino è contro di me ?! TANTO PEGGIO PER LUI!!

Computer DESKTOP Acer E700- IE74
INTEL CORE2 QUAD Q6600
RAM 2 GB DDR II
ATI RADEON X1650SE 1024 RAM dedicata
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum