Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[Install]Nuovo piccolo&veloce pinguino..forse..[Risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
xoen
Guru
Guru


Joined: 06 Sep 2003
Posts: 472
Location: /dev/null

PostPosted: Mon Sep 08, 2003 10:27 am    Post subject: [Install]Nuovo piccolo&veloce pinguino..forse..[Risolto] Reply with quote

Da un cucciolo di Gentoo a Gentoo Adulti ... pazienti si spera ;)

Allora : Ho cominciato a conoscere Gentoo grazie ad un articolo su Linux Magazine di Settembre (2003)...e sono deciso ad installare Gentoo! :!:

Ho scaricato da www.linuxiso.org la prima immagine di Gentoo quella per Athlon XP GPS...

Inserita premo invio niente...riprovo con gentoo acpi e parte..si apre la shell...alcuni caratteri li scrive a cacchio allora riavvio e do' gentoo acpi dokeymap scelgo la tastiera it .. si parte..

#links /mnt/cdrom/install.html

seguo tutte le istruzioni (su un'altra shell) passo passo...ed e' fantastico mi rendo conto che sto creando la distro dal nulla ;)

Cmq...

#emerge -k sys-kernel/gaming-sources
#emerge genkernel
#genkernel

... make dep .. make bzImage .. : aborting .. porca putt..

calmo rilassato :

#genkernel
..make dep .. make bzImage .. make modules (evvai..) .. : aborting ...

che fare?

la prima volta ero riuscito a compilare il kernel... ma all'avvio dopo il boot-loader mi dava kernel panic..

ho provato anche con #genkernel --config ..stessa storia

... ho provato a compilarlo manualmente nada! non penso sia il kernel che ho scelto (vorrei che il mio computer sia velocissimo per applicazioni multimediali..ho fatto bene a scegliere sto kernel?!)

Cmq ho provato anche con i gentoo-sources...

PS : Quando do emerge -k sys-kernel/... o quello che e' dice che non riesce a scaricare .. ma io ho gia' copiato i pacchetti dal cd1 ... ogni volta (non l'ho dimenticato o ho sbagliato a dare il comando perche' e' successo 5 volte !) devo ridare il comando cp -a /mnt/cdrom... e' un bug?

[OT ?] PS2 : Ho scaricato con GetRight da www.linuxiso.org il cd2 di gentoo per Athlon XP ma ad un certo punto sembra che il download sia finito...non vorrei che il file iso sia corrotto..se provo a masterizzarlo nero non da problemi a caricarlo..se provo a montarlo nel Clone Virtual Drive o come diavolo si chiama non da problemi...ma se apro un file con WinRAR dice che e' corrotto e' normale?i file .tbz2 non sono file normali giusto?ma alcuni li apre..lo devo riscaricare? :evil:
E' normale che nel cd ci sia solo la directory /packages/All con 219 files

[PS3] Il mio computer :
MotherBoard : Asus A7V8X
CPU : AMD Athlon XP 2000+
RAM : 768 MB DDR 333
HD : Maxtor 120 GB ATA133
Scheda Video : GeForce 2 MX 400

... per compilare il tutto da Stage 1 come sono messo? ho notato che la mia Scheda di rete integrata e' rilevata ed installata! ci sono gia' i driver per la GeForce! posso abilitare l'ULTRA DMA per l'HD...ma e' grandiosa Gento!!!! :lol:

Ciao e scusate se sono stato prolisso...
_________________
xoen.Blog()
god@paradise # tar xfvjp big-bang.tar.bz2 -C universe


Last edited by xoen on Fri Sep 12, 2003 5:41 pm; edited 3 times in total
Back to top
View user's profile Send private message
koma
Advocate
Advocate


Joined: 06 Jun 2003
Posts: 2700
Location: Italy

PostPosted: Mon Sep 08, 2003 10:47 am    Post subject: Reply with quote

Solito consiglio che abbiamo dato ormai milioni di volte segui la guida ufficiale di gentoo.
Non quella della rivista (che è proprio sbagliata).
Se seguirai passo passo la guida gentoo fidati che non avrai problemi di sorta. (o meglio si spera ;) )
http://www.gentoo.it/doc/gentoo-x86-1.4-install.html
_________________
Remember! Gnu is not Unix!
http://www.youtube.com/watch?v=_yoJI-Tl94g GLORY GLORY HYPNOTOAD
Linux Counter[code:1]
User n° #466586
ID 375005 EkatombeII
ID 375006 Apocalypto
ID 375007 KHP[/code:1]
Back to top
View user's profile Send private message
xoen
Guru
Guru


Joined: 06 Sep 2003
Posts: 472
Location: /dev/null

PostPosted: Mon Sep 08, 2003 10:51 am    Post subject: Quale rivista? Reply with quote

Io ho letto la guida che dici tu in italiano...e seguo quella in inglese nel file /mnt/cdrom/install.html passo passo...

PS : Leggasi con tono NON arrogante ;)
_________________
xoen.Blog()
god@paradise # tar xfvjp big-bang.tar.bz2 -C universe
Back to top
View user's profile Send private message
koma
Advocate
Advocate


Joined: 06 Jun 2003
Posts: 2700
Location: Italy

PostPosted: Mon Sep 08, 2003 11:03 am    Post subject: Re: Quale rivista? Reply with quote

xoen wrote:
Io ho letto la guida che dici tu in italiano...e seguo quella in inglese nel file /mnt/cdrom/install.html passo passo...

PS : Leggasi con tono NON arrogante ;)

Non importa il tono cmq fidati usa la guida in italiano è stratestata e comprende passaggi che INSTALL non prevede nè consiglia ma semplicemente ignora.
In più sul sito ww.gentoo.it troverai molti doc utilissimi.
Fidati :!: 8)
_________________
Remember! Gnu is not Unix!
http://www.youtube.com/watch?v=_yoJI-Tl94g GLORY GLORY HYPNOTOAD
Linux Counter[code:1]
User n° #466586
ID 375005 EkatombeII
ID 375006 Apocalypto
ID 375007 KHP[/code:1]
Back to top
View user's profile Send private message
koma
Advocate
Advocate


Joined: 06 Jun 2003
Posts: 2700
Location: Italy

PostPosted: Mon Sep 08, 2003 11:05 am    Post subject: Reply with quote

PS dimenticavo
Benvenuto e ricorda la pazienza di un pinguino è paragonabile solo alla memoria di un elefante CAPITO?

:twisted: :twisted: :twisted:
_________________
Remember! Gnu is not Unix!
http://www.youtube.com/watch?v=_yoJI-Tl94g GLORY GLORY HYPNOTOAD
Linux Counter[code:1]
User n° #466586
ID 375005 EkatombeII
ID 375006 Apocalypto
ID 375007 KHP[/code:1]
Back to top
View user's profile Send private message
teknux
Guru
Guru


Joined: 19 Feb 2003
Posts: 517
Location: Rome, IT

PostPosted: Mon Sep 08, 2003 11:09 am    Post subject: Re: Un nuovo piccolo e veloce pinguino...forse... Reply with quote

xoen wrote:
Da un cucciolo di Gentoo a Gentoo Adulti ... pazienti si spera ;)

benvenuto, qui sono tutti mooolto pazienti e gentili :wink:

xoen wrote:

la prima volta ero riuscito a compilare il kernel... ma all'avvio dopo il boot-loader mi dava kernel panic..

io farei a mano senza genkernel, ma soprattutto se ricevi dei kernel panic devi controllare che tipo di errore ti da (ed eventualmente postalo qui). è probabile che hai sbagliato qualcosa nella configurazione del tuo kernel (tipo mettere il supporto al tuo filesystem come modulo...) oppure nella configurazione del bootloader potresti aver sbagliato qualche settaggio (come la root da montare, mi è successo ieri :oops:)[/quote]

xoen wrote:

... ho provato a compilarlo manualmente nada! non penso sia il kernel che ho scelto (vorrei che il mio computer sia velocissimo per applicazioni multimediali..ho fatto bene a scegliere sto kernel?!)

qui non posso aiutarti, io uso solo i kernel vanilla, provenendo da slack mi è rimasto questo vizio :D

xoen wrote:

PS : Quando do emerge -k sys-kernel/... o quello che e' dice che non riesce a scaricare .. ma io ho gia' copiato i pacchetti dal cd1 ... ogni volta (non l'ho dimenticato o ho sbagliato a dare il comando perche' e' successo 5 volte !) devo ridare il comando cp -a /mnt/cdrom... e' un bug?

beh innanzi tutto non so se il kernel che hai scelto sia incluso nel CD (basta controllare), eventualmente prova a configurare la connessione ad internet, e ti togli il dente

xoen wrote:

[OT ?] PS2 : Ho scaricato con GetRight da www.linuxiso.org il cd2 di gentoo per Athlon XP ma ad un certo punto sembra che il download sia finito...non vorrei che il file iso sia corrotto..se provo a masterizzarlo nero non da problemi a caricarlo..se provo a montarlo nel Clone Virtual Drive o come diavolo si chiama non da problemi...ma se apro un file con WinRAR dice che e' corrotto e' normale?i file .tbz2 non sono file normali giusto?ma alcuni li apre..lo devo riscaricare?

mistero della fede... boh! alla peggio se continua così ed hai banda per scaricare, prova ad usare un mirror più ufficiale per la iso...
xoen wrote:

E' normale che nel cd ci sia solo la directory /packages/All con 219 files

beh è un sistema ababstanza basilare di default, non ti sembrano già tanti 219 pacchetti? :D

xoen wrote:

... per compilare il tutto da Stage 1 come sono messo? ho notato che la mia Scheda di rete integrata e' rilevata ed installata! ci sono gia' i driver per la GeForce! posso abilitare l'ULTRA DMA per l'HD...ma e' grandiosa Gento!!!! :lol:


per niente male, anzi ottima! poi i tempi dipendono anche da cosa installi, per capirci solo kde ti prende almeno 10 ore di compilazione, per il resto (sempre in base a cosa/quanto metti) diciamo che in linea di massima non più di 6 ore. il tutto trascurando eventuali problemi, difficile che si presentino ma vanno considerati ;)

spero di esserti stato di aiuto :wink:

saluti,
tek
Back to top
View user's profile Send private message
JacoMozzi
l33t
l33t


Joined: 12 May 2003
Posts: 645
Location: Giubiasco world(EU(CH(TI)))

PostPosted: Mon Sep 08, 2003 11:27 am    Post subject: Reply with quote

Ciao e benvenuto....
Jaco
Back to top
View user's profile Send private message
shev
Bodhisattva
Bodhisattva


Joined: 03 Feb 2003
Posts: 4084
Location: Italy

PostPosted: Mon Sep 08, 2003 11:28 am    Post subject: Re: Un nuovo piccolo e veloce pinguino...forse... Reply with quote

xoen wrote:
Da un cucciolo di Gentoo a Gentoo Adulti ... pazienti si spera ;)


Prima di tutto benvenuto tra noi! ;)

Quote:
(vorrei che il mio computer sia velocissimo per applicazioni multimediali..ho fatto bene a scegliere sto kernel?!)


Sul resto t'hanno bene o male già risposto, quindi non aggiungo altro. Sulla scelta del kernel vedo che nessuno t'ha detto nulla, quindi ti do un paio di consigli io: il primo è di dare un'occhiata alla sezione tips&tricks di gentoo.it, c'è un doc che spiega brevemente pregi e difetti dei vari kernel disponibili in gentoo. Entrando nello specifico dei due kernel che citavi, io li ho provati entrambi e tra i due preferisco i gentoo-sources. Come prestazioni sono simili, forse meglio i gentoo imho, quindi scegliere l'uno o l'altro poco importa, sono due ottime scelte.
Poi anche per il tipo di kernel si tratta di gusti e scelte personali, non c'è la "scelta giusta" ;)

Quote:
Ciao e scusate se sono stato prolisso...


Scusa di cosa? Imho non è un difetto spiegare con calma e nei dettagli i propri problemi, certamente aiuta chi deve risponde ad avere le idee chiare. :D
_________________
Se per vivere ti dicono "siediti e stai zitto" tu alzati e muori combattendo
Back to top
View user's profile Send private message
xoen
Guru
Guru


Joined: 06 Sep 2003
Posts: 472
Location: /dev/null

PostPosted: Mon Sep 08, 2003 1:00 pm    Post subject: Riprovo con emerge -k sys-kernel/gentoo-sources Reply with quote

Visto che la prima volta avevo avuto successo con il kernel gentoo (che culo!) riprovo appena mi disconnetto..
_________________
xoen.Blog()
god@paradise # tar xfvjp big-bang.tar.bz2 -C universe
Back to top
View user's profile Send private message
xoen
Guru
Guru


Joined: 06 Sep 2003
Posts: 472
Location: /dev/null

PostPosted: Mon Sep 08, 2003 1:22 pm    Post subject: #cp -a /mnt/cdrom/packages /mnt/gentoo/usr/portage/packages Reply with quote

La versione italiana della guida all'installazione dice di dare questo comando piuttosto che

#cp -a /mnt/cdrom/packages/* /mnt/gentoo/usr/portage/packages

Del file install.html contenuto nel CD-Rom d'installazione...aspettate ho guardato la guida in inglese ed e' cosi' anche in quella...quindi e' un errore nel file install.html del CD...
_________________
xoen.Blog()
god@paradise # tar xfvjp big-bang.tar.bz2 -C universe
Back to top
View user's profile Send private message
xoen
Guru
Guru


Joined: 06 Sep 2003
Posts: 472
Location: /dev/null

PostPosted: Mon Sep 08, 2003 1:26 pm    Post subject: Re: Un nuovo piccolo e veloce pinguino...forse... Reply with quote

teknux wrote:
beh è un sistema ababstanza basilare di default, non ti sembrano già tanti 219 pacchetti? :D


Non mi lamentavo dei 219 pacchetti ;) ma era avere un riscontro da voi e capire se almeno a livello di directory e files era come quella che avete voi...


PS : Ah grazie a tutti per il caloroso benvenuto :oops:
_________________
xoen.Blog()
god@paradise # tar xfvjp big-bang.tar.bz2 -C universe
Back to top
View user's profile Send private message
xoen
Guru
Guru


Joined: 06 Sep 2003
Posts: 472
Location: /dev/null

PostPosted: Mon Sep 08, 2003 1:43 pm    Post subject: E lo squalo di JacoMozzi e' sistemato... Reply with quote

Per la serie icone per gentoo...lo squalo di JacoMozzi in bolla ;)

[img:971c811055]http://xoen.altervista.org/gentoo_icons/shark_JacoMozzi.png[/img:971c811055]

... spero che non te la prendi ;)
_________________
xoen.Blog()
god@paradise # tar xfvjp big-bang.tar.bz2 -C universe
Back to top
View user's profile Send private message
koma
Advocate
Advocate


Joined: 06 Jun 2003
Posts: 2700
Location: Italy

PostPosted: Mon Sep 08, 2003 1:46 pm    Post subject: Re: E lo squalo di JacoMozzi e' sistemato... Reply with quote

xoen wrote:
Per la serie icone per gentoo...lo squalo di JacoMozzi in bolla ;)

[img:2b4d3a869c]http://xoen.altervista.org/gentoo_icons/shark_JacoMozzi.png[/img:2b4d3a869c]

... spero che non te la prendi ;)

I file png non sono visibili singolarmente su altervista devi convertirli in jpg
_________________
Remember! Gnu is not Unix!
http://www.youtube.com/watch?v=_yoJI-Tl94g GLORY GLORY HYPNOTOAD
Linux Counter[code:1]
User n° #466586
ID 375005 EkatombeII
ID 375006 Apocalypto
ID 375007 KHP[/code:1]
Back to top
View user's profile Send private message
xoen
Guru
Guru


Joined: 06 Sep 2003
Posts: 472
Location: /dev/null

PostPosted: Mon Sep 08, 2003 1:53 pm    Post subject: Reply with quote

Some others icons...

[img:65a675e8d2]http://xoen.altervista.org/gentoo_icons/l33t_UNK_mathematica.png[/img:65a675e8d2] an icon for Mathematica a great mathematic software .. also for linux (commercial :()

[img:65a675e8d2]http://xoen.altervista.org/gentoo_icons/l33t_P2P_emule2.png[/img:65a675e8d2]
Another icon for emule..the other don't impress me too.. (scuse me)

[img:65a675e8d2]http://xoen.altervista.org/gentoo_icons/l33t_P2P_kazaa.png[/img:65a675e8d2]
Another KaZaA icon ;)

[img:65a675e8d2]http://xoen.altervista.org/gentoo_icons/ship_magne.png[/img:65a675e8d2]

Do you remember this sheep? the sheep is back :evil: ;)
_________________
xoen.Blog()
god@paradise # tar xfvjp big-bang.tar.bz2 -C universe
Back to top
View user's profile Send private message
xoen
Guru
Guru


Joined: 06 Sep 2003
Posts: 472
Location: /dev/null

PostPosted: Mon Sep 08, 2003 1:56 pm    Post subject: Reply with quote

Grazie koma .. cmq l'ultimo post era per la discussione delle icone per le applicazioni in gentoo...

Allora come faccio?devo trovare un'altro server?sai se xoom lo permette?

PS : Forse e' di qualcuno di voi il mirino laser che ho puntato sulla tempia?
_________________
xoen.Blog()
god@paradise # tar xfvjp big-bang.tar.bz2 -C universe
Back to top
View user's profile Send private message
shev
Bodhisattva
Bodhisattva


Joined: 03 Feb 2003
Posts: 4084
Location: Italy

PostPosted: Mon Sep 08, 2003 2:34 pm    Post subject: Re: #cp -a /mnt/cdrom/packages /mnt/gentoo/usr/portage/packa Reply with quote

xoen wrote:

Del file install.html contenuto nel CD-Rom d'installazione...aspettate ho guardato la guida in inglese ed e' cosi' anche in quella...quindi e' un errore nel file install.html del CD...


Non so se di errore si tratti (nel doc sul cvs questa fantomatica riga è stata cambiata almeno cinque volte!), cmq non bisogna fare troppo affidamento al documento presente sul cd per stessa ammissione dei developer gentoo, infatti come normale che sia quel documento non può essere aggioranto come la controparte sul sito, che invece è corretta e aggiornata spesso e volentieri.

xoen wrote:
Visto che la prima volta avevo avuto successo con il kernel gentoo (che culo!) riprovo appena mi disconnetto..


Non si tratta di "culo", la gentoo è una distribuzione pulita e logica come poche, quindi se qualcosa ti funziona non è fortuna ma soltanto normale, non siamo su win qui :lol:

Cmq piccolo consiglio: non c'è bisogno di mandare mille messaggi per rispondere ai vari post, ne basta uno ben quotato, come t'ho fatto vedere qui sopra ;)

p.s. Le immagini/icone che hai postato non si vedono...
_________________
Se per vivere ti dicono "siediti e stai zitto" tu alzati e muori combattendo
Back to top
View user's profile Send private message
koma
Advocate
Advocate


Joined: 06 Jun 2003
Posts: 2700
Location: Italy

PostPosted: Mon Sep 08, 2003 3:07 pm    Post subject: Reply with quote

xoen wrote:
Grazie koma .. cmq l'ultimo post era per la discussione delle icone per le applicazioni in gentoo...

Allora come faccio?devo trovare un'altro server?sai se xoom lo permette?

PS : Forse e' di qualcuno di voi il mirino laser che ho puntato sulla tempia?
usare gimp e convertirle in jpg? :D poi per preservare la trasparenza le metti in un tar.gz e le sbatti sul sito e ci piazzi il link in un post
_________________
Remember! Gnu is not Unix!
http://www.youtube.com/watch?v=_yoJI-Tl94g GLORY GLORY HYPNOTOAD
Linux Counter[code:1]
User n° #466586
ID 375005 EkatombeII
ID 375006 Apocalypto
ID 375007 KHP[/code:1]
Back to top
View user's profile Send private message
xoen
Guru
Guru


Joined: 06 Sep 2003
Posts: 472
Location: /dev/null

PostPosted: Mon Sep 08, 2003 4:31 pm    Post subject: Kernel Panic dopo installazione Reply with quote

Sono riuscito a compilare il kernel ... (ma puo' essere che :aborting compare se si preme qualche tasto anche stupido tipo

freccia sx?!)

Ma all'avvio : kernel panic...stavolta pero' posto anche il messaggio che ho copiato su un foglio :(

Code:
Hid-core.c : USB HID Support drivers
---- Detected hid hardware
---- Scanning for usb-storage ... Initializing USB Mass Driver ...

usb.c: registered new driver usb-storage
USB MASS storage support registered

---- Detected usb-storage hardware

Kernel Panic : Attempted to kill init!


Se provo da floppy ...

Code:
Loading .......
Uncompressing Linux ...

Invalid compressed format (err=1)

 -- System Halted


Se provo passando al kernel l'opzione nousb ...

Code:
3w-xxxx: No cards with valid units found.

---- Scanning for NCR53c406a: no available ports found

---- Scanning for aacraid...Red Hat/Adaptec aacraid driver, Sep 8 2003

---- Scanning for dpt_i20...Loading Adapter I20 RAID : Version 2.4 Build 5 Detecting Adaptec I20 RAID controllers...

---- Scanning for sim710...sim710 : No NCR53C710 Adapter Found.


Kernel panic : Attempted to kill init!


PS : C'era anche qualcos'altro scritto in bianco , ma ho postato solo le ultime righe prima del kernel panic ... abbiate pieta' di me :(


Mod edit: formattato un po' umanamente. PF non usate linee eccessivamente lunghe senza spazi dato che non possono essere wrappate. Il BBCode è utile per rendere più chiaro un post, usatelo senza timore. - bsolar
_________________
xoen.Blog()
god@paradise # tar xfvjp big-bang.tar.bz2 -C universe
Back to top
View user's profile Send private message
xoen
Guru
Guru


Joined: 06 Sep 2003
Posts: 472
Location: /dev/null

PostPosted: Mon Sep 08, 2003 10:18 pm    Post subject: ... Reply with quote

Neanche l'undicesima installazione e' andata a buon fine...sono nella media?! ;)

Cmq..Il mio presentimento era giusto...

genkernel una volta avviato se si preme qualche tasto (tipo freccia sx...) lo prende come una sorta di comando di annullamento...non proprio normale!

Adesso il kernel kompila alla normalita...ma al boot sempre kernel panic...

Ho provato anche a non emergere hotplug ma nada...attendo & riprovo :D


PS : BSolar ... sono nuovo..cmq ho notato adesso il *tasto* code che usero' d'ora in poi...;)
_________________
xoen.Blog()
god@paradise # tar xfvjp big-bang.tar.bz2 -C universe
Back to top
View user's profile Send private message
shev
Bodhisattva
Bodhisattva


Joined: 03 Feb 2003
Posts: 4084
Location: Italy

PostPosted: Tue Sep 09, 2003 8:26 am    Post subject: Re: ... Reply with quote

xoen wrote:

genkernel una volta avviato se si preme qualche tasto (tipo freccia sx...) lo prende come una sorta di comando di annullamento...non proprio normale!

Adesso il kernel kompila alla normalita...ma al boot sempre kernel panic...


Ma compilare il kernel "manualmente" ti pare proprio brutto? Se ne sei appena appena capace (e basta un howto o gli help del kernel per capire come si fa) conviene farlo da sè, ottieni certamente un kernel migliore e più prestante. Usi Gentoo e poi ti accontenti di genkernel? :D
Ovviamente imho.
_________________
Se per vivere ti dicono "siediti e stai zitto" tu alzati e muori combattendo
Back to top
View user's profile Send private message
xoen
Guru
Guru


Joined: 06 Sep 2003
Posts: 472
Location: /dev/null

PostPosted: Tue Sep 09, 2003 8:45 am    Post subject: Re: ... Reply with quote

Shev wrote:

Ma compilare il kernel "manualmente" ti pare proprio brutto? Se ne sei appena appena capace (e basta un howto o gli help del kernel per capire come si fa) conviene farlo da sè, ottieni certamente un kernel migliore e più prestante. Usi Gentoo e poi ti accontenti di genkernel? :D
Ovviamente imho.


Io configuro il kernel con make menuconfig .. lo compilo make bzImage poi make modules ... e make modules install ... contento?! poi riavvio e ho di nuovo il kernel panic...se almeno dal kernel panic che ho postato mi dite cosa e' sbagliato nel kenel...;)

C'e' qualcosa che non va ma non conosco il kernel abbastanza per capire cos'e' ... nella documentazione (italiana) c'e' scritto che l'autorilevamento scsi puo' causare problemi con alcune schede di rete...sembrerebbe il mio caso...anche se la documentazione si riferisce all'avvio del liveCD e non al boot del sistema...

PS : Motherboard Asus A7V8X con chipset Via KT400 e scheda di rete Broadcom 10/100 Mbit bm4400 o qualcosa del genere ...


PS : :D Grazie per i vostri sforze , anche se risultassero vani :(
_________________
xoen.Blog()
god@paradise # tar xfvjp big-bang.tar.bz2 -C universe
Back to top
View user's profile Send private message
shev
Bodhisattva
Bodhisattva


Joined: 03 Feb 2003
Posts: 4084
Location: Italy

PostPosted: Tue Sep 09, 2003 9:15 am    Post subject: Re: ... Reply with quote

xoen wrote:

Io configuro il kernel con make menuconfig .. lo compilo make bzImage poi make modules ... e make modules install ... contento?! poi riavvio e ho di nuovo il kernel panic...se almeno dal kernel panic che ho postato mi dite cosa e' sbagliato nel kenel...;)


Attento che se installi a mano o con genkernel le cose da fare per configurare il bootloader che usi (e non solo forse...) sono diverse, dai un'occhiata alla guida a riguardo.

Quote:

PS : :D Grazie per i vostri sforze , anche se risultassero vani :(


Se usi lilo e hai messo la riga:
Code:
append="root=/dev/ram0 init=/linuxrc


prova a sotituire /dev/ram0 con la tua partizione root reale, ad alcuni che hanno avuto il tuo provblema dava il kpanic proprio per questo.

p.s.: o se non va da un'occhiata qui
_________________
Se per vivere ti dicono "siediti e stai zitto" tu alzati e muori combattendo
Back to top
View user's profile Send private message
johnnystuff
Tux's lil' helper
Tux's lil' helper


Joined: 28 Aug 2003
Posts: 141

PostPosted: Tue Sep 09, 2003 11:03 am    Post subject: Reply with quote

Avevo lo stesso problema. Il fatto è che devi aggiornare lilo ogni volta che cambi il file /boot/bzImage (ammesso che tu tenga solo UNA immagine del kernel in /boot che si chiama bzImage).
In pratica, dopo cp /usr/src/linux/srch/i386/boot/bzImage /boot, dicci cosa ti dice "/sbin/lilo -v", sempre che al reboot tu abbia ancora problemi.....
:roll:
Back to top
View user's profile Send private message
xoen
Guru
Guru


Joined: 06 Sep 2003
Posts: 472
Location: /dev/null

PostPosted: Tue Sep 09, 2003 2:50 pm    Post subject: Reply with quote

Ho provato a configurare con
Code:
genkernel --configure


e ho levato di tutto ... usb..firewire...dispositivi di rete...bello leggerino sto kernel...

ho configurato lillo ;) e al riavvio kernel panic...

alche ho pensato (DOPO 11 INSTALLAZIONI...) perche' ogni volta andarsi a ricompilare il kernel e riconfigurare tutto l'ambaradam?! ... monto le partizioni che mi interessano ... mi chrutto con
Code:
chroot /mnt/gentoo bash

... e modifico quello che devo modificare ... mi e' venuto molto meglio fare delle prove...


Ho provato a modificare ram0 con ram (symlink a ram1) ... cambia il kernel panic...

Allora ho provato a configurare lilo come se avessi configurato il kernel a mano...cioe' senza append="root=/dev/ram0 init=/linuxrc"... senza initrd (io non ho mai usato ste cose e funzionavano i kernel compilati a mano..)... ed indovinate ... niente kernel panic .... parte ma qualche errore lo da sempre .. non so se e' perche' ho tolto molta roba dal kernel o se e' per le opzioni tolte a caso...

Scev wrote:

prova a sotituire /dev/ram0 con la tua partizione root reale, ad alcuni che hanno avuto il tuo provblema dava il kpanic proprio per questo.


quel root in append significa questo? cioe' lo devo fare puntare alla mia partizione root reiserfs?

johnnystuff wrote:

Il fatto è che devi aggiornare lilo ogni volta che cambi il file /boot/bzImage (ammesso che tu tenga solo UNA immagine del kernel in /boot che si chiama bzImage)

Si lo so, mentre con grub non c'e' questa esigenza..cmq avevo fatto un symlink al kernel (l'avevo chiamato kernel con molta fantasia;)) in previsione di altri kernel...ma poi ho optato per farlo puntare direttamente da lilo visto la precisione con cui si devono seguire le istruzioni per installare sta distro...


PRIME IMPRESSIONI ...

I pochi minuti che l'ho potuto usare ... ho notato una cosa stupenda...il mio HD non macina..sara' che ho usato hdparm in fase d'installazione...

Ricordate il CD2 che per magia in poco tempo si era scaricato?! ... lo masterizzo ... a livello di filesystem (iso9660) tutto OK...ma alcuni file sono corrotti...li ho copiati in /usr/portage/packages...e quando provo installare kde con

Code:

#USE="bindist" emerge -k kde


I pacchetti che in teoria installa prima per il discorso della dipendenza...risultano non validi o cmq il senzo e' quello...


PS : Non la considero ancora installata...cmq secondo voi 11 volte per arrivare al login vi sembrano nella media :?: :!: 8O :D :D

Sony PS2 : Io comunque non mi arrendo ...[/quote]
_________________
xoen.Blog()
god@paradise # tar xfvjp big-bang.tar.bz2 -C universe
Back to top
View user's profile Send private message
shev
Bodhisattva
Bodhisattva


Joined: 03 Feb 2003
Posts: 4084
Location: Italy

PostPosted: Tue Sep 09, 2003 3:14 pm    Post subject: Reply with quote

xoen wrote:

alche ho pensato (DOPO 11 INSTALLAZIONI...) perche' ogni volta andarsi a ricompilare il kernel e riconfigurare tutto l'ambaradam?! ... monto le partizioni che mi interessano ... mi chrutto... mi e' venuto molto meglio fare delle prove...


8O 8O Ma reinstallavi tutto ogni volta per questo? 8O 8O
Non te l'abbiamo detto, ma era sottointeso che si dovesse chroottare e riprendere da dove avevi sbagliato.... incredibile :lol:
Quote:

non so se e' perche' ho tolto molta roba dal kernel o se e' per le opzioni tolte a caso...


Dipende da che errori sono, cmq se parte è già un buon segno, gli errorii poi si tolgono con calma ;)

Quote:
Shev wrote:

prova a sotituire /dev/ram0 con la tua partizione root reale, ad alcuni che hanno avuto il tuo provblema dava il kpanic proprio per questo.


quel root in append significa questo? cioe' lo devo fare puntare alla mia partizione root reiserfs?


Così dicono, diversi sul forum hanno avuto questo problema e l'hanno risolto così. Oppure toglilo direttamente, fa un po' di prove, cmq dovrebbe essere quello che rompe.

Quote:
PS : Non la considero ancora installata...cmq secondo voi 11 volte per arrivare al login vi sembrano nella media :?: :!: 8O :D :D


In media per vincere il premio di "utente Gentoo più tenace" sicuramente :lol: (non di dico quanti tentativi ho fatto io o ti deprimi... diciamo che il numero dei miei tentativi è uno dei divisori che il tuo numero ha in comune con tutti i suoi fratelli "primi" ;) )

p.s.: sui pacchetti corrotti non ho ben capito, ma se sono corrotti riscarica l'iso, non credo sia un problema tuo/mio/di gentoo.
_________________
Se per vivere ti dicono "siediti e stai zitto" tu alzati e muori combattendo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum