Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
GCJ as Java SDK, dead, long live IcedTea!
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 18, 19, 20 ... 24, 25, 26  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Fri Apr 18, 2008 9:30 am    Post subject: Reply with quote

Andrew's overlay (from http://iced-tea.org/wiki/GentooBuildInstructions)
- The ebuild actually depends on having gcj-jdk installed and set as active VM (missing in DEPEND)
- need to create a link from /usr/bin/ecj-3.3 to /usr/bin/ecj - otherwhise the javac symlink in gcj-jdk points to nowhere.
- need to add following to the ebuild in src_compile():
Code:
        LIBFFI_CFLAGS="-I/usr/lib64/gcj-4.3.0/include"
        LIBFFI_LIBS="-L/usr/lib64/gcj-4.3.0/lib64 -lffi"
        export LIBFFI_CFLAGS LIBFFI_LIBS

It configures and starts compiling fine using gcj+ecj, but errors out later in the build process compiling the c++ files, not finding ffi.h (seems autofoo is broken there, configure did find ffi lib/headers)


Now.. removing gcj-jdk, gcj and all stuff from andrew's overlay again, and trying geki's overlay - without gcj first.
Code:
 * Using: sun-jdk-1.6
...some coffe later...
 * Setting 64bit nsplugin to icedtea-6

YAY!
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2325
Location: Germania

PostPosted: Fri Apr 18, 2008 11:26 am    Post subject: Reply with quote

Need4Speed I used sun-jdk-1.6.0.5 :o --- .6 is out, btw.

gimpel yaya! :twisted:
_________________
boost|select libs to build|slotable|python-buildid

hear hear
Back to top
View user's profile Send private message
Need4Speed
Guru
Guru


Joined: 06 Jun 2004
Posts: 497

PostPosted: Fri Apr 18, 2008 3:46 pm    Post subject: Reply with quote

I upgraded sun-jdk and still got the same error. I managed to get that line to compile by increasing the javac heap size by using "-J-Xms1000m -J-Xmx1000m" and running javac from the command line. Is there some way I can get the ebuild to use this option? I tried setting JAVACFLAGS but it didn't do anything..
Oh and I assume you guys are talking about the java-gcj-overlay from layman, right?
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2325
Location: Germania

PostPosted: Fri Apr 18, 2008 3:55 pm    Post subject: Reply with quote

emerald you may test and send patches

Need4Speed JAVACFLAGS should not be used. I wonder...
_________________
boost|select libs to build|slotable|python-buildid

hear hear
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2325
Location: Germania

PostPosted: Fri Apr 18, 2008 4:30 pm    Post subject: Reply with quote

ok, there was some makefile code for java heap sizing. hardwired '-J-Xmx512m' for now.
edit dev-java/icedtea/files/bootstrap_fix-heapsize-so-we-get-happy-please-thanks.diff to increase it if it still fails with 512m.
though, 512m should suffice.

rev.6175
_________________
boost|select libs to build|slotable|python-buildid

hear hear
Back to top
View user's profile Send private message
Need4Speed
Guru
Guru


Joined: 06 Jun 2004
Posts: 497

PostPosted: Fri Apr 18, 2008 6:38 pm    Post subject: Reply with quote

geki wrote:
ok, there was some makefile code for java heap sizing. hardwired '-J-Xmx512m' for now.
edit dev-java/icedtea/files/bootstrap_fix-heapsize-so-we-get-happy-please-thanks.diff to increase it if it still fails with 512m.
though, 512m should suffice.

rev.6175


Thanks geki! Everything compiled and is working great! :)
Back to top
View user's profile Send private message
Need4Speed
Guru
Guru


Joined: 06 Jun 2004
Posts: 497

PostPosted: Sat Apr 19, 2008 3:31 pm    Post subject: Reply with quote

Any chance we can get this into portage? I think a lot of people would benefit from it since it's the only stable 64bit browser plugin..
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2325
Location: Germania

PostPosted: Sun Apr 20, 2008 4:15 pm    Post subject: Reply with quote

rev.6185
- net-p2p/azureus 3.0.5.2 bump
_________________
boost|select libs to build|slotable|python-buildid

hear hear
Back to top
View user's profile Send private message
gnu_andrew
n00b
n00b


Joined: 11 Apr 2008
Posts: 19

PostPosted: Sun Apr 20, 2008 9:56 pm    Post subject: Reply with quote

Sorry changed the link to the more appropriate:

http://fuseyism.com/hg/libre_java_overlay/

You can go to that URL and download a zip or tarball if you don't want to install Mercurial.
The IcedTea6 build differs from the one in java-experimental in being based on OpenJDK6,
which provides a FOSS version of 1.6, rather than being based on OpenJDK, which provides
1.7. 1.7 doesn't even have a JSR yet.

After installing gcj-jdk and then icedtea6, I have:

The following VMs are available for generation-2:
1) GCJ 4.3.0 [gcj-jdk-4.3]
*) OpenJDK/IcedTea 1.1 [icedtea6-1.1]

IcedTea6 will build on x86, x86_64, ppc and ppc64. In fact, it should do ARM, MIPS and SPARC too but I haven't added these tags yet, as I haven't tested it on these archs myself.
The IcedTea and GCJ builds are based on those in java-experimental and java-gcj-overlay respectively.
The main differences are:

1. The GCJ is 4.3 as released, not a random snapshot as in the java-gcj-overlay. It also doesn't require ecj to build (creating a circular dependency problem),
but works as it should with the downloadable ecj (manual gcc builds use contrib/download_ecj to get this). It uses the ecj1 package for this. You can
remove this once you've properly installed eclipse-ecj using the gcj-jdk as long as you fix the symlink in /usr/share/java.
2. IcedTea6 doesn't require Mercurial and is a production JDK unlike OpenJDK. This will ship with Fedora 9 for example in place of OpenJDK.
3. There is a fixed version of Ant which doesn't demonstrate the bug https://bugs.gentoo.org/show_bug.cgi?id=217572. This bug breaks the OpenJDK build
working, because it ignores the JAVA_HOME specified by the OpenJDK build.

I'll try and continue to check here, but you can also mail me: gnu_andrew@member.fsf.org.
Back to top
View user's profile Send private message
gnu_andrew
n00b
n00b


Joined: 11 Apr 2008
Posts: 19

PostPosted: Sun Apr 20, 2008 10:00 pm    Post subject: Reply with quote

BTW, I don't get why the name of this thread was changed.
gcj-jdk is still required to be able to build IcedTea6, you can't build without a JDK...
Back to top
View user's profile Send private message
gnu_andrew
n00b
n00b


Joined: 11 Apr 2008
Posts: 19

PostPosted: Sun Apr 20, 2008 10:03 pm    Post subject: Reply with quote

gimpel wrote:

- need to create a link from /usr/bin/ecj-3.3 to /usr/bin/ecj - otherwhise the javac symlink in gcj-jdk points to nowhere.


The eclipse-ecj build in the overlay does:

dosym /usr/bin/${MY_PN}-${SLOT} /usr/bin/${MY_PN}

which adds /usr/bin/ecj. You must be using the main tree version, which is broken.
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2325
Location: Germania

PostPosted: Sun Apr 20, 2008 10:40 pm    Post subject: Reply with quote

gnu_andrew wrote:
BTW, I don't get why the name of this thread was changed.
gcj-jdk is still required to be able to build IcedTea6, you can't build without a JDK...
right, one needs a jdk-1.6 compatible, not especially gcj-jdk. ;)
_________________
boost|select libs to build|slotable|python-buildid

hear hear
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2325
Location: Germania

PostPosted: Sun Apr 20, 2008 10:44 pm    Post subject: Reply with quote

mah, https://bugs.gentoo.org/show_bug.cgi?id=218633
azureus ebuild update as soon as that is fixed...
_________________
boost|select libs to build|slotable|python-buildid

hear hear
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2325
Location: Germania

PostPosted: Mon Apr 21, 2008 3:48 pm    Post subject: Reply with quote

get fixed patch for dev-java/json-simple
https://bugs.gentoo.org/attachment.cgi?id=150507
_________________
boost|select libs to build|slotable|python-buildid

hear hear
Back to top
View user's profile Send private message
gimpel
Advocate
Advocate


Joined: 15 Oct 2004
Posts: 2720
Location: Munich, Bavaria

PostPosted: Mon Apr 21, 2008 4:47 pm    Post subject: Reply with quote

gnu_andrew wrote:
gimpel wrote:

- need to create a link from /usr/bin/ecj-3.3 to /usr/bin/ecj - otherwhise the javac symlink in gcj-jdk points to nowhere.


The eclipse-ecj build in the overlay does:

dosym /usr/bin/${MY_PN}-${SLOT} /usr/bin/${MY_PN}

which adds /usr/bin/ecj. You must be using the main tree version, which is broken.

It worked fine to bootstrap with that one. My problem was with g++/ld compiling/linking against libffi. You can trick ./configure by setting the paths manually (see my post above) - but that still will not make it compile.
_________________
http://proaudio.tuxfamily.org/wiki - pro-audio software overlay
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2325
Location: Germania

PostPosted: Tue Apr 22, 2008 12:39 am    Post subject: Reply with quote

rev.6195
- azureus: Fix UI setting in ~/.azureus/gentoo.config
: swt, vuze, vuze_advanced
: console seems broken; noone cared yet

edit #1
rev.6202
- azureus: misc. fixes

have fun! :o
_________________
boost|select libs to build|slotable|python-buildid

hear hear
Back to top
View user's profile Send private message
gnu_andrew
n00b
n00b


Joined: 11 Apr 2008
Posts: 19

PostPosted: Wed Apr 23, 2008 6:01 pm    Post subject: Reply with quote

gimpel wrote:

It worked fine to bootstrap with that one. My problem was with g++/ld compiling/linking against libffi. You can trick ./configure by setting the paths manually (see my post above) - but that still will not make it compile.


Yes, I didn't understand your point on libffi...

* IcedTea6 only needs it if you are not on x86/amd64 -- what arch are you on?
* On ppc64 I didn't need any special options for it to pick up libffi (although that was a pre-ebuild manual install).
Back to top
View user's profile Send private message
gnu_andrew
n00b
n00b


Joined: 11 Apr 2008
Posts: 19

PostPosted: Wed Apr 23, 2008 6:01 pm    Post subject: Reply with quote

geki wrote:
gnu_andrew wrote:
BTW, I don't get why the name of this thread was changed.
gcj-jdk is still required to be able to build IcedTea6, you can't build without a JDK...
right, one needs a jdk-1.6 compatible, not especially gcj-jdk. ;)


Indeed, but gcj is the only one that seems to be packaged by Gentoo as a JDK. IIRC, the Kaffe one was too dated.
Back to top
View user's profile Send private message
Need4Speed
Guru
Guru


Joined: 06 Jun 2004
Posts: 497

PostPosted: Fri Apr 25, 2008 2:40 am    Post subject: Reply with quote

I noticed some fonts that look fine in windows are really ugly in OpenJDK. It seems like it mainly affects bold fonts. Is this a bug or do I just need to install some fonts?

http://img103.imageshack.us/my.php?image=javafontswq0.png
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2325
Location: Germania

PostPosted: Fri Apr 25, 2008 3:20 pm    Post subject: Reply with quote

looks like a feature, same here
http://kennke.org/blog/category/free-software/openjdk/

other font setup may help.
_________________
boost|select libs to build|slotable|python-buildid

hear hear
Back to top
View user's profile Send private message
emerald
Tux's lil' helper
Tux's lil' helper


Joined: 31 Jul 2005
Posts: 113

PostPosted: Fri Apr 25, 2008 9:48 pm    Post subject: Reply with quote

btw, has anyone tried icedtea (6.1.1 from java-overlay) with doc use-flag?
for me it bails out with
Code:

IcedTea is served: openjdk/control/build/linux-amd64
>>> Source compiled.
>>> Test phase [not enabled]: dev-java/icedtea-6.1.1

>>> Install icedtea-6.1.1 into /home/tmp/portage/dev-java/icedtea-6.1.1/image/ category dev-java
 *
 * ERROR: dev-java/icedtea-6.1.1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_install
 *             environment, line 5158:  Called die
 * The specific snippet of code:
 *           dohtml -r docs/* || die;
 *  The die message:
 *   (no error message)
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/home/tmp/portage/dev-java/icedtea-6.1.1/temp/build.log'.
 * The ebuild environment file is located at '/home/tmp/portage/dev-java/icedtea-6.1.1/temp/environment'.
 *
!!! When you file a bug report, please include the following information:
GENTOO_VM=sun-jdk-1.6  CLASSPATH="" JAVA_HOME=""
JAVACFLAGS="" COMPILER=""
and of course, the output of emerge --info

:(
_________________
Knowledge is scary....

... running Gentoo Linux ...
... and Windows in a 'small corner'(C) - i.e. vmware - :D ...
System Profile

Don't open the Red Door !
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2325
Location: Germania

PostPosted: Fri Apr 25, 2008 10:46 pm    Post subject: Reply with quote

# what says this
find /home/tmp/portage/dev-java/icedtea-6.1.1 -type d -name docs
_________________
boost|select libs to build|slotable|python-buildid

hear hear
Back to top
View user's profile Send private message
emerald
Tux's lil' helper
Tux's lil' helper


Joined: 31 Jul 2005
Posts: 113

PostPosted: Fri Apr 25, 2008 11:48 pm    Post subject: Reply with quote

emerald ~ # find /home/tmp/portage/dev-java/icedtea-6.1.1 -type d -name docs
/home/tmp/portage/dev-java/icedtea-6.1.1/work/icedtea6-1.1/openjdk/control/build/linux-amd64/hotspot/import/docs
/home/tmp/portage/dev-java/icedtea-6.1.1/work/icedtea6-1.1/openjdk/jdk/make/docs
/home/tmp/portage/dev-java/icedtea-6.1.1/work/icedtea6-1.1/openjdk/jdk/test/com/sun/net/httpserver/docs
_________________
Knowledge is scary....

... running Gentoo Linux ...
... and Windows in a 'small corner'(C) - i.e. vmware - :D ...
System Profile

Don't open the Red Door !
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2325
Location: Germania

PostPosted: Sat Apr 26, 2008 12:02 am    Post subject: Reply with quote

are there any interesting javadocs within these folders?
_________________
boost|select libs to build|slotable|python-buildid

hear hear
Back to top
View user's profile Send private message
geki
Advocate
Advocate


Joined: 13 May 2004
Posts: 2325
Location: Germania

PostPosted: Sat Apr 26, 2008 12:17 am    Post subject: Reply with quote

looks like another configure fsck up.
I tweaked ebuild; svn up; and retry rev.6212 :o
_________________
boost|select libs to build|slotable|python-buildid

hear hear
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3 ... 18, 19, 20 ... 24, 25, 26  Next
Page 19 of 26

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum