Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
VMWare 6 startup error
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message

Joined: 25 Feb 2008
Posts: 37

PostPosted: Tue Mar 25, 2008 11:25 pm    Post subject: VMWare 6 startup error Reply with quote


I installed VMWare 6 and did exactly what this guy did (from this thread:


So, here's how it went, more or less:
emerge -av =app-emulation/vmware-workstation-

[ nope... ]

echo app-emulation/vmware-workstation ~x86 \
app-emulation/vmware-modules ~x86 \
dev-cpp/libsexymm ~x86 \
x11-libs/libview ~x86 >> /etc/portage/package.keywords

[ so: ]

[ebuild N ] app-emulation/vmware-modules- 483 kB
[ebuild N ] dev-cpp/libsexymm-0.1.9 USE="-debug -doc" 341 kB
[ebuild N ] x11-libs/libview-0.6.1 USE="-debug" 274 kB
[ebuild N F ] app-emulation/vmware-workstation- 213,943

Total: 4 packages (4 new), Size of downloads: 215,039 kB
Fetch Restriction: 1 package (1 unsatisfied)
`/portdir/portage/distfiles/VMware-workstation-6.0.2-59824.i386.tar.gz' ...
* Fetch failed for 'app-emulation/vmware-workstation-'

[ so I: ]

mv dump/downloads/VMware-workstation-6.0.2-59824.i386.tar.gz \

# emerge -av =app-emulation/vmware-workstation-

Total: 1 package (1 new), Size of downloads: 0 kB [ ... thanks, Neil! ]
Fetch Restriction: 1 package

* checking
vmware-any-any-update115.tar.gz ;-) ... [ ok ]

[ but I must first: ]
* Rebuild dev-cpp/gtkmm with USE="accessibility"

echo dev-cpp/gtkmm accessibility >> /etc/portage/package.use
emerge -av dev-cpp/gtkmm

Machine crashes, locks hard... I clean the CPU heatsink fan... :(

emerge --resume

* Messages for package app-emulation/vmware-workstation-

* Fallback PaX marking -m
* VMWare allows for the potential of overwriting files as root. Only
* give VMWare access to trusted individuals.
* Remember, in order to run VMware Workstation, you have to
* be in the 'vmware' group.
* You need to run
* /opt/vmware/workstation/bin/
* to complete the install.
* After configuring, run vmware-workstation to launch
* Also note that when you reboot you should run:
* /etc/init.d/vmware start
* before trying to run vmware. Or you could just add it to
* the default runlevel:
* rc-update add vmware default
* GNU info directory index is up-to-date.

Linux lbg2 2.6.23-gentoo-r6 #1 Sun Jan 27 22:25:30 PST 2008 i686 AMD
Athlon(tm) XP 2400+ AuthenticAMD GNU/Linux

passwd -a myuser vmware
Adding user myuser to group vmware

Running /opt/vmware/workstation/bin/

[I know no surely appropriate answer to any of the questions, but: ]
* Loading vmblock for drag and drop
support ... [ ok ]
* Starting VMware
services: [ ok ]
* Virtual machine
monitor [ ok ]
* Bridged networking
on /dev/vmnet0 [ ok ]
* DHCP server
on /dev/vmnet1 [ ok ]
* Host-only networking
on /dev/vmnet1 [ ok ]
* DHCP server
on /dev/vmnet8 [ ok ]
* NAT service
on /dev/vmnet8 [ ok ]
* Host-only networking
on /dev/vmnet8 [ ok ]
* Virtual
ethernet [ ok ]

The configuration of VMware Workstation 6.0.2 build-59824 for Linux for
this running kernel completed successfully.

You can now run VMware Workstation by invoking the following command:

I installed it. It runs. Now what?

"After configuring, run vmware-workstation to launch"

# which vmware-workstation
which: no vmware-workstation in (/sbin:/bin:/usr/sbin:/usr/bin)


locate vmware-workstation |grep -v -P 'db/pkg|cache|portage'

Okay, so that was a ruse. Hmm. Yes, I have to log back into X to have
my new group honored. Duh.

which vmware

Wow. Magic. And it's in my Gnome menu too.

/opt/vmware/workstation/lib/bin/vmware: symbol lookup
error: /opt/vmware/workstation/lib/lib/
undefined symbol: _ZThn12_N4view10FieldEntry17delete_text_vfuncEii


I tried emerging bits of the libraries... can't figure out where this
error comes from... not much help on the web yet, but for this:

~ $ cat .xinitrc
# Use thoughtfully the GTK+ runtime environment (lib & conf files) from
exec gnome-session

(Have to export _before_ starting X, yes.)

Hope this helps someone else. If anyone knows about the above error,
I'd love to fix this properly.

[I] x11-libs/gtk+
Available versions:
(1) 1.2.10-r12
(2) 2.10.14 2.12.1-r2 ~2.12.5-r1

echo x11-libs/gtk+ ~x86 >> /etc/portage/package.keywords

Recompiling that. I'll let y'all know if it matters. Meanwhile, none of
the file browser routines to access my system (say, for configuring
virtual machine storage location) work, but crash with a libgnome-vfs.0
error about undefined symbol g_get_user_special_dir. Somehow, that
makes sense, given that I'm using different libraries. Well, that's a
lot like ndoze, anyway.

Maybe I have to down/upgrade to the versions of libraries shipped with

Meanwhile, I made an ISO image of my XP disk and got the VMWare to use
it as a boot.

Chose bridged networking in the setup. ISO image for CD-ROM.

Installed ndoze. Set up networking with a fixed IP and DNS info as from
my ISP. Ran I-extort-ya. And it works. How 'bout that?

None of the upgrades to the Gtk and related libraries seemed to make
any difference.

Anyway, this little annoyance on vmware startup:
(vmware-tray:21028): Gtk-WARNING **: GModule initialization check
failed: Gtk+ version too old (micro mismatch)

And no file browser when setting up the package. Other than that, it's
working (so far) with:

exec gnome-session

... in my user's .xinitrc.

Well, there it is. Now, to install with a bigger footprint and figure
out how to register my copy of XP again.

I'm also getting the error he mentioned:


/opt/vmware/workstation/lib/bin/vmware: symbol lookup error: /opt/vmware/workstation/lib/lib/ undefined symbol: _ZThn12_N4view10FieldEntry17delete_text_vfuncEii

Any ideas on what happens and how to solve it?
Back to top
View user's profile Send private message

Joined: 22 Jun 2003
Posts: 1219

PostPosted: Wed Mar 26, 2008 7:57 am    Post subject: Reply with quote

I guess you need to recompile libsexymm (probably libview too) since you've re-installed gtkmm after you had installed those to packages.
Hello 911? How are you?
Back to top
View user's profile Send private message
Tux's lil' helper
Tux's lil' helper

Joined: 09 Aug 2004
Posts: 141
Location: Speyer/Germany

PostPosted: Wed Aug 13, 2008 12:26 pm    Post subject: Reply with quote

Thanks, that solved the problem for me! :-)
Es wurde Win XP oder besser verlangt, also installierte ich Linux
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum