Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
KDE 4 in gentoo portage?
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... 9, 10, 11 ... 27, 28, 29  Next  
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
rek2
Guru
Guru


Joined: 05 Jan 2003
Posts: 477
Location: Boston USA/Barcelona Spain

PostPosted: Thu Jan 31, 2008 7:44 pm    Post subject: Reply with quote

Thanks for the response, this may be possible, any easy way to find and emerge -C them?

Thanks again.

EDITED, yes that resolved the problem thanks.
_________________
http://www.dailyradical.org
http://www.binaryfreedom.info
use jabber!!! sing on now, register an account:
http://jabber.binaryfreedom.info


Last edited by rek2 on Sun Feb 03, 2008 3:54 am; edited 1 time in total
Back to top
View user's profile Send private message
ranmakun
Guru
Guru


Joined: 06 Nov 2002
Posts: 372
Location: Buenos Aires - Argentina

PostPosted: Fri Feb 01, 2008 6:11 pm    Post subject: Reply with quote

I'm having the following problem with kdebase

Code:

[ 46%] Building CXX object workspace/kmenuedit/CMakeFiles/kdeinit_kmenuedit.dir/menufile.o
[ 46%] Building CXX object workspace/krunner/lock/CMakeFiles/krunner_lock.dir/kscreensaversettings.o
[ 46%] Building CXX object workspace/kmenuedit/CMakeFiles/kdeinit_kmenuedit.dir/menuinfo.o
Linking CXX executable krunner_lock
CMakeFiles/krunner_lock.dir/lockprocess.o: In function `LockProcess::createSaverWindow()':
lockprocess.cc:(.text+0x9ff): undefined reference to `glXChooseVisual'
collect2: ld devolvió el estado de salida 1
make[2]: *** [workspace/krunner/lock/krunner_lock] Error 1
make[1]: *** [workspace/krunner/lock/CMakeFiles/krunner_lock.dir/all] Error 2
make[1]: *** Se espera a que terminen otras tareas....
Linking CXX shared library ../../lib/libkdeinit4_kmenuedit.so
[ 46%] Built target kdeinit_kmenuedit
make: *** [all] Error 2
 *
 * ERROR: kde-base/kdebase-4.0.0 failed.
 * Call stack:
 *              ebuild.sh, line 1701:  Called dyn_compile
 *              ebuild.sh, line 1039:  Called qa_call 'src_compile'
 *              ebuild.sh, line   44:  Called src_compile
 *   kdebase-4.0.0.ebuild, line  215:  Called kde4-base_src_compile
 *       kde4-base.eclass, line  298:  Called kde4-base_src_make
 *       kde4-base.eclass, line  345:  Called cmake-utils_src_make
 *     cmake-utils.eclass, line  146:  Called die
 * The specific snippet of code:
 *              emake "$@" || die "Make failed!"
 *  The die message:
 *   Make failed!
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/kde-base/kdebase-4.0.0/temp/build.log'.
 *


My emerge info

Code:

Portage 2.1.3.19 (default-linux/x86/2007.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.17-gentoo-r4-web100 i686)
=================================================================
System uname: 2.6.17-gentoo-r4-web100 i686 Pentium III (Coppermine)
Timestamp of tree: Fri, 25 Jan 2008 13:30:08 +0000
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.10-r5
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.61-r1
sys-devel/automake:  1.6.3, 1.7.9-r1, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium3 -Os -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/4.0/env /usr/kde/4.0/share/config /usr/kde/4.0/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/udev/rules.d"
CXXFLAGS="-march=pentium3 -Os -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://adelie.polymtl.ca/"
LANG="es_AR"
LC_ALL="es_AR"
LINGUAS="es"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X accessibility acl aiglx alsa berkdb bitmap-fonts bzip2 cjk cli cracklib curl dbus dri fortran gdbm gif glitz gnutls gpm iconv idn ipv6 isdnlog jpeg kde midi mmx msn mudflap ncurses nls nptl nptlonly openmp openssh pam pcre perl pic png pppd python qt3support readline reflection semantic-desktop session snmp spl sqlite sse ssl tcpd threads tiff truetype-fonts type1-fonts unicode x86 xcb xcomposite xine xorg zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es" USERLAND="GNU" VIDEO_CARDS="i810"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Any ideas? Thanks
Back to top
View user's profile Send private message
mhelvens
Guru
Guru


Joined: 17 Mar 2005
Posts: 337
Location: The Netherlands

PostPosted: Sun Feb 03, 2008 5:39 pm    Post subject: Reply with quote

I'm sorry if this has been asked before, but it is quite a long running thread:

* Can KDE 3 and the KDE 4 overlay coexist together in portage?
* Do I need to do anything special to accomplish this?
* Can I expect any problems?
* Will I have a choice between the two in KDM?

I am kind of curious to see KDE 4. But I hear it's still a long way from the configurability and stability of KDE 3, so I want to keep that working too.

Thanks!
Back to top
View user's profile Send private message
Yukimura
Apprentice
Apprentice


Joined: 25 Aug 2006
Posts: 161
Location: Slovenia

PostPosted: Sun Feb 03, 2008 5:54 pm    Post subject: Reply with quote

Quote:
* Can KDE 3 and the KDE 4 overlay coexist together in portage?

Yes! Just unmask and install everything. :)

Quote:
* Do I need to do anything special to accomplish this?

You only have to move your ~/.kde to ~/.kde3.5 and make a symlink from ~/.kde3.5 to ~/.kde.

Quote:
* Can I expect any problems?

Well yes in KDE4, since it's not stable and far away from that, but KDE3.5 stays the same as it was, thanks god (or I would probably have my system broken again).

Quote:
* Will I have a choice between the two in KDM?

I'm not sure about that, but I like the kdm from kde4. :)

Kind regards. ;)
Back to top
View user's profile Send private message
mhelvens
Guru
Guru


Joined: 17 Mar 2005
Posts: 337
Location: The Netherlands

PostPosted: Sun Feb 03, 2008 5:59 pm    Post subject: Reply with quote

Yukimura wrote:
You only have to move your ~/.kde to ~/.kde3.5 and make a symlink from ~/.kde3.5 to ~/.kde.


That's the sort of thing I meant, yes. But this was already done on my system. :)

Quote:
Quote:
* Can I expect any problems?

Well yes in KDE4, since it's not stable and far away from that, but KDE3.5 stays the same as it was, thanks god (or I would probably have my system broken again).


I meant problems with the dual-KDE setup.

Thanks for the info! I'm going to try it.

Edit: Is there a quick way to unmask and ~amd64 kde-4.0.0 and all its dependencies (instead of discovering them one at a time)?
Back to top
View user's profile Send private message
Vicuna
n00b
n00b


Joined: 16 Aug 2006
Posts: 6

PostPosted: Sun Feb 03, 2008 6:54 pm    Post subject: Reply with quote

Michiel_H wrote:
Is there a quick way to unmask and ~amd64 kde-4.0.0 and all its dependencies (instead of discovering them one at a time)?


Code:
emerge autounmask


It'll take a while to run, but it should do the trick. Just to be on the safe side do a search as someone mentioned that autounmask might unmask some packages which you don't want. Eliminate those by hand once autounmask is through.
Back to top
View user's profile Send private message
Yukimura
Apprentice
Apprentice


Joined: 25 Aug 2006
Posts: 161
Location: Slovenia

PostPosted: Sun Feb 03, 2008 7:04 pm    Post subject: Reply with quote

Michiel_H wrote:
Edit: Is there a quick way to unmask and ~amd64 kde-4.0.0 and all its dependencies (instead of discovering them one at a time)?


Take a look at this site: http://www.gentoo.org/proj/en/desktop/kde/kde4.xml!

It helped me out! :)

Kind regards. :)
Back to top
View user's profile Send private message
sir_nacnud
n00b
n00b


Joined: 27 Nov 2007
Posts: 33
Location: USA

PostPosted: Sun Feb 03, 2008 7:04 pm    Post subject: Reply with quote

Michiel_H wrote:

* Will I have a choice between the two in KDM?

Yes you will, there will be an entry for kde 3.5 and kde 4 in kdm.
Back to top
View user's profile Send private message
mhelvens
Guru
Guru


Joined: 17 Mar 2005
Posts: 337
Location: The Netherlands

PostPosted: Sun Feb 03, 2008 7:11 pm    Post subject: Reply with quote

Ah, perfect. Thanks everyone!
Back to top
View user's profile Send private message
bartek
Tux's lil' helper
Tux's lil' helper


Joined: 16 Mar 2004
Posts: 78
Location: Poland, Pysznica

PostPosted: Tue Feb 05, 2008 2:39 am    Post subject: Reply with quote

i have problem with kopete-4.0

SSL support could not be initialized for account timbek@jabber.i-bs.pl. This is most likely because the QCA TLS plugin is not installed on your system.

how can i install QCA TLS plugin?
Back to top
View user's profile Send private message
Lori
Apprentice
Apprentice


Joined: 30 Mar 2004
Posts: 265
Location: Barcelona, Spain

PostPosted: Tue Feb 05, 2008 10:13 am    Post subject: Reply with quote

bartek wrote:
i have problem with kopete-4.0

SSL support could not be initialized for account timbek@jabber.i-bs.pl. This is most likely because the QCA TLS plugin is not installed on your system.

how can i install QCA TLS plugin?


I suppose you already have app-crypt/qca-2.0.0-r2 installed (kopete-4.0.0 pulls it in as a dependency) so you should install app-crypt/qca-ossl. This however is beta, and I don't know how well it works with qca-2.0. I installed it and kopete would not work with Google Talk accounts, a known bug. It would be interesting to see if it is only Google Talk, or XMPP in general. Please report back your findings!
_________________
"The hunt is sweeter then the kill."
Registered Linux User #176911
Back to top
View user's profile Send private message
Bzub
Tux's lil' helper
Tux's lil' helper


Joined: 25 Dec 2004
Posts: 89
Location: Belgium

PostPosted: Tue Feb 05, 2008 7:28 pm    Post subject: Reply with quote

When I try to
Code:
  emerge kdebase-startkde:kde-4

I keep getting this message.
    CMake Error: This project requires some variables to be set,
    and cmake can not find them.
    Please set the following variables:
    QT_QT3SUPPORT_LIBRARY (ADVANCED)
    QT_QTDESIGNER_LIBRARY (ADVANCED)
    QT_QTGUI_LIBRARY (ADVANCED)
    QT_QTSVG_LIBRARY (ADVANCED)
    QT_QTTEST_LIBRARY (ADVANCED)
    QT_QTUITOOLS_LIBRARY (ADVANCED)

    -- Configuring done
    *
    * ERROR: kde-base/kdelibs-4.0.0-r1 failed.
    * Call stack:
    * ebuild.sh, line 1701: Called dyn_compile
    * ebuild.sh, line 1039: Called qa_call 'src_compile'
    * ebuild.sh, line 44: Called src_compile
    * kdelibs-4.0.0-r1.ebuild, line 125: Called kde4-base_src_compile
    * kde4-base.eclass, line 297: Called kde4-base_src_configure
    * kde4-base.eclass, line 335: Called cmake-utils_src_configureout
    * cmake-utils.eclass, line 109: Called die
    * The specific snippet of code:
    * cmake ${cmakeargs} "${S}" || die "Cmake failed"
    * The die message:
    * Cmake failed
    *
    * If you need support, post the topmost build error, and the call stack if relevant.
    * A complete build log is located at '/var/tmp/portage/kde-base/kdelibs-4.0.0-r1/temp/build.log'.
    *


emerge --info
    Portage 2.1.3.19 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-gentoo-r3 i686)
    =================================================================
    System uname: 2.6.23-gentoo-r3 i686 Mobile AMD Athlon(tm) XP 3000+
    Timestamp of tree: Tue, 05 Feb 2008 02:00:01 +0000
    app-shells/bash: 3.2_p17-r1
    dev-java/java-config: 1.3.7, 2.1.4
    dev-lang/python: 2.4.4-r6
    dev-python/pycrypto: 2.0.1-r6
    sys-apps/baselayout: 1.12.10-r5
    sys-apps/sandbox: 1.2.18.1-r2
    sys-devel/autoconf: 2.13, 2.61-r1
    sys-devel/automake: 1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
    sys-devel/binutils: 2.18-r1
    sys-devel/gcc-config: 1.4.0-r4
    sys-devel/libtool: 1.5.24
    virtual/os-headers: 2.6.23-r3
    ACCEPT_KEYWORDS="x86"
    CBUILD="i686-pc-linux-gnu"
    CFLAGS="-O2 -march=i686 -pipe"
    CHOST="i686-pc-linux-gnu"
    CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/qmail/alias /var/qmail/control"
    CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
    CXXFLAGS="-O2 -march=i686 -pipe"
    DISTDIR="/usr/portage/distfiles"
    FEATURES="distlocks metadata-transfer sandbox sfperms strict unmerge-orphans userfetch"
    GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
    LANG="en_US.utf8"
    LC_ALL="en_US.utf8"
    MAKEOPTS="-j2"
    PKGDIR="/usr/portage/packages"
    PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
    PORTAGE_TMPDIR="/var/tmp"
    PORTDIR="/usr/portage"
    PORTDIR_OVERLAY="/usr/portage/local/layman/sunrise"
    SYNC="rsync://rsync.gentoo.org/gentoo-portage"
    USE="X a52 aac aalib accessibility acl acpi aim alsa amr arts bash-completion berkdb bitmap-fonts bzip2 cairo cdparanoia cdr cli cracklib crypt cscope cups curl dbus dga divx4linux dri dts dvd dvdr dvdread eds emacs emboss encode esd evo exif fam fbcon firefox fortran gdbm ggi gif glitz gphoto2 gpm gstreamer gtk gtk2 hal iconv imagemagick imlib isdnlog jack java jpeg jpeg2k junit kde kerberos ldap leim lesstif libcaca libwww live mad matroska midi mikmod mmx mng mp3 mpeg mplayer msn mudflap mythtv nas ncurses nls nptl nptlonly ogg opengl openmp oss pam pcre pdf perl png pppd python qt3 qt3support qt4 quicktime readline real reflection sdl session spell spl ssl svg szip tcl tcpd tetex theora tiff tk truetype truetype-fonts type1-fonts unicode usb vorbis win32codecs x86 xanim xinerama xml xorg xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" USERLAND="GNU" VIDEO_CARDS="radeon"
    Unset: CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, LINGUAS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


what am I doing wrong?
Back to top
View user's profile Send private message
Lori
Apprentice
Apprentice


Joined: 30 Mar 2004
Posts: 265
Location: Barcelona, Spain

PostPosted: Tue Feb 05, 2008 10:50 pm    Post subject: Reply with quote

While you do have the qt3support USE flag set, you probably didn't rebuild Qt4 after setting it. See if running 'emerge -uDNav world' solves your problem.
_________________
"The hunt is sweeter then the kill."
Registered Linux User #176911
Back to top
View user's profile Send private message
Bzub
Tux's lil' helper
Tux's lil' helper


Joined: 25 Dec 2004
Posts: 89
Location: Belgium

PostPosted: Tue Feb 05, 2008 11:14 pm    Post subject: Reply with quote

Lori wrote:
While you do have the qt3support USE flag set, you probably didn't rebuild Qt4 after setting it. See if running 'emerge -uDNav world' solves your problem.


equery u qt gives

    [ Searching for packages matching qt... ]
    [ Colour Code : set unset ]
    [ Legend : Left column (U) - USE flags from make.conf ]
    [ : Right column (I) - USE flags packages was installed with ]
    [ Found these USE variables for x11-libs/qt-3.3.8-r4 ]
    U I
    + + cups : Add support for CUPS (Common Unix Printing System)
    - - debug : Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see http://www.gentoo.org/proj/en/qa/backtraces.xml
    - - doc : Adds extra documentation (API, Javadoc, etc)
    - - examples : Install examples, usually source code
    - - firebird : Adds support for the Firebird relational database
    + + gif : Adds GIF image support
    - - immqt : Enable binary incompatible version of immodule for Qt
    - - immqt-bc : Enable binary compatible version of immodule for Qt
    - - ipv6 : Adds support for IP version 6
    - - mysql : Adds mySQL Database support
    + + nas : Adds support for network audio sound
    - - nis : Support for NIS/YP services
    - - odbc : Adds ODBC Support (Open DataBase Connectivity)
    + + opengl : Adds support for OpenGL (3D graphics)
    - - postgres : Adds support for the postgresql database
    - - sqlite : Adds support for sqlite - embedded sql database
    + + xinerama : Add support for the xinerama X11 extension, which allows you to stretch your display across multiple monitors
    [ Found these USE variables for x11-libs/qt-4.3.3 ]
    U I
    + + accessibility : Adds support for accessibility (eg 'at-spi' library)
    + + cups : Add support for CUPS (Common Unix Printing System)
    + + dbus : Enable dbus support for anything that needs it (gpsd, gnomemeeting, etc)
    - - debug : Enable extra debug codepaths, like asserts and extra output. If you want to get meaningful backtraces see http://www.gentoo.org/proj/en/qa/backtraces.xml
    - - doc : Adds extra documentation (API, Javadoc, etc)
    - - examples : Install examples, usually source code
    - - firebird : Adds support for the Firebird relational database
    + + gif : Adds GIF image support
    - - glib : Enable glib eventloop support
    - - input_devices_wacom : <unknown>
    + + jpeg : Adds JPEG image support
    + + mng : Adds support for libmng (MNG images)
    - - mysql : Adds mySQL Database support
    + + nas : Adds support for network audio sound
    - - nis : Support for NIS/YP services
    - - odbc : Adds ODBC Support (Open DataBase Connectivity)
    + + opengl : Adds support for OpenGL (3D graphics)
    - - pch : Enable precompiled header support for faster compilation times (gcc >3.4 only)
    + + png : Adds support for libpng (PNG images)
    - - postgres : Adds support for the postgresql database
    + + qt3support : Enable the Qt3Support libraries for Qt4
    - - sqlite : Adds support for sqlite - embedded sql database
    - - sqlite3 : Adds support for sqlite3 - embedded sql database
    + + ssl : Adds support for Secure Socket Layer connections
    + + tiff : Adds support for the TIFF image format
    + + xinerama : Add support for the xinerama X11 extension, which allows you to stretch your display across multiple monitors
    + + zlib : Adds support for zlib (de)compression


So I'm very sure that I compiled it with qt3support.
But have upgraded poppler-bindings last week and I remember that couldn't compile it with the qt4 use-flag. Could that have something todo with it?
Back to top
View user's profile Send private message
bartek
Tux's lil' helper
Tux's lil' helper


Joined: 16 Mar 2004
Posts: 78
Location: Poland, Pysznica

PostPosted: Tue Feb 05, 2008 11:53 pm    Post subject: Reply with quote

Lori wrote:
bartek wrote:
i have problem with kopete-4.0

SSL support could not be initialized for account timbek@jabber.i-bs.pl. This is most likely because the QCA TLS plugin is not installed on your system.

how can i install QCA TLS plugin?


I suppose you already have app-crypt/qca-2.0.0-r2 installed (kopete-4.0.0 pulls it in as a dependency) so you should install app-crypt/qca-ossl. This however is beta, and I don't know how well it works with qca-2.0. I installed it and kopete would not work with Google Talk accounts, a known bug. It would be interesting to see if it is only Google Talk, or XMPP in general. Please report back your findings!

thx, now it works (I installed app-crypt/qca-ossl-2.0.0_beta3)
Back to top
View user's profile Send private message
wrc1944
Advocate
Advocate


Joined: 15 Aug 2002
Posts: 2734
Location: Gainesville, Florida

PostPosted: Wed Feb 06, 2008 1:32 am    Post subject: Reply with quote

ranmakun,
QT, kdelibs, and kdebase need to be compiled with the opengl USE flag, otherwise kdebase fails with that glXChooseVisual error.
_________________
Main box- Gigabyte GIGABYTE GA-990FXA-UD3 AM3+ rev.-4.0
Amd FX 8320, 3.5 GHz, 16GB GSkill DDR3 1866mhz
Samsung SATA 1000GB, Radeon HD 6570 2GB DDR3
Gentoo ~x86, ~amd64, glibc-2.19, gcc-4.8.2, kernel 3.14.0-gentoo (USE=experimental)
Back to top
View user's profile Send private message
tnt
Veteran
Veteran


Joined: 27 Feb 2004
Posts: 1126

PostPosted: Wed Feb 06, 2008 1:48 am    Post subject: Reply with quote

kde 4.0.1 available !!!


http://www.kde.org/announcements/announce-4.0.1.php
_________________
gentoo user
Back to top
View user's profile Send private message
mephx
n00b
n00b


Joined: 23 Nov 2006
Posts: 11

PostPosted: Wed Feb 06, 2008 2:59 am    Post subject: Reply with quote

tnt wrote:
kde 4.0.1 available !!!


http://www.kde.org/announcements/announce-4.0.1.php


any hint on when available in portage?

x
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Wed Feb 06, 2008 6:59 am    Post subject: Reply with quote

mephx wrote:
any hint on when available in portage?
As always, 'when it is ready' :P
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
Lori
Apprentice
Apprentice


Joined: 30 Mar 2004
Posts: 265
Location: Barcelona, Spain

PostPosted: Wed Feb 06, 2008 8:44 am    Post subject: Reply with quote

mephx wrote:
any hint on when available in portage?

One dev on #gentoo-kde mentioned 1 to 7 days...
_________________
"The hunt is sweeter then the kill."
Registered Linux User #176911
Back to top
View user's profile Send private message
cmyster
n00b
n00b


Joined: 06 Feb 2008
Posts: 1

PostPosted: Wed Feb 06, 2008 12:27 pm    Post subject: Reply with quote

Look at the changelog http://www.kde.org/announcements/changelogs/changelog4_0to4_0_1.php
maybe I'm old fassion, but I'm good without 4 for the moment. wait 2 more weeks to make it more stable... :P
Back to top
View user's profile Send private message
ArneBab
Guru
Guru


Joined: 24 Jan 2006
Posts: 361
Location: Graben-Neudorf, Germany

PostPosted: Wed Feb 06, 2008 12:59 pm    Post subject: Reply with quote

Since I'm just writing this from KDE 4.0 and quite like the feel of it, I'm very excited about KDE 4.0.1

There are some things which don't yet work (mainly kontact *oww*), but even with these issues I just decided to make KDE 4.0 my main desktop and to use KDE 3.5 only for reading my mail :)

If you want a stable working desktop for all your demands: Hands away from 4.0.

But if you are willing to switch to KDE 3.5 for some tasks, I can only suggest to try KDE 4.0.

And once KDE 4.0.1 is in portage, I can even more suggest using it.

The only serious bug I get is, that the kde 3.5 libraries aren't in the path, so KDE 3.5 Kontact doesn't work properly.
The only bug which is serious to me :)

A screenshot is avaible from my short (german) review: http://draketo.de/deutsch/freie-software/licht/kde/kde4

Best wishes,
Arne
PS: Many thanks for your great work with the meta ebuilds! If I could, I'd gladly buy you a coffee or two (or something similar) to say a proper thank you!
_________________
Being unpolitical means being political without realizing it. - Arne Babenhauserheide ( http://draketo.de )

pkgcore: So fast that it feels unreal - by doing only what is needed.
Back to top
View user's profile Send private message
renrutal
Tux's lil' helper
Tux's lil' helper


Joined: 26 Mar 2005
Posts: 135
Location: Brazil

PostPosted: Wed Feb 06, 2008 3:56 pm    Post subject: Reply with quote

ArneBab, try an antialiased font, such as the Bitstream Vera family
Back to top
View user's profile Send private message
Lori
Apprentice
Apprentice


Joined: 30 Mar 2004
Posts: 265
Location: Barcelona, Spain

PostPosted: Wed Feb 06, 2008 5:18 pm    Post subject: Reply with quote

You could just disable bitmap fonts, your current screen font is the bitmap Helvetica. Try this:
Code:

eselect fontconfig list
eselect fontconfig enable 21

You should check to which number 70-no-bitmaps.conf corresponds and adjust 21 accordingly.
_________________
"The hunt is sweeter then the kill."
Registered Linux User #176911
Back to top
View user's profile Send private message
ArneBab
Guru
Guru


Joined: 24 Jan 2006
Posts: 361
Location: Graben-Neudorf, Germany

PostPosted: Thu Feb 07, 2008 1:41 am    Post subject: Reply with quote

I'll look into it, but at the moment I'm quite happy with my non-anti-aliased fonts...

I explicitely disabled anti-aliasing for small font-sizes, because I liked it better without anti-aliasing, but I'll have to check that again for KDE 4.
_________________
Being unpolitical means being political without realizing it. - Arne Babenhauserheide ( http://draketo.de )

pkgcore: So fast that it feels unreal - by doing only what is needed.
Back to top
View user's profile Send private message
Display posts from previous:   
This topic is locked: you cannot edit posts or make replies.    Gentoo Forums Forum Index Desktop Environments All times are GMT
Goto page Previous  1, 2, 3 ... 9, 10, 11 ... 27, 28, 29  Next
Page 10 of 29

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum