Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
HAL 0.5.10 e KDE 3.5: problema mappature dopo aggiornamento
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
gommosgol
n00b
n00b


Joined: 07 Jan 2008
Posts: 6

PostPosted: Mon Jan 07, 2008 3:08 pm    Post subject: HAL 0.5.10 e KDE 3.5: problema mappature dopo aggiornamento Reply with quote

Dopo l`upgrade a HAL 0.5.10, le mappature di KDE si sono tutte corrotte 8O

Di default, tengo sempre la mappatura di KDE disattivata, e lascio che usi la mappatura di default di xorg.conf.
Dopo l`update a hal-0.5.10, ha brutalmente smesso di funzionare: la mappatura e` improvvisamente divenuta americana; se attivo le mappature di KDE e imposto quella italiana, noto che il layout e` completamente sballato (la freccia in su e` divenuta stamp, stamp e` canc, ...).
Hal funziona perfettamente...
Naturalmente, se downgrado torna tutto a posto.
Perche`?

Anche un altra volta era accaduta una cosa del genere, solo che quella volta era decisammente piu` serio: i locali si erano corrotti (sempre dopo e a causa di un aggiornamento di hal), e ho dovuto correggerli a mano; infatti il giorno dopo nel portage l`ebuild era stato mascherato....

EDIT: se termino il demone di hal e riavvio X, torna a posto.. 8O

Uso la keyword ~amd64, e il problema lo hanno anche gli altri ambienti, proprio tutto X...
Back to top
View user's profile Send private message
Xet
Apprentice
Apprentice


Joined: 02 May 2004
Posts: 170

PostPosted: Tue Jan 08, 2008 12:56 pm    Post subject: Reply with quote

confermo anche io lo stesso problema con GNOME e keyword ~x86

per evitare di scaricare hal 0.5.10

Code:
echo =sys-apps/hal-0.5.10 >> /etc/portage/package.mask


e poi se l'avete già installato date un bel

Code:
emerge hal

e vi installerà la 0.5.9.1-r3
_________________
sono colui che sostiene il reale
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Tue Jan 08, 2008 1:12 pm    Post subject: Re: HAL 0.5.10 e KDE 3.5: problema mappature dopo aggiorname Reply with quote

gommosgol wrote:
Uso la keyword ~amd64

Xet wrote:
keyword ~x86

Avete provato a cercare per bene su bugzilla ed eventualmente a postare un bugreport? Quello di solito è il posto migliore per cercare soluzioni quando si usano pacchetti non sufficientemente testati.

Inoltre avete controllato se nei messaggi di emersione viene detto qualcosa in merito?
grep elog /usr/portage/sys-apps/hal/hal-0.5.10.ebuild wrote:

elog "The HAL daemon needs to be running for certain applications to"
elog "work. Suggested is to add the init script to your start-up"
elog "scripts, this should be done like this :"
elog "\`rc-update add hald default\`"
elog "Looking for automounting support? Add yourself to the plugdev group"
elog "IF you have additional applications which consume ACPI events, you"
elog "should consider installing acpid to allow applications to share ACPI"
elog "events."
elog "If you wish to use a non US layout, you may do so by executing:"
elog "setxkbmap <layout> or by utilizing your Desktop Environment's"
elog "Keyboard Layout Settings mechanism."
elog "Under GNOME, this is gnome-keyboard-properties, and under KDE"
elog "it is kxkb."

_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
gommosgol
n00b
n00b


Joined: 07 Jan 2008
Posts: 6

PostPosted: Tue Jan 08, 2008 6:11 pm    Post subject: Re: HAL 0.5.10 e KDE 3.5: problema mappature dopo aggiorname Reply with quote

Onip wrote:
gommosgol wrote:
Uso la keyword ~amd64

Xet wrote:
keyword ~x86

Avete provato a cercare per bene su bugzilla ed eventualmente a postare un bugreport? Quello di solito è il posto migliore per cercare soluzioni quando si usano pacchetti non sufficientemente testati.

Inoltre avete controllato se nei messaggi di emersione viene detto qualcosa in merito?
grep elog /usr/portage/sys-apps/hal/hal-0.5.10.ebuild wrote:

elog "The HAL daemon needs to be running for certain applications to"
elog "work. Suggested is to add the init script to your start-up"
elog "scripts, this should be done like this :"
elog "\`rc-update add hald default\`"
elog "Looking for automounting support? Add yourself to the plugdev group"
elog "IF you have additional applications which consume ACPI events, you"
elog "should consider installing acpid to allow applications to share ACPI"
elog "events."
elog "If you wish to use a non US layout, you may do so by executing:"
elog "setxkbmap <layout> or by utilizing your Desktop Environment's"
elog "Keyboard Layout Settings mechanism."
elog "Under GNOME, this is gnome-keyboard-properties, and under KDE"
elog "it is kxkb."

No, non serve setxkbmap, dovro` downgradare. :?
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Tue Jan 08, 2008 7:02 pm    Post subject: Reply with quote

Vedete un po' se questo vi aiuta. Leggendo velocemente pare che qualcuno sia riuscito a far funzionare tutto quanto.

Byez

p.s. non per essere maleducato, ma se si usa (coscientemente) un ambiente ~ si dovrebbe quanto meno imparare ad utilizzare correttamente bugzilla, cercando hal sono venuti fuori solo 3 bug per il 0.5.10 e sembrano pure correlati...
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
gommosgol
n00b
n00b


Joined: 07 Jan 2008
Posts: 6

PostPosted: Tue Jan 08, 2008 8:39 pm    Post subject: Reply with quote

Onip wrote:
Vedete un po' se questo vi aiuta. Leggendo velocemente pare che qualcuno sia riuscito a far funzionare tutto quanto.

Byez

p.s. non per essere maleducato, ma se si usa (coscientemente) un ambiente ~ si dovrebbe quanto meno imparare ad utilizzare correttamente bugzilla, cercando hal sono venuti fuori solo 3 bug per il 0.5.10 e sembrano pure correlati...

Si, solo che raramente mi capitano di questi bug, e tra l'altro ho perso la password del mio account bugzilla.... dovrò farmela rimandare :D
Back to top
View user's profile Send private message
edux
Apprentice
Apprentice


Joined: 15 Nov 2005
Posts: 223
Location: Bologna

PostPosted: Wed Jan 09, 2008 10:27 am    Post subject: Reply with quote

Ok è giusto usare bugzilla per i programmi in testing prima di postare sul forum, però ragazzi anche se non lo ripetiamo ogni volta stiamo bene lo stesso, suvvia, in fondo anch'io quando ho un problema per prima cosa cerco sul forum e poi spesso, come in questo caso, vengo indirizzato a bugzilla o a altro.

Comunque, guardando proprio bugzilla e non mi ricordo che blog, sembra proprio che xorg si aspetti la configurazione della keyboard da hal, quindi la soluzione sembra essere quella di specificarne i settaggi in un file fdi, e precisamente /etc/hal/fdi/policy/10-keymap.fdi, la cui configurazione di default si trova in /usr/share/hal/fdi/policy/10osvendor/.

Per me che non ho impostazioni particolari della tastiera, è sufficiente questo:

Code:
<?xml version="1.0" encoding="ISO-8859-1"?> <!-- -*- SGML -*- -->
<match key="info.capabilities" contains="input.keyboard">
        <merge key="input.x11_driver" type="string">keyboard</merge>
        <merge key="input.xkb.layout" type="string">it</merge>
        <merge key="input.xkb.model" type="string">pc101</merge>
        <merge key="input.xkb.rules" type="string">xorg</merge>
</match>


Saluti!
_________________
E' la seconda più grande testa di scimmia che abbia mai visto!
(Guybrush Threepwood)
Back to top
View user's profile Send private message
bandreabis
Advocate
Advocate


Joined: 18 Feb 2005
Posts: 2413
Location: イタリアのロディで

PostPosted: Wed Jan 09, 2008 12:54 pm    Post subject: Reply with quote

A me pare un po' assurdo dover modificare un file xml per configurare la tastiera... /etc/conf.d/ che ci sta a fare, e /etc/X11/xorg.conf?
_________________
Il numero di post non fa di me un esperto! Anzi!
Back to top
View user's profile Send private message
Onip
Advocate
Advocate


Joined: 02 Sep 2004
Posts: 2912
Location: Parma (Italy)

PostPosted: Wed Jan 09, 2008 2:14 pm    Post subject: Reply with quote

edux wrote:
Ok è giusto usare bugzilla per i programmi in testing prima di postare sul forum, però ragazzi anche se non lo ripetiamo ogni volta stiamo bene lo stesso, suvvia, in fondo anch'io quando ho un problema per prima cosa cerco sul forum e poi spesso, come in questo caso, vengo indirizzato a bugzilla o a altro.


Giusto cercare nel forum, ma bisogna considerare anche bugzilla prima di postare. Secondo me il senso di usare programmi ~ è anche quello di contribuire al testing, con segnalazioni e, se possibile, soluzioni.

Inoltre volevo solo far presente che se non si è in grado di cercare su bugzilla (nulla di male, intendiamoci) forse un sistema completamente ~ è una scelta un tantinello azzardata, ma comunque ognuno è libero sempre ciò che vuole, gentoo is about choice.

Ripeto, non voglio offendere o tacciare di incapacità nessuno, ma solo dare un consiglio pratico per poter 'sopravvivere' al meglio assieme alla propria gentoo.
OT chiuso, per me

bandreabis wrote:
A me pare un po' assurdo dover modificare un file xml per configurare la tastiera... /etc/conf.d/ che ci sta a fare, e /etc/X11/xorg.conf?

Anche a me un pochino scoccia, ma pare (a quanto si legge nel bug che ho postato sopra) che i devel di xorg abbiano tutta l'intenzione di lasciare perdere xorg.conf e sfruttare hal per l' (auto)configurazione di xorg.
_________________
Linux Registered User n. 373835

Titus Lucretius Carus, De Rerum Natura - Tantum religio potuit suadere malorum
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum