Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
python blocking python-updater
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
malnar
n00b
n00b


Joined: 20 Sep 2007
Posts: 4

PostPosted: Thu Sep 20, 2007 5:31 pm    Post subject: python blocking python-updater Reply with quote

Trying to run revdep-rebuild I run into a problem with python blocking python-updater. I know I shouldn't remove python because it is used by portage, but I went ahead and gave it a try anyways. Funny thing is, I don't have the version of python installed which revdep-rebuild is claiming blocks python-updater. Looking for advice on how to proceed.

Code:

# revdep-rebuild -av
Configuring search environment for revdep-rebuild

Checking reverse dependencies...

Packages containing binaries and libraries broken by a package update
will be emerged.

Collecting system binaries and libraries... using existing /root/.revdep-rebuild.1_files.

Collecting complete LD_LIBRARY_PATH... using existing /root/.revdep-rebuild.2_ldpath.

Checking dynamic linking consistency... using existing /root/.revdep-rebuild.3_rebuild.

Assigning files to ebuilds... using existing /root/.revdep-rebuild.4_ebuilds.

Evaluating package order... using existing /root/.revdep-rebuild.5_order.

All prepared. Starting rebuild...
emerge --oneshot -av =app-emulation/emul-linux-x86-baselibs-10.2 =dev-lang/perl-5.8.8-r2 =net-nds/openldap-2.3.35-r1 =dev-lang/python-2.4.4-r4 =dev-lang/python-2.3.5-r3 =x11-apps/xclock-1.0.2
..........

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] app-emulation/emul-linux-x86-baselibs-10.2  0 kB
[ebuild   R   ] dev-lang/perl-5.8.8-r2  USE="berkdb gdbm* -build -debug -doc -ithreads -perlsuid" 0 kB
[ebuild   R   ] net-nds/openldap-2.3.35-r1  USE="berkdb crypt gdbm ipv6 perl readline ssl tcpd -debug -kerberos -minimal -odbc -overlays -samba -sasl (-selinux) -slp -smbkrb5passwd" 0 kB
[ebuild   R   ] dev-lang/python-2.4.4-r4  USE="berkdb gdbm ipv6 ncurses readline ssl -bootstrap -build -doc -examples -nocxx -nothreads -tk -ucs2" 0 kB
[ebuild   R   ] dev-lang/python-2.3.5-r3  USE="berkdb gdbm ipv6 ncurses readline ssl -bootstrap -build -doc -nocxx -tk -ucs2" 0 kB
[ebuild   R   ] x11-apps/xclock-1.0.2  USE="-debug -xprint" 0 kB
[blocks B     ] <dev-lang/python-2.3.6-r2 (is blocking app-admin/python-updater-0.2)

Total: 6 packages (6 reinstalls, 1 block), Size of downloads: 0 kB

!!! Error: The above package list contains packages which cannot be installed
!!!        at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked


revdep-rebuild failed to emerge all packages
you have the following choices:

- if emerge failed during the build, fix the problems and re-run revdep-rebuild
    or
- use -X or --package-names as first argument (trys to rebuild package, not exact
  ebuild)
    or
- set ACCEPT_KEYWORDS="~<your platform>" and/or /etc/portage/package.unmask
  (and remove /root/.revdep-rebuild.5_order to be evaluated again)
    or
- modify the above emerge command and run it manually
    or
- compile or unmerge unsatisfied packages manually, remove temporary files and
  try again (you can edit package/ebuild list first)

To remove temporary files, please run:
rm /root/.revdep-rebuild*.?_*


Code:

# emerge -aC python

>>> These are the packages that would be unmerged:


!!! 'dev-lang/python' is part of your system profile.
!!! Unmerging it may be damaging to your system.


 dev-lang/python
    selected: 2.3.5-r3 2.4.4-r4
   protected: none
     omitted: none

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

Would you like to unmerge these packages? [Yes/No] no

Quitting.
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Thu Sep 20, 2007 5:58 pm    Post subject: Reply with quote

You do have the python version python-updater is complaining about.
<dev-lang/python-2.3.6-r2 (note the '<') means any version earlier than 2.3.6-r2 and dev-lang/python-2.3.5-r3 fits the bill.
try emerge -C =dev-lang/python-2.3.5-r3 and then run revdep-rebuild again
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
malnar
n00b
n00b


Joined: 20 Sep 2007
Posts: 4

PostPosted: Fri Sep 21, 2007 1:04 am    Post subject: Reply with quote

worked like a charm. thank you.
Back to top
View user's profile Send private message
lab
n00b
n00b


Joined: 20 Dec 2006
Posts: 13

PostPosted: Sat Sep 22, 2007 9:02 pm    Post subject: python-updater-0.2 blocked by non-existent (older) python Reply with quote

Hi,

I have a similar block:

Code:

# emerge --oneshot --ask -v app-admin/python-updater

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] app-admin/python-updater-0.2  0 kB
[blocks B     ] <dev-lang/python-2.3.6-r2 (is blocking app-admin/python-updater-0.2)

Total: 1 package (1 reinstall, 1 block), Size of downloads: 0 kB

!!! Error: The above package list contains packages which cannot be installed
!!!        at the same time on the same system.

For more information about Blocked Packages, please refer to the following
section of the Gentoo Linux x86 Handbook (architecture is irrelevant):

http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?full=1#blocked



The problem is that when I try to remove this blocking package portage says it does not exist:

Code:
# emerge -C =dev-lang/python2.3.6-r2

--- Couldn't find '=dev-lang/python2.3.6-r2' to unmerge.

>>> No packages selected for removal by unmerge


Some where in portage, in some file, there is a reference to this version of python which is causing portage to think it is installed, and it is blocking app-admin/python-updater-0.2, which is required by newer versions of python: Where might one look?
Back to top
View user's profile Send private message
malnar
n00b
n00b


Joined: 20 Sep 2007
Posts: 4

PostPosted: Sun Sep 23, 2007 8:13 am    Post subject: Reply with quote

Run "emerge -pC python". You'll get a line similar to "selected: 2.3.5-r3 2.4.4-r4". This tells you which versions you have installed. Anything before 2.3.6-r2 is a candidate for blocking and must be removed. In my case it was 2.3.5-r3. In your case it may be different. I then had to run "emerge -C dev-lang/python-2.3.5-r3" and *not* "emerge -C dev-lang/python-2.3.6-r2" as one would expect.
Back to top
View user's profile Send private message
lab
n00b
n00b


Joined: 20 Dec 2006
Posts: 13

PostPosted: Sun Sep 23, 2007 1:45 pm    Post subject: [solved] old python blocking python-updater Reply with quote

It turns out python-2.3.5-r3 was the actual blocking package. When I removed it, everything was happy. I have no idea why it was reporting a different blocking version that did not exist.

Code:

# emerge -pC python

>>> These are the packages that would be unmerged:


!!! 'dev-lang/python' is part of your system profile.
!!! Unmerging it may be damaging to your system.


 dev-lang/python
    selected: 2.3.5-r3 2.4.4-r4
   protected: none
     omitted: none

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

# emerge -C =dev-lang/python-2.3.5-r3 --ask

>>> These are the packages that would be unmerged:

 dev-lang/python
    selected: 2.3.5-r3
   protected: none
     omitted: 2.4.4-r4

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

emerge -p  python

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-lang/python-2.4.4-r4

Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 10484
Location: Somewhere over Atlanta, Georgia

PostPosted: Sun Sep 23, 2007 1:49 pm    Post subject: Reply with quote

You had
Code:
[blocks B     ] <dev-lang/python-2.3.6-r2 (is blocking app-admin/python-updater-0.2)
in your emerge output. The "<" symbol denotes any version less than the listed version. In other words python-updater-0.2 needs a version of python at least as new as 2.3.6-r2. Clear? :)

- John
Back to top
View user's profile Send private message
ElCondor
Guru
Guru


Joined: 10 Apr 2002
Posts: 520
Location: Vienna, Austria, Europe

PostPosted: Sun Sep 30, 2007 2:33 pm    Post subject: Reply with quote

I have a similar problem (on a system not touched for over 2 years), exept that I only have 2.3.5 installed:
Quote:
www ~ # emerge -pC python

>>> These are the packages that I would unmerge:

!!! Trying to unmerge package(s) in system profile. 'dev-lang/python'
!!! This could be damaging to your system.

dev-lang/python
selected: 2.3.5-r2
protected: none
omitted: none

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.


when I try to upgrade I get (shortened):
Quote:
www etc # emerge -pv python

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B ] <dev-lang/python-2.3.6-r2 (is blocking app-admin/python-updater-0.2)

[ebuild U ] .... some packages ...
[ebuild U ] sys-devel/m4-1.4.9-r1 [1.4.3] +examples* +nls 595 kB
[ebuild U ] sys-devel/autoconf-2.61-r1 [2.59-r6] -emacs 1,364 kB
[ebuild U ] sys-devel/automake-wrapper-3-r1 [1-r1] 0 kB
[ebuild NS ] sys-devel/automake-1.10 872 kB
[ebuild NS ] dev-lang/python-2.4.4-r5 +berkdb -bootstrap -build -doc +examples +gdbm +ipv6 +ncurses -nocxx -nothreads +readline +ssl -tk -ucs2 7,975 kB
[ebuild U ] sys-apps/sandbox-1.2.17 [1.2.12] 227 kB
[ebuild N ] app-misc/pax-utils-0.1.16 -caps 63 kB
[ebuild U ] app-shells/bash-3.2_p17 [3.0-r12] -afs -bashlogger +nls -vanilla 2,521 kB
[ebuild U ] sys-apps/portage-2.1.3.9 [2.0.51.22-r2] -build -doc (-elibc_FreeBSD) +elibc_glibc (-elibc_uclibc) -epydoc -linguas_pl (-selinux) +userland_GNU 376 kB
*** Portage will stop merging at this point and reload itself,
[ebuild N ] app-admin/python-updater-0.2 2 kB
[ebuild U ] net-misc/rsync-2.6.9-r3 [2.6.0-r6] -acl +ipv6 -static -xinetd 792 kB
[ebuild N ] virtual/libiconv-0 0 kB
[ebuild U ] sys-devel/gettext-0.16.1-r1 [0.14.4] -doc -emacs +nls -nocxx 8,339 kB
[ebuild U ] sys-apps/coreutils-6.9-r1 [5.2.1-r6] -acl +nls (-selinux) -static -xattr 5,306 kB
[ebuild U ] dev-python/pycrypto-2.0.1-r6 [2.0-r1] -bindist +gmp* -test 150 kB


how can this be solved? I think unmerging the only python I have is not the best idea?

* ElCondor pasa *
_________________
Here I am the victim of my own choices and I'm just starting!
Back to top
View user's profile Send private message
nixnut
Bodhisattva
Bodhisattva


Joined: 09 Apr 2004
Posts: 10974
Location: the dutch mountains

PostPosted: Sun Sep 30, 2007 4:27 pm    Post subject: Reply with quote

Update python first to 2.4.4-r5. If you don't and unmerge your current python version you'll find that portage stops working.
Once you've installed the new python version you can unmerge the older one. After that you can update world. And don't forget to run python-updater afterwards.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
ElCondor
Guru
Guru


Joined: 10 Apr 2002
Posts: 520
Location: Vienna, Austria, Europe

PostPosted: Sun Sep 30, 2007 5:53 pm    Post subject: Reply with quote

But that'S exactly my problem: I cannot update python:
Quote:
www ~ # emerge -pv =dev-lang/python-2.4.4-r5

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B ] <dev-lang/python-2.3.6-r2 (is blocking app-admin/python-updater-0.2)

[ebuild NS ] dev-lang/python-2.4.4-r5 +berkdb -bootstrap -build -doc +examples +gdbm +ipv6 +ncurses -nocxx -nothreads +readline +ssl -tk -ucs2 7,975 kB
[ebuild U ] sys-apps/sandbox-1.2.17 [1.2.12] 227 kB
[ebuild N ] app-misc/pax-utils-0.1.16 -caps 63 kB
[ebuild U ] app-shells/bash-3.2_p17 [3.0-r12] -afs -bashlogger +nls -vanilla 2,521 kB
[ebuild U ] sys-apps/portage-2.1.3.9 [2.0.51.22-r2] -build -doc (-elibc_FreeBSD) +elibc_glibc (-elibc_uclibc) -epydoc -linguas_pl (-selinux) +userland_GNU 376 kB
*** Portage will stop merging at this point and reload itself,
recalculate dependencies, and complete the merge.
You may avoid the remerging of packages by updating portage on its own.
[ebuild N ] app-admin/python-updater-0.2 2 kB
[ebuild U ] net-misc/rsync-2.6.9-r3 [2.6.0-r6] -acl +ipv6 -static -xinetd 792 kB
[ebuild N ] virtual/libiconv-0 0 kB
[ebuild U ] sys-devel/gettext-0.16.1-r1 [0.14.4] -doc -emacs +nls -nocxx 8,339 kB
[ebuild U ] sys-apps/coreutils-6.9-r1 [5.2.1-r6] -acl +nls (-selinux) -static -xattr 5,306 kB
[ebuild U ] dev-python/pycrypto-2.0.1-r6 [2.0-r1] -bindist +gmp* -test 150 kB


I only have one python installed, thats 2.3.5-r2! an though 2.4.4 is slotted, it won't install!
_________________
Here I am the victim of my own choices and I'm just starting!
Back to top
View user's profile Send private message
Arfrever
Bodhisattva
Bodhisattva


Joined: 29 Apr 2006
Posts: 2463
Location: 異世界

PostPosted: Sun Sep 30, 2007 5:58 pm    Post subject: Reply with quote

ElCondor wrote:
But that'S exactly my problem: I cannot update python:
Quote:
www ~ # emerge -pv =dev-lang/python-2.4.4-r5

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[blocks B ] <dev-lang/python-2.3.6-r2 (is blocking app-admin/python-updater-0.2)

[ebuild NS ] dev-lang/python-2.4.4-r5 +berkdb -bootstrap -build -doc +examples +gdbm +ipv6 +ncurses -nocxx -nothreads +readline +ssl -tk -ucs2 7,975 kB
[ebuild U ] sys-apps/sandbox-1.2.17 [1.2.12] 227 kB
[ebuild N ] app-misc/pax-utils-0.1.16 -caps 63 kB
[ebuild U ] app-shells/bash-3.2_p17 [3.0-r12] -afs -bashlogger +nls -vanilla 2,521 kB
[ebuild U ] sys-apps/portage-2.1.3.9 [2.0.51.22-r2] -build -doc (-elibc_FreeBSD) +elibc_glibc (-elibc_uclibc) -epydoc -linguas_pl (-selinux) +userland_GNU 376 kB
*** Portage will stop merging at this point and reload itself,
recalculate dependencies, and complete the merge.
You may avoid the remerging of packages by updating portage on its own.
[ebuild N ] app-admin/python-updater-0.2 2 kB
[ebuild U ] net-misc/rsync-2.6.9-r3 [2.6.0-r6] -acl +ipv6 -static -xinetd 792 kB
[ebuild N ] virtual/libiconv-0 0 kB
[ebuild U ] sys-devel/gettext-0.16.1-r1 [0.14.4] -doc -emacs +nls -nocxx 8,339 kB
[ebuild U ] sys-apps/coreutils-6.9-r1 [5.2.1-r6] -acl +nls (-selinux) -static -xattr 5,306 kB
[ebuild U ] dev-python/pycrypto-2.0.1-r6 [2.0-r1] -bindist +gmp* -test 150 kB


I only have one python installed, thats 2.3.5-r2! an though 2.4.4 is slotted, it won't install!


Try:
Code:
FEATURES="-collision-protect" emerge -1O python-updater


Perduodu linkėjimus
Arfrever
Back to top
View user's profile Send private message
wskellenger
n00b
n00b


Joined: 01 Dec 2003
Posts: 52

PostPosted: Sun Sep 30, 2007 10:10 pm    Post subject: Reply with quote

[quote="Arfrever"]
ElCondor wrote:
But that'S exactly my problem: I cannot update python:
I only have one python installed, thats 2.3.5-r2! an though 2.4.4 is slotted, it won't install!

Quote:

Try:
Code:
FEATURES="-collision-protect" emerge -1O python-updater



I have the same problem (only one version of Python installed, it it is blocking the new version (WTF)), tried this suggestion and then just simply:

Code:
emerge python


It is compiling now.

This is another one of those Gentoo-isms that bugs me. Why are there so many obscure solutions like this? I know I wouldn't have figured this one out on my own.
Back to top
View user's profile Send private message
melbaum
n00b
n00b


Joined: 01 Jul 2004
Posts: 35

PostPosted: Sun Sep 30, 2007 10:26 pm    Post subject: Reply with quote

Now let's just suppose that emerge is already not working...
/usr/bin/emerge: /usr/bin/python: bad interpreter: No such file or directory
Am I back to a fresh install? It's a test system so not a big disaster, but I'm wondering if there's a better way.
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 10484
Location: Somewhere over Atlanta, Georgia

PostPosted: Sun Sep 30, 2007 10:38 pm    Post subject: Reply with quote

No, follow NeddySeagoon's advice on another post and you should be able to recover. :) Prebuilt binaries of critical packages are available on Gentoo Tinderbox.

- John
Back to top
View user's profile Send private message
melbaum
n00b
n00b


Joined: 01 Jul 2004
Posts: 35

PostPosted: Sun Sep 30, 2007 11:34 pm    Post subject: Reply with quote

Thanks. That looked great, but no matter what I do I still get:
/usr/bin/python: error while loading shared libraries: libpython2.3.so.1.0: cannot open shared object file: No such file or directory
I've installed python2.4 as well as portage from Tinderbox, so I don't see why it still looks for libpython2.3
python-config gives me the same error.

just to be sure...
ls -l /usr/lib/portage/bin/emerge
-rwxr-xr-x 1 root root 223616 Sep 20 01:50 /usr/lib/portage/bin/emerge

ls -l /usr/lib/libpython2.4.so*
lrwxrwxrwx 1 root root 19 Oct 1 02:12 /usr/lib/libpython2.4.so -> libpython2.4.so.1.0
-r-xr-xr-x 1 root root 995808 May 15 18:17 /usr/lib/libpython2.4.so.1.0

So after an hour of nothing I did another unthinkable and linked libpython2.3.so.1.0 to libpython2.4.so.1.0
Now python-2.4 has emerged successfully and python-updater seems to be doing something like emerge system.
I'll kill the link when it's over, but this is certainly the wrong way to do it. like I said, it's a test system.
Any thoughts what I should have done to recover at this stage?
Back to top
View user's profile Send private message
John R. Graham
Administrator
Administrator


Joined: 08 Mar 2005
Posts: 10484
Location: Somewhere over Atlanta, Georgia

PostPosted: Mon Oct 01, 2007 12:22 am    Post subject: Reply with quote

Probably your environment is just out of date. You might try removing that unthinkable symlink and running
Code:
env-update
source /etc/profile
Betcha emerge works after that. :)

- John
Back to top
View user's profile Send private message
ElCondor
Guru
Guru


Joined: 10 Apr 2002
Posts: 520
Location: Vienna, Austria, Europe

PostPosted: Mon Oct 01, 2007 7:12 am    Post subject: Reply with quote

okay, what I did was
Code:
emerge --nodeps -v =dev-lang/python-2.4.4-r5

that way I got a new python, could unmerge the old one and update the rest of the system afterwards.
maybe I will have to revdep-rebuild (didn't check last night), but on the first look everything seems to work ;)

* ElCondor pasa *
_________________
Here I am the victim of my own choices and I'm just starting!
Back to top
View user's profile Send private message
melbaum
n00b
n00b


Joined: 01 Jul 2004
Posts: 35

PostPosted: Tue Oct 02, 2007 10:45 pm    Post subject: Reply with quote

I managed a little less gracefully. I copied the untared Tinderbox binaries into / , and then with emerge working I re-emerged python-2.4 and unmerged 2.3. Then I ran into the libexpat.so.0 nonsense and eventually got it all fixed with revdep-rebuild. m4 didn't build because of a missing symlink from /usr/bin/ar to /usr/bin/i686-pc-linux-gnu-ar . db was also troublesome.

Now I can do emerge -av world, but emerge -auDv world ends with:

[blocks B ] <dev-lang/python-2.3.6-r2 (is blocking app-admin/python-updater-0.2)

I already unmerged the old python. from /var/log/emerge.log:
1191192230: === Unmerging... (dev-lang/python-2.3.5-r3)
1191192280: >>> unmerge success: dev-lang/python-2.3.5-r3

emerge -Cp python has no mention of 2.3.5:
dev-lang/python
selected: 2.4.4-r5
protected: none
omitted: none

Curious... I'll try without the -D for now.
Back to top
View user's profile Send private message
taavetti
n00b
n00b


Joined: 08 Aug 2004
Posts: 16
Location: On a comfy chair

PostPosted: Sat Oct 06, 2007 3:13 am    Post subject: Reply with quote

Wanted to update the box and ran

Code:
emerge -p -e system


got the following output

Code:
snip
[blocks B     ] <dev-lang/python-2.3.6-r2 (is blocking app-admin/python-updater-0.2)



no problem...have been reading the thread here

Code:

ndor dcl # equery list python
[ Searching for package 'python' in all categories among: ]
 * installed packages
[I--] [  ] app-admin/python-updater-0.2 (0)
[I--] [  ] dev-lang/python-2.3.5-r3 (2.3)
[I--] [  ] dev-lang/python-2.4.4-r5 (2.4)
[I--] [  ] dev-python/dnspython-1.3.3 (0)
[I--] [  ] dev-python/python-fchksum-1.7.1 (0)
[I--] [M ] dev-python/wxpython-2.4.2.4-r2 (2.4)
[I--] [  ] dev-python/wxpython-2.6.3.3 (2.6)
andor dcl # emerge -C python-2.3.5-r3

 dev-lang/python
    selected: 2.3.5-r3
   protected: none
     omitted: 2.4.4-r5

>>> 'Selected' packages are slated for removal.
>>> 'Protected' and 'omitted' packages will not be removed.

>>> Waiting 5 seconds before starting...
>>> (Control-C to abort)...
>>> Unmerging in: 5 4 3 2 1
>>> Unmerging dev-lang/python-2.3.5-r3...
Traceback (most recent call last):
  File "/usr/bin/emerge", line 6474, in ?
    retval = emerge_main()
  File "/usr/bin/emerge", line 6454, in emerge_main
    mtimedb["ldpath"]):
  File "/usr/bin/emerge", line 4302, in unmerge
    vartree=vartree, ldpath_mtimes=ldpath_mtimes)
  File "/usr/lib/portage/pym/portage.py", line 4273, in unmerge
    ldpath_mtimes=ldpath_mtimes)
  File "/usr/lib/portage/pym/portage.py", line 7350, in unmerge
    vartree=self.vartree)
  File "/usr/lib/portage/pym/portage.py", line 3883, in doebuild
    mysettings, debug=debug, free=1, logfile=logfile)
  File "/usr/lib/portage/pym/portage.py", line 2377, in spawn
    set_term_size(rows, columns, slave_fd)
  File "/usr/lib/portage/pym/output.py", line 342, in set_term_size
    spawn(cmd, env=os.environ, fd_pipes={0:fd})
  File "/usr/lib/portage/pym/portage_exec.py", line 179, in spawn
    raise CommandNotFound(mycommand[0])
portage_exception.CommandNotFound: stty


Any ideas how to unmerge python-2.3.5-r3?



Does this shed light on the situation?
Code:

andor dcl # which stty
which: no stty in (/sbin:/bin:/usr/sbin:/usr/bin)
Back to top
View user's profile Send private message
melbaum
n00b
n00b


Joined: 01 Jul 2004
Posts: 35

PostPosted: Sat Oct 06, 2007 3:38 pm    Post subject: Reply with quote

Can you upgrade it? emerge -av ="dev-lang/python-2.3.6-r2"
That should get rid of the 2.3.5 version without affecting the 2.4 slot.
2.3.6-r2 is masked ~x86, so don't forget: echo "dev-lang/python-2.3.6-r2" >>/etc/portage/package.keywords
If emerge is completely fried and "env-udpate && source /etc/profile" doesn't help, the only thing that worked for me was to install 2.4 from Tinderbox (above) and then re-emerge.
Back to top
View user's profile Send private message
taavetti
n00b
n00b


Joined: 08 Aug 2004
Posts: 16
Location: On a comfy chair

PostPosted: Sat Oct 06, 2007 8:21 pm    Post subject: Reply with quote

melbaum,
Thanks for the reply. Emerging does not work....thought about Tinderbox but the time has come to reinstall.

I have been running the same (and stable) system for 3+ years - largely thanks to the Gentoo Discussion Forums. Whenever there has been a problem the Forums have had the answers.

There was a bit of a triple whammy lately with
1) a long-overdue upgrade
2) expat-2.0.x issues (that got worked out, thanks to the Forums)
3) power outage in the middle of a world emerge

Anyway, something got borked (finger pointing at me :D ). Don't mind doing a reinstall actually and I know I will learn something else new in the reinstall process.
Back to top
View user's profile Send private message
geta
Apprentice
Apprentice


Joined: 10 May 2003
Posts: 153

PostPosted: Tue Oct 09, 2007 5:55 pm    Post subject: Reply with quote

Hello,

nixnut wrote:
You do have the python version python-updater is complaining about.
<dev-lang/python-2.3.6-r2 (note the '<') means any version earlier than 2.3.6-r2 and dev-lang/python-2.3.5-r3 fits the bill.
try emerge -C =dev-lang/python-2.3.5-r3 and then run revdep-rebuild again


unmerging the 2.3 version of python also did the trick for me. Because my system is a fairly old installation (about 3 - 4 years) and I only run security updates I did a quick check with

Code:
revdep-rebuild -p --library libpython2.3.so

and
Code:
revdep-rebuild -p --library libpython2.3.so.1.0


to see if anything still depended on python 2.3 (on a binary level at least). It turned out only python 2.3 depended on the 2.3 libraries, which is fairly logical :roll:

Thanks to this thread for reassuring me that python 2.3 is not necessarily needed anymore.
_________________
geta - pronounced: "djetta"
Back to top
View user's profile Send private message
muffy
n00b
n00b


Joined: 15 Sep 2003
Posts: 28
Location: :noitacoL

PostPosted: Wed Nov 21, 2007 2:21 pm    Post subject: Reply with quote

nixnut wrote:
You do have the python version python-updater is complaining about.
<dev-lang/python-2.3.6-r2 (note the '<') means any version earlier than 2.3.6-r2 and dev-lang/python-2.3.5-r3 fits the bill.
try emerge -C =dev-lang/python-2.3.5-r3 and then run revdep-rebuild again


Thanks! :)
Back to top
View user's profile Send private message
papapenguin
l33t
l33t


Joined: 20 Sep 2005
Posts: 694
Location: Bellevue

PostPosted: Wed Dec 12, 2007 8:02 pm    Post subject: Reply with quote

Oh no, I have a similar problem...

I just rebuilt my system due to numerous problems, upgrading from 2005.something to 2007.0.

Everything seemed to go fine until I updated my system with -avuDN world

My computer now will not shutdown -r or even log into kde, I get:
Quote:

usr/bin/xterm: Could not exec bin/bash: No such file or directory

and it goes back to login.

When I return to console, I have a message that states:
Quote:

papapenguin~# emerge python
!!! Problem with sandbox binary. Disabling...

Calculating dependencies... done!

>>>Emerging (1 of 1) dev-lang/python-2.4.4-r6 to /
Traceback (most recent call last):
File "/usr/bin/emerge", line 5481, in ?
rebval = emerge_main()
File"/usr/bin/emerge", line 5476, in emerge_main
myopts, myaction, myfiles, spinner)

etc., etc.

portage_exception.CommandNotFound: /bin/bash


I'm on another computer and typing this in, so I've left out a few lines.

Upon attempted shutdown, the computer is locked into a loop trying to log into kde.

I don't really know what happened here, or how to remedy...
Back to top
View user's profile Send private message
mbell
Tux's lil' helper
Tux's lil' helper


Joined: 18 Dec 2004
Posts: 93

PostPosted: Wed Dec 12, 2007 8:14 pm    Post subject: Reply with quote

Does 'emerge bash' work?
_________________
Google is your friend.
Google site:forums.gentoo.org is also your friend.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum