Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
merge no system falhando
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Portuguese
View previous topic :: View next topic  
Author Message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Thu Jul 31, 2003 2:00 pm    Post subject: merge no system falhando Reply with quote

pessoal estou utlizando o kportage, vejam o erro quando tento usar o merge system

Code:
These are the packages that I would merge, in order:
Calculating system dependencies    ...done!
[ebuild    U ] sys-apps/baselayout-1.8.6.8-r1 [1.8.5.9]
[ebuild    U ] sys-apps/portage-2.0.48-r5 [2.0.47-r10]
*** Portage will stop merging at this point and reload itself,
    recalculate dependancies, and complete the merge.
    You may avoid the remerging of packages by updating portage on its own.
[ebuild    U ] sys-devel/binutils-2.14.90.0.2 [2.13.90.0.18]
[ebuild    U ] sys-devel/gcc-3.2.3-r1 [3.2.2]
[ebuild    U ] sys-libs/glibc-2.3.2-r1 [2.3.1-r4]
[ebuild    U ] dev-lang/python-2.2.3-r1 [2.2.2]
[blocks B    ] <dev-perl/ExtUtils-MakeMaker-6.05-r6 (from pkg dev-lang/perl-5.8.0-r12)
[blocks B    ] <dev-perl/File-Spec-0.84-r1 (from pkg dev-lang/perl-5.8.0-r12)
[ebuild    U ] dev-lang/perl-5.8.0-r12 [5.8.0-r10]
[ebuild  N   ] net-misc/iputils-020927 
[ebuild    U ] net-misc/rsync-2.5.6-r2 [2.5.6-r1]
[ebuild    U ] app-shells/bash-2.05b-r5 [2.05b-r3]
[ebuild    U ] sys-apps/debianutils-1.16.7-r2 [1.16.7-r1]
[ebuild    U ] sys-apps/e2fsprogs-1.33 [1.32-r2]
[ebuild    U ] sys-apps/fileutils-4.1.11-r1 [4.1.11]
[ebuild    U ] sys-apps/gawk-3.1.3 [3.1.2-r3]
[ebuild    U ] sys-apps/grep-2.5.1-r1 [2.5-r1]
[ebuild    U ] sys-apps/groff-1.18.1-r2 [1.18.1-r1]
[ebuild    U ] sys-apps/gzip-1.3.3-r2 [1.3.3-r1]
[ebuild    U ] sys-apps/hdparm-5.4 [5.3-r2]
[ebuild    U ] sys-apps/man-1.5l-r6 [1.5l-r3]
[ebuild    U ] sys-apps/net-tools-1.60-r7 [1.60-r6]
[ebuild    U ] sys-apps/procps-3.1.9 [3.1.8]
[ebuild    U ] sys-apps/psmisc-21.2-r2 [21.2-r1]
[ebuild  N   ] sys-devel/gnuconfig-20030708 
[ebuild    U ] sys-apps/pam-login-3.11 [3.10]
[ebuild    U ] sys-apps/texinfo-4.5 [4.3-r1]
[ebuild    U ] sys-apps/util-linux-2.11z-r4 [2.11y]
[ebuild    U ] sys-devel/patch-2.5.4-r5 [2.5.4-r4]
[ebuild    U ] sys-libs/cracklib-2.7-r7 [2.7-r6]
Calculating system dependencies    ...done!
!!! Error: the <dev-perl/ExtUtils-MakeMaker-6.05-r6 package conflicts with this package and both can't be installed on the same system together.

_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
AngusYoung
Retired Dev
Retired Dev


Joined: 20 Dec 2002
Posts: 473
Location: Campinas, SP - Brazil

PostPosted: Thu Jul 31, 2003 3:04 pm    Post subject: Reply with quote

Olá Domus-BR ...
é o seguinte, você tem que remover os pacotes marcados como B (Blocked).

Quote:
[blocks B ] <dev-perl/ExtUtils-MakeMaker-6.05-r6 (from pkg dev-lang/perl-5.8.0-r12)
[blocks B ] <dev-perl/File-Spec-0.84-r1 (from pkg dev-lang/perl-5.8.0-r12)


Basta fazer:
Code:
emerge -C ExtUtils-MakeMaker && emerge -C File-Spec

_________________
N.U.S.: A cross platform C++ application development framework
My blog (in Portuguese)
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Fri Aug 01, 2003 2:43 pm    Post subject: Reply with quote

removi e tentei na linha de comando, olha só

Code:
otavio root # emerge system
Calculating system dependencies ...done!
>>> emerge (1 of 28) sys-apps/baselayout-1.8.6.8-r1 to /
>>> md5 ;-) sysvinit-2.84.tar.gz
>>> Unpacking source...
>>> Unpacking sysvinit-2.84.tar.gz to /var/tmp/portage/baselayout-1.8.6.8-r1/work
>>> Unpacking rc-scripts-1.4.3.8p1.tar.bz2
 * Checking if we need to tweak CONFIG_PROTECT_MASK
>>> Source unpacked.
 * Building utilities...
gcc -O3 -mcpu=pentium3 -pipe   -c -o consoletype.o consoletype.c
gcc -o consoletype consoletype.o
gcc -O3 -mcpu=pentium3 -pipe   -c -o runscript.o runscript.c
gcc -o runscript runscript.o
gcc -O3 -mcpu=pentium3 -pipe   -c -o start-stop-daemon.o start-stop-daemon.c
gcc -o start-stop-daemon start-stop-daemon.o
 * Building sysvinit...
gcc -c -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE init.c
gcc -c -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE -DINIT_MAIN utmp.c -o init_utmp.o
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE   -c -o halt.o halt.c
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE   -c -o ifdown.o ifdown.c
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE   -c -o hddown.o hddown.c
gcc -c -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE utmp.c
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE   -c -o dowall.o dowall.c
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE   -c -o shutdown.o shutdown.c
init.c: In function `init_main':
init.c:2439: warning: no return statement in function returning non-void
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE    killall5.c   -o killall5
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE   -c -o runlevel.o runlevel.c
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE   -c -o sulogin.o sulogin.c
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE   -c -o utmpdump.o utmpdump.c
sulogin.c: In function `main':
sulogin.c:347: warning: `p' might be used uninitialized in this function
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE   -c -o last.o last.c
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE   -c -o mesg.o mesg.c
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE   -c -o wall.o wall.c
gcc   -o init init.o init_utmp.o
gcc  -o halt halt.o ifdown.o hddown.o utmp.o
gcc  -o shutdown dowall.o shutdown.o utmp.o
gcc  -o runlevel runlevel.o
gcc   -o sulogin sulogin.o -lcrypt
gcc  -o utmpdump utmpdump.o
gcc  -o last last.o
gcc  -o mesg mesg.o
gcc  -o wall dowall.o wall.o
 * Please install sys-apps/gawk-3.1.1-r2 or later!

!!! ERROR: sys-apps/baselayout-1.8.6.8-r1 failed.
!!! Function src_compile, Line 128, Exitcode 0
!!! gawk too old

otavio root #

_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
spirinaites
n00b
n00b


Joined: 26 May 2002
Posts: 15
Location: Lisboa - Portugal

PostPosted: Sat Aug 02, 2003 3:32 pm    Post subject: Reply with quote

Já verificaste se tens o gawk instalado e qual a versão?
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Mon Aug 04, 2003 12:53 pm    Post subject: Reply with quote

spirinaites wrote:
Já verificaste se tens o gawk instalado e qual a versão?


hmm bem observado, estava com uma versao velha

vou atualizar aqui e já informo

t+
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Mon Aug 04, 2003 5:24 pm    Post subject: Reply with quote

putz agora pirei, nao vai mesmo

Quote:
otavio root # emerge -U gawk
>>> --upgradeonly implies --update... adding --update to options.
Calculating dependencies ...done!
>>> emerge (1 of 3) sys-apps/baselayout-1.8.6.8-r1 to /
>>> md5 src_uri ;-) sysvinit-2.84.tar.gz
>>> Unpacking source...
>>> Unpacking sysvinit-2.84.tar.gz to /var/tmp/portage/baselayout-1.8.6.8-r1/wor
k
>>> Unpacking rc-scripts-1.4.3.8p1.tar.bz2
* Checking if we need to tweak CONFIG_PROTECT_MASK
>>> Source unpacked.
* Building utilities...
gcc -O3 -mcpu=pentium3 -pipe -c -o consoletype.o consoletype.c
gcc -o consoletype consoletype.o
gcc -O3 -mcpu=pentium3 -pipe -c -o runscript.o runscript.c
gcc -o runscript runscript.o
gcc -O3 -mcpu=pentium3 -pipe -c -o start-stop-daemon.o start-stop-daemon.c
gcc -o start-stop-daemon start-stop-daemon.o
* Building sysvinit...
gcc -c -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE init.c
gcc -c -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE -DINIT_MAIN utmp.c -o init_u
tmp.o
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE -c -o halt.o halt.c
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE -c -o ifdown.o ifdown.c
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE -c -o hddown.o hddown.c
gcc -c -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE utmp.c
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE -c -o dowall.o dowall.c
init.c: In function `init_main':
init.c:2439: warning: no return statement in function returning non-void
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE -c -o shutdown.o shutdown.c
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE killall5.c -o killall5
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE -c -o runlevel.o runlevel.c
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE -c -o sulogin.o sulogin.c
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE -c -o utmpdump.o utmpdump.c
sulogin.c: In function `main':
sulogin.c:347: warning: `p' might be used uninitialized in this function
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE -c -o last.o last.c
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE -c -o mesg.o mesg.c
gcc -Wall -O3 -mcpu=pentium3 -pipe -D_GNU_SOURCE -c -o wall.o wall.c
gcc -o init init.o init_utmp.o
gcc -o halt halt.o ifdown.o hddown.o utmp.o
gcc -o shutdown dowall.o shutdown.o utmp.o
gcc -o runlevel runlevel.o
gcc -o sulogin sulogin.o -lcrypt
gcc -o utmpdump utmpdump.o
gcc -o last last.o
gcc -o mesg mesg.o
gcc -o wall dowall.o wall.o
* Please install sys-apps/gawk-3.1.1-r2 or later!

!!! ERROR: sys-apps/baselayout-1.8.6.8-r1 failed.
!!! Function src_compile, Line 128, Exitcode 0
!!! gawk too old

otavio root #

_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
AngusYoung
Retired Dev
Retired Dev


Joined: 20 Dec 2002
Posts: 473
Location: Campinas, SP - Brazil

PostPosted: Mon Aug 04, 2003 6:33 pm    Post subject: Reply with quote

Olá domus-br, estive verificando algumas threads nos fóruns, e a recomendação é fazer um re-emerge no gawk. Para isto basta:

Code:
emerge gawk


Se quiser dar uma olhada nas threads, pode verificar esses links aqui:

ERROR: sys-apps/baselayout-1.8.6.8-r1 failed.
emerging baselayout failed - gawk too old (but it's not)
baselayout-1.8.6.8-r1 says gawk is too old (it isn't)

Espero que ajude, boa sorte.
_________________
N.U.S.: A cross platform C++ application development framework
My blog (in Portuguese)
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Mon Aug 04, 2003 8:06 pm    Post subject: Reply with quote

AngusYoung wrote:
Olá domus-br, estive verificando algumas threads nos fóruns, e a recomendação é fazer um re-emerge no gawk. Para isto basta:

Code:
emerge gawk


Se quiser dar uma olhada nas threads, pode verificar esses links aqui:

ERROR: sys-apps/baselayout-1.8.6.8-r1 failed.
emerging baselayout failed - gawk too old (but it's not)
baselayout-1.8.6.8-r1 says gawk is too old (it isn't)

Espero que ajude, boa sorte.


opa so depois vi seu post
tive q tirar o gawk na mao grande mesmo (-C) , ai fiz o emerge gawk, tudo OK, to dando continuedade no emerge system (2-16), to esperando (mofando) ate agora terminar o glibc demora decadas :) assim q terminar volto a informar se foi tudo ok ou nao,

obrigado ai
t+ :)
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
domus-br
Apprentice
Apprentice


Joined: 27 May 2003
Posts: 292
Location: Niterói-RJ,Brasil

PostPosted: Wed Aug 06, 2003 1:13 pm    Post subject: Reply with quote

voltou tudo ao normal, obrigado ai angus :)
t+
_________________
http://www.mozilla.org.br

"Este site só funciona com browser IE 5 ou superior"
O Mozilla é superior!!
:=:=:=:=:=:
Forumgdh
LinuxBsd
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portuguese All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum