Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[ GLSA 200711-07 ] Python: User-assisted execution of arbitrary code
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index News & Announcements
View previous topic :: View next topic  
Author Message
GLSA
Veteran
Veteran


Joined: 12 May 2004
Posts: 1471

PostPosted: Wed Nov 07, 2007 9:26 pm    Post subject: [ GLSA 200711-07 ] Python: User-assisted execution of arbitr Reply with quote

Gentoo Linux Security Advisory

Title: Python: User-assisted execution of arbitrary code (GLSA 200711-07)
Severity: normal
Exploitable: remote
Date: November 07, 2007
Bug(s): #192876
ID: 200711-07

Synopsis

Multiple integer overflow vulnerabilities have been discovered in Python, possibly resulting in the execution of arbitrary code or a Denial of Service.

Background

Python is an interpreted, interactive, object-oriented programming language.

Affected Packages

Package: dev-lang/python
Vulnerable: < 2.4.4-r6
Unaffected: >= 2.3.6-r3 < 2.3.7
Unaffected: >= 2.4.4-r6
Architectures: All supported architectures


Description

Slythers Bro discovered multiple integer overflows in the imageop module, one of them in the tovideo() method, in various locations in files imageop.c, rbgimgmodule.c, and also in other files.

Impact

A remote attacker could entice a user to process specially crafted images with an application using the Python imageop module, resulting in the execution of arbitrary code with the privileges of the user running the application, or a Denial of Service. Note that this vulnerability may or may not be exploitable, depending on the application using the module.

Workaround

There is no known workaround at this time.

Resolution

All Python 2.3.x users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/python-2.3.6-r3"
All Python 2.4.x users should upgrade to the latest version:
Code:
# emerge --sync
# emerge --ask --oneshot --verbose ">=dev-lang/python-2.4.4-r6"


References

CVE-2007-4965
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index News & Announcements All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum