Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Code::Blocks live svn ebuild [Check last page for news]
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
sasq
Apprentice
Apprentice


Joined: 09 Sep 2005
Posts: 221
Location: Poland

PostPosted: Sun Aug 19, 2007 5:05 pm    Post subject: Reply with quote

keenblade wrote:
It is no good to emerge this way [...] Because next "emerge --sync" and "emerge -vuDN world" it will downgrade to x86 again.


I don't do emerge -vuDN world, only emerge --sync and upgrade only the packages I want.

keenblade wrote:
A better way is using portage.keywords, so that updates will not downgrade.

Yes, it's a good idea too, and I do it if I often update the same package.

Thanks for explaining me that xrc flag.

keenblade wrote:
For your main problem compiling codeblocks, I have to ask codeblocks guys. It must be something with your gcc and or binutils version. My gcc is version 4.2.0. Maybe somebody will answer untill then.


Now I have problem with wxGTK-2.8, as you can see above. When I removed stl USE flag it doesnt't want to compile :-/ I've read in Code::Blocks Wiki, that it uses wxGTK-2.6, but I don't know if that information are up to date and where are the current exact dependencies listed for Code::Blocks and some instructions for current C::B SVN version.

BTW I looked into your wxGTK-2.8 ebuild and I'm wondering why it downloads wxPython instead of wxGTK archive?

EDIT:
Strange, but I've unmerged the previously compiled wxGTK-2.8 [that one with stl flag] and merged again without stl and gnome flag, and this time it compiled without problems :| I don't know what has solved the problem: unmerging old version, or not using gnome flag, but now it's OK. I'm compiling codeblocks now...

EDIT2:
Whoa! It works! :D Thanks man! :D At last I have C::B with all plugins and errors fixed :)
_________________
SasQ
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Mon Aug 20, 2007 12:07 am    Post subject: Reply with quote

sasq wrote:
EDIT2:
Whoa! It works! :D Thanks man! :D At last I have C::B with all plugins and errors fixed :)

Great to hear that. Also I see you disabled contrib useflag for C:B. Enabling it gives you all the nice plugins.
wxGTK-2.8 ebuild downloads wxPython instead of wxGTK archive, because the official one wxGTK-2.6 in the portage does that, too.
wxPython is a GUI toolkit that wraps the wxWidgets cross platform GUI library around python language.
Code::Blocks Wiki is not up to date. C::B uses wxGTK-2.8.4.0 for some time.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
superman2001
Apprentice
Apprentice


Joined: 09 Dec 2004
Posts: 157
Location: Tubize (Belgique)

PostPosted: Tue Aug 28, 2007 12:42 pm    Post subject: Reply with quote

Hello guys.

I'm trying to compile C::B with the ebuilds from the overlay mentioned in this thread.
It hangs there :
Code:
i686-pc-linux-gnu-g++ -O2 -ffast-math -O3 -march=prescott -pipe -falign-functions=4 -fprefetch-loop-arrays -fvisibility-inlines-hidden -fno-strict-aliasing -DCB_PRECOMP -Winvalid-pch -fPIC -DPIC -fexceptions -Wl,-O1 -Wl,--hash-style=both -o .libs/codeblocks app.o appglobals.o compilersettingsdlg.o crashhandler.o dlgabout.o dlgaboutplugin.o environmentsettingsdlg.o infopane.o ipc.o main.o prefix.o printdlg.o scriptconsole.o scriptingsettingsdlg.o splashscreen.o startherepage.o -pthread -Wl,-O1 -Wl,--hash-style=both  -L/usr/lib -L/var/tmp/paludis/dev-util/codeblocks-9999-r17/work/codeblocks-9999/src/src/wxAUI /var/tmp/paludis/dev-util/codeblocks-9999-r17/work/codeblocks-9999/src/src/wxAUI/.libs/libwxaui.a /usr/lib/libgtk-x11-2.0.so /usr/lib/libgdk-x11-2.0.so /usr/lib/libatk-1.0.so /usr/lib/libgdk_pixbuf-2.0.so /usr/lib/libpangocairo-1.0.so /usr/lib/libpangoft2-1.0.so /usr/lib/libpango-1.0.so /usr/lib/libcairo.so /usr/lib/libfontconfig.so /usr/lib/libfreetype.so /usr/lib/libxml2.so /usr/lib/libglitz-glx.so /usr/lib/libglitz.so /usr/lib/libGL.so /usr/lib/libXext.so /usr/lib/libpng12.so -lm -lz /usr/lib/libXrender.so /usr/lib/libX11.so /usr/lib/libxcb-xlib.so /usr/lib/libxcb.so /usr/lib/libXau.so /usr/lib/libXdmcp.so /usr/lib/libgobject-2.0.so /usr/lib/libgmodule-2.0.so /usr/lib/libglib-2.0.so -L/var/tmp/paludis/dev-util/codeblocks-9999-r17/work/codeblocks-9999/src/sdk /var/tmp/paludis/dev-util/codeblocks-9999-r17/work/codeblocks-9999/src/sdk/.libs/libcodeblocks.so -L/usr/X11R6/lib -lwx_gtk2u_aui-2.8 -lwx_gtk2u_xrc-2.8 -lwx_gtk2u_qa-2.8 -lwx_gtk2u_html-2.8 -lwx_gtk2u_adv-2.8 -lwx_gtk2u_core-2.8 -lwx_baseu_xml-2.8 -lwx_baseu_net-2.8 -lwx_baseu-2.8 -lpthread -ldl
/usr/lib/libwx_gtk2u_xrc-2.8.so: undefined reference to `wxColour::IsOk() const'
collect2: ld returned 1 exit status
make[3]: *** [codeblocks] Error 1
make[3]: Leaving directory `/var/tmp/paludis/dev-util/codeblocks-9999-r17/work/codeblocks-9999/src/src'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/paludis/dev-util/codeblocks-9999-r17/work/codeblocks-9999/src/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/paludis/dev-util/codeblocks-9999-r17/work/codeblocks-9999/src'
make: *** [all-recursive] Error 1


Here are the USE flags for each package (note that i use Paludis) :
Code:
x11-libs/wxGTK-2.8.4.0::codeblocks {:2.8} X -debug -doc gif -gnome joystick odbc opengl sdl -stl unicode
dev-util/codeblocks-9999-r17::codeblocks {:0} contrib -debug -monolithic -static unicode vanilla -xrc

I tried to compile wxGTK with and without stl and gnome USE flags but nothing changed.

Here is my emerge --info (I removed the -Wl,--as-needed ldflag for both packages) :
Code:
Portage 2.1.3.7 (default-linux/x86/2007.0/desktop, gcc-4.2.0/vanilla, glibc-2.6.1-r0, 2.6.22-gentoo-r5 i686)
=================================================================
System uname: 2.6.22-gentoo-r5 i686 Intel(R) Pentium(R) 4 CPU 2.80GHz
Gentoo Base System release 1.12.10
Timestamp of tree: Mon, 27 Aug 2007 05:50:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
app-admin/eselect-compiler: 2.0.0_rc2-r1
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4, 2.5.1-r2
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.10-r4
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17.50.0.18
sys-devel/gcc-config: 2.0.0_rc1
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="x86 ~x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O3 -march=prescott -pipe -falign-functions=4 -fprefetch-loop-arrays -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/eselect/compiler /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O3 -march=prescott -pipe -falign-functions=4 -fprefetch-loop-arrays -fomit-frame-pointer -fvisibility-inlines-hidden"
DISTDIR="/mnt/distfiles"
FEATURES="ccache distlocks metadata-transfer parallel-fetch prelink sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://mirror.switch.ch/mirror/gentoo/ ftp://mirror.scarlet-internet.nl/pub/gentoo ftp://pandemonium.tiscali.de/pub/gentoo/ ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/"
LANG="fr_FR.UTF-8"
LC_ALL="fr_FR.UTF-8"
LINGUAS="fr"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/zugaina /usr/portage/local/layman/initng /usr/portage/local/layman/xwing /usr/portage/local/layman/sunrise /usr/portage/local/layman/xeffects /usr/portage/local/layman/berkano /usr/portage/local/layman/WTK-Testing /usr/portage/local/layman/gentopia /usr/portage/local/layman/einit /usr/portage/local/layman/nx /usr/portage/local/layman/toolchain /usr/portage/local/layman/gnome-experimental /usr/portage/local/layman/custom-kernels /usr/portage/local/layman/nouveau /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X Xaw3d a52 aac accessibility acl acpi alsa ao apache2 avahi avi bash-completion berkdb bitmap-fonts bonobo boost bzip2 cairo cdparanoia cdr chardet cli cracklib crypt ctype cups dba dbus dga divx4linux dri dts dv dvb dvd dvdr dvdread eds emboss encode esd evo exif fam fame fb fbcon ffmpeg firefox flac flash foomaticdb fortran ftp gcj gd gdbm gif gimp glitz glut gnome gphoto2 gpm gs gstreamer gtk gtkhtml hal hashstyle howl iconv icq idn imagemagick imlib ipod ipv6 isdnlog jack java javascript joystick jpeg kerberos lcms ldap lm_sensors lzo mad matroska midi mikmod mime mmx mono motif mozilla mp3 mpeg msn mudflap mysql ncurses nls nptl nptlonly nsplugin odbc ogg openal openexr opengl openmp oss pam pcre pdf perl php pic png postgres ppds pppd python qt3 qt3support qt4 quicktime readline reflection samba scanner sdl session spell spl sqlite sse ssl subtitles svg svga tcl tcpd threads tiff tk truetype truetype-fonts type1-fonts unicode usb v4l videos vorbis win32codecs wmf wxwindows x86 xine xml xorg xpm xprint xsl xv xvid yahoo zlib zvbi" ALSA_CARDS="intel8x0 bt87x" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INITNG_PLUGINS="also bash_launcher chdir chroot conflict cpout critical cron daemon dev dllaunch envparser find fstat history idleprobe initctl interactive iparser last limit logfile netprobe ngc2 ngc4 pause pidfile reload renice rlparser simple_launcher stcmd stdout suid syncron syslog sysreq unneeded" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" SANE_BACKENDS="niash" USERLAND="GNU" VIDEO_CARDS="nv nvidia vesa"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS


Thanks in advance for your answers.
Back to top
View user's profile Send private message
kfiaciarka
Veteran
Veteran


Joined: 20 May 2005
Posts: 1498
Location: Dobre Miasto, Poland

PostPosted: Tue Aug 28, 2007 9:47 pm    Post subject: Reply with quote

try portage version instead :)
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Wed Aug 29, 2007 5:00 am    Post subject: Reply with quote

superman2001 wrote:
Hello guys.

I'm trying to compile C::B with the ebuilds from the overlay mentioned in this thread.

Hi superman. I've just built c::b svn revision 4413, successfully. Could you try again. Maybe it was just a svn commit issue that makes svn sources fail sometimes.
I see you use vanilla useflag for c::b. Probably the problem is this useflag. It disables patches to c::b sources. Try it without vanilla useflag.
Also Could you try to emerge c::b without contrib useflag. So we could see if the problem is plugin related.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
superman2001
Apprentice
Apprentice


Joined: 09 Dec 2004
Posts: 157
Location: Tubize (Belgique)

PostPosted: Wed Aug 29, 2007 6:35 am    Post subject: Reply with quote

Hello,

I already have revision 4413. I'm trying to compile C::B without the contrib and vanilla USE flags, as advised.

I'll tell you if it worked or not.

Thanks.

EDIT : It hangs at the same place... :?
Back to top
View user's profile Send private message
moesasji
Apprentice
Apprentice


Joined: 10 May 2005
Posts: 263

PostPosted: Wed Aug 29, 2007 8:23 am    Post subject: Reply with quote

superman2001 wrote:
EDIT : It hangs at the same place... :?


Google gives only one hit when searching for "undefined reference to `wxColour::IsOk()" see here (just scroll down a bit) That points towards problems/bug with GCC. As you are using GCC-4.2 as your compiler it might be that that is the origin of the fact that codeblocks does not compile. Bottomline: compare the versions of GCC you are both using.

ps) Note that the workaround could be to compile wxGTK with the static useflag.
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Wed Aug 29, 2007 9:09 am    Post subject: Reply with quote

moesasji wrote:
...As you are using GCC-4.2 as your compiler it might be that that is the origin of the fact that codeblocks does not compile. Bottomline: compare the versions of GCC you are both using.

I use GCC-4.2 without a problem. I think it must be something with his CFLAGS and CXXFLAGS.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
superman2001
Apprentice
Apprentice


Joined: 09 Dec 2004
Posts: 157
Location: Tubize (Belgique)

PostPosted: Wed Aug 29, 2007 9:40 am    Post subject: Reply with quote

Yes, I also think so. I recompiled wxGTK without the -finline-visibility-hidden CXXFLAG disabled. It's recompiling C::B now. I'll tell you what.

EDIT : It worked. Thanks for your help.
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8208
Location: ~Brussels - Belgique

PostPosted: Mon Sep 03, 2007 3:30 pm    Post subject: Reply with quote

hello,

just switched from portage version to :
Code:
[ebuild   R   ] x11-libs/wxGTK-2.8.4.0  USE="X gif opengl sdl unicode -debug -doc -gnome -joystick -odbc -stl" 0 kB [1]
[ebuild   R   ] dev-util/codeblocks-9999-r16  USE="contrib unicode -debug" 0 kB [1]


:D
SVN 4421, but displayed "version 0". I saw that the working copy didn't have the .svn folders needed by update_revision.sh ; how to tell to copy all ?
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Fri Sep 07, 2007 7:47 pm    Post subject: Reply with quote

XavierMiller wrote:
just switched from portage version to :
Code:
...
[ebuild   R   ] dev-util/codeblocks-9999-r16  USE="contrib unicode -debug" 0 kB [1]


YOu are using old version codeblocks-9999-r16. Try the one I uploaded to savefile (codeblocks-9999-r17)
Quote:

SVN 4421, but displayed "version 0". I saw that the working copy didn't have the .svn folders needed by update_revision.sh ; how to tell to copy all ?

I fixed version numbering problem with codeblocks-9999-r17. It displays revision number correctly, try it.
"svn: '.' is not a working copy" is a harmless warning. Nothing to worry.
I emerged C::B rev 4439 just fine and working.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
xaviermiller
Administrator
Administrator


Joined: 23 Jul 2004
Posts: 8208
Location: ~Brussels - Belgique

PostPosted: Wed Sep 12, 2007 7:35 pm    Post subject: Reply with quote

ok, I'll try it but I cannot compile revision 4466 (missing WX options in autoconf files) ; I'll wait C::B is fixed;)

EDIT: some files were deleted by wxGTK-2.6 when I purged it. After re-emerging wxGTK-2.8.4, C::B builds with the -r17 ebuild. Compile in progress

EDIT2: IT WORKS :D

Thanks for the ebuilds ;)
_________________
Kind regards,
Xavier Miller
Back to top
View user's profile Send private message
rhill
Retired Dev
Retired Dev


Joined: 22 Oct 2004
Posts: 1629
Location: sk.ca

PostPosted: Thu Sep 13, 2007 2:37 pm    Post subject: Reply with quote

is --disable-stl needed for later codeblocks builds? I could add the USE flag to the upcoming 2.6.4.0 and 2.8.4.2 ebuilds.
_________________
by design, by neglect
for a fact or just for effect
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Fri Sep 14, 2007 9:38 pm    Post subject: Reply with quote

dirtyepic wrote:
is --disable-stl needed for later codeblocks builds? I could add the USE flag to the upcoming 2.6.4.0 and 2.8.4.2 ebuilds.

I don't think --disable-stl is needed. Because I guess it already defaults to being disabled by configure script, while emerging wxGTK, unless --enable-stl option (or stl useflag) is not used.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
Vlad.Sharp
Guru
Guru


Joined: 08 Dec 2004
Posts: 337
Location: Cambridgeshire, UK

PostPosted: Mon Sep 17, 2007 7:57 pm    Post subject: Reply with quote

I think (from looking at this bug: https://bugs.gentoo.org/show_bug.cgi?id=145884 ) that we may soon have a wxGTK-2.8 in the tree 8)
Back to top
View user's profile Send private message
StifflerStealth
Retired Dev
Retired Dev


Joined: 03 Jul 2002
Posts: 968

PostPosted: Mon Sep 24, 2007 12:38 pm    Post subject: Reply with quote

Would it be possible for the person maintaining this start a new thread so that the first post can be updated with the latest info/ebuilds/where to get links? It would be a lot easier for people. ;)
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Mon Sep 24, 2007 5:25 pm    Post subject: Reply with quote

StifflerStealth wrote:
Would it be possible for the person maintaining this start a new thread so that the first post can be updated with the latest info/ebuilds/where to get links? It would be a lot easier for people. ;)

Thanks for your suggestion. I created a new thread Code::Blocks live svn ebuild - Part 2
I will only update that thread. Please continue the C::B talking, there. And do not post anything here so people do not get lost here.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
muhsinzubeir
l33t
l33t


Joined: 29 Sep 2007
Posts: 948
Location: /home/muhsin

PostPosted: Fri Oct 12, 2007 11:08 pm    Post subject: codeblocks Reply with quote

hey guys..

Im trying to shift from borland in window to codeblocks or other programming IDE that can run my gentoo.But I was only been able run hello world at the beginning now i have no idea what happened...it seemed like it doesnt read the programs at all it gives this error when i try to run hello world on codeblocks.

sh:<file location>:Permission denied
Press Enter to continue

Does anybody have any clue what setup makes this error on my system?..as i just moved to linux actually got not too much experience to fix errors...any error just kick my but with no idea at all :roll:

any help will be appreciated...

cheers...
Back to top
View user's profile Send private message
StifflerStealth
Retired Dev
Retired Dev


Joined: 03 Jul 2002
Posts: 968

PostPosted: Sat Oct 13, 2007 2:22 am    Post subject: Reply with quote

Hi. This is the old thread. The new thread is here:
https://forums.gentoo.org/viewtopic-t-588089.html
The first post may have the answers you seek. :)

Thanks.
Back to top
View user's profile Send private message
muhsinzubeir
l33t
l33t


Joined: 29 Sep 2007
Posts: 948
Location: /home/muhsin

PostPosted: Thu Oct 18, 2007 1:49 am    Post subject: Re: codeblocks Reply with quote

muhsinzubeir wrote:
hey guys..

Im trying to shift from borland in window to codeblocks or other programming IDE that can run my gentoo.But I was only been able run hello world at the beginning now i have no idea what happened...it seemed like it doesnt read the programs at all it gives this error when i try to run hello world on codeblocks.

sh:<file location>:Permission denied
Press Enter to continue

Does anybody have any clue what setup makes this error on my system?..as i just moved to linux actually got not too much experience to fix errors...any error just kick my but with no idea at all :roll:

any help will be appreciated...

cheers...


This is resolved...i was trying to compile in a partition that is not executation:solution add exec on the fstab enty :wink:
Back to top
View user's profile Send private message
aquahawk
n00b
n00b


Joined: 10 Aug 2006
Posts: 6

PostPosted: Wed Nov 21, 2007 11:38 pm    Post subject: Reply with quote

tboloo wrote:
I have a strange error while trying to compile newest svn revision
Code:

bolek@abt ~/work/codeblocks $ make
Making all in src
make[1]: Wej¶cie do katalogu `/home/bolek/work/codeblocks/src'
Making all in build_tools
make[2]: Wej¶cie do katalogu `/home/bolek/work/codeblocks/src/build_tools'
Making all in autorevision
make[3]: Wej¶cie do katalogu `/home/bolek/work/codeblocks/src/build_tools/autorevision'
if g++ -DHAVE_CONFIG_H -I. -I. -I../../../src/sdk     -O2 -ffast-math -g -O2 -DCB_PRECOMP -Winvalid-pch -fPIC -DPIC -MT autorevision.o -MD -MP -MF ".deps/autorevision.Tpo" -c -o autorevision.o autorevision.cpp; \
        then mv -f ".deps/autorevision.Tpo" ".deps/autorevision.Po"; else rm -f ".deps/autorevision.Tpo"; exit 1; fi
/bin/sh ../../../libtool --tag=CXX --mode=link g++  -O2 -ffast-math -g -O2 -DCB_PRECOMP -Winvalid-pch -fPIC -DPIC   -o auto_revision  autorevision.o  -lpthread -ldl
mkdir .libs
g++ -O2 -ffast-math -g -O2 -DCB_PRECOMP -Winvalid-pch -fPIC -DPIC -o auto_revision autorevision.o  -lpthread -ldl
./auto_revision +int +wx +t ../../.. ./../../sdk/autorevision.h
*** glibc detected *** ./auto_revision: free(): invalid next size (normal): 0x0804f320 ***
======= Backtrace: =========
/lib/libc.so.6[0x401b2bab]
/lib/libc.so.6(__libc_free+0x79)[0x401b40e7]
/usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libstdc++.so.6(_ZdlPv+0x21)[0x400f5929]
/usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libstdc++.so.6(_ZdaPv+0x1d)[0x400f5975]
/usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libstdc++.so.6(_ZNSt13basic_filebufIcSt11char_traitsIcEE26_M_destroy_internal_bufferEv+0x2b)[0x4009d957]
/usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libstdc++.so.6(_ZNSt13basic_filebufIcSt11char_traitsIcEE5closeEv+0x51)[0x400a0511]
./auto_revision[0x8049faf]
./auto_revision[0x804ae98]
/lib/libc.so.6(__libc_start_main+0xdc)[0x40167864]
./auto_revision(__gxx_personality_v0+0x49)[0x8049251]
======= Memory map: ========
08048000-0804c000 r-xp 00000000 03:45 2851671    /home/bolek/work/codeblocks/src/build_tools/autorevision/auto_revision
0804c000-0804d000 rw-p 00004000 03:45 2851671    /home/bolek/work/codeblocks/src/build_tools/autorevision/auto_revision
0804d000-0806e000 rw-p 0804d000 00:00 0          [heap]
40000000-40019000 r-xp 00000000 03:45 3597523    /lib/ld-2.4.so
40019000-4001a000 r--p 00019000 03:45 3597523    /lib/ld-2.4.so
4001a000-4001b000 rw-p 0001a000 03:45 3597523    /lib/ld-2.4.so
4001b000-4001c000 r-xp 4001b000 00:00 0          [vdso]
4001c000-4001d000 rw-p 4001c000 00:00 0
40033000-40042000 r-xp 00000000 03:45 3597570    /lib/libpthread-2.4.so
40042000-40043000 r--p 0000e000 03:45 3597570    /lib/libpthread-2.4.so
40043000-40044000 rw-p 0000f000 03:45 3597570    /lib/libpthread-2.4.so
40044000-40046000 rw-p 40044000 00:00 0
40046000-40048000 r-xp 00000000 03:45 3597557    /lib/libdl-2.4.so
40048000-4004a000 rw-p 00001000 03:45 3597557    /lib/libdl-2.4.so
4004a000-40118000 r-xp 00000000 03:45 1684362    /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libstdc++.so.6.0.8
40118000-4011b000 r--p 000ce000 03:45 1684362    /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libstdc++.so.6.0.8
4011b000-4011d000 rw-p 000d1000 03:45 1684362    /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libstdc++.so.6.0.8
4011d000-40123000 rw-p 4011d000 00:00 0
40123000-40145000 r-xp 00000000 03:45 3597559    /lib/libm-2.4.so
40145000-40147000 rw-p 00021000 03:45 3597559    /lib/libm-2.4.so
40147000-40148000 rw-p 40147000 00:00 0
40148000-40151000 r-xp 00000000 03:45 1684361    /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libgcc_s.so.1
40151000-40152000 rw-p 00008000 03:45 1684361    /usr/lib/gcc/i686-pc-linux-gnu/4.1.1/libgcc_s.so.1
40152000-40262000 r-xp 00000000 03:45 3597554    /lib/libc-2.4.so
40262000-40264000 r--p 0010f000 03:45 3597554    /lib/libc-2.4.so
40264000-40266000 rw-p 00111000 03:45 3597554    /lib/libc-2.4.so
40266000-4026a000 rw-p 40266000 00:00 0
40300000-40321000 rw-p 40300000 00:00 0
40321000-40400000 ---p 40321000 00:00 0
bfa21000-bfa37000 rw-p bfa21000 00:00 0          [stack]
make[3]: *** [all-local] Przerwane
make[3]: Opuszczenie katalogu `/home/bolek/work/codeblocks/src/build_tools/autorevision'
make[2]: *** [all-recursive] B³±d 1
make[2]: Opuszczenie katalogu `/home/bolek/work/codeblocks/src/build_tools'
make[1]: *** [all-recursive] B³±d 1
make[1]: Opuszczenie katalogu `/home/bolek/work/codeblocks/src'
make: *** [all-recursive] B³±d 1

The odd thing is that everything compiles fine when I set LC_ALL=C instead of default LC_ALL=pl_PL.UTF8.
And yes, I have compiled wxGTK with unicode flag


This will allow codeblocks to launch its a glib/widgets problem i think.. I get that error and i launch codeblocks also vlc
this way.

G_SLICE=always-malloc codeblocks
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6, 7, 8, 9
Page 9 of 9

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum