Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problemi durante l'upgrade di expat [risolto con pezza]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

Goto page Previous  1, 2, 3, 4, 5, 6  Next  
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
MeMyselfAndI
l33t
l33t


Joined: 15 Nov 2005
Posts: 784
Location: Between the monitor and the chair

PostPosted: Thu Aug 16, 2007 11:15 pm    Post subject: Reply with quote

Perdonami l' OT ma che senso ha ricompilare tutto il world per cambiare le ottimizzazioni su un P2 500 ?
Back to top
View user's profile Send private message
gionnico
Apprentice
Apprentice


Joined: 29 Jun 2007
Posts: 192
Location: Italy

PostPosted: Thu Aug 16, 2007 11:46 pm    Post subject: Reply with quote

MeMyselfAndI wrote:
Perdonami l' OT ma che senso ha ricompilare tutto il world per cambiare le ottimizzazioni su un P2 500 ?

Ottimizzato và meglio. :o Tanto non mi costa nulla farlo lavorare qualche ora ^_^
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Thu Aug 16, 2007 11:52 pm    Post subject: Reply with quote

MeMyselfAndI wrote:
Perdonami l' OT ma che senso ha ricompilare tutto il world per cambiare le ottimizzazioni su un P2 500 ?

Forse vive in Siberia e ha bisogno di scaldarsi... :lol:
_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Fri Aug 17, 2007 8:35 am    Post subject: Reply with quote

lavish wrote:
MeMyselfAndI wrote:
Perdonami l' OT ma che senso ha ricompilare tutto il world per cambiare le ottimizzazioni su un P2 500 ?

Forse vive in Siberia e ha bisogno di scaldarsi... :lol:


Probabilmente anche il developer che ha smascherato expat2 in agosto ha questo problema :evil:
_________________
Ciao da me!
Back to top
View user's profile Send private message
Luc484
Veteran
Veteran


Joined: 26 Mar 2005
Posts: 1035
Location: Italy

PostPosted: Fri Aug 17, 2007 5:15 pm    Post subject: Reply with quote

MeMyselfAndI wrote:
Ma solo io sono riuscito ad aggiornare senza troppi casini ? A me e' bastato un revdep-rebuiuld -X e basta.


Non so se possa essere utile a chi ancora ha problemi. Io ho avuto problemi la prima volta che ho ricompilato tutto dopo l'aggiornamento di expat. Allora sono tornato indietro ed ho notato che avevo delle dipendenze rotte indipendentemente da expat. Ho sistemato tutto con revdep-rebuild, poi ho eseguito nuovamente l'upgrade di expat, e poi il revdep-rebuild successivo è andato senza problemi fino alla fine degli oltre 280 pacchetti. Probabilmente revdep-rebuild aveva dei problemi per via di altre dipendenze rotte? Strano no?
Back to top
View user's profile Send private message
marco.mac
n00b
n00b


Joined: 02 Aug 2007
Posts: 41
Location: Terni

PostPosted: Sat Aug 18, 2007 3:21 pm    Post subject: errore in emerge xorg-x11 Reply with quote

installando xorg-x11 mi è capitato questo errore ho cercato su google e ho trovato qualcosa su revdep-rebuilt ma dice che il comando non esiste come posso fare???


Code:
>>> Emerging (1 of 1) x11-misc/shared-mime-info-0.21-r1 to /
 * shared-mime-info-0.21.tar.bz2 RMD160 ;-) ...                           [ ok ]
 * shared-mime-info-0.21.tar.bz2 SHA1 ;-) ...                             [ ok ]
 * shared-mime-info-0.21.tar.bz2 SHA256 ;-) ...                           [ ok ]
 * shared-mime-info-0.21.tar.bz2 size ;-) ...                             [ ok ]
 * checking ebuild checksums ;-) ...                                      [ ok ]
 * checking auxfile checksums ;-) ...                                     [ ok ]
 * checking miscfile checksums ;-) ...                                    [ ok ]
 * checking shared-mime-info-0.21.tar.bz2 ;-) ...                         [ ok ]
>>> Unpacking source...
>>> Unpacking shared-mime-info-0.21.tar.bz2 to /var/tmp/portage/x11-misc/shared-mime-info-0.21-r1/work
 * Applying shared-mime-info-0.21-pkgconfig.patch ...
  [ ok ]
 * Running automake --add-missing --copy --foreign ...
  [ ok ]
>>> Source unpacked.
>>> Compiling source in /var/tmp/portage/x11-misc/shared-mime-info-0.21-r1/work/shared-mime-info-0.21 ...
 * econf: updating shared-mime-info-0.21/config.guess with /usr/share/gnuconfig/config.guess
 * econf: updating shared-mime-info-0.21/config.sub with /usr/share/gnuconfig/config.sub
./configure --prefix=/usr --host=x86_64-pc-linux-gnu --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --disable-update-mimedb --libdir=/usr/lib64 --build=x86_64-pc-linux-gnu
checking for a BSD-compatible install... /bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking for x86_64-pc-linux-gnu-gcc... x86_64-pc-linux-gnu-gcc
checking for C compiler default output file name... a.out
checking whether the C compiler works... yes
checking whether we are cross compiling... no
checking for suffix of executables...
checking for suffix of object files... o
checking whether we are using the GNU C compiler... yes
checking whether x86_64-pc-linux-gnu-gcc accepts -g... yes
checking for x86_64-pc-linux-gnu-gcc option to accept ISO C89... none needed
checking for style of include used by make... GNU
checking dependency style of x86_64-pc-linux-gnu-gcc... gcc3
checking for an ANSI C-conforming const... yes
checking for intltool >= 0.35.0... 0.35.0 found
checking for perl... /usr/bin/perl
checking for XML::Parser... ok
checking for iconv... /usr/bin/iconv
checking for msgfmt... /usr/bin/msgfmt
checking for msgmerge... /usr/bin/msgmerge
checking for xgettext... /usr/bin/xgettext
checking how to run the C preprocessor... x86_64-pc-linux-gnu-gcc -E
checking for grep that handles long lines and -e... /bin/grep
checking for egrep... /bin/grep -E
checking for ANSI C header files... yes
checking for sys/types.h... yes
checking for sys/stat.h... yes
checking for stdlib.h... yes
checking for string.h... yes
checking for memory.h... yes
checking for strings.h... yes
checking for inttypes.h... yes
checking for stdint.h... yes
checking for unistd.h... yes
checking build system type... x86_64-pc-linux-gnu
checking host system type... x86_64-pc-linux-gnu
checking locale.h usability... yes
checking locale.h presence... yes
checking for locale.h... yes
checking for LC_MESSAGES... yes
checking libintl.h usability... yes
checking libintl.h presence... yes
checking for libintl.h... yes
checking for ngettext in libc... yes
checking for dgettext in libc... yes
checking for bind_textdomain_codeset... yes
checking for msgfmt... /usr/bin/msgfmt
checking for dcgettext... yes
checking for gmsgfmt... /usr/bin/gmsgfmt
checking for xgettext... /usr/bin/xgettext
found xgettext program is not GNU xgettext; ignore it
checking for x86_64-pc-linux-gnu-pkg-config... no
checking for pkg-config... /usr/bin/pkg-config
checking pkg-config is at least version 0.9.0... yes
checking for ALL... yes
configure: creating ./config.status
config.status: creating Makefile
config.status: creating shared-mime-info.pc
config.status: creating po/Makefile.in
config.status: creating config.h
config.status: executing depfiles commands
config.status: executing intltool commands
config.status: executing default-1 commands
config.status: executing po/stamp-it commands
Making check in po
make[1]: Entering directory `/var/tmp/portage/x11-misc/shared-mime-info-0.21-r1/work/shared-mime-info-0.21/po'
file=`echo az | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file az.po
file=`echo bg | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file bg.po
file=`echo cs | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file cs.po
file=`echo cy | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file cy.po
file=`echo da | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file da.po
file=`echo de | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file de.po
file=`echo el | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file el.po
file=`echo eo | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file eo.po
file=`echo es | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file es.po
file=`echo eu | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file eu.po
file=`echo fi | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file fi.po
file=`echo fr | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file fr.po
file=`echo hu | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file hu.po
file=`echo it | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file it.po
file=`echo ja | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file ja.po
file=`echo ko | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file ko.po
file=`echo lt | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file lt.po
file=`echo ms | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file ms.po
file=`echo nb | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file nb.po
file=`echo nl | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file nl.po
file=`echo nn | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file nn.po
file=`echo pl | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file pl.po
file=`echo pt | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file pt.po
file=`echo pt_BR | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file pt_BR.po
file=`echo ru | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file ru.po
file=`echo rw | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file rw.po
file=`echo sq | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file sq.po
file=`echo sr | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file sr.po
file=`echo sv | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file sv.po
file=`echo uk | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file uk.po
file=`echo vi | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file vi.po
file=`echo zh_CN | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file zh_CN.po
file=`echo zh_TW | sed 's,.*/,,'`.gmo \
     && rm -f $file && /usr/bin/gmsgfmt -o $file zh_TW.po
INTLTOOL_EXTRACT=../intltool-extract srcdir=. ../intltool-update --gettext-package shared-mime-info --pot
WARNING: This version of gettext does not support extracting non-ASCII
         strings. That means you should install a version of gettext
         that supports non-ASCII strings (such as GNU gettext >= 0.12),
         or have to let non-ASCII strings untranslated. (If there is any)
/usr/bin/xgettext: error while loading shared libraries: libexpat.so.0: cannot open shared object file: No such file or directory
ERROR: xgettext failed to generate PO template file. Please consult
       error message above if there is any.
make[1]: *** [shared-mime-info.pot] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-misc/shared-mime-info-0.21-r1/work/shared-mime-info-0.21/po'
make: *** [check-recursive] Error 1

!!! ERROR: x11-misc/shared-mime-info-0.21-r1 failed.
Call stack:
  ebuild.sh, line 1632:   Called dyn_compile
  ebuild.sh, line 983:   Called qa_call 'src_compile'
  ebuild.sh, line 44:   Called src_compile
  shared-mime-info-0.21-r1.ebuild, line 32:   Called die

!!! emake failed.
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/x11-misc/shared-mime-info-0.21-r1/temp/build.log'.



da cosa potrebbe dipendere???
_________________
Al mio segnale... Scatenate l'inferno!!!
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Sat Aug 18, 2007 3:38 pm    Post subject: Re: errore in emerge xorg-x11 Reply with quote

marco.mac wrote:
Code:

/usr/bin/xgettext: error while loading shared libraries: libexpat.so.0: cannot open shared object file: No such file or directory


expat.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Tigerwalk
Guru
Guru


Joined: 15 May 2007
Posts: 475
Location: Napoli

PostPosted: Sat Aug 18, 2007 4:05 pm    Post subject: Re: errore in emerge xorg-x11 Reply with quote

marco.mac wrote:
installando xorg-x11 mi è capitato questo errore ho cercato su google e ho trovato qualcosa su revdep-rebuilt ma dice che il comando non esiste come posso fare???


il comando è:
Code:
revdep-rebuild
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Sat Aug 18, 2007 4:53 pm    Post subject: Re: errore in emerge xorg-x11 Reply with quote

Fatto il merge del thread aperto da marco.mac.
Tigerwalk wrote:
Code:
revdep-rebuild

Code:
revdep-rebuild -X

_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
Ic3M4n
Advocate
Advocate


Joined: 02 Nov 2004
Posts: 3489
Location: Bergamo.

PostPosted: Sat Aug 18, 2007 7:48 pm    Post subject: Reply with quote

revdep-rebuild fa parte di gentoolkit. Nel caso non l'avessi installato ti conviene farlo.
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Wed Aug 22, 2007 4:44 pm    Post subject: Reply with quote

anche dopo un revdep-rebuild -X, libexpat.so.0 dava ancora problemi con subversion, ho risolto con un brutale:
Code:
ln -sf /usr/lib/libexpat.so.1.5.2 /usr/lib/libexpat.so.0

_________________
LP
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Wed Aug 22, 2007 6:56 pm    Post subject: Reply with quote

lucapost wrote:
anche dopo un revdep-rebuild -X, libexpat.so.0 dava ancora problemi con subversion, ho risolto con un brutale:
Code:
ln -sf /usr/lib/libexpat.so.1.5.2 /usr/lib/libexpat.so.0

Controlla di aver ricompilato TUTTE le versioni installate di apr-util: siccome questo pacchetto ha più slot, devi ricompilare sia l'eventuale versione 0.9* che la 1.*.
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed Aug 22, 2007 7:03 pm    Post subject: Reply with quote

lucapost wrote:
anche dopo un revdep-rebuild -X, libexpat.so.0 dava ancora problemi con subversion, ho risolto con un brutale:
Code:
ln -sf /usr/lib/libexpat.so.1.5.2 /usr/lib/libexpat.so.0

per me è altamente sconsigliabile.

in questo modo tutti i nuovi pacchetti che compilarai d'ora in avanti potrebbero credere di essere lincati alla versione sbagliata di expat, genrando un sistema incoerente. il giorno che ti dimentichi del problema e togli il link, ti salta tutto e non riesci a capire il perché.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Thu Aug 23, 2007 7:58 am    Post subject: Reply with quote

cloc3 wrote:
lucapost wrote:
anche dopo un revdep-rebuild -X, libexpat.so.0 dava ancora problemi con subversion, ho risolto con un brutale:
Code:
ln -sf /usr/lib/libexpat.so.1.5.2 /usr/lib/libexpat.so.0

per me è altamente sconsigliabile.


Concordo. A preferenza:

Code:
emerge -c subversion && emerge subversion


Quote:
in questo modo tutti i nuovi pacchetti che compilarai d'ora in avanti potrebbero credere di essere lincati alla versione sbagliata di expat


Non proprio. I pacchetti compilati d'ora in poi dovrebbero usare gli header della nuova expat. Il problema é che i pacchetti che al momento sono problematici (subversion, ma anche pacchetti slotted come apr-util) userebbero la libreria 1.5.2 convinti di usare la .0 e questo potrebbe causare malfunzionamenti (o il crash dell'applicativo).
_________________
Ciao da me!
Back to top
View user's profile Send private message
motosauro
Tux's lil' helper
Tux's lil' helper


Joined: 23 Nov 2005
Posts: 83
Location: Verona, Italy

PostPosted: Thu Aug 23, 2007 10:46 am    Post subject: Reply with quote

Ciao a tutti.
Anch'io vittima del simpatico expat.

Ho risolto su tutti i sistemi x86 che controllo (che sono server headless, quindi con pochi fronzoli)

Sull'unico client però sto incontrando delle difficoltà non da poco. Le gtk+ non ne vogliono sapere di compilare: si bloccano cercando libexpat.so.0 se installo expat-2x e si bloccano cercando libexpat.so.1 se faccio un downgrade alla 1.9.x :cry:

Inoltre senza libexpat.so.0 non mi parte il pannello di controllo della Nvidia.

A questo punto mi sarei anche abbastanza rotto i cosiddetti di correre dietro a dipendenze che revdep-rebuild non è in grado di sistemare.
Secondo voi un
Code:

emerge -e system && emerge -e world

sistemerebbe?

P.S.
posto l'emerge --info per completezza: non ci dovrebbero essere problemi a riguardo, ma non si sa mai :)
Code:

Portage 2.1.2.12 (default-linux/amd64/2007.0, gcc-4.1.2, glibc-2.5-r4, 2.6.20-gentoo-r8 x86_64)
=================================================================
System uname: 2.6.20-gentoo-r8 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System release 1.12.9
Timestamp of tree: Thu, 23 Aug 2007 07:00:01 +0000
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -march=k8 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O3 -march=k8 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.inode.at/ http://www.die.unipd.it/pub/Linux/distributions/gentoo-sources/ "
LC_ALL="it_IT.UTF-8"
LINGUAS="it"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext 7zip X aac acl acpi aiglx alsa amd64 amuled arj arts automount bash-completion berkdb bindist bitmap-fonts branding cdr cdrom cdsound cli cpudetection cracklib crypt cups dbus dcraw directfb dri dts dvd dvdr dvdread emerald encode escreen esd etwin fbcon fbsplash ffmpeg firefox flac fortran gdbm gif gimp gimpprint glitz gphoto2 gpm graphviz gtk hal iconv ieee1394 imagemagick insecure-savers ipv6 isdnlog jack java java5 javascript jpeg jpeg2k kde kdeenablefinal ldap lha libcaca lirc lm_sensors logitech-mouse logrotate mad matroska midi mmap mmx mmxext motif mouse mp3 mp4 mp4live mpeg mpeg2 mplayer mudflap musepack musicbrainz mysql mysqli ncurses netbeans nextaw nls noamazon nptl nptlonly nsplugin nvidia offensive ogg openal opengl openmp oss pam pcre perl png portaudio pppd print python qt4 quicktime rar rdesktop readline reflection samba sdl sensord server session skins slp sndfile spl sse sse2 ssl startup-notification stream svg tcpd tga thumbnail tiff truetype truetype-fonts type1-fonts unicode usb userlocales v4l v4l2 visualization vorbis vorbis-psy wxwindows xcomposite xinerama xorg xscreensaver xv xvid zip zlib" ALSA_CARDS="emu10k1" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse wacom" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" LIRC_DEVICES="livedrive_midi" USERLAND="GNU" VIDEO_CARDS="vga"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

_________________
Per aspera ad astra
Back to top
View user's profile Send private message
Scen
Retired Dev
Retired Dev


Joined: 29 Jul 2003
Posts: 2470
Location: Padova, Italy

PostPosted: Thu Aug 23, 2007 12:06 pm    Post subject: Reply with quote

revdep-rebuild non ti restituisce più nulla da ricompilare?
Magari la compilazione fallita di gtk+ è causata da una dipendenza di gtk+ che necessita di essere ricompilata.
_________________
I was born in a deep forest/I wish I could live here all my life/I am made from stones and roots/My home, these woods and roads
All my life I loved this sound/Of the woods all around/Eagles flies where the winds blows free
Journey is my destiny
Back to top
View user's profile Send private message
motosauro
Tux's lil' helper
Tux's lil' helper


Joined: 23 Nov 2005
Posts: 83
Location: Verona, Italy

PostPosted: Thu Aug 23, 2007 1:01 pm    Post subject: Reply with quote

Scen wrote:
revdep-rebuild non ti restituisce più nulla da ricompilare?
Magari la compilazione fallita di gtk+ è causata da una dipendenza di gtk+ che necessita di essere ricompilata.


è quello che penso anch'io, ma valla a trovare.
Intanto ho dato un revdep-rebuild senza parametri e qualche risultato pare che ci sia:
Adesso le gtk si bloccano cercando libGL.so (dovrebbe essere quello dell'Nvidia) e ho appena fatto emerge mesa

Dopo aver riemerso kdelibs e kdebase adesso vediamo se si riesce ad avere un sistema funzionante :(

le opzioni che sto valutando qualora non riuscissi a sistemare tutto in breve tempo sono:
1) reinstallare partendo dal base-system
2) emerge -e system && emerge -e world
3) kubuntu :?

P.S.
revdep aveva trovato varie cose da sistemare, tutte connesse a libexpat.so.0 e fra queste anche kdelibs, kdebase e altri pacchettini leggeri :evil:

P.P.S.
Sarà un'impressione mia dovuta al fatto che in questo frangente mi sto muovendo come una formica impazzita, ma revdep non vi pare dia risultati diversi a seconda di quante volte viene lanciato? Vi pare normale?
_________________
Per aspera ad astra
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Thu Aug 23, 2007 2:09 pm    Post subject: Reply with quote

motosauro wrote:
Sarà un'impressione mia dovuta al fatto che in questo frangente mi sto muovendo come una formica impazzita, ma revdep non vi pare dia risultati diversi a seconda di quante volte viene lanciato? Vi pare normale?


Prima di rilanciare revdep-rebuild fai anche un:
Code:
 rm ~/.revdep*

:?:
_________________
Ciao da me!
Back to top
View user's profile Send private message
motosauro
Tux's lil' helper
Tux's lil' helper


Joined: 23 Nov 2005
Posts: 83
Location: Verona, Italy

PostPosted: Thu Aug 23, 2007 2:28 pm    Post subject: Reply with quote

randomaze wrote:
motosauro wrote:
Sarà un'impressione mia dovuta al fatto che in questo frangente mi sto muovendo come una formica impazzita, ma revdep non vi pare dia risultati diversi a seconda di quante volte viene lanciato? Vi pare normale?


Prima di rilanciare revdep-rebuild fai anche un:
Code:
 rm ~/.revdep*

:?:


ovviamente sì, altrimenti dato che si scrive per comodità i risultati in quei files sarebbe come cercare di parcheggiare la macchina senza usare lo sterzo (come la maggior parte delle donne insomma :D )
Adesso sono arrivato al punto che mi trova solo gtklibs e gtk da compilare.
Gtklibs si è compilato, gtk+ è in forno adesso, sperém....

La cosa che non capiscoi però è:
se equery g gtk+ | grep expat
mi trova solo expat-2, com'è che in compilazione si lamenta della mancanza di libexpat.so.0?
_________________
Per aspera ad astra
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Fri Aug 24, 2007 11:13 am    Post subject: Reply with quote

[SFOGO!!!]
Non è possibile che ad ogni aggiornamento di expat molti utenti abbiano molti problemi, in più in questo caso anche quello che dovrebbe essere un efficace revdep-rebuild si è rivelato una fetecchia!!! ricompila questo, ricompila quello: non dovrebbe accadere! :evil:
[/SFOGO]
_________________
LP
Back to top
View user's profile Send private message
motosauro
Tux's lil' helper
Tux's lil' helper


Joined: 23 Nov 2005
Posts: 83
Location: Verona, Italy

PostPosted: Fri Aug 24, 2007 11:20 am    Post subject: update Reply with quote

Io ho risolto sostanzialmente tutto:
Dopo vari revdep-rebuild allafine pare che le dipendenze si siano sistemate.
Per me la chiave pare che siano state le gtklibs ricompilate più volte.

Io continuo ad avere l'impressione che il revdep-rebuild dia risultati un po' aleatori in condizioni come questa di dipendenze svaccate per mezzo sistema.
Ad ogni modo è bene quel che finisce bene (fino al prossimo casino da PITA) :)
Grazie a tutti per il supporto e buona fortuna a chi deve ancora risolvere
_________________
Per aspera ad astra
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Fri Aug 24, 2007 11:21 am    Post subject: Reply with quote

lucapost wrote:
[SFOGO!!!]
Non è possibile che ad ogni aggiornamento di expat molti utenti abbiano molti problemi, in più in questo caso anche quello che dovrebbe essere un efficace revdep-rebuild si è rivelato una fetecchia!!! ricompila questo, ricompila quello: non dovrebbe accadere! :evil:
[/SFOGO]

Questo e' il primo aggiornamento di expat in gentoo che richiede una ricompilazione sostanziale di parte del sistema. Mi sembra che la frase "ad ogni aggiornamento di expat" sia quantomeno fuori luogo.

Detto questo, e' inutile ricordare che l'esistenza di expat e' indipendente da gentoo, vero? :roll:
revdep-rebuild ha lacune, ma non e' che possa fare sempre miracoli...

Gentoo non ha MAI uno sbalzo da una release all'altra a differenza di ogni altra distro binaria. Quando cambiano le ABI di una libreria pero' c'e' poco da fare.

Non condivido lo sfogo.

//EDIT: aggiungo che buona parte delle persone che hanno avuto grossi problemi in questo aggiornamento, si sono ritrovati in questa situazione a causa di una inconsistenza del sistema precedente.
_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
lucapost
Veteran
Veteran


Joined: 24 Nov 2005
Posts: 1415
Location: <ud|me|ts> - Italy

PostPosted: Fri Aug 24, 2007 11:40 am    Post subject: Reply with quote

Non è la prima: https://forums.gentoo.org/viewtopic-p-3219668-highlight-basta.html#3219668.
_________________
LP
Back to top
View user's profile Send private message
randomaze
Bodhisattva
Bodhisattva


Joined: 21 Oct 2003
Posts: 9985

PostPosted: Fri Aug 24, 2007 12:01 pm    Post subject: Reply with quote

lucapost wrote:
Non è la prima: https://forums.gentoo.org/viewtopic-p-3219668-highlight-basta.html#3219668.


Non é la prima e non sarà neanche l'ultima! Ma non la cosa non cambia la sostanza: compilare un intero sistema partendo dai sorgenti produce inevitabilmente dei problemi ad ogni cambio di versione di una qualche libreria, l'impatto é ovviamente proporzionale all'uso che viene fatto di tale libreria.

In quanto a revdep-rebuild: non é sicuramente esente da difetti ma non mi ha mai dato particolari problemi, e considerando che sulla mia installazione ci sono quasi 4 anni di rilasci di compilatori, librerie e ammennicoli vari credo di averlo usato un pò di volte :roll:
_________________
Ciao da me!
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Fri Aug 24, 2007 12:21 pm    Post subject: Reply with quote

lucapost wrote:
Non è la prima: https://forums.gentoo.org/viewtopic-p-3219668-highlight-basta.html#3219668.

Quel post risale a quando expat-2 era passato in ~arch...
_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Goto page Previous  1, 2, 3, 4, 5, 6  Next
Page 3 of 6

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum