Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libexpat 2.0.0 ABI breakage
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3 ... , 9, 10, 11  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
isnogood
Tux's lil' helper
Tux's lil' helper


Joined: 09 Jul 2003
Posts: 96

PostPosted: Mon Jan 08, 2007 4:52 pm    Post subject: Reply with quote

I did a rather nasty rebuild after frying my system with kde4 svn.Anyway after purging all kde stuff and rebuilding about everything with an 'upgrade' to ~amd64 the expat problem showed up and no - revdep-rebuild didn't fix it because gtk+ still was complaining about missing libexpat.so.0
Finally got everything to run (seems like anyway) by emerging a older version of expat and then emerging expat2 to slot 2 like somebody mentioned in the bugreport.
Nice thing the maintainers point out that there is the revdep message with new expat version but unfortunately that doesn't seem to work for a bunch of people.
Just telling people to shove it if they run unstable is also not really a resolution to stuff like that - heck,the first post in this thread is close to a year old and this still isn't fixed?Plus the bugstatus reads resolved. This is openssl ,gnome2 and the likes all over again.
Back to top
View user's profile Send private message
ericxx2005
Apprentice
Apprentice


Joined: 05 Apr 2005
Posts: 231
Location: 10 square miles surrounded by reality

PostPosted: Thu Jan 11, 2007 8:19 pm    Post subject: Reply with quote

I just switched to ~amd64 and I'm having this problem too. Maybe there should be some sort of warning before you emerge the new expat to notify us that we have to re-emerge or revdep-rebuild everything. I was thinking that they could put something like this into portage when emerging it:

Code:
WARNING: Upgrading expat requires that you do a revdep-rebuild or many packages will be broken, do you want to continue?  [yes/No]


Something like this should be implemented BEFORE it gets emerged, not after, but I don't know if portage is able to do something like this... :roll:

So far I'm on about 200 out of 1070 packages, if this doesn't work I'm kinda SOL.
_________________
AMD 1090T | 2 GB | AMD 890GX | Gentoo x86_64
Core i7-920 | 6 GB | AMD 5850 | Windows 7 Pro
Back to top
View user's profile Send private message
AnXa
Apprentice
Apprentice


Joined: 06 Apr 2004
Posts: 250
Location: Lahti, Finland

PostPosted: Wed Feb 07, 2007 4:36 pm    Post subject: Reply with quote

ericxx2005 wrote:
I was thinking that they could put something like this into portage when emerging it:

Code:
WARNING: Upgrading expat requires that you do a revdep-rebuild or many packages will be broken, do you want to continue?  [yes/No]


Something like this should be implemented BEFORE it gets emerged, not after, but I don't know if portage is able to do something like this... :roll:


Seconded! I support this idea. :P
_________________
The idea isn't about how do you see or hear it, it's about how do you experience it...
--//--
Asus K8V Deluxe, Athlon64 3500+, nVidia 7600 GT, 3Gb 400MHz DDR, IDE HD 160Gb, IDE HD 850Mb and SATA HD 250Gb
Back to top
View user's profile Send private message
adekoba
Tux's lil' helper
Tux's lil' helper


Joined: 06 Oct 2006
Posts: 129

PostPosted: Thu Feb 22, 2007 12:22 am    Post subject: Reply with quote

uh. expat hell.

So i emerge expat-2.0 and i noticed that certain programs wouldn't launch anymore. then i revdep-rebuild, and at first it looks like it's going to fix it, but it fails when trying to build a package that requires the expat library. i remerged neon like users suggested earlier in the thread before running revdep-rebuild and still, nothing.

can i emerge both versions?
_________________
website
Back to top
View user's profile Send private message
adekoba
Tux's lil' helper
Tux's lil' helper


Joined: 06 Oct 2006
Posts: 129

PostPosted: Fri Feb 23, 2007 1:03 am    Post subject: Reply with quote

As a temporary solution I just blocked all versions greater than or equal to 2.0. Does anybody know if theres a definite solution to this (besides revdep-rebuild which does NOT work)?
_________________
website
Back to top
View user's profile Send private message
thedarkspirit
n00b
n00b


Joined: 28 Mar 2007
Posts: 7

PostPosted: Wed Mar 28, 2007 4:04 pm    Post subject: Reply with quote

revdep-rebuild doesn't work for me either. I switched my system to ~x86 some days ago because I wanted to try some stuff. Almost everything worked fine. But emerging x11-libs/pango failed telling me:

Code:
Writing a pango.modules file to use with tests/examples.
/var/tmp/portage/x11-libs/pango-1.14.10/work/pango-1.14.10/pango/.libs/lt-pango-querymodules: error while loading shared libraries: libexpat.so.0: cannot open shared object file: No such file or directory
make[3]: *** [pango.modules] Fehler 127
make[3]: Leaving directory `/var/tmp/portage/x11-libs/pango-1.14.10/work/pango-1.14.10/modules'
make[2]: *** [all-recursive] Fehler 1
make[2]: Leaving directory `/var/tmp/portage/x11-libs/pango-1.14.10/work/pango-1.14.10/modules'
make[1]: *** [all-recursive] Fehler 1
make[1]: Leaving directory `/var/tmp/portage/x11-libs/pango-1.14.10/work/pango-1.14.10'


revdep-rebuild just wanted to re-emerge pango, failing for the same reason of course. Great. Any easier / "cleaner" solution than creating a syslink?

// edit:
Well, I tried some stuff like
- re-emerging perl
- running perl-cleaner
- ...and emerge --newuse for updating some old ebuilds
- (maybe other stuff too)

But now, it finally works - as pango is compiling now.
Back to top
View user's profile Send private message
Decibels
Veteran
Veteran


Joined: 16 Aug 2002
Posts: 1555
Location: U.S.A.

PostPosted: Sat Apr 14, 2007 3:06 pm    Post subject: Reply with quote

This expat-2.0.0 just hit me when upgrading to a fcron fix. Revdep-rebuild wanted to install some packages that portage balked out. Anyway, my fix was to go back stable to the problem fcron with deps. That remerged expat and all the others back to previous 'working' status, since didn't know what the problem was at first. Then did a --oneshot for the new fcron fix.

Not touching this new unstable expat until have to.
_________________
http://webpages.charter.net/decibelshelp/
Don't assume malice for what stupidity can explain.
Always remember you're unique. Just like everyone else.
Everybody lies........but it doesn't matter since nobody listens.
Back to top
View user's profile Send private message
eean
Guru
Guru


Joined: 10 Jun 2002
Posts: 355
Location: Kirksville, MO USA

PostPosted: Thu Apr 19, 2007 10:18 pm    Post subject: Reply with quote

Ok, does this thread ever address the original posters problem?

I can't run SVN, it doesn't matter how many times I recompile it. Or recompile neon. Or expat.
Code:
 # svn
svn: error while loading shared libraries: libexpat.so.0: cannot open shared object file: No such file or directory


What the hell? How does subversion manage to compile?
_________________
Amarok - Rediscover your Music
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Thu Apr 19, 2007 10:31 pm    Post subject: Reply with quote

eean wrote:
libexpat.so.0

Check these:
Code:
$ ls -l /usr/lib/libexpat.*
-rw-r--r-- 1 root root 154240 2007-04-10 12:48 /usr/lib/libexpat.a
-rw-r--r-- 1 root root    793 2007-04-10 12:48 /usr/lib/libexpat.la
lrwxrwxrwx 1 root root     17 2007-04-10 12:48 /usr/lib/libexpat.so -> libexpat.so.1.5.0
lrwxrwxrwx 1 root root     17 2007-04-10 12:48 /usr/lib/libexpat.so.1 -> libexpat.so.1.5.0
-rwxr-xr-x 1 root root 123420 2007-04-10 12:48 /usr/lib/libexpat.so.1.5.0

$ ldd /usr/bin/svn | grep expat
libexpat.so.1 => /usr/lib/libexpat.so.1 (0x001f9000)

$ equery list -p -o -e expat
[I--] [ ~] dev-libs/expat-2.0.0 (0)
Back to top
View user's profile Send private message
eean
Guru
Guru


Joined: 10 Jun 2002
Posts: 355
Location: Kirksville, MO USA

PostPosted: Thu Apr 19, 2007 10:45 pm    Post subject: Reply with quote

I "fixed" it by editing the ebuild of expat-2.0 and changing its slot from 0 to 1. So now I have both emerged and subversion runs fine.

Of course next time I forget and emerge expat-2.0.1 or something I might be screwed.
_________________
Amarok - Rediscover your Music
Back to top
View user's profile Send private message
M.Pomme
n00b
n00b


Joined: 24 Oct 2005
Posts: 4

PostPosted: Sat Aug 11, 2007 4:39 pm    Post subject: Reply with quote

eean wrote:
Ok, does this thread ever address the original posters problem?

I can't run SVN, it doesn't matter how many times I recompile it. Or recompile neon. Or expat.
Code:
 # svn
svn: error while loading shared libraries: libexpat.so.0: cannot open shared object file: No such file or directory


What the hell? How does subversion manage to compile?


I found the solution so I thought I should share : recompile apr-util

The problem was that svn links against some libs provided by apr-util, and at least one of those libs was linked to expat.

If this is still not enough for you, use ldd on svn and then recursively on the shared libraries it depends on to find out which one still uses libexpat.so.0
Back to top
View user's profile Send private message
dritan
Apprentice
Apprentice


Joined: 01 Feb 2006
Posts: 210
Location: New York

PostPosted: Mon Aug 13, 2007 1:48 am    Post subject: Who unmasked >expat-2.0.0?? Reply with quote

Today I upgraded to the stable gnome-2.18 and metacity wasn't compiling complaining about XML, then I checked XML-Parser and expat and found that expat was unmasked, I don't know if they fixed their numbering issues but metacity compiled fine after I manually masked it. So maybe it's better left masked until we make sure that nothing will break with it, after all it is a dependency of many packages.
_________________
Regards,
Dritan

Please try to help answer the unanswered
Back to top
View user's profile Send private message
dutchThomas
n00b
n00b


Joined: 13 Aug 2007
Posts: 6
Location: Huntington Beach, CA, USA

PostPosted: Mon Aug 13, 2007 5:56 am    Post subject: solution Reply with quote

It doesn't seem like the original problem was ever fully solved here. I ran revdep-rebuild, and everything worked correctly except SVN. I noticed that when trying to use layman. The problem is that apr-util is slotted, and slot 0 must be rebuilt also. I donno if the newest version of revdep-rebuild accounts for the slot

so basically... however you wanna run revdep-rebuild, and then

Code:

emerge =dev-libs/apr-util-0*
Back to top
View user's profile Send private message
tapted
Tux's lil' helper
Tux's lil' helper


Joined: 02 Dec 2003
Posts: 122
Location: Sydney, Australia

PostPosted: Mon Aug 13, 2007 6:20 am    Post subject: Reply with quote

For anyone else who is going through libexpat/subversion hell (I *really* needed svn working ASAP), the package you want might not simply be 'apr-util' because it's a slotted ebuild.

For me I wanted =dev-libs/apr-util-0.9.12-r1

But to find this out I used a script:
Code:

#!/bin/bash
BINARY=/usr/bin/svn
GREPSTR="not found"
libs=`ldd $BINARY | cut -f3 '-d ' | xargs echo`
checked=""
broken=""
checked="$checked $libs"
while [ -n "$libs" ] ; do
  check="$libs"
  libs=""
  for i in $check ; do
    echo -n "checking $i.. "
    if ldd $i | grep "$GREPSTR" >/dev/null ; then
      echo "Broken"     
      broken="$broken $i"
      for j in `ldd "$i" | cut -f3 '-d ' | xargs echo` ; do
        if ! echo "$checked" | grep "$j" > /dev/null ; then
          echo "  adding $j"
          libs="$libs $j"
          checked="$checked $j"
        fi
      done
    else
      echo "OK"
    fi
  done
done

echo "Broken: $broken"
ebuilds=""
for b in $broken ; do
  build=`qfile -qCe $b | xargs echo`
  if ! echo "$ebuilds" | grep "$build" > /dev/null ; then
    echo "Adding $build"
    ebuilds="$ebuilds =$build"
  fi
done

echo "Ebuilds: $ebuilds"


might come in handy for something else..
Back to top
View user's profile Send private message
tapted
Tux's lil' helper
Tux's lil' helper


Joined: 02 Dec 2003
Posts: 122
Location: Sydney, Australia

PostPosted: Mon Aug 13, 2007 6:28 am    Post subject: Re: solution Reply with quote

dutchThomas wrote:

so basically... however you wanna run revdep-rebuild, and then

Code:

emerge =dev-libs/apr-util-0*


funny.

If only I had hit 'refresh' in the forums occasionally while writing that bloody script.
Back to top
View user's profile Send private message
gringo
Advocate
Advocate


Joined: 27 Apr 2003
Posts: 3706

PostPosted: Mon Aug 13, 2007 7:24 am    Post subject: Reply with quote

maybe next time start by reading the guide and you´ll know what breaks.

cheers
_________________
Error: Failing not supported by current locale
Back to top
View user's profile Send private message
baeksu
l33t
l33t


Joined: 26 Sep 2004
Posts: 609
Location: Seoul, Korea

PostPosted: Mon Aug 13, 2007 7:53 am    Post subject: Reply with quote

I think there will be a lot of this kind of threads in the coming week. It's not the devs' fault, though.

@dritan: New versions of expat break compatibility with previous ones. That's why it was kept in unstable for as long as possible. Now that new versions of gnome and kde have been marked stable, it was a suitable time to release expat as well.

After upgrading expat and curl, do a revdep-rebuild to see which packages need to be re-emerged. I had about 25 packages to do.
_________________
Gnome:
1. A legendary being.
2. A never ending quest to make unix friendly to people who don't want unix and excruciating for those that do.
Back to top
View user's profile Send private message
tw04l124
Veteran
Veteran


Joined: 03 Oct 2006
Posts: 1308
Location: A t z e l, lower austria

PostPosted: Mon Aug 13, 2007 2:37 pm    Post subject: Reply with quote

hi,

My system is also broken => Upgrade Hell => Openoffice comiles a long time, still compiling

Thanks for the tricks, roman
Back to top
View user's profile Send private message
dritan
Apprentice
Apprentice


Joined: 01 Feb 2006
Posts: 210
Location: New York

PostPosted: Mon Aug 13, 2007 2:48 pm    Post subject: Reply with quote

Sorry, my bad. I had been using gnome-experimental until about a month ago and went back to stable, so now that 2.18 is stable I didn't go through the guide, I will do the revdep-rebuild as soon as I get home.
_________________
Regards,
Dritan

Please try to help answer the unanswered
Back to top
View user's profile Send private message
nixnut
Administrator
Administrator


Joined: 09 Apr 2004
Posts: 10973
Location: the dutch mountains

PostPosted: Mon Aug 13, 2007 3:56 pm    Post subject: Reply with quote

merged some posts above here.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
dritan
Apprentice
Apprentice


Joined: 01 Feb 2006
Posts: 210
Location: New York

PostPosted: Mon Aug 13, 2007 4:39 pm    Post subject: Reply with quote

Update,

I couldn't wait to get home so I sshed from office and while revdep-rebuilding gtk2 won't compile, it complains about pango and when I tried re-emerging pango it wanted libexpat.so.0, should I unmask pango-1.16.5?
_________________
Regards,
Dritan

Please try to help answer the unanswered
Back to top
View user's profile Send private message
eno2001
Tux's lil' helper
Tux's lil' helper


Joined: 20 Oct 2006
Posts: 136

PostPosted: Mon Aug 13, 2007 7:53 pm    Post subject: Also in expat hell. HELP!!! Reply with quote

I tried to run an 'emerge -uvDa world' over the weekend and got about halfway through the 300+ packages only to hit a problem when attempting to rebuild Metacity. So I looked at the error, poked around the forum here and found out about the problem with expat. I've been through every possible iteration of revdep-rebuild and just unmerging and re-installing expat. No luck. Here's the output of my latest revdep-rebuild attempt:

Code:
(cd .libs && rm -f im-viqr.la && ln -s ../im-viqr.la im-viqr.la)
../../gtk/gtk-query-immodules-2.0 im-xim.la  im-am-et.la im-cedilla.la im-cyrillic-translit.la im-inuktitut.la im-ipa.la im-thai.la im-ti-er.la im-ti-et.la im-viqr.la  > gtk.immodules
/var/tmp/portage/x11-libs/gtk+-2.10.14/work/gtk+-2.10.14/gtk/.libs/lt-gtk-query-immodules-2.0: error while loading shared libraries: libexpat.so.0: cannot open shared object file: No such file or directory
make[3]: *** [gtk.immodules] Error 127
make[3]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-2.10.14/work/gtk+-2.10.14/modules/input'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-2.10.14/work/gtk+-2.10.14/modules'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/x11-libs/gtk+-2.10.14/work/gtk+-2.10.14'
make: *** [all] Error 2

!!! ERROR: x11-libs/gtk+-2.10.14 failed.
Call stack:
  ebuild.sh, line 1632:   Called dyn_compile
  ebuild.sh, line 983:   Called qa_call 'src_compile'
  ebuild.sh, line 44:   Called src_compile
  gtk+-2.10.14.ebuild, line 108:   Called die

!!! compile failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/x11-libs/gtk+-2.10.14/temp/build.log'.


revdep-rebuild failed to emerge all packages
you have the following choices:

- if emerge failed during the build, fix the problems and re-run revdep-rebuild
    or
- use -X or --package-names as first argument (trys to rebuild package, not exact
  ebuild)
    or
- set ACCEPT_KEYWORDS="~<your platform>" and/or /etc/portage/package.unmask
  (and remove /root/.revdep-rebuild.5_order to be evaluated again)
    or
- modify the above emerge command and run it manually
    or
- compile or unmerge unsatisfied packages manually, remove temporary files and
  try again (you can edit package/ebuild list first)

To remove temporary files, please run:
rm /root/.revdep-rebuild*.?_*


I've also tried 'revdep-rebuild -X --library libexpat.so.0' which attempts to build fewer packages to no avail. It seems that every time the system hits gtk+, it freaks out. I've also tried unmerging gtk+ but now that it's not on the system, trying to re-install it still hits this same problem. Should I just put a symlink in called libexpat.so.0? I've done things like that in the past no matter how unwise it is, just to get things going. But, it seems this is a larger problem and I'd really like to fix it the "right" way. Any ideas? For the time being my laptop is screwed until I can get past this snag. Would it be better for me to mask any version of expat higher than 2.x and revdep-rebuild again?
Back to top
View user's profile Send private message
roderick
l33t
l33t


Joined: 11 Jul 2005
Posts: 908
Location: St. John's, NL CANADA

PostPosted: Mon Aug 13, 2007 8:30 pm    Post subject: Reply with quote

Read this.... should help

https://forums.gentoo.org/viewtopic-t-575655.html
_________________
If God were a pickle, I'd still say "no pickle on my burger".
http://roderick-greening.blogspot.com/
Back to top
View user's profile Send private message
tapted
Tux's lil' helper
Tux's lil' helper


Joined: 02 Dec 2003
Posts: 122
Location: Sydney, Australia

PostPosted: Tue Aug 14, 2007 1:44 am    Post subject: Reply with quote

gringo wrote:
maybe next time start by reading the guide and you´ll know what breaks.


That's just silly.

GWN has been broken for a while -- if there was something announced in there I would have seen it. And there is nothing at gentoo.org, so even if I did check online every time I did an emerge -uvD world I wouldn't have known about the guide until I started getting errors.

But even then, the guide is pitifully inadequate -- gnome-pilot and epiphany no longer build and there is no mention of gettext/XML-Parser/subversion breakage. Having >5 gentoo systems I sysadmin (including AMD64, Pentium -4 and -M, so no emerge -k for me), fixing this breakage now feels old hat.

The best strategy for minimal system downtime seems to be something along the lines of the following:

Code:

K="~x86"
emerge --sync
echo '>=dev-libs/expat-2.0.0' >> /etc/portage/package.mask
echo '=www-client/epiphany-2.16.3* -doc' >> /etc/portage/package.use
echo "=net-im/pidgin-2.1.0* $K" >> /etc/portage/package.keywords
echo "=app-pda/gnome-pilot-2.0.15* $K" >> /etc/portage/package.keywords
echo "=app-pda/gnome-pilot-conduits-2.0.15* $K" >> /etc/portage/package.keywords
emerge -puvD --newuse world # check for blockers
emerge --unmerge control-center kpersonalizer aspell-en kmail ksync #and whatever other blockers you have
emerge -uvD --newuse world || until emerge --resume --skipfirst ; do echo ; done
emerge --depclean
revdep-rebuild
until emerge --resume --skipfirst ; do echo ; done
#<comment out the expat mask from /etc/portage/package.mask
emerge expat
emerge -1 XML-Parser gettext apr-util =dev-libs/apr-util-0* subversion
revdep-rebuild
until emerge --resume --skipfirst ; do echo ; done
revdep-rebuild #for good measure


the emerge -uvD world before the revdep-rebuild will cause some things to get compiled/installed twice, but revdep-rebuild bails too easily -- it really should try much harder to fix as much of your system as possible without intervention. Doing `emerge -uvD --newuse world` and `emerge --depclean` will optimise your chances of it finding all the packages.
Back to top
View user's profile Send private message
astor84
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2007
Posts: 96
Location: Dallas, Tx

PostPosted: Tue Aug 14, 2007 5:36 am    Post subject: Reply with quote

I haven't an answer to this posted yet, but here is the problem I am having with this:

I have been compiling various dependencies manually with emerge --oneshot [package] to try to get KDE 3.5.7 to compile after this libexpat nonsense (since revdep-rebuild isn't able to build packages in the right order, apparently). However, I've hit a brick wall with kdemultimedia. I want to build it with xine support, but whenever the config step of the compile tries to execute the Xine binary, it fails because Xine is linked to the old version of libexpat. I've tried recompiling the package xine-ui twice, to no avail. Checking dynamic linking on the xine binary still shows:
Code:
chris@coruscant ~ $ ldd /usr/bin/xine
        linux-gate.so.1 =>  (0xffffe000)
        libxine.so.1 => /usr/lib/libxine.so.1 (0xb7f48000)
        libz.so.1 => /lib/libz.so.1 (0xb7f36000)
        libnsl.so.1 => /lib/libnsl.so.1 (0xb7f21000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb7f0b000)
        librt.so.1 => /lib/librt.so.1 (0xb7f01000)
        libXinerama.so.1 => /usr/lib/libXinerama.so.1 (0xb7efe000)
        libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0xb7ef8000)
        libdl.so.2 => /lib/libdl.so.2 (0xb7ef4000)
        libXft.so.2 => /usr/lib/libXft.so.2 (0xb7ee2000)
        libXrender.so.1 => /usr/lib/libXrender.so.1 (0xb7eda000)
        libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0xb7eb0000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0xb7e37000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0xb7d41000)
        libXtst.so.6 => /usr/lib/libXtst.so.6 (0xb7d3b000)
        libcurl.so.4 => /usr/lib/libcurl.so.4 (0xb7d04000)
        libm.so.6 => /lib/libm.so.6 (0xb7ce0000)
        libXv.so.1 => /usr/lib/libXv.so.1 (0xb7cda000)
        libpng12.so.0 => /usr/lib/libpng12.so.0 (0xb7cb9000)
        libc.so.6 => /lib/libc.so.6 (0xb7b97000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0xb7b87000)
        /lib/ld-linux.so.2 (0xb7fb3000)
        libexpat.so.0 => not found             
        libxml2.so.2 => /usr/lib/libxml2.so.2 (0xb7a77000)
        libxcb-xlib.so.0 => /usr/lib/libxcb-xlib.so.0 (0xb7a75000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0xb7a5e000)
        libssl.so.0.9.8 => /usr/lib/libssl.so.0.9.8 (0xb7a21000)
        libcrypto.so.0.9.8 => /usr/lib/libcrypto.so.0.9.8 (0xb78ec000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0xb78e8000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0xb78e3000)


What am I doing wrong?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2, 3 ... , 9, 10, 11  Next
Page 10 of 11

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum