Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
autounmask - Unmasken von Paketen und deren Abhängigkeiten
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Deutsche Dokumentation
View previous topic :: View next topic  
Author Message
ian!
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 3827
Location: Essen, Germany

PostPosted: Wed Apr 25, 2007 3:00 pm    Post subject: autounmask - Unmasken von Paketen und deren Abhängigkeiten Reply with quote

Wer kennt es nicht? Man benutzt stable, möchte aber ein Paket aus testing ausprobieren. Das zieht natürlich einige Abhänigkeiten mit sich, die auch noch testing sind. So fängt dann meisst das lustige manuelle unmasken an. - Das nervte mich schon geraume Zeit. Spätestens immer dann, wenn ein neues KDE-Release anstand.

Also flott was geschrieben. Schauen wir mal, wie app-portage/autounmask uns bei folgendem Beispiel helfen kann.

Code:
# emerge -pv =gnome-base/gnome-2.18.0

These are the packages that would be merged, in order:

Calculating dependencies -
!!! All ebuilds that could satisfy "=gnome-base/gnome-2.18.0" have been masked.
!!! One of the following masked packages is required to complete your request:
- gnome-base/gnome-2.18.0 (masked by: package.mask, ~x86 keyword)
# Rémi Cardona <remi@gentoo.org> (08 Apr 2007)
# Meta packages for Gnome 2.18.0
# See below for actual packages


For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.


Wie wir sehen ist das Paket, welches wir installieren wollen masked. Nun machen wir folgendes:

Code:
# autounmask gnome-base/gnome-2.18.0

 autounmask version 0.12 (using PortageXS-0.02.06)
 Bugs and requests go to ian <ian@gentoo.org>.

 * Using repository: /usr/portage

 * Using package.keywords file: /etc/portage/package.keywords
 * Using package.unmask file: /etc/portage/package.unmask

 * Unmasking gnome-base/gnome-2.18.0 and its dependencies.. this might take a while..

 * Added '=gnome-base/gnome-2.18.0 ~x86' to package.keywords
 * Added '=gnome-base/gnome-2.18.0' to package.unmask
 * Added '=gnome-extra/evolution-data-server-1.10.1 ~x86' to package.keywords
 * Added '=gnome-extra/evolution-data-server-1.10.1' to package.unmask
 * Added '=gnome-extra/evolution-data-server-1.10.0 ~x86' to package.keywords
 * Added '=gnome-extra/evolution-data-server-1.10.0' to package.unmask
 * Added '=dev-util/intltool-0.35.5 ~x86' to package.keywords
 * Added '=gnome-base/gnome-volume-manager-2.17.0 ~x86' to package.keywords
 * Added '=gnome-base/gnome-volume-manager-2.17.0' to package.unmask
 * Added '=www-client/epiphany-2.18.0 ~x86' to package.keywords
 * Added '=www-client/epiphany-2.18.0' to package.unmask
 * Added '=www-client/epiphany-2.18.1 ~x86' to package.keywords
 * Added '=www-client/epiphany-2.18.1' to package.unmask
 * Added '=net-analyzer/gnome-nettool-2.18.0 ~x86' to package.keywords
 * Added '=net-analyzer/gnome-nettool-2.18.0' to package.unmask
 * Added '=x11-libs/libwnck-2.18.0' to package.unmask
 * Added '=gnome-base/eel-2.18.0.1 ~x86' to package.keywords
 * Added '=gnome-base/eel-2.18.0.1' to package.unmask
 * Added '=gnome-extra/deskbar-applet-2.18.0 ~x86' to package.keywords
 * Added '=gnome-extra/deskbar-applet-2.18.0' to package.unmask
 * Added '=gnome-extra/deskbar-applet-2.18.1 ~x86' to package.keywords
 * Added '=gnome-extra/deskbar-applet-2.18.1' to package.unmask
 * Added '=dev-libs/atk-1.18.0 ~x86' to package.keywords
 * Added '=dev-libs/atk-1.18.0' to package.unmask
 * Added '=gnome-base/libbonoboui-2.18.0 ~x86' to package.keywords
 * Added '=gnome-base/libbonoboui-2.18.0' to package.unmask
 * Added '=media-libs/libart_lgpl-2.3.19-r1 ~x86' to package.keywords
 * Added '=gnome-extra/gnome-games-2.18.0 ~x86' to package.keywords
 * Added '=gnome-extra/gnome-games-2.18.0' to package.unmask
 * Added '=gnome-extra/gnome-games-2.18.1 ~x86' to package.keywords
 * Added '=gnome-extra/gnome-games-2.18.1' to package.unmask
 * Added '=dev-python/gnome-python-desktop-2.18.0 ~x86' to package.keywords
 * Added '=dev-python/gnome-python-desktop-2.18.0' to package.unmask
 * Added '=x11-wm/metacity-2.18.2 ~x86' to package.keywords
 * Added '=x11-wm/metacity-2.18.2' to package.unmask
 * Added '=x11-wm/metacity-2.18.0 ~x86' to package.keywords
 * Added '=x11-wm/metacity-2.18.0' to package.unmask
 * Added '=x11-wm/metacity-2.18.1 ~x86' to package.keywords
 * Added '=x11-wm/metacity-2.18.1' to package.unmask
 * Added '=gnome-base/gnome-panel-2.18.1 ~x86' to package.keywords
 * Added '=gnome-base/gnome-panel-2.18.1' to package.unmask
 * Added '=gnome-base/gnome-panel-2.18.0 ~x86' to package.keywords
 * Added '=gnome-base/gnome-panel-2.18.0' to package.unmask
 * Added '=x11-libs/pango-1.16.1 ~x86' to package.keywords
 * Added '=x11-libs/pango-1.16.1' to package.unmask
 * Added '=x11-libs/pango-1.16.3 ~x86' to package.keywords
 * Added '=x11-libs/pango-1.16.3' to package.unmask
 * Added '=x11-libs/pango-1.16.2 ~x86' to package.keywords
 * Added '=x11-libs/pango-1.16.2' to package.unmask
 * Added '=gnome-extra/yelp-2.18.0 ~x86' to package.keywords
 * Added '=gnome-extra/yelp-2.18.0' to package.unmask
 * Added '=app-arch/file-roller-2.18.2 ~x86' to package.keywords
 * Added '=app-arch/file-roller-2.18.2' to package.unmask
 * Added '=app-arch/file-roller-2.18.0 ~x86' to package.keywords
 * Added '=app-arch/file-roller-2.18.0' to package.unmask
 * Added '=gnome-base/orbit-2.14.7 ~x86' to package.keywords
 * Added '=gnome-extra/gcalctool-5.9.14 ~x86' to package.keywords
 * Added '=gnome-extra/gcalctool-5.9.14' to package.unmask
 * Added '=gnome-base/libgnome-2.18.0 ~x86' to package.keywords
 * Added '=gnome-base/libgnome-2.18.0' to package.unmask
 * Added '=app-text/evince-0.8.0 ~x86' to package.keywords
 * Added '=app-text/evince-0.8.0' to package.unmask
 * Added '=app-text/evince-0.8.1 ~x86' to package.keywords
 * Added '=app-text/evince-0.8.1' to package.unmask
 * Added '=x11-themes/gnome-icon-theme-2.18.0 ~x86' to package.keywords
 * Added '=x11-themes/gnome-icon-theme-2.18.0' to package.unmask
 * Added '=media-sound/sound-juicer-2.16.3 ~x86' to package.keywords
 * Added '=gnome-base/gconf-2.18.0.1' to package.unmask
 * Added '=gnome-extra/gucharmap-1.10.0 ~x86' to package.keywords
 * Added '=gnome-extra/gucharmap-1.10.0' to package.unmask
 * Added '=gnome-extra/fast-user-switch-applet-2.17.4 ~x86' to package.keywords
 * Added '=gnome-extra/fast-user-switch-applet-2.17.4' to package.unmask
 * Added '=gnome-extra/fast-user-switch-applet-2.18.0 ~x86' to package.keywords
 * Added '=gnome-extra/fast-user-switch-applet-2.18.0' to package.unmask
 * Added '=gnome-extra/zenity-2.18.0 ~x86' to package.keywords
 * Added '=gnome-extra/zenity-2.18.0' to package.unmask
 * Added '=app-text/gnome-doc-utils-0.10.3 ~x86' to package.keywords
 * Added '=app-text/gnome-doc-utils-0.10.3' to package.unmask
 * Added '=app-text/gnome-doc-utils-0.10.1 ~x86' to package.keywords
 * Added '=app-text/gnome-doc-utils-0.10.1' to package.unmask
 * Added '=gnome-extra/gnome-screensaver-2.18.0 ~x86' to package.keywords
 * Added '=gnome-extra/gnome-screensaver-2.18.0' to package.unmask
 * Added '=gnome-extra/gnome-screensaver-2.18.1 ~x86' to package.keywords
 * Added '=gnome-extra/gnome-screensaver-2.18.1' to package.unmask
 * Added '=gnome-base/libgnomekbd-2.18.0 ~x86' to package.keywords
 * Added '=gnome-base/libgnomekbd-2.18.0' to package.unmask
 * Added '=gnome-base/libgnomekbd-2.18.1 ~x86' to package.keywords
 * Added '=gnome-base/libgnomekbd-2.18.1' to package.unmask
 * Added '=gnome-base/libgnomeui-2.18.1' to package.unmask
 * Added '=gnome-base/libgtop-2.14.8 ~x86' to package.keywords
 * Added '=gnome-extra/evolution-webcal-2.9.92 ~x86' to package.keywords
 * Added '=gnome-extra/evolution-webcal-2.9.92' to package.unmask
 * Added '=gnome-extra/gnome-keyring-manager-2.18.0 ~x86' to package.keywords
 * Added '=gnome-extra/gnome-keyring-manager-2.18.0' to package.unmask
 * Added '=gnome-base/libgnomeprint-2.18.0 ~x86' to package.keywords
 * Added '=gnome-base/libgnomeprint-2.18.0' to package.unmask
 * Added '=gnome-extra/gconf-editor-2.18.0 ~x86' to package.keywords
 * Added '=gnome-extra/gconf-editor-2.18.0' to package.unmask
 * Added '=gnome-base/gnome-menus-2.18.0 ~x86' to package.keywords
 * Added '=gnome-base/gnome-menus-2.18.0' to package.unmask
 * Added '=gnome-extra/gtkhtml-3.14.0' to package.unmask
 * Added '=gnome-extra/gtkhtml-3.14.1' to package.unmask
 * Added '=x11-libs/gtksourceview-1.8.5 ~x86' to package.keywords
 * Added '=gnome-base/gnome-vfs-2.18.1 ~x86' to package.keywords
 * Added '=gnome-base/gnome-vfs-2.18.1' to package.unmask
 * Added '=gnome-base/gnome-vfs-2.18.0.1 ~x86' to package.keywords
 * Added '=gnome-base/gnome-vfs-2.18.0.1' to package.unmask
 * Added '=gnome-base/libgnomeprintui-2.18.0 ~x86' to package.keywords
 * Added '=gnome-base/libgnomeprintui-2.18.0' to package.unmask
 * Added '=gnome-base/gnome-desktop-2.18.1 ~x86' to package.keywords
 * Added '=gnome-base/gnome-desktop-2.18.1' to package.unmask
 * Added '=gnome-base/gnome-desktop-2.18.0 ~x86' to package.keywords
 * Added '=gnome-base/gnome-desktop-2.18.0' to package.unmask
 * Added '=gnome-extra/bug-buddy-2.18.1 ~x86' to package.keywords
 * Added '=gnome-extra/bug-buddy-2.18.1' to package.unmask
 * Added '=gnome-extra/bug-buddy-2.18.0 ~x86' to package.keywords
 * Added '=gnome-extra/bug-buddy-2.18.0' to package.unmask
 * Added '=gnome-base/nautilus-2.18.1 ~x86' to package.keywords
 * Added '=gnome-base/nautilus-2.18.1' to package.unmask
 * Added '=gnome-base/nautilus-2.18.0.1 ~x86' to package.keywords
 * Added '=gnome-base/nautilus-2.18.0.1' to package.unmask
 * Added '=app-admin/pessulus-2.16.2 ~x86' to package.keywords
 * Added '=net-libs/libsoup-2.2.100 ~x86' to package.keywords
 * Added '=gnome-base/gdm-2.18.0 ~x86' to package.keywords
 * Added '=gnome-base/gdm-2.18.0' to package.unmask
 * Added '=gnome-base/gdm-2.18.1 ~x86' to package.keywords
 * Added '=gnome-base/gdm-2.18.1' to package.unmask
 * Added '=sys-auth/consolekit-0.2.0-r1 ~x86' to package.keywords
 * Added '=sys-auth/consolekit-0.2.1 ~x86' to package.keywords
 * Added '=media-sound/esound-0.2.37 ~x86' to package.keywords
 * Added '=media-sound/esound-0.2.37-r1 ~x86' to package.keywords
 * Added '=x11-themes/gtk-engines-2.10.1 ~x86' to package.keywords
 * Added '=x11-themes/gtk-engines-2.10.1' to package.unmask
 * Added '=x11-themes/gtk-engines-2.10.0 ~x86' to package.keywords
 * Added '=x11-themes/gtk-engines-2.10.0' to package.unmask
 * Added '=x11-terms/gnome-terminal-2.18.0 ~x86' to package.keywords
 * Added '=x11-terms/gnome-terminal-2.18.0' to package.unmask
 * Added '=x11-libs/vte-0.16.1 ~x86' to package.keywords
 * Added '=x11-libs/vte-0.16.1' to package.unmask
 * Added '=x11-libs/vte-0.16.0-r1 ~x86' to package.keywords
 * Added '=x11-libs/vte-0.16.0-r1' to package.unmask
 * Added '=gnome-base/gnome-applets-2.18.0 ~x86' to package.keywords
 * Added '=gnome-base/gnome-applets-2.18.0' to package.unmask
 * Added '=app-editors/gedit-2.18.0 ~x86' to package.keywords
 * Added '=app-editors/gedit-2.18.0' to package.unmask
 * Added '=app-editors/gedit-2.18.1 ~x86' to package.keywords
 * Added '=app-editors/gedit-2.18.1' to package.unmask
 * Added '=app-editors/gedit-2.18.0-r1 ~x86' to package.keywords
 * Added '=app-editors/gedit-2.18.0-r1' to package.unmask
 * Added '=gnome-base/control-center-2.18.0 ~x86' to package.keywords
 * Added '=gnome-base/control-center-2.18.0' to package.unmask
 * Added '=gnome-base/control-center-2.18.1 ~x86' to package.keywords
 * Added '=gnome-base/control-center-2.18.1' to package.unmask
 * Added '=gnome-extra/gnome-power-manager-2.18.1 ~x86' to package.keywords
 * Added '=gnome-extra/gnome-power-manager-2.18.1' to package.unmask
 * Added '=gnome-extra/gnome-power-manager-2.18.2 ~x86' to package.keywords
 * Added '=gnome-extra/gnome-power-manager-2.18.2' to package.unmask
 * Added '=sys-apps/hal-0.5.9' to package.unmask
 * Added '=app-misc/hal-info-20070402 ~x86' to package.keywords
 * Added '=app-misc/hal-info-20070402' to package.unmask
 * Added '=gnome-base/libbonobo-2.18.0 ~x86' to package.keywords
 * Added '=gnome-base/libbonobo-2.18.0' to package.unmask
 * Added '=gnome-extra/gnome-media-2.18.0 ~x86' to package.keywords
 * Added '=gnome-extra/gnome-media-2.18.0' to package.unmask
 * Added '=x11-misc/alacarte-0.11.3 ~x86' to package.keywords
 * Added '=x11-misc/alacarte-0.11.3' to package.unmask
 * Added '=net-misc/vino-2.18.0 ~x86' to package.keywords
 * Added '=net-misc/vino-2.18.0' to package.unmask
 * Added '=mail-client/evolution-2.10.1 ~x86' to package.keywords
 * Added '=mail-client/evolution-2.10.1' to package.unmask
 * Added '=mail-client/evolution-2.10.0 ~x86' to package.keywords
 * Added '=mail-client/evolution-2.10.0' to package.unmask
 * Added '=gnome-extra/nautilus-cd-burner-2.18.1 ~x86' to package.keywords
 * Added '=gnome-extra/nautilus-cd-burner-2.18.1' to package.unmask
 * Added '=gnome-extra/nautilus-cd-burner-2.18.0 ~x86' to package.keywords
 * Added '=gnome-extra/nautilus-cd-burner-2.18.0' to package.unmask
 * Added '=media-gfx/eog-2.18.1 ~x86' to package.keywords
 * Added '=media-gfx/eog-2.18.1' to package.unmask
 * Added '=media-gfx/eog-2.18.0.1 ~x86' to package.keywords
 * Added '=media-gfx/eog-2.18.0.1' to package.unmask
 * Added '=media-video/totem-2.18.0 ~x86' to package.keywords
 * Added '=media-video/totem-2.18.0' to package.unmask
 * Added '=media-video/totem-2.18.1 ~x86' to package.keywords
 * Added '=media-video/totem-2.18.1' to package.unmask
 * Added '=gnome-base/gnome-keyring-0.8 ~x86' to package.keywords
 * Added '=gnome-base/gnome-keyring-0.8' to package.unmask
 * Added '=gnome-base/gnome-keyring-0.8.1 ~x86' to package.keywords
 * Added '=gnome-base/gnome-keyring-0.8.1' to package.unmask
 * Added '=gnome-base/gnome-session-2.18.0 ~x86' to package.keywords
 * Added '=gnome-base/gnome-session-2.18.0' to package.unmask
 * Added '=dev-libs/libIDL-0.8.8 ~x86' to package.keywords
 * Added '=x11-themes/gnome-themes-2.18.1 ~x86' to package.keywords
 * Added '=x11-themes/gnome-themes-2.18.1' to package.unmask
 * Added '=x11-themes/gnome-themes-2.18.0 ~x86' to package.keywords
 * Added '=x11-themes/gnome-themes-2.18.0' to package.unmask
 * Added '=gnome-extra/gnome-utils-2.18.0 ~x86' to package.keywords
 * Added '=gnome-extra/gnome-utils-2.18.0' to package.unmask
 * Added '=gnome-extra/gnome-utils-2.18.1 ~x86' to package.keywords
 * Added '=gnome-extra/gnome-utils-2.18.1' to package.unmask
 * done!


Fertig. Das Paket lässt sich nun installieren. - Viel Spass damit. :wink:
_________________
"To have a successful open source project, you need to be at least somewhat successful at getting along with people." -- Daniel Robbins
Back to top
View user's profile Send private message
76062563
l33t
l33t


Joined: 16 Aug 2004
Posts: 637
Location: 127.0.0.1

PostPosted: Wed Apr 25, 2007 3:42 pm    Post subject: Re: autounmask - Unmasken von Paketen und deren Abhängigkei Reply with quote

http://packages.gentoo.org/search/?sstring=autounmask wrote:

I could not find any ebuild that match your query. Try a different query or check the packages.gentoo.org main page.

_________________
gentoo - compile your own world
Back to top
View user's profile Send private message
Finswimmer
Moderator
Moderator


Joined: 02 Sep 2004
Posts: 5347
Location: Langen (Hessen), Germany

PostPosted: Wed Apr 25, 2007 4:46 pm    Post subject: Re: autounmask - Unmasken von Paketen und deren Abhängigkei Reply with quote

76062563 wrote:
http://packages.gentoo.org/search/?sstring=autounmask wrote:

I could not find any ebuild that match your query. Try a different query or check the packages.gentoo.org main page.


Geht jetzt wieder, war evtl nur ein kurzfristiger Fehler.

Tobi
_________________
Bitte auf Rechtschreibung, korrekte Formatierung und Höflichkeit achten!
Danke
Back to top
View user's profile Send private message
ian!
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 3827
Location: Essen, Germany

PostPosted: Wed Apr 25, 2007 5:32 pm    Post subject: Reply with quote

packages.gentoo.org updated afaik nur alle 2-4 Stunden; das Paket war einfach noch zu neu. Ich habe es erst heute Mittag eingestellt.
_________________
"To have a successful open source project, you need to be at least somewhat successful at getting along with people." -- Daniel Robbins
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1437
Location: Oranienburg/Germany

PostPosted: Wed Apr 25, 2007 5:40 pm    Post subject: Reply with quote

Hi,

Da scheint wohl noch ein extremer Bug drin zu sein ;)

Code:

apollo ~ # autounmask kde-base/kde-3.80.3

 autounmask version 0.12 (using PortageXS-0.02.06)
 Bugs and requests go to ian <ian@gentoo.org>.

 * Using repositories:
     /usr/portage
     /usr/local/portage/
     /usr/portage/local/layman/kde/
     /usr/portage/local/layman/kde-experimental/
     /usr/portage/local/layman/xeffects/

 * Using package.keywords file: /etc/portage/package.keywords
 * Using package.unmask file: /etc/portage/package.unmask

 * Unmasking kde-base/kde-3.80.3 and its dependencies.. this might take a while..

 * Added '=kde-base/kde-3.80.3 ~x86' to package.keywords
 * Added '=kde-base/kde-3.80.3 ~x86' to package.keywords
 * Added '=kde-base/kde-3.80.3 ~x86' to package.keywords
 * Added '=kde-base/kde-3.80.3 ~x86' to package.keywords
 * Added '=kde-base/kde-3.80.3 ~x86' to package.keywords
 * Added '=kde-base/kde-3.80.3 ~x86' to package.keywords
 * Added '=kde-base/kde-3.80.3 ~x86' to package.keywords
 * Added '=kde-base/kde-3.80.3 ~x86' to package.keywords
 * Added '=kde-base/kde-3.80.3 ~x86' to package.keywords
 * Added '=kde-base/kde-3.80.3 ~x86' to package.keywords
 * Added '=kde-base/kde-3.80.3 ~x86' to package.keywords
 * Added '=kde-base/kde-3.80.3 ~x86' to package.keywords

apollo ~ #


/etc/portage/package.keywords wrote:

# ---
# BEGIN: kde-base/kde-3.80.3
# ---
=kde-base/kde-3.80.3 ~x86
=kde-base/kde-3.80.3 ~x86
=kde-base/kde-3.80.3 ~x86
=kde-base/kde-3.80.3 ~x86
=kde-base/kde-3.80.3 ~x86
=kde-base/kde-3.80.3 ~x86
=kde-base/kde-3.80.3 ~x86
=kde-base/kde-3.80.3 ~x86
=kde-base/kde-3.80.3 ~x86
=kde-base/kde-3.80.3 ~x86
=kde-base/kde-3.80.3 ~x86
=kde-base/kde-3.80.3 ~x86


Code:

apollo ~ # emerge --info
Portage 2.1.2.4 (default-linux/x86/2006.1/desktop, gcc-4.1.2, glibc-2.5-r1, 2.6.20-gentoo-r3 i686)
=================================================================
System uname: 2.6.20-gentoo-r3 i686 Intel(R) Pentium(R) D CPU 2.66GHz
Gentoo Base System release 1.12.10
Timestamp of tree: Wed, 25 Apr 2007 16:59:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-java/java-config: 1.3.7, 2.0.31-r7
dev-lang/python:     2.4.4
dev-python/pycrypto: 2.0.1-r5
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.3.5, 1.5.23b
virtual/os-headers:  2.6.20-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer -msse3"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/php/apache1-php5/ext-active/ /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=prescott -O2 -pipe -fomit-frame-pointer -msse3"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LINGUAS="de"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/portage/local/layman/kde /usr/portage/local/layman/kde-experimental /usr/portage/local/layman/xeffects"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="X acpi alsa apache2 avahi bash-completion berkdb bitmap-fonts cairo cdr cli cpudetection cracklib crypt cups dbus dri dvd dvdr dvdread eds emboss encode esd fam firefox fortran gd gdbm gif gnome gpm gstreamer gtk hal iconv ieee1394 ipv6 isdnlog jpeg ldap libg++ lm_sensors mad memlimit midi mikmod mmx mmxext mp3 mpeg mplayer mysql ncurses nls nptl nptlonly nsplugin offensive ogg opengl oss pam pcre perl php png ppds pppd python qt3 qt4 quicktime rdesktop readline reflection samba sdl session spell spl sse sse2 ssl tcpd threads truetype truetype-fonts type1-fonts unicode vorbis win32codecs wxwindows x86 xml xorg xv zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="vesa fglrx vga fbdev"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

apollo ~ #


Oder hat das System einfach nur Probleme mit Overlays, da es mit dem normalen Portage Tree funktioniert (siehe dein Beispiel mit gnome-2.18)?

MfG. Stefan
_________________
1st: C2D 3GHz, 8GB, 2.25TB, HD4850
2nd: Celeron 2.6GHz, 2GB, 500GB, HD4350
3rd: TP X220, 2,5GHz, 8GB, 320GB, HD3000
4th: Athlon X2 BE-2300, 4GB, 64GB SSD + 3TB RAID5 GF7025
5th: Samung N350, 2GB, 250GB, HD3150
6th: Rasperry Pi, 512MB, 32GB SD
Back to top
View user's profile Send private message
ian!
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 3827
Location: Essen, Germany

PostPosted: Wed Apr 25, 2007 5:58 pm    Post subject: Reply with quote

bbgermany wrote:
Da scheint wohl noch ein extremer Bug drin zu sein ;)

Das Problem rührt von den ebuilds:

Code:
# grep KEYWORDS /usr/portage/local/layman/kde/kde-base/kde/kde-3.80.3.ebuild
KEYWORDS=""


Welche Keywords soll autounmask da unmasken?
_________________
"To have a successful open source project, you need to be at least somewhat successful at getting along with people." -- Daniel Robbins
Back to top
View user's profile Send private message
bbgermany
Veteran
Veteran


Joined: 21 Feb 2005
Posts: 1437
Location: Oranienburg/Germany

PostPosted: Wed Apr 25, 2007 6:12 pm    Post subject: Reply with quote

Da hast du natürlich recht. Danke für die Info :)

MfG. Stefan
_________________
1st: C2D 3GHz, 8GB, 2.25TB, HD4850
2nd: Celeron 2.6GHz, 2GB, 500GB, HD4350
3rd: TP X220, 2,5GHz, 8GB, 320GB, HD3000
4th: Athlon X2 BE-2300, 4GB, 64GB SSD + 3TB RAID5 GF7025
5th: Samung N350, 2GB, 250GB, HD3150
6th: Rasperry Pi, 512MB, 32GB SD
Back to top
View user's profile Send private message
ian!
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 3827
Location: Essen, Germany

PostPosted: Wed Apr 25, 2007 6:26 pm    Post subject: Reply with quote

Danke für die Meldung. ;)

0.13 wird das Problem dann erkennen und an den User melden.
_________________
"To have a successful open source project, you need to be at least somewhat successful at getting along with people." -- Daniel Robbins
Back to top
View user's profile Send private message
ian!
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 3827
Location: Essen, Germany

PostPosted: Tue May 01, 2007 10:08 am    Post subject: Reply with quote

0.15 kann --pretend und Co. siehe Changelog
_________________
"To have a successful open source project, you need to be at least somewhat successful at getting along with people." -- Daniel Robbins
Back to top
View user's profile Send private message
ian!
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 3827
Location: Essen, Germany

PostPosted: Thu May 24, 2007 8:31 pm    Post subject: Reply with quote

bbgermany wrote:
Da hast du natürlich recht. Danke für die Info :)

Hatte ich nicht. :wink:

0.17 kanns..
_________________
"To have a successful open source project, you need to be at least somewhat successful at getting along with people." -- Daniel Robbins
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Mon Aug 06, 2007 7:53 pm    Post subject: Reply with quote

Es wäre toll, wenn das Script um folgendes erweitert werden könnte:

-pakete unmasken ohne eine bestimmte version angeben zu müssen, also so dass man von dem gewünschten paket immer die neuste ~ version hat

-BUG: Die Pakete sollten mit ~kategorie/paket-version unmasked werden, ansonsten gibts keine -rX Sicherheitupdates oder?

Liebe Grüsse und besten Dank für das Script!
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
ian!
Bodhisattva
Bodhisattva


Joined: 25 Feb 2003
Posts: 3827
Location: Essen, Germany

PostPosted: Sun Aug 12, 2007 10:10 am    Post subject: Reply with quote

Phlogiston wrote:
-pakete unmasken ohne eine bestimmte version angeben zu müssen, also so dass man von dem gewünschten paket immer die neuste ~ version hat

https://bugs.gentoo.org/show_bug.cgi?id=180702

Phlogiston wrote:
-BUG: Die Pakete sollten mit ~kategorie/paket-version unmasked werden, ansonsten gibts keine -rX Sicherheitupdates oder?

Naja. Das ist jetzt Ansichtssache. autounmask war immer dazu gedacht genau eine Version/Revision zu demaskieren. Sicherlich könnte man deinen Vorschlag als weitere Option mit einbauen.
_________________
"To have a successful open source project, you need to be at least somewhat successful at getting along with people." -- Daniel Robbins
Back to top
View user's profile Send private message
Phlogiston
Veteran
Veteran


Joined: 27 Jan 2004
Posts: 1925
Location: Europe, Swizerland

PostPosted: Sun Aug 12, 2007 12:40 pm    Post subject: Reply with quote

ian! wrote:

Naja. Das ist jetzt Ansichtssache. autounmask war immer dazu gedacht genau eine Version/Revision zu demaskieren. Sicherlich könnte man deinen Vorschlag als weitere Option mit einbauen.


Ich fände es gut wenn es standardmässig mit ~demaskieren würde. Denn es macht einfach wenig Sinn keine Revisionen zu erlauben. Gerade wegen der Sicherheit. Aber ansonsten ist autounmask ein nettes Tool, nur leider sehr langsam, aber das liegt wohl eher an portage.
_________________
Workstation: 5.1 SurroundSound, LIRC remote control; Laptop [IBM-T43]: patched sources, s2disk/ram, fingerprint sensor
Back to top
View user's profile Send private message
UTgamer
Veteran
Veteran


Joined: 10 Aug 2003
Posts: 1326
Location: Troisdorf (Köln) Deutschland

PostPosted: Sun Aug 12, 2007 1:21 pm    Post subject: Reply with quote

ian! kann man das evtl, auch statt zum entmaskieren auch zum maskieren verwenden, wenn man eine Version nicht möchte?

Ich möchte die aktuelle KDE Version nicht, und das eigenhändige maskieren hatte doch seine Zeit gekostet, wäre echt praktisch. Denn wenn ich Glück habe kann ich die darauffolgende Version ja wieder nutzen. ;)
_________________
AMD Phenom II x4 >> CFLAGS="-march=amdfam10 -O2 -mmmx -msse3 -mfpmath=sse,387 -pipe -ffast-math" is stable and here in use.

Did Intel produce at any time bugfree HW?
http://www.urbanmyth.org/microcode/
http://www.heise.de/newsticker/meldung/91748
Back to top
View user's profile Send private message
Max Steel
Veteran
Veteran


Joined: 12 Feb 2007
Posts: 1951
Location: My own world! I and Gentoo!

PostPosted: Wed Oct 03, 2007 9:04 am    Post subject: Reply with quote

Hmm Ian habe hier folgendes Problem:

Code:
autounmask kde-base/kde-9999.4
 autounmask version 0.15 (using PortageXS-0.02.07)
 Bugs and requests go to ian <ian@gentoo.org>.

 * Using repositories:
     /usr/portage
     /usr/portage/local/eigen/
     /usr/portage/local/layman/kde"

 * The given category/package-version does not seem to exist. Please check and try again.


Dasselbe bei 3.93.0

Aber das ist laut eix verfügbar:
Code:
# eix kde-base/kde
* kde-base/kde
     Available versions:
        (3.5)   3.5.5 ~3.5.6 3.5.7
        (kde-4) **3.93.0[1]
        (kde-svn)       **9999.4[1]
        {accessibility}
     Homepage:            http://www.kde.org/
     Description:         KDE - merge this to pull in all non-developer kde-base/* packages

[1] /usr/portage/local/layman/kde



kde3 ist splittet installiert.

Code:
eix autounmask
[I] app-portage/autounmask
     Available versions:  0.15 ~0.21
     Installed versions:  0.15(00:50:33 11.08.2007)
     Homepage:            http://download.mpsna.de/opensource/autounmask/
     Description:         autounmask - Unmasking packages the easy way


Edith:
Hat sich erledigt, musste die Reihenfolge der Overlays ändern, zuerst das laymankde-Overlay dann das eigene.
_________________
mfg
Steel
___________________
Big sorry for my bad English.

Heim-PC: AMD Phenom II X4 3,2GHz, 16GB RAM, gentoo-sources-3.10.7, NV GTX 780
Laptop: Intel Celeron 1,7GHz, 512MB Ram, tuxonice-sources-3.7.1, SIS Graphic

Version 0.4
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Deutsches Forum (German) Deutsche Dokumentation All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum