Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
2.6.22 wont compile SOLVED!!!!
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64
View previous topic :: View next topic  
Author Message
billydv
l33t
l33t


Joined: 22 Dec 2006
Posts: 885
Location: Mount Vernon, NY

PostPosted: Fri Jul 13, 2007 4:05 am    Post subject: 2.6.22 wont compile SOLVED!!!! Reply with quote

heres the messages


genkernel --menuconfig --install kernel --gensplash=Emergance initrd
* Gentoo Linux Genkernel; Version 3.4.8
* Running with options: --menuconfig --install kernel --gensplash=Emergance initrd

* Linux Kernel 2.6.22-gentoo-r1 for x86_64...
* kernel: >> Running mrproper...
* config: Using config from /usr/share/genkernel/x86_64/kernel-config-2.6
* Previous config backed up to .config.bak
* >> Running oldconfig...
* kernel: >> Cleaning...
* config: >> Invoking menuconfig...
#
# configuration written to .config
#


*** End of Linux kernel configuration.
*** Execute 'make' to build the kernel or try 'make help'.

* ERROR: Failed to compile the "prepare" target...

* -- Grepping log... --

SHIPPED scripts/kconfig/lex.zconf.c
SHIPPED scripts/kconfig/zconf.hash.c
HOSTCC scripts/kconfig/zconf.tab.o
HOSTLD scripts/kconfig/conf
scripts/kconfig/conf -o arch/x86_64/Kconfig
.config:47:warning: trying to assign nonexistent symbol VM86
.config:148:warning: trying to assign nonexistent symbol GART_IOMMU
.config:161:warning: trying to assign nonexistent symbol REORDER
.config:182:warning: trying to assign nonexistent symbol ACPI_HOTKEY
.config:188:warning: trying to assign nonexistent symbol ACPI_IBM
.config:189:warning: trying to assign nonexistent symbol ACPI_IBM_DOCK
.config:288:warning: trying to assign nonexistent symbol NETDEBUG
.config:351:warning: trying to assign nonexistent symbol NET_DIVERT
.config:512:warning: trying to assign nonexistent symbol PARIDE_PARPORT
.config:594:warning: trying to assign nonexistent symbol IDEDMA_PCI_AUTO
.config:625:warning: trying to assign nonexistent symbol IDEDMA_AUTO
.config:679:warning: trying to assign nonexistent symbol AIC79XX_ENABLE_RD_STRM
.config:688:warning: trying to assign nonexistent symbol SCSI_SATA
.config:689:warning: trying to assign nonexistent symbol SCSI_SATA_AHCI
.config:690:warning: trying to assign nonexistent symbol SCSI_SATA_SVW
.config:691:warning: trying to assign nonexistent symbol SCSI_ATA_PIIX
.config:692:warning: trying to assign nonexistent symbol SCSI_SATA_MV
.config:693:warning: trying to assign nonexistent symbol SCSI_SATA_NV
.config:694:warning: trying to assign nonexistent symbol SCSI_PDC_ADMA
.config:695:warning: trying to assign nonexistent symbol SCSI_SATA_QSTOR
.config:696:warning: trying to assign nonexistent symbol SCSI_SATA_PROMISE
.config:697:warning: trying to assign nonexistent symbol SCSI_SATA_SX4
.config:698:warning: trying to assign nonexistent symbol SCSI_SATA_SIL
.config:699:warning: trying to assign nonexistent symbol SCSI_SATA_SIL24
.config:700:warning: trying to assign nonexistent symbol SCSI_SATA_SIS
.config:701:warning: trying to assign nonexistent symbol SCSI_SATA_ULI
.config:702:warning: trying to assign nonexistent symbol SCSI_SATA_VIA
.config:703:warning: trying to assign nonexistent symbol SCSI_SATA_VITESSE
.config:704:warning: trying to assign nonexistent symbol SCSI_SATA_INTEL_COMBINED
.config:731:warning: trying to assign nonexistent symbol SCSI_QLA2XXX_EMBEDDED_FIRMWARE
.config:753:warning: trying to assign nonexistent symbol MD_RAID5
.config:755:warning: trying to assign nonexistent symbol MD_RAID6
.config:787:warning: trying to assign nonexistent symbol IEEE1394_OUI_DB
.config:788:warning: trying to assign nonexistent symbol IEEE1394_EXTRA_CONFIG_ROMS
.config:789:warning: trying to assign nonexistent symbol IEEE1394_CONFIG_ROM_IP1394
.config:790:warning: trying to assign nonexistent symbol IEEE1394_EXPORT_FULL_API
.config:955:warning: trying to assign nonexistent symbol NET_RADIO
.config:956:warning: trying to assign nonexistent symbol NET_WIRELESS_RTNETLINK
.config:978:warning: trying to assign nonexistent symbol IPW_QOS
.config:1015:warning: trying to assign nonexistent symbol NET_WIRELESS
.config:1038:warning: trying to assign nonexistent symbol SYNCLINK_SYNCPPP
.config:1055:warning: trying to assign nonexistent symbol DLCI_COUNT
.config:1451:warning: symbol value 'm' invalid for VIDEO_V4L2
.config:1532:warning: trying to assign nonexistent symbol DVB
.config:1535:warning: trying to assign nonexistent symbol VIDEO_VIDEOBUF
.config:1551:warning: trying to assign nonexistent symbol FB_FIRMWARE_EDID
.config:1604:warning: trying to assign nonexistent symbol BACKLIGHT_DEVICE
.config:1606:warning: trying to assign nonexistent symbol LCD_DEVICE
.config:1612:warning: trying to assign nonexistent symbol SPEAKUP
.config:1613:warning: trying to assign nonexistent symbol SPEAKUP_ACNTSA
.config:1614:warning: trying to assign nonexistent symbol SPEAKUP_ACNTPC
.config:1615:warning: trying to assign nonexistent symbol SPEAKUP_APOLLO
.config:1616:warning: trying to assign nonexistent symbol SPEAKUP_AUDPTR
.config:1617:warning: trying to assign nonexistent symbol SPEAKUP_BNS
.config:1618:warning: trying to assign nonexistent symbol SPEAKUP_DECTLK
.config:1619:warning: trying to assign nonexistent symbol SPEAKUP_DECEXT
.config:1620:warning: trying to assign nonexistent symbol SPEAKUP_DECPC
.config:1621:warning: trying to assign nonexistent symbol SPEAKUP_DTLK
.config:1622:warning: trying to assign nonexistent symbol SPEAKUP_KEYPC
.config:1623:warning: trying to assign nonexistent symbol SPEAKUP_LTLK
.config:1624:warning: trying to assign nonexistent symbol SPEAKUP_SFTSYN
.config:1625:warning: trying to assign nonexistent symbol SPEAKUP_SPKOUT
.config:1626:warning: trying to assign nonexistent symbol SPEAKUP_TXPRT
.config:1631:warning: trying to assign nonexistent symbol SPEAKUP_DEFAULT
.config:1668:warning: trying to assign nonexistent symbol SND_AC97_BUS
.config:1757:warning: trying to assign nonexistent symbol USB_BANDWIDTH
.config:1770:warning: trying to assign nonexistent symbol USB_OHCI_BIG_ENDIAN
.config:1806:warning: trying to assign nonexistent symbol USB_HIDINPUT
.config:1819:warning: trying to assign nonexistent symbol USB_AIPTEK
.config:1820:warning: trying to assign nonexistent symbol USB_WACOM
.config:1821:warning: trying to assign nonexistent symbol USB_ACECAD
.config:1822:warning: trying to assign nonexistent symbol USB_KBTAB
.config:1823:warning: trying to assign nonexistent symbol USB_POWERMATE
.config:1824:warning: trying to assign nonexistent symbol USB_TOUCHSCREEN
.config:1825:warning: trying to assign nonexistent symbol USB_TOUCHSCREEN_EGALAX
.config:1826:warning: trying to assign nonexistent symbol USB_TOUCHSCREEN_PANJIT
.config:1827:warning: trying to assign nonexistent symbol USB_TOUCHSCREEN_3M
.config:1828:warning: trying to assign nonexistent symbol USB_TOUCHSCREEN_ITM
.config:1829:warning: trying to assign nonexistent symbol USB_YEALINK
.config:1830:warning: trying to assign nonexistent symbol USB_XPAD
.config:1831:warning: trying to assign nonexistent symbol USB_ATI_REMOTE
.config:1832:warning: trying to assign nonexistent symbol USB_ATI_REMOTE2
.config:1833:warning: trying to assign nonexistent symbol USB_KEYSPAN_REMOTE
.config:1834:warning: trying to assign nonexistent symbol USB_APPLETOUCH
.config:1872:warning: trying to assign nonexistent symbol USB_SERIAL_ANYDATA
.config:1968:warning: trying to assign nonexistent symbol IPATH_CORE
.config:1988:warning: symbol value 'm' invalid for RTC_INTF_SYSFS
.config:1989:warning: symbol value 'm' invalid for RTC_INTF_PROC
.config:1990:warning: symbol value 'm' invalid for RTC_INTF_DEV
.config:2037:warning: trying to assign nonexistent symbol XFS_EXPORT
.config:2061:warning: trying to assign nonexistent symbol ZISOFS_FS
.config:2151:warning: trying to assign nonexistent symbol RXRPC
.config:2244:warning: trying to assign nonexistent symbol UNWIND_INFO
--
* Bus options (PCI etc.)
*
PCI support (PCI) [Y] y
Support mmconfig PCI config space access (PCI_MMCONFIG) [Y/n] y
PCI Express support (PCIEPORTBUS) [Y/n/?] y
Root Port Advanced Error Reporting support (PCIEAER) [Y/n/?] (NEW) Message Signaled Interrupts (MSI and MSI-X) (PCI_MSI) [Y/n/?] y
--
SCSI media changer support (CHR_DEV_SCH) [M/n/y/?] m
*
* Some SCSI devices (e.g. CD jukebox) support multiple LUNs
*
Probe all LUNs on each SCSI device (SCSI_MULTI_LUN) [N/y/?] n
Verbose SCSI error reporting (kernel size +=12K) (SCSI_CONSTANTS) [N/y/?] n
--
QLogic InfiniPath Driver (INFINIBAND_IPATH) [M/n/?] m
Ammasso 1100 HCA support (INFINIBAND_AMSO1100) [N/m/?] (NEW) Mellanox ConnectX HCA support (MLX4_INFINIBAND) [N/m/?] (NEW) IP-over-InfiniBand (INFINIBAND_IPOIB) [M/n/?] m
IP-over-InfiniBand Connected Mode support (INFINIBAND_IPOIB_CM) [N/y/?] (NEW) IP-over-InfiniBand debugging (INFINIBAND_IPOIB_DEBUG) [N/y/?] n
InfiniBand SCSI RDMA Protocol (INFINIBAND_SRP) [M/n/?] m
iSCSI Extensions for RDMA (iSER) (INFINIBAND_ISER) [N/m/?] (NEW) *
* EDAC - error detection and reporting (RAS) (EXPERIMENTAL)
*
EDAC core system error reporting (EXPERIMENTAL) (EDAC) [N/m/y/?] n
--
from include/linux/preempt.h:9,
from include/linux/spinlock.h:49,
from include/linux/module.h:9,
from include/linux/crypto.h:21,
from arch/x86_64/kernel/asm-offsets.c:7:
include/asm/page.h:89:2: error: #error "CONFIG_PHYSICAL_START must be a multiple of 2MB"
make[1]: *** [arch/x86_64/kernel/asm-offsets.s] Error 1
make: *** [prepare0] Error 2
* Gentoo Linux Genkernel; Version 3.4.8
* Running with options: --menuconfig --install kernel --gensplash=Emergance initrd

* ERROR: Failed to compile the "prepare" target...

* -- End log... --

* Please consult /var/log/genkernel.log for more information and any
* errors that were reported above.

* Report any genkernel bugs to bugs.gentoo.org and
* assign your bug to genkernel@gentoo.org. Please include
* as much information as you can in your bug report; attaching
* /var/log/genkernel.log so that your issue can be dealt with effectively.
*
* Please do *not* report compilation failures as genkernel bugs!
*
_________________
Billy DeVincentis


Last edited by billydv on Sun Jul 15, 2007 2:25 am; edited 1 time in total
Back to top
View user's profile Send private message
slak5
n00b
n00b


Joined: 27 Jul 2006
Posts: 41

PostPosted: Fri Jul 13, 2007 4:32 am    Post subject: Reply with quote

gentoo-sources-2.6.20-r8 is currently stable, see if somebody posted a bug report already and if not file one. Is there a reason your not using 2.6.20-r8? you can try running make clean and make mrproper in the kernel source, if that doesn't work backup your config and try a default one. If all else fails, re install the source and try again; If that fails, try submitting a bug report.
Back to top
View user's profile Send private message
santiago
n00b
n00b


Joined: 08 Oct 2006
Posts: 35
Location: Argentina

PostPosted: Sat Jul 14, 2007 6:26 am    Post subject: Reply with quote

I'm having exactly the same problem.
I'm using kernel 2.6.21-gentoo-r3 and genkernel 3.4.8
Tried with kernel 2.6.22 and 2.6.22-r1
It happened that I added 512mb of ram to my machine since my last kernel compilation but I think it has nothing to do with this error.
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Sat Jul 14, 2007 10:09 am    Post subject: Re: 2.6.22 wont compile Reply with quote

Hi. This is your problem.
billydv wrote:

include/asm/page.h:89:2: error: #error "CONFIG_PHYSICAL_START must be a multiple of 2MB"
*

It is easy to solve. I don't use genkernel but it must be the same. While configuring kernel options within genkernel go to:
"Processor type and features". You must see "Physical address where the kernel is loaded". Change its value to (0x200000). then everything must be ok.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
nigelhannam
n00b
n00b


Joined: 21 Feb 2003
Posts: 70

PostPosted: Sat Jul 14, 2007 10:10 am    Post subject: Reply with quote

The default genkernel config uses the following value:

Code:
CONFIG_PHYSICAL_START=0x100000


The kernel config help states:
Quote:
This gives the physical address where the kernel is loaded. It
should be aligned to 2MB boundary.

If kernel is a not relocatable (CONFIG_RELOCATABLE=n) then
bzImage will decompress itself to above physical address and
run from there. Otherwise, bzImage will run from the address where
it has been loaded by the boot loader and will ignore above physical
address.

In normal kdump cases one does not have to set/change this option
as now bzImage can be compiled as a completely relocatable image
(CONFIG_RELOCATABLE=y) and be used to load and run from a different
address. This option is mainly useful for the folks who don't want
to use a bzImage for capturing the crash dump and want to use a
vmlinux instead.

So if you are using bzImage for capturing the crash dump, leave
the value here unchanged to 0x200000 and set CONFIG_RELOCATABLE=y.
Otherwise if you plan to use vmlinux for capturing the crash dump
change this value to start of the reserved region (Typically 16MB
0x1000000). In other words, it can be set based on the "X" value as
specified in the "crashkernel=YM@XM" command line boot parameter
passed to the panic-ed kernel. Typically this parameter is set as
crashkernel=64M@16M. Please take a look at
Documentation/kdump/kdump.txt for more details about crash dumps.

Usage of bzImage for capturing the crash dump is advantageous as
one does not have to build two kernels. Same kernel can be used
as production kernel and capture kernel.

Don't change this unless you know what you are doing.


I have just built a kenel with the suggested:

Code:

CONFIG_RELOCATABLE=y
CONFIG_PHYSICAL_START=0x200000


Will see how it runs shortly, but this looks as though a fix to the genkernel default config is required.

EDIT: Boots and looks good!
Back to top
View user's profile Send private message
billydv
l33t
l33t


Joined: 22 Dec 2006
Posts: 885
Location: Mount Vernon, NY

PostPosted: Sat Jul 14, 2007 4:10 pm    Post subject: Reply with quote

When I use genkernel it keeps changing it back, what can be done?
_________________
Billy DeVincentis
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Sat Jul 14, 2007 5:24 pm    Post subject: Reply with quote

billydv wrote:
When I use genkernel it keeps changing it back, what can be done?

Try this way:
1- Backup & config:
cp /usr/src/linux/.config /home/****/CONFIG-kernelversionY.ZZZZ
cd /usr/src/linux
make distclean
make mrproper
cp /home/****/CONFIG-kernelversionY.ZZZZ /usr/src/.config
make oldconfig
make menuconfig (or make xconfig)

make && make modules_install

2- Mounting & copying files :
mount /mnt/boot
cp /usr/src/linux/arch/x86_64/boot/bzImage /mnt/boot/bzImage-kernelversion-Y.ZZZZ
cp /usr/src/linux/System.map /boot/System.map-x86_64-2.6.22-gentoo-r1
ln -s /boot/System.map-x86_64-2.6.22-gentoo-r1 /boot/System.map
adjust /boot/grub/grub.conf
3-Reboot and emerge some needed drivers and packages change accordingly:
# emerge -va1 nvidia-drivers alsa-driver realtime-lsm dazuko iwlwifi
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
nigelhannam
n00b
n00b


Joined: 21 Feb 2003
Posts: 70

PostPosted: Sat Jul 14, 2007 7:10 pm    Post subject: Reply with quote

billydv wrote:
When I use genkernel it keeps changing it back, what can be done?


add --menuconfig to your usual genkernel parameters.

Go to "Processor type and features", and towards the bottom you will find the relevant options.
"Build a relocatable kernel (EXPERIMENTAL)" and "Physical address where the kernel is loaded".

Once you have a successfull build, if you want to continue using genkernel, you can add another parameter to the command line "--kernel-config=<path to config>". This uses the config specified as the starting point instead of the genkernel default.
Back to top
View user's profile Send private message
billydv
l33t
l33t


Joined: 22 Dec 2006
Posts: 885
Location: Mount Vernon, NY

PostPosted: Sun Jul 15, 2007 2:25 am    Post subject: Reply with quote

Okay, Problem is solved, in order for you to see config physical start you must select configure standard kernel feature under general setup, Then just under build relocatable kernel will show up the physical start address and you need to replace the 1 with a 2

build relocatable kernel is not required
_________________
Billy DeVincentis
Back to top
View user's profile Send private message
Caleb Brightmore
n00b
n00b


Joined: 25 Apr 2006
Posts: 5
Location: Moscow, Russia

PostPosted: Tue Jul 24, 2007 4:58 pm    Post subject: Reply with quote

Code:
--
                 from include/linux/preempt.h:9,
                 from include/linux/spinlock.h:49,
                 from include/linux/module.h:9,
                 from include/linux/crypto.h:21,
                 from arch/x86_64/kernel/asm-offsets.c:7:
include/asm/page.h:89:2: error: #error "CONFIG_PHYSICAL_START must be a multiple of 2MB"
make[1]: *** [arch/x86_64/kernel/asm-offsets.s] ¾èØÑÚÐ 1
make: *** [prepare0] ¾èØÑÚÐ 2
* Gentoo Linux Genkernel; Version 3.4.8
* Running with options: --menuconfig --bootloader=grub all

* ERROR: Failed to compile the "prepare" target...

Code:
localhost linux # cat /etc/kernels/kernel-config-x86_64-2.6.21-gentoo-r3 | grep CONFIG_PHYSICAL_START
CONFIG_PHYSICAL_START=0x200000

Kernel does not build.
Back to top
View user's profile Send private message
loftwyr
l33t
l33t


Joined: 29 Dec 2004
Posts: 970
Location: 43°38'23.62"N 79°27'8.60"W

PostPosted: Tue Jul 24, 2007 8:03 pm    Post subject: Reply with quote

Go to "Processor type and features", and towards the bottom you will find the relevant options.
"Build a relocatable kernel (EXPERIMENTAL)" and "Physical address where the kernel is loaded".

Change the physical address from 100000 to 200000 and it will build.
_________________
My emerge --info
Have you run revdep-rebuild lately? It's in gentoolkit and it's worth a shot if things don't work well.
Celebrating 5 years of Gentoo-ing.
Back to top
View user's profile Send private message
Caleb Brightmore
n00b
n00b


Joined: 25 Apr 2006
Posts: 5
Location: Moscow, Russia

PostPosted: Wed Aug 01, 2007 3:55 pm    Post subject: Reply with quote

Code:
localhost caleb # cat /root/ker.config | grep CONFIG_PHYSICAL_START
CONFIG_PHYSICAL_START=0x200000

Code:
cat /root/ker.config | grep CONFIG_RELOCATABLE
CONFIG_RELOCATABLE=y

Code:
--
                 from include/linux/preempt.h:9,
                 from include/linux/spinlock.h:49,
                 from include/linux/module.h:9,
                 from include/linux/crypto.h:21,
                 from arch/x86_64/kernel/asm-offsets.c:7:
include/asm/page.h:89:2: error: #error "CONFIG_PHYSICAL_START must be a multiple of 2MB"
make[1]: *** [arch/x86_64/kernel/asm-offsets.s] ¾èØÑÚÐ 1
make: *** [prepare0] ¾èØÑÚÐ 2
* Gentoo Linux Genkernel; Version 3.4.8
* Running with options: --menuconfig --bootloader=grub all

* ERROR: Failed to compile the "prepare" target...

* -- End log... --
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Thu Aug 02, 2007 6:39 pm    Post subject: Reply with quote

Caleb Brightmore wrote:
Code:
localhost caleb # cat /root/ker.config | grep CONFIG_PHYSICAL_START
CONFIG_PHYSICAL_START=0x200000

Code:
cat /root/ker.config | grep CONFIG_RELOCATABLE
CONFIG_RELOCATABLE=y


What do the following commands output?
Code:

zgrep CONFIG_PHYSICAL_START /proc/config.gz
zgrep CONFIG_RELOCATABLE /proc/config.gz

Are you using genkernel?
If so did you try with;
Code:

genkernel --menuconfig all

_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
Caleb Brightmore
n00b
n00b


Joined: 25 Apr 2006
Posts: 5
Location: Moscow, Russia

PostPosted: Fri Aug 03, 2007 5:29 am    Post subject: Reply with quote

To kdeenable
loftwyr wrote:
Go to "Processor type and features", and towards the bottom you will find the relevant options.
"Build a relocatable kernel (EXPERIMENTAL)" and "Physical address where the kernel is loaded".

Change the physical address from 100000 to 200000 and it will build.

loftwyr recommended me to change this options, but it's not working.
Back to top
View user's profile Send private message
keenblade
Veteran
Veteran


Joined: 03 Oct 2004
Posts: 1087

PostPosted: Fri Aug 03, 2007 1:32 pm    Post subject: Reply with quote

Caleb Brightmore wrote:
To kdeenable
loftwyr recommended me to change this options, but it's not working.

I see but the error reveals that this option is not changed, somehow. Maybe the --bootloader=grub option changes physical address to 100000 again. Did you try without genkernel? It is very easy and preferred way. Just look at my first post. Even, since you used genkernel, only the following procedure must work for you;
Code:

cd /usr/src/linux
make oldconfig
make menuconfig (or make xconfig)(make xconfig has a gtk gui and it is nicer. Adjust the required options here)
make
make modules_install
mount /boot/
cp System.map /boot/System.map-x86_64-2.6.22-gentoo-r2
cp arch/x86_64/boot/bzImage /boot/kernel-x86_64-2.6.22-gentoo-r2
cd /boot
rm System.map
ln -s System.map-x86_64-2.6.22-gentoo-r2 System.map

Then one thing remains; adjusting grub.conf. The file has some entries to boot the desired kernels. I have four entries to choose while booting ; latest, stable, rescue and vista. You just need to add a new entry for the new kernel (latest). I provide my entry. Just change and add it to the file
/boot/grub/grub.conf
Customize it by looking at your entries at your grub.conf. Your partition scheme is probably different than mine. Ex: if you have "root (hd0,3)" than change it. If you have ide hard disk than change "root=/dev/hda5" or something.
Code:

# For booting Gentoo Latest
title  Gentoo Latest 2.6.22-gentoo-r2
root (hd0,4)
kernel /boot/kernel-x86_64-2.6.22-gentoo-r2 root=/dev/sda7 udev doscsi vga=792

Also don't forget to emerge some packages like:
Code:

emerge -va1 nvidia-drivers alsa-driver iwlwifi

then reboot.
_________________
Anyway it's all the same at the end...
Need help to get it working: "x-fi surround 5.1"
Back to top
View user's profile Send private message
wlchase
Tux's lil' helper
Tux's lil' helper


Joined: 04 Jul 2003
Posts: 81
Location: Texas

PostPosted: Fri Aug 03, 2007 10:27 pm    Post subject: Reply with quote

Weird!

On my system building 2.6.22-r1 broke no matter what, until I manually edited the .config file! Maybe it's "menuconfig" itself?

Go figure!
Bill
Back to top
View user's profile Send private message
fraterm
n00b
n00b


Joined: 23 Apr 2002
Posts: 54
Location: Pflugerville, TX

PostPosted: Wed Aug 08, 2007 6:03 pm    Post subject: Works for me. Reply with quote

genkernel --menuconfig all worked for me with the Linux Kernel 2.6.22-gentoo-r2 simply by altering the 0x1... to 0x2...
_________________
What, me hurry?

Sitey sites:
http://fraterm.deviantart.com
http://www.approachzero.net
Back to top
View user's profile Send private message
roymaster
n00b
n00b


Joined: 05 Jan 2003
Posts: 64
Location: Europe

PostPosted: Fri Aug 17, 2007 8:09 am    Post subject: Reply with quote

wlchase wrote:
Weird!

On my system building 2.6.22-r1 broke no matter what, until I manually edited the .config file! Maybe it's "menuconfig" itself?

Go figure!
Bill



Hi guys.

I read this thread and had to say WOW here is a solution.

I changed values in my backed .config.genkernel

ran genkernel --menuconfig --bootloader=grub all

then selected "Load ...." and loaded .config.genkernel

then selected exit (thought it should save actual state to .config)

and what the hell.... the same error

But I discovered that .config - the file with genkernel trying to build kernel from - is smaller than my .config.genkernel

So I copied .config.genkernel to .config, ran genkernel with cmd above, gave Load ...., loaded .config.genkernel and clicked Exit ...

The same error.

Well well end of tale.
What you need during menuconfig is to Load your config (if you have any) and then Save it to ".config"

After this .config is not overwritten with default values of .config file!

I just started to compile kernel, hope it works :-)

Roman
Back to top
View user's profile Send private message
dnadesign
Apprentice
Apprentice


Joined: 23 Dec 2006
Posts: 172
Location: Poland

PostPosted: Sun Aug 19, 2007 12:42 am    Post subject: Reply with quote

In order to make the config changes visible for genkernel (and the whole make process) after loading an alternative config file you just need to save you config to an alternative file, but in the name field type in ".config". That way genkernel will proceed with compiling the config you want. If you won't do that it'll simply save the changes to the file you loaded. :)

UPDATE: Just ran through the 2.6.22 kernel changelogs and found this:
Code:

 x86_64: display more intuitive error message if kernel is not 2MB aligned

    o x86_64 kernel needs to be compiled for 2MB aligned addresses. Currently
      we are using BUILD_BUG_ON() to warn the user if he has not done so. But
      looks like folks are not finding message very intutive and don't open
      the respective c file to find problem source. (Bug 8439)

    arch/x86_64/kernel/head64.c: In function 'x86_64_start_kernel':
    arch/x86_64/kernel/head64.c:70: error: size of array 'type name' is negative

    o Using preprocessor directive #error to print a better message if
      CONFIG_PHYSICAL_START is not aligned to 2MB boundary.

Now we know what's going on. :)
_________________
MacBook Pro 5.1
Intel C2D 2.53 GHz, 4GB RAM DDR3, GF 9400M and 9600M GT 512MB
Back to top
View user's profile Send private message
Mgiese
Veteran
Veteran


Joined: 23 Mar 2005
Posts: 1387
Location: indiana

PostPosted: Tue Oct 09, 2007 6:34 pm    Post subject: Reply with quote

thx a lot for that hint, same problem here with gentoo-sources-2.6.22-r5 & r8

Code:
CONFIG_PHYSICAL_START=0x200000
did it for me..
_________________
I do not have a Superman complex, for I am God not Superman :D
Back to top
View user's profile Send private message
optik_knight
n00b
n00b


Joined: 15 Apr 2005
Posts: 12
Location: eastern Washington, western Idaho, USA

PostPosted: Wed Oct 24, 2007 4:36 pm    Post subject: Reply with quote

roymaster wrote:

What you need during menuconfig is to Load your config (if you have any) and then Save it to ".config"

After this .config is not overwritten with default values of .config file!


This worked for me, as well as setting the start to 2mb.
Back to top
View user's profile Send private message
gwrtheyrn
n00b
n00b


Joined: 14 Mar 2008
Posts: 6
Location: switzerland

PostPosted: Fri Mar 14, 2008 11:47 pm    Post subject: Reply with quote

hi

i'm new to gentoo, hope this fits here...

i also have problems when trying to compile the kernel (linux-2.6.24-gentoo-r3) on a core2duo processor, whether i configure the kernel using menuconfig or without menuconfig, i always get the error "ERROR: Failed to compile the "prepare" target..."

http://pastebin.ca/943120

anyone know what the problem could be?

thanks in advance

edit: i think this is the main problem, but don't know what exactly the problem is :)
Quote:
arch/x86/kernel/asm-offsets.c:1: error: code model 'kernel' not supported in the 32 bit mode
arch/x86/kernel/asm-offsets.c:1: sorry, unimplemented: 64-bit mode not compiled in
Back to top
View user's profile Send private message
Mgiese
Veteran
Veteran


Joined: 23 Mar 2005
Posts: 1387
Location: indiana

PostPosted: Thu Mar 20, 2008 11:26 am    Post subject: Reply with quote

hi there,

for those who did not notice yet, have a look here, there are some serious security holes in 2.6 kernel versions :

http://www.spreetec.net/modules.php?name=News&file=article&sid=319
_________________
I do not have a Superman complex, for I am God not Superman :D
Back to top
View user's profile Send private message
mimosinnet
Guru
Guru


Joined: 10 Aug 2006
Posts: 549
Location: Barcelona, Spain

PostPosted: Fri Jun 06, 2008 9:21 am    Post subject: Reply with quote

gwrtheyrn wrote:
Quote:
arch/x86/kernel/asm-offsets.c:1: error: code model 'kernel' not supported in the 32 bit mode
arch/x86/kernel/asm-offsets.c:1: sorry, unimplemented: 64-bit mode not compiled in


I have wollowed jjrojo advice and it has worked for me:

Instead of:
Code:
chroot /mnt/gentoo /bin/bash

I have used:
Code:
linux32 chroot /mnt/gentoo /bin/bash


I think the issue is that I was chrooting from a x86-64 environment.

Cheers!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on AMD64 All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum