Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[konqueror] stappare il naso ad mplayer [stappato]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4669
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Aug 03, 2007 11:19 am    Post subject: [konqueror] stappare il naso ad mplayer [stappato] Reply with quote

curiosità: se lancio:
Code:

 konqueror http://www.media.rai.it/mpmedia/0,,RaiTre-Report%5E10616,00.html

a sua volta, koqueror esegue questo comando :
Code:

mplayer -wid 8389743 -slave  -vo xv,sdl,x11 -ao alsa,oss,sdl,arts -framedrop -ao nas  -contrast 0 -brightness 0 -hue 0 -saturation 0  -cache 384 'mms://rntlivewm.rai.it/raitre/report/2409report.wmv' -identify

(ovviamente kmplayer è impostato su mplayer - con xine funziona).
risultato: non sento nulla se il server nas è spento (e se è acceso sento male, che la latenza non regge).
ora. chi glielo fa fare a konqueror di aggiungere l'attributo -ao nas? il comando, testato in linea, funziona perfettamente.
naturalmente, ho provato a modificare un po' in tutti i modi le impostazioni di kcontrol, ma cilecca. in particolare ho provato a togliere il supporto di rete o a impostarlo su alsa. ho seguito anche le istruzioni di questo topic.

quale sarà il click giusto stappare mplayer?
_________________
vu vu vu
gentù
mi piaci tu


Last edited by cloc3 on Fri Aug 03, 2007 7:13 pm; edited 1 time in total
Back to top
View user's profile Send private message
to.alex
n00b
n00b


Joined: 08 Apr 2007
Posts: 67

PostPosted: Fri Aug 03, 2007 2:50 pm    Post subject: Re: [konqueror] stappare il naso ad mplayer Reply with quote

cloc3 wrote:
curiosità: se lancio:
Code:

 konqueror http://www.media.rai.it/mpmedia/0,,RaiTre-Report%5E10616,00.html

a sua volta, koqueror esegue questo comando :
Code:

mplayer -wid 8389743 -slave  -vo xv,sdl,x11 -ao alsa,oss,sdl,arts -framedrop -ao nas  -contrast 0 -brightness 0 -hue 0 -saturation 0  -cache 384 'mms://rntlivewm.rai.it/raitre/report/2409report.wmv' -identify

(ovviamente kmplayer è impostato su mplayer - con xine funziona).
risultato: non sento nulla se il server nas è spento (e se è acceso sento male, che la latenza non regge).
ora. chi glielo fa fare a konqueror di aggiungere l'attributo -ao nas? il comando, testato in linea, funziona perfettamente.
naturalmente, ho provato a modificare un po' in tutti i modi le impostazioni di kcontrol, ma cilecca. in particolare ho provato a togliere il supporto di rete o a impostarlo su alsa. ho seguito anche le istruzioni di questo topic.

quale sarà il click giusto stappare mplayer?


A "naso" ti direi che devi cercare in qualche file .desktop di quelli presenti in /usr/kde/3.5/share/services e provare, una volta individuato il file giusto, a modificare la linea di comando che viene lanciata.

In realtà a fare le cose per bene dovresti copiare il file .desktop responsabile, in ~/.kde/3.5/share/services/ e modificare questo, così che eventuali aggiornamenti del file originale non vadano a sovrascrivere le modifiche che potresti apportare.

Solo che adesso sono su una SuSE e non posso essere più preciso di così.

In caso aggiorno più tardi il post.

Ciao.

---- Aggiunta ----
Ah, a volerlo fare a colpi di click, dovresti poterlo fare cercando fra le associazioni dei file nelle impostazioni di konqueror, sempre che non si tratti di qualcosa associato ad un servizio (piuttosto che ad un tipo di file).
Su konqueror in inglese si trovano in Settings -> Configure Konqueror -> File Associations. Poi da qui devi individuare qual'è il tipo di file legato al servizio e modificare il comando che viene eseguito.

---- Aggiunta all'aggiunta ----
Se non vuoi che mplayer non usi mai nas rifanne l'emerge impostando fra le flag use specifiche per mplayer -nas.
Back to top
View user's profile Send private message
djinnZ
Advocate
Advocate


Joined: 02 Nov 2006
Posts: 4831
Location: somewhere in L.O.S.

PostPosted: Fri Aug 03, 2007 3:37 pm    Post subject: Reply with quote

non ti confermo mplayer ma c'erano un paio di pacchetti che anche con USE="-nas" si autoimpostavano per lui se era installato sul sistema (motivo per il quale ho preferito eliminarlo, personalmente ti consiglio pulse).
_________________
scita et risus abundant in ore stultorum sed etiam semper severi insani sunt:wink:
mala tempora currunt...mater stultorum semper pregna est :evil:
Murpy'sLaw:If anything can go wrong, it will - O'Toole's Corollary:Murphy was an optimist :wink:
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4669
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Aug 03, 2007 7:13 pm    Post subject: Reply with quote

eureka! alla fine ho trovato.

bisognava navigare il menu delle impostazioni del plugin di kmplayer (che ho raggiunto con il tasto sinistro sopra il filmino) e modificare una voce 'opzioni aggiuntive in riga di comando' che qualche imbecille (:roll: chi, io?) aveva piazzato immemorabile tempo fa, quando usavo nas per l'audio ltsp.

naso stoppato.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum