Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sound for Vmware 5
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
iamlarryboy
Guru
Guru


Joined: 25 Jan 2003
Posts: 480
Location: Prince George, BC, Canada

PostPosted: Fri Jul 08, 2005 3:23 am    Post subject: Sound for Vmware 5 Reply with quote

I was just able to get sound working with vmware 5 and alsa and thought someone else might want a heads up.

1) make sure you have oss emulation support in your kernel
2) make sure you have the following in your /etc/modules.d/aliases file
Code:
alias /dev/dsp snd-pcm-oss

3) use this vmware wrapper.

That worked for me anyway.
_________________
Esteem : Essays, Fiction, and News Commentary.
Back to top
View user's profile Send private message
Headrush
Watchman
Watchman


Joined: 06 Nov 2003
Posts: 5597
Location: Bizarro World

PostPosted: Sat Jul 09, 2005 11:53 pm    Post subject: Re: Sound for Vmware 5 Reply with quote

iamlarryboy wrote:
I was just able to get sound working with vmware 5 and alsa and thought someone else might want a heads up.

1) make sure you have oss emulation support in your kernel
2) make sure you have the following in your /etc/modules.d/aliases file
Code:
alias /dev/dsp snd-pcm-oss

3) use this vmware wrapper.

That worked for me anyway.

What problem were you having?
Sounds work ok for me, no additions were needed in /etc/modules.d/aliases, but that line is included in the /etc/modules.d/alsa file.
No wrapper needed either. Are you sure your ALSA is correctly set up?

My /etc/modules.d/alsa
Code:
# ALSA portion
alias char-major-116 snd
# OSS/Free portion
alias char-major-14 soundcore

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

alias /dev/mixer snd-mixer-oss
alias /dev/dsp snd-pcm-oss
alias /dev/midi snd-seq-oss

# Set this to the correct number of cards.
options snd cards_limit=1
Back to top
View user's profile Send private message
BigBaaadBob
Guru
Guru


Joined: 19 Apr 2003
Posts: 342
Location: Swampscott, MA USA

PostPosted: Sat Dec 03, 2005 3:11 am    Post subject: Reply with quote

I get the standard "/dev/dsp busy" error reported in a dozen places here. Are you saying you can play alsa sounds at the same time as your vmware is running and you don't get this error?
Back to top
View user's profile Send private message
crys0000
n00b
n00b


Joined: 11 Jan 2006
Posts: 44
Location: Todi, Italy

PostPosted: Tue Jan 17, 2006 6:55 pm    Post subject: Re: Sound for Vmware 5 Reply with quote

iamlarryboy wrote:
I was just able to get sound working with vmware 5 and alsa and thought someone else might want a heads up.

1) make sure you have oss emulation support in your kernel
2) make sure you have the following in your /etc/modules.d/aliases file
Code:
alias /dev/dsp snd-pcm-oss

3) use this vmware wrapper.

That worked for me anyway.


I followed your tips but when I run vmwareesd or vmwarearts I get this error:

Code:
ERROR: ld.so: object 'libvmdsp.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libvmdsp.so' from LD_PRELOAD cannot be preloaded: ignored.
ERROR: ld.so: object 'libvmdsp.so' from LD_PRELOAD cannot be preloaded: ignored.


Where is the problem?

Thanks :)
Back to top
View user's profile Send private message
Thrain
Guru
Guru


Joined: 01 Sep 2003
Posts: 380

PostPosted: Sat Sep 02, 2006 4:18 pm    Post subject: Reply with quote

Same problem as above here... did someone solved? :roll:
_________________
Thrain

"...only astonishment knows..."
Back to top
View user's profile Send private message
imanassypov
Tux's lil' helper
Tux's lil' helper


Joined: 08 Dec 2005
Posts: 118
Location: Toronto, Canada

PostPosted: Thu Jul 26, 2007 6:20 pm    Post subject: Reply with quote

Nope,

having 'device busy' warning and no sound as well. followed all the suggestions posted here.
_________________
I.M.
Back to top
View user's profile Send private message
marwiol1980
n00b
n00b


Joined: 31 Jul 2007
Posts: 2

PostPosted: Tue Jul 31, 2007 11:33 am    Post subject: Reply with quote

hI
I'm new on this forum. I need help.
_________________
Zdjêcia ¦lubne - zdjêcia ¶lubne to moja pasja
Back to top
View user's profile Send private message
Lars
Apprentice
Apprentice


Joined: 06 Feb 2003
Posts: 151
Location: Germany, near baltic sea

PostPosted: Wed Aug 01, 2007 9:54 am    Post subject: Reply with quote

I've the same problem, no sound, but found a solution which works also for me.
My System runs native on Linux, with Xorg & KDE.
Windows XP Pro runs in a VMware 5.5.

1. Stop the KDE sound-server (arts) which I never use, make more problems for me ever.
With the Control Center
search for 'sound server'
select 'Sound System'
Click off the Checkbox 'Enable the sound system'

2. Put the follows in the *.vmx File
Quote:

sound.startConnected = "TRUE"
sound.fileName = "/dev/dsp"
sound.present = "TRUE"
sound.virtualDev = "sb16"
sound.autodetect = "FALSE"

I know there exist also a es1371 sound card, but this doesn't works for me at the moment therefore I use sb16.

3. Start VMware, Start Windows XP in it, install the 'Creative Sound Blaster 16' driver by hand.
Start->Control Panel->Add Hardware
-> Next
Choose 'Yes, I have already connected the hardware' -> Next
Choose 'Add a new hardware device' -> Next
Choose 'Install the hardware that I manually select from a list (Advanced) -> Next
Choose 'Sound, video and game controllers' -> Next
Select Manufacturer 'Creative Technology Ltd.' and Model 'Sound Blaster 16 or AWE32 or compatible (WDM)' -> Next
-> Next
-> Finish

Maybe you need a Windows typical reboot...
After this long manual adventure I got sound in my VMware Windows Guest.

Maybe check on Linux and Windows the sound loudness of pcm sounds.
Switch on the 100W booster.

The other, like vmware wrapper doesn't works for me, libpng* is not found, which libcairo* needs.

Regards
Lars
_________________
Quote:
Alles was nicht einfach ist, ist entweder falsch oder zu kompliziert.

V.Glazounov
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum