Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
cardmgr error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
truth
n00b
n00b


Joined: 20 Jun 2002
Posts: 31

PostPosted: Fri Jul 11, 2003 3:06 am    Post subject: cardmgr error Reply with quote

I setup gentoo on a compaq presario 1690 recently, left pcmcia out of the kernel compile, and emerged pcmcia-cs, , networking is working properly, however when i do a reboot/shutdown i get the following, i have to copy it from the laptop screen as i only have one patch cable running in here , but ill check for typing errors before submitting.
Reboot shows ::

* Bringing eth0 down... [ok]
* Bringing lo down... [ok]
* Stopping pcmcia... [ok]
cardmgr[706]: executing: './network check eth0'
cardmgr[706]: executing: './network stop eth0'
cardmgr[706]: + * ERROR: "net.eth0" has not yet been started.
cardmgr[706]: stop cmd exited with status 1
cardmgr[706]: executing: 'modprobe -r 3c574_cs'
cardmgr[706] exiting
rest of reboot/shutdown follows....................

as you can probably tell its a 3com pcmcia nic, i have pcmcia-cs emerged, i have i82365 and ds in /etc/modules.autoload, networking works fine, i do NOT have pcmcia support compiled into the kernel. It looks like the error is occuring because eth0 is already down before cardmgr tries to stop it, i could be wrong though. I have net.eth0 and pcmcia in default runlevel, i cannot determine what is stopping eth0 before cardmgr tries to or where to prevent cardmgr from trying to stop it, i have grep'ed through all the /etc/init.d scripts and it seems as though that line is coming from runscript.sh which every startup script is using to start/stop etc, maybe im way off but any help would be appreciated, im too anal to let it go even though functionality is not broken. Also i went back into make menuconfig and removed Ethernet ( 10Mbit and 100Mbit) and recompiled the kernel, thinking maybe eth0 was being stopped by the kernel, nothing changed. Hope thats enough info for someone to help.

<Edit as follows:>
Ok heres some added info: When i do /etc/init.d/./pcmcia stop before doing reboot it goes through without errors, when i do /etc/init.d/net.eth0 stop before reboot it doesnt do first "Bringing eth0 down..." but the errors still occur right after "Stopping pcmcia..." So i guess if i could somehow make pcmcia shutdown before net.eth0 then i would be set., i would prefer to do it nicely and not some hack job that shuts down pcmcia before real shutdown process takes over.
_________________
truth
---------
Squirells..Natures little speed bumps.
Back to top
View user's profile Send private message
Sormuras
n00b
n00b


Joined: 14 Mar 2003
Posts: 19
Location: Germany / Koblenz

PostPosted: Fri Jul 11, 2003 10:24 am    Post subject: Reply with quote

Hi truth!

As I like a clean boot/shutdown screen, I followed your suggestion and added to /etc/conf.d/local.stop the line
Code:
/etc/init.d/pcmcia stop


Now, only green '* ... [ ok ]' messages are seen.
Back to top
View user's profile Send private message
truth
n00b
n00b


Joined: 20 Jun 2002
Posts: 31

PostPosted: Mon Jul 14, 2003 1:20 am    Post subject: Thx Sormuras Reply with quote

I have done the same now and it is acceptable. Weird thing is the intermittent errors i get with cardmgr upon bootup. Anyways the reboot/shutdown screen is nice and clean now
_________________
truth
---------
Squirells..Natures little speed bumps.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum