Joined: 12 May 2004
|Posted: Tue Mar 20, 2007 10:26 pm Post subject: [ GLSA 200703-21 ] PHP: Multiple vulnerabilities
|Gentoo Linux Security Advisory
Title: PHP: Multiple vulnerabilities (GLSA 200703-21)
Date: March 20, 2007
Updated: March 29, 2008
PHP contains several vulnerabilities including a heap buffer overflow, potentially leading to the remote execution of arbitrary code under certain conditions.
PHP is a widely-used general-purpose scripting language that is especially suited for Web development and can be embedded into HTML.
Vulnerable: < 5.2.1-r3
Unaffected: >= 5.2.1-r3
Unaffected: >= 5.1.6-r11 < 5.1.7
Unaffected: >= 4.4.6 < 4.4.7
Unaffected: >= 4.4.7 < 4.4.8
Unaffected: >= 4.4.8_pre20070816 < 4.4.9
Architectures: All supported architectures
Several vulnerabilities were found in PHP by the Hardened-PHP Project and other researchers. These vulnerabilities include a heap-based buffer overflow in htmlentities() and htmlspecialchars() if called with UTF-8 parameters, and an off-by-one error in str_ireplace(). Other vulnerabilities were also found in the PHP4 branch, including possible overflows, stack corruptions and a format string vulnerability in the *print() functions on 64 bit systems.
Remote attackers might be able to exploit these issues in PHP applications making use of the affected functions, potentially resulting in the execution of arbitrary code, Denial of Service, execution of scripted contents in the context of the affected site, security bypass or information leak.
There is no known workaround at this time.
All PHP users should upgrade to the latest version:
|# emerge --sync
# emerge --ask --oneshot --verbose "dev-lang/php"
PHP 4.4.5 Release Announcement
PHP 5.2.1 Release Announcement
Last edited by GLSA on Sat Mar 29, 2008 4:18 am; edited 2 times in total