Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
su non va anche se il mio utente fa parte di wheel [risolto]
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
ema
Guru
Guru


Joined: 27 Aug 2003
Posts: 380

PostPosted: Tue Mar 06, 2007 1:49 pm    Post subject: su non va anche se il mio utente fa parte di wheel [risolto] Reply with quote

dopo aver risolto il problema https://forums.gentoo.org/viewtopic-t-544872.html , mi ritrovo come da oggetto. Se eseguo il comando su, mi dice continuamente che la password è sbagliata nonostante io sia nel gruppo wheel. Ho anche tentato di creare ex novo un utente e anche in questo caso non mi accetta il login.
Code:

ema@bulma ~ $ su
Password:
su: Authentication failure
Sorry.
ema@bulma ~ $


come già detto il mio utente fa parte di wheel e non mi sembra configurato diversamente rispetto a un altro pc dove il comando su funziona...
/etc/group:
Code:

wheel::10:root,ema


/etc/passwd:
Code:

ema:x:1000:100::/home/ema:/bin/bash


E ora che cavolo è successo?
_________________
D Per fare il SysAdmin e' necessario conoscere Unix/Linux e disprezzare Windows?
R Se ti interessa lavorare in ambiente Unix/Linux dovrai averne un minimo di conoscenza, quando acquisisci tale conoscenza la seconda parte arriva da sola.


Last edited by ema on Tue Mar 06, 2007 4:10 pm; edited 1 time in total
Back to top
View user's profile Send private message
crisandbea
Veteran
Veteran


Joined: 03 Jul 2005
Posts: 1778
Location: BOSCO (SA) ... ma domiciliato a Bologna....

PostPosted: Tue Mar 06, 2007 1:58 pm    Post subject: Reply with quote

sei sicuro di aver creato una passordw per l'utente root?

prova a dare un
Code:
sudo passwd root
e modifica o crea la passwd di root.

ciao
Back to top
View user's profile Send private message
ema
Guru
Guru


Joined: 27 Aug 2003
Posts: 380

PostPosted: Tue Mar 06, 2007 2:05 pm    Post subject: Reply with quote

mi ero dimenticato di specificarlo: si, l'utente root ha una password. Ho anche provato a cambiarla senza risultato. Al login funziona perfettamente, se tento di diventare root invece dice sempre che è errata.
_________________
D Per fare il SysAdmin e' necessario conoscere Unix/Linux e disprezzare Windows?
R Se ti interessa lavorare in ambiente Unix/Linux dovrai averne un minimo di conoscenza, quando acquisisci tale conoscenza la seconda parte arriva da sola.
Back to top
View user's profile Send private message
ema
Guru
Guru


Joined: 27 Aug 2003
Posts: 380

PostPosted: Tue Mar 06, 2007 4:10 pm    Post subject: Reply with quote

ho risolto da solo...
ma non riesco a capire come cavolo possa essere successo il guaio!

Confrontandolo con un altro pc, mi sono accorto che su non era suid. Ho dato chmod u+s a su nel portatile e ora funziona tutto. Anche mount, umount e altri comandi erano senza suid. Boh...!

Comunque se a qualcuno capitasse una assurdità simile, ecco la soluzione: chmod u+s /bin/su
_________________
D Per fare il SysAdmin e' necessario conoscere Unix/Linux e disprezzare Windows?
R Se ti interessa lavorare in ambiente Unix/Linux dovrai averne un minimo di conoscenza, quando acquisisci tale conoscenza la seconda parte arriva da sola.
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4669
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Wed Mar 07, 2007 6:03 am    Post subject: Reply with quote

ema wrote:

Boh...!

Comunque se a qualcuno capitasse una assurdità simile, ecco la soluzione: chmod u+s /bin/su

io emergei nuovamente shadow (il pacchetto che contiene su) e i pacchetti degli altri eseguibili di /bin (usa `equery b foo` per trovarli)
se non sei in grado di capire l'origine del guasto, può essere che tu abbia altre cose sconfigurati.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
ema
Guru
Guru


Joined: 27 Aug 2003
Posts: 380

PostPosted: Thu Mar 08, 2007 5:21 pm    Post subject: Reply with quote

infatti... credo mi sia partito un comando sbagliato sistemando i permessi della mia home! Devo smetterla di bere prima di sistemare i problemi, sennò li ingigantisco e basta... Si sono incasinati anche i permessi di etc e dev. Al che, visto che come installazione non era venuta proprio benissimo, sono ripartito da zero, e usando distcc in mezza giornata ho reinstallato tutto, kde compreso 8)

Grazie cmq x le info, specie per quelle relative al contenuto del pacchetto shadow.
_________________
D Per fare il SysAdmin e' necessario conoscere Unix/Linux e disprezzare Windows?
R Se ti interessa lavorare in ambiente Unix/Linux dovrai averne un minimo di conoscenza, quando acquisisci tale conoscenza la seconda parte arriva da sola.
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4669
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Thu Mar 08, 2007 7:43 pm    Post subject: Reply with quote

ema wrote:
Devo smetterla di bere prima di sistemare i problemi

anche dopo.
mi raccomando.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum