Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
USB works only under the win4lin kernel?
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message

Joined: 23 May 2003
Posts: 53

PostPosted: Mon Jun 30, 2003 6:27 pm    Post subject: USB works only under the win4lin kernel? Reply with quote

I've compiled at least half a dozen different kernel sources and stuck with the win4lin-sources because they seem to be the only one that will fix my usb.
With gentoo-sources, vanilla-sources, and gaming-sources usb has an error stating "device not accepting address".

According to the USB FAQ (see below) ACPI would probably be the most likely culprit. I'm using smp and so must use acpi, although it has never worked correctly (the computer still won't power off by itself after a halt). When I was looking at the other sources a few halted correctly but it seemed completly random. In a test with the gaming-sources where I just rebooted over and over, it powered down correctly three times, and failed twice. By this I mean it shut off by itself instead of sitting with 'Power down.' displayed. The power managment issue asside, I was wondering if anyone is familiar enough with the win4lin sources to answer my question:

What is different about the win4lin sources that allows usb to work with my configuration?


Dual PIII 1ghz
ASUS CUV4XD motherboard

Excerpt from the Linux USB FAQ (
Q: Why doesn't USB work at all? I get "device not accepting address".

A: You may have some problem with your PCI setup that's preventing your USB host controller from getting hardware interrupts. When Linux submits a request, but never hears back from the controller, this is the diagnostic you'll see. To see if this is the problem, look at /proc/interrupts to see if the interrupt count for your host controller driver ever goes up. If it doesn't, this is the problem: either your BIOS isn't telling the truth to Linux (ACPI sometimes confuses these things, or setting the expected OS to windows in your BIOS), or Linux doesn't understand what it's saying.

Sometimes a BIOS fix will be available for your motherboard, and in other cases a more recent kernel will have a Linux fix. You may be able to work around this by passing the noapic boot option to your kernel, or (when you're using an add-in PCI card) moving the USB adapter to some other PCI slot. If you're using a current kernel and BIOS, report this problem to the Linux-kernel mailing list, with details about your motherboard and BIOS.

A user with an AOpen AK73Pro motherboard reported that turning off the BIOS option "Assign IRQ for USB" solved this problem for him. Another mentioned that upgrading from BIOS revision 1.16 to 1.20 fixed it (but he wasn't sure if he had an AK73 or the Pro or some other variant).
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum