Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Block device error
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
a-slayeriq
n00b
n00b


Joined: 06 Feb 2007
Posts: 33

PostPosted: Tue Feb 06, 2007 4:11 pm    Post subject: Block device error Reply with quote

Hallo,

Ik had gister besloten om Gentoo eens erop te zetten. ik heb de handbook uitgeprint over het installeren. en ik heb elke stap uit het handboox gedaan. ik heb genkernel gebruikt en ik heb lilo als bootmanager. nu krijg ik het volgende als ik start

Code:
>> Mounting filesystems
>> Activating udev...
>> Determining root device...
>> Block device 100 is not a valid root device...
>> The root block device is unspecified or not detected.
   Please specify a device to boot, or “shell” for a shell...


Verder kan ik niks doen. lilo werkt gewoon want ik kan gewoon op windows . mijn hardeschijf ziet er als volgt uit

Code:
sdb1 = windows
sdb2= /boot
sdb3 = windows partitie
sdb4 = swap
sdb5 = windows partitie
sdb6 = /root
sdb7 = windows


mijn lilo.conf ziet er zo uit

Code:
boot=/dev/hda             
prompt                 
timeout=50               
default=gentoo

image=/boot/kernel-genkernel-x86-2.6.19-gentoo-r5
  label=gentoo
  read-only
  root=/dev/ram0
  append="init=/linuxrc ramdisk=8192 real_root=/dev/sdb6 udev"
  initrd=/boot/initramfs-genkernel-x86-2.6.19-gentoo-r5


Hoe kan ik dit probleem oplossen.


alvast bedankt,
Back to top
View user's profile Send private message
nixnut
Administrator
Administrator


Joined: 09 Apr 2004
Posts: 10973
Location: the dutch mountains

PostPosted: Tue Feb 06, 2007 6:27 pm    Post subject: Reply with quote

Quote:
boot=/dev/hda

Start je computer vanaf een harddisk die master is op de 1e ide controller? Als je computer start vanaf een sata harddisk dan moet je waarschijnlijk iets anders gebruiken zoals /dev/sda.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
koenderoo
Guru
Guru


Joined: 03 Jan 2004
Posts: 514
Location: Zwolle, The Netherlands

PostPosted: Tue Feb 06, 2007 6:28 pm    Post subject: Reply with quote

Ik zit een beetje raar naar je partitietabel te kijken. Mag ik concluderen dat je 1 sata hardeschijf hebt die op je tweede sata-poort ingesteld staat? Zo niet dan klopt je tabel al niet.

Lilo vertel je vervolgens dat hij op de eerste poort moet kijken! hda en sdb komen niet overeen. Lilo start schijnbaar wel dus dan mag je er van uitgaan dat hda goed was.

Dus ik denk dat je een foutje maakt met je harde schijf sdb te noemen. probeer dus eens of het werkt als je sdb6 verandert in sda6 in de append regel.
_________________
webmaster van www.koenderoo.nl
Back to top
View user's profile Send private message
a-slayeriq
n00b
n00b


Joined: 06 Feb 2007
Posts: 33

PostPosted: Tue Feb 06, 2007 6:49 pm    Post subject: Reply with quote

maar sdb6 is mijn ik heb hem niet zo genoemd mijn partities heten gewoon sdb allemaal
Back to top
View user's profile Send private message
koenderoo
Guru
Guru


Joined: 03 Jan 2004
Posts: 514
Location: Zwolle, The Netherlands

PostPosted: Wed Feb 07, 2007 12:16 pm    Post subject: Reply with quote

Lilo en grub gaan wel eens wat raar om met harde schijf aanduidingen. Probeer het eerst eens uit, of had je dat al gedaan?
_________________
webmaster van www.koenderoo.nl
Back to top
View user's profile Send private message
a-slayeriq
n00b
n00b


Joined: 06 Feb 2007
Posts: 33

PostPosted: Wed Feb 07, 2007 4:03 pm    Post subject: Reply with quote

nee werkt niet maar ik ben derover aan het denken om grub erop te zetten inplaats van lilo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum