Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
apache+mod_php+phpsysinfo
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks
View previous topic :: View next topic  
Author Message
gigel
Guru
Guru


Joined: 14 Jan 2003
Posts: 344
Location: .RO

PostPosted: Thu Apr 10, 2003 12:32 pm    Post subject: apache+mod_php+phpsysinfo Reply with quote

i have seen that many of gentoo users had some problems with apache,mod_php etc.etc..

so now i'm going to post how to install all of the above without any problem(for me worked just fine)

first modify the CFLAGS in /etc/make.conf
Code:

CFLAGS="-march=put_what_your_arch_is -O3 -pipe -fomit-frame-pointer"

than modify USE="-java -qt"
#emerge apache mod_php phpsysinfo etc..
after all is installed you shoul modify /etc/apache/conf/apache.conf
comment the Inlcude conf/commonapache.conf
Code:

LoadModule php4_module            extramodules/libphp4.so

Code:

AddModule mod_php4.c

Code:

AddType application/x-httpd-php             .php .php4 .php3 .phtml
AddType application/x-httpd-php-source  .phps


and you've done it!!
it's simple,but maybe this would help someone
_________________
$emerge sux
:D
Back to top
View user's profile Send private message
christsong84
Veteran
Veteran


Joined: 06 Apr 2003
Posts: 1002
Location: GMT-8 (Spokane)

PostPosted: Sun Apr 13, 2003 7:07 pm    Post subject: Reply with quote

Wodnerful...it helped me immensly, thx! :D :D :D
Back to top
View user's profile Send private message
michaelb
l33t
l33t


Joined: 06 Jun 2002
Posts: 686
Location: Ann Arbor, MI

PostPosted: Mon Apr 14, 2003 1:50 pm    Post subject: Reply with quote

Quote:
than modify USE="-java -qt"
this is a workaround to this bug. If you want to install java support to php, you can do so by first installing the sun-jdk1.4.1.02 release and setting it up with
Code:
# java-config --set-system-vm=sun-jdk-1.4.1.02
Now you don't need to set USE="-java -qt" :)

Michael
_________________
Behold, The power of SEARCH!
Back to top
View user's profile Send private message
Guybrush
Tux's lil' helper
Tux's lil' helper


Joined: 06 Feb 2003
Posts: 90
Location: 48°27'N, 11°8'O

PostPosted: Wed Jun 18, 2003 12:14 pm    Post subject: Reply with quote

I have both java and qt in my USE-variable and it still works.
Even with blackdown-java (version 1.4.1)

GREAT!!!
Back to top
View user's profile Send private message
puke
Tux's lil' helper
Tux's lil' helper


Joined: 05 Oct 2002
Posts: 128

PostPosted: Wed Jun 18, 2003 12:24 pm    Post subject: Reply with quote

This may be a dumb question.. :oops:

When I performed an emerge mod_php my system tried to merge all sorts of packages, fonts, libpng, even X stuff. They seemed to be dependancies for mod_php. Surely not?

My server is not a workstation, doesn't have a monitor or keyboard, what are the minimum packages needed for a mod_php install, how can I do this?
Back to top
View user's profile Send private message
niki
n00b
n00b


Joined: 25 May 2003
Posts: 19
Location: Switzerland

PostPosted: Thu Jun 19, 2003 2:50 pm    Post subject: Reply with quote

I put

Code:
-X -qt


in my USE Flag then
emerge mod_php
didn't install xfree
Back to top
View user's profile Send private message
Dragon561
Tux's lil' helper
Tux's lil' helper


Joined: 25 Oct 2002
Posts: 112

PostPosted: Sat Jun 21, 2003 7:08 pm    Post subject: Reply with quote

Thanks a bunch!! :!: :D
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Documentation, Tips & Tricks All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum