Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Gentoo on Toshiba Satellite A45 series
View unanswered posts
View posts from last 24 hours

Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message

Joined: 31 Dec 2004
Posts: 1340

PostPosted: Sun Nov 19, 2006 5:04 am    Post subject: Gentoo on Toshiba Satellite A45 series Reply with quote

Gentoo Linux on A45 Series Toshiba's
Models include A45-S120, A45-S1201, A45-S1501, A45-S130, A45-S1511, A45-S151, A45-S1211, A45-S121, A45-S1202, A45-S2502, A45-S1301, A45-S2501, A45-S250, A45-S150

Kernel config below notes: Parallel port is set up for PLIP not a printer,
Wireless: The A45-s120 did not come with a built in wifi. The A45-151 seems to have
lspci | grep -i net
 0000:01:05.0 Ethernet controller: Atheros Communications, Inc. AR5212 802.11abg NIC (rev 01)

If this is your case the Madwifi drivers are it.
emerge madwifi-driver

Note that at this time there may be better wireless cards available than the stock minipci one. I have not looked into this as my laptop did not come with one and does not have the internal antenna.
Have not tested ppp dialup modem.
There are Alsa drivers for the modem. I wonder if these can be used for anything fun.

Latest Config:
kernel config is here

KDE & mplayer optimized make.conf
I am now using
CFLAGS="-march=pentium4 -mtune=pentium4 -pipe -O2"
In my make.conf
All my binary packages are going to be here here
I am not sure how to make md5 sums for them yet.

DRI works.
Need more work, I am currently working on a Double-Screen set up but
encountering some problems.[/color]


More system packages to check out:
To optimize the touchpad. The xorg.conf above is set up for this. I am interested if anyone has further optimized this.
ifplugd a tool to automate switching between wired and wireless eth0 connection doesnt seem to work right ever.
You need to set up
and see the example in the [url=] Gentoo wiki
fnfx related to function keys.
Here are some power management utilitys:
emerge -av laptop-mode-tools toshiba-utils

Gentoo is weak on fonts.[/url]
I ended running the command
to add the path to each added font.

Links and hardware notes:
How to disassemble and repair The memory upgrades under the keybord running more than 2 gigs is not possible without upgrading the memory controller. The processors in these models are a lSocket 478. I imagine a Intel Pentium 4 Socket 478 CPU Speed: 3 GHz would be the last upgrade made.
If you are starting from scratch and installing Gentoo consider upgrading the 4200 rpm hard drive with a 5200. Research shows that all ATA types are compatible Although this laptop only supports ATA-5 features. Not found a replacement drive with a cache larger than 8MB.
Have some heat sink compound around when if you decide to take things apart.
Tech Specs for A45-S120
Pentium 4 selected in kernel config.
1000hz timer
cat /proc/cpuinfo
processor       : 0
vendor_id       : GenuineIntel
cpu family      : 15
model           : 2
model name      : Intel(R) Celeron(R) CPU 2.60GHz
stepping        : 9
cpu MHz         : 2593.676
cache size      : 128 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 2
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush dts acpi mmx fxsr sse sse2 ss ht tm pbe up cid xtpr
bogomips        : 5191.09
clflush size    : 64

Mass Storage/Optical Drive
• Primary Hard Disk Drive: 40GB* hard disk drive, Enhanced IDE
(ATA-5) interface, 4200rpm drive rotation; 9.5mm height, 0.2lbs,
Service Removable
• DVD-ROM/CDRW Multi-function Drive: Enhanced IDE (ATAPI)
Interface; Maximum speed: CD-R(24x), CD-RW(10x), CDROM(
24x), DVD-ROM(8x); Compatibility: CD-ROM, CD-R
(read/write), CD-RW (read/re-write), DVD-ROM, DVD-R (read
only), DVD-RW (read only), DVD-RAM (read only); Service
• Software Decoder: InterVideo (Win-DVD 4®) - w/SRS Technology
• 15.0” TFT active-matrix display****; internal display supports up to
16M colors at 1024 x 768
• Intel® 852GME Integrated graphics controller; 32MB DDR SDRAM
• Direct 3D support and DirectVideo
• External Color Support/Refresh rate:
• 640 x 480: 60/75/85/100Hz Non-Interlaced @16M colors
800 x 600; 60/75/85/100Hz Non-Interlaced @16M colors
1024 x 768; 60/75/85/100Hz Non-Interlaced @16M colors
1280 x 1024; 60/75/85/100Hz Non-Interlaced @16M colors
1600 x 1200; 60/75/85Hz Non-Interlaced @16M colors
1920 x 1440; 60/Hz Non-Interlaced @16M colors
Everything posted below this first post is solved and out of date.
Donate to Gentoo

Last edited by turtles on Wed Feb 03, 2010 4:19 am; edited 26 times in total
Back to top
View user's profile Send private message

Joined: 23 Jun 2003
Posts: 482

PostPosted: Wed Nov 22, 2006 3:54 pm    Post subject: Reply with quote

did you try to enable the marvell driver in the kernel?

.config of a running kernel is sometimes available in /proc/config.gz
Back to top
View user's profile Send private message

Joined: 11 Feb 2004
Posts: 387
Location: Berne, Switzerland

PostPosted: Wed Nov 22, 2006 5:35 pm    Post subject: Reply with quote

Run "lshw" (emerge it first) or "lspci" - it should give you more detailed informations about the chipset in use. You can then either look up if and how your driver is supported here and using Google if that fails. Or alternatively post the output in this forums.
Back to top
View user's profile Send private message

Joined: 31 Dec 2004
Posts: 1340

PostPosted: Wed Nov 22, 2006 5:36 pm    Post subject: Reply with quote

Thanks for the tip I have used that config that came with the GUI installer live cd and cannot get a kernel that boots, however when the live cd installed the kernel it works fine other than that it complains about not being able to load the ACPI modules.

I compared the kernel config in proc to the one I have been working with in xxdiff and they are the same. I have also tried 7 different times making minor changes each time as well as reading the manual, and other wireless posts here. I also question the necessity of recompiling the kernel to use ndiswrapper for the airlink card which is what I was assuming I had to do.

I have looked thru the menuconfig a 8th time nd see no marvell driver where is this driver in the menuconfig? That would be Ideal if I did not have to use ndis wrapper.

In this is the post I have for not being able to compile the last kernel It also shows my situation in more detail. the interesting thing is that lspci no longer even sees the card wich it did before??
I am no dev so I might be missing somthing obvious here.
I really appreciate all the help, I know this is solve able. Sorry for all the seperate posts it seems like it is prefered to have posts relate to a particular problem.
Donate to Gentoo
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum