Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Portage-2.0.5 through 2.0.7 Semi-Broken
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2, 3, 4, 5  Next  
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
sanity
n00b
n00b


Joined: 19 May 2002
Posts: 39
Location: Iowa

PostPosted: Sat Jun 29, 2002 10:04 pm    Post subject: up to 2.0.8 worked... Reply with quote

When I updated my system, this is what I'd do:
Code:

emerge -u portage
etc-update
emerge clean
emerge rsync
emerge -u world
etc-update
emerge clean
emerge rsync
emerge -u world...

Starting with portage, and then updating everything until I got an error because of no packages to update.

Sometimes if I rsync enough, things that appeared broken start working.

Now, if I can rely on the digests and tarballs in my /usr/portage/sys-apps/portage/files directory, the last version that worked was 2.0.5. Upgrading from that to 2.0.8 worked fine, but after the upgrade, I got this error from 'emerge -u world':
Code:

Calculating world dependencies /Traceback (most recent call last):
  File "/usr/bin/emerge", line 1227, in ?
    if not mydepgraph.syscreate(getworldlist()):
  File "/usr/bin/emerge", line 513, in syscreate
    if not self.create(self.match(myline,mykey="update (likely old /var/db/pkg entry)")):
  File "/usr/bin/emerge", line 410, in create
    edepend=portage.db[myroot]["porttree"].dbapi.aux_get(mykey,portage.auxdbkeys)
  File "/usr/lib/python2.2/site-packages/portage.py", line 2565, in aux_get
    self.auxcache[mycpv][auxdbkeys[x]]=mylines[x][:-1]
IndexError: list index out of range

I get a similar error from 'emerge -u system' but not from 'emerge -u xbill' -- straight 'emerge foo' seems to work, searching works, and cleaning (and therefore unmerging) works. But updating doesn't work.

Since emerging a single package seems to work, I will try to downgrade for the time being.

EDIT: Wierd. After downgrading to 2.0.5, then upgrading to 2.0.8 (to double-check before submitting a bug report), it works. Yet another of Gentoo's little oddities. Once again, sometimes just retrying in various ways will fix it.
_________________
Every time you read a signature, God kills a kitten.
Back to top
View user's profile Send private message
strife
n00b
n00b


Joined: 14 Jun 2002
Posts: 22

PostPosted: Sat Jun 29, 2002 11:27 pm    Post subject: Portage 2.0.8 interesting.. 'ebuild' missing. Reply with quote

'ebuild' no longer exists anywhere on my system, I think there is something wrong with 2.0.8.

Since there is no portage* in /usr/portage/distfiles how does one *fix* this when you don't have another machine to copy over a working version of the portage scripts?
Back to top
View user's profile Send private message
daos
n00b
n00b


Joined: 18 Apr 2002
Posts: 50
Location: Virginia, USA

PostPosted: Sun Jun 30, 2002 1:35 am    Post subject: Reply with quote

I think portage 2.0.8 still has problem. Emerge single package is OK, but I have a common error "index out of range" if I do something else such as emerge -p -u world , or even emerge to an old portage version.
Back to top
View user's profile Send private message
Dolio
l33t
l33t


Joined: 17 Jun 2002
Posts: 650

PostPosted: Sun Jun 30, 2002 1:56 am    Post subject: Yeah. Reply with quote

I agree. Portage 2.0.8 fixed a bunch of stuff from 2.0.5 - 2.0.7, but there are still problems.

Just re-emerged 2.0.8 (had been using 2.0.4) and emerge -pu world causes python errors (index out of range), as does emerge -pe world, as does emerge -pe system (not, it seems, emerge -pu system).

Could this be a problem with my world database? Other than that I can't think of anything off hand that would be wrong. Rsyncing doesn't help me.
_________________
They don't have a good bathroom to do coke in.
Back to top
View user's profile Send private message
Scandium
Retired Dev
Retired Dev


Joined: 22 Apr 2002
Posts: 340
Location: Germany

PostPosted: Sun Jun 30, 2002 2:54 pm    Post subject: Reply with quote

If you take a look at
http://www.gentoo.org/cgi-bin/viewcvs.cgi/gentoo-src/portage/ChangeLog?rev=HEAD&
you can see that there are many changes in portage every day and as far as I remember portage 2.0.0 was released with a notice that it's release so early because there are so many problems with the old version (or whatever can't remember ;) ) so 2.0.0 was doomed, too...

I guess with 2.0.9 or 2.0.10 it's ok for all people again and shows how well it is :)
Back to top
View user's profile Send private message
delta407
Bodhisattva
Bodhisattva


Joined: 23 Apr 2002
Posts: 2876
Location: Chicago, IL

PostPosted: Mon Jul 01, 2002 10:31 pm    Post subject: Reply with quote

I just installed Gentoo about four hours ago onto a friend's computer and Portage 2.0.8 works fully with no errors. (Including emerge -ep world, etc.)
Back to top
View user's profile Send private message
BradB
Apprentice
Apprentice


Joined: 18 Jun 2002
Posts: 190
Location: Christchurch NZ

PostPosted: Tue Jul 02, 2002 12:27 am    Post subject: Reply with quote

Portage 2.0.8 is broken for me with errors as Dolio has. Delta - do you know why it would work fine on a fresh install?

Cheers
Brad
Back to top
View user's profile Send private message
delta407
Bodhisattva
Bodhisattva


Joined: 23 Apr 2002
Posts: 2876
Location: Chicago, IL

PostPosted: Tue Jul 02, 2002 2:17 am    Post subject: Reply with quote

Maybe the Portage database upgrade fudged some stuff... I'm not sure, because it installed with Portage 1.9.something but I upgraded to Portage 2.0.8 shortly thereafter, so I really have no idea. It was the 1.2 stage 3 tarball with a handful of packages were installed (syslog-alike, cron-alike, etc.), so...

Yeah, I have no idea. But Portage 2.0.8 isn't completely broken, just mostly.
Back to top
View user's profile Send private message
Pigeon
Guru
Guru


Joined: 21 Jun 2002
Posts: 307

PostPosted: Tue Jul 02, 2002 6:34 am    Post subject: Reply with quote

Yeah 2.0.8 is broke too :cry:

It can install some packages, but runs into python errors on about half of everything else... just happened to b0rk itself on the nvidia drivers right after updating my kernel heh...

It *did* however work well enough to install 2.0.9, haven't had any problems with it. (yet)

is there a limit to the number of packages you can have installed with 2.0.8 etc?
Back to top
View user's profile Send private message
jay
l33t
l33t


Joined: 08 May 2002
Posts: 980

PostPosted: Tue Jul 02, 2002 7:45 am    Post subject: Reply with quote

Take care. 2.0.8 is also broken in that way, that when you try to unmerge older prortage versions you'll end up with a non-functional 2.0.8.
_________________
Do you want your posessions identified? [ynq] (n)
Back to top
View user's profile Send private message
AutoBot
l33t
l33t


Joined: 22 Apr 2002
Posts: 968
Location: Usually Out

PostPosted: Tue Jul 02, 2002 7:59 am    Post subject: Reply with quote

I emerged from 2.0.4 to 2.0.8 to see if it was fixed but it wasn't so I unmerged 2.0.8 only to find that somehow my 2.0.4 and 2.0.8 were both unprotected, can you guess what happened?
_________________
This message self destructed a long time ago.
Back to top
View user's profile Send private message
jay
l33t
l33t


Joined: 08 May 2002
Posts: 980

PostPosted: Tue Jul 02, 2002 8:11 am    Post subject: Reply with quote

Autobot: Guess why I was posting the warning above? :cry:
_________________
Do you want your posessions identified? [ynq] (n)
Back to top
View user's profile Send private message
CoronaLover
Retired Dev
Retired Dev


Joined: 20 Jun 2002
Posts: 163
Location: Rosh-ha'ayin, Israel

PostPosted: Tue Jul 02, 2002 10:26 am    Post subject: Reply with quote

so guys what about portage 2.0.9? any luck?
Back to top
View user's profile Send private message
ElCondor
Guru
Guru


Joined: 10 Apr 2002
Posts: 520
Location: Vienna, Austria, Europe

PostPosted: Tue Jul 02, 2002 11:07 am    Post subject: Reply with quote

I switched from 2.0.4 to 2.0.9 today. I just did an emerge -bu world and a emerge -c world afterwards ..
everything works, portage 2.0.9 is installed now and an emerge -pu world shows nothing - as expected ;) but also no more errors. Seems everything is the way it used to be before 2.0.5 :D

* ElCondor pasa *
_________________
Here I am the victim of my own choices and I'm just starting!


Last edited by ElCondor on Tue Jul 02, 2002 2:15 pm; edited 1 time in total
Back to top
View user's profile Send private message
jouzts
n00b
n00b


Joined: 29 Apr 2002
Posts: 68
Location: South Carolina

PostPosted: Tue Jul 02, 2002 2:06 pm    Post subject: more emerge problems with portage 2.0.8, fixed with 2.0.9 Reply with quote

July 1st I did an rsync and updated portage among other things. I landed
on portage 2.0.8 and began to get the follow error, for practically every emerge command option I tried.

bash-2.05a# emerge -u world -p
Calculating dependencies \Traceback (most recent call last):
File "/usr/bin/emerge", line 1259, in ?
if not mydepgraph.create(mytype+" "+portage.root+" "+mykey,None,"--onlydeps" not in myopts):
File "/usr/bin/emerge", line 410, in create edepend=portage.db[myroot]["porttree"].dbapi.aux_get(mykey,portage.auxdbkeys)
File "/usr/lib/python2.2/site-packages/portage.py", line 2565, in aux_get
self.auxcache[mycpv][auxdbkeys[x]]=mylines[x][:-1]
IndexError: list index out of range

On July 2, I rsynced again to find that portage 2.0.9 was available. Following various suggestions on this list I tried a variety of emerge comands, most of which still led to the error message above. emerge xscreensaver did work, however. So I tried emerge -u portage -p, which mercifully worked, showing a Python dependency also. emerge -u portage then worked and I have had no further trouble with emerge commands since.

Thanks for all the invaluable suggestions. You guys make Gentoo the painless way to be on the bleeding edge.

John
Back to top
View user's profile Send private message
metalhedd
l33t
l33t


Joined: 30 May 2002
Posts: 692
Location: Ontario Canada

PostPosted: Fri Jul 05, 2002 5:27 pm    Post subject: Reply with quote

So, Just to confirm... is 2.0.9 safe?! I'ev been watching this thread for a while waiting to hear reports that it is now stable.
Back to top
View user's profile Send private message
jay
l33t
l33t


Joined: 08 May 2002
Posts: 980

PostPosted: Fri Jul 05, 2002 5:33 pm    Post subject: Reply with quote

I'm using it for almost 4 days. No problems so far.
_________________
Do you want your posessions identified? [ynq] (n)
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 18158

PostPosted: Sat Jul 06, 2002 7:02 pm    Post subject: Reply with quote

Anyone else having luck with portage-2.0.9? I'm still on 2.0.3 because of all the issues.
Versions 2.0.5, .8 and .9 are the only ones left on my system, so I've been avoiding an
upgrade.

As a side note, the Portage ChangeLog is now showing 2.0.10, but isn't appearing after
an rsync.
_________________
Those who know what's best for us must rise and save us from ourselves.
Back to top
View user's profile Send private message
metalhedd
l33t
l33t


Joined: 30 May 2002
Posts: 692
Location: Ontario Canada

PostPosted: Sat Jul 06, 2002 7:08 pm    Post subject: Reply with quote

I just emerged 2.0.9 this morning, works fine so far. All I merged after that was kvirc though.
Back to top
View user's profile Send private message
delta407
Bodhisattva
Bodhisattva


Joined: 23 Apr 2002
Posts: 2876
Location: Chicago, IL

PostPosted: Sat Jul 06, 2002 8:23 pm    Post subject: Reply with quote

Ditto. 2.0.9 is good.
_________________
I don't believe in witty sigs.
Back to top
View user's profile Send private message
Scandium
Retired Dev
Retired Dev


Joined: 22 Apr 2002
Posts: 340
Location: Germany

PostPosted: Sat Jul 06, 2002 9:10 pm    Post subject: Reply with quote

so is 2.0.10 :)
Back to top
View user's profile Send private message
AutoBot
l33t
l33t


Joined: 22 Apr 2002
Posts: 968
Location: Usually Out

PostPosted: Sun Jul 07, 2002 1:03 am    Post subject: Reply with quote

I noticed something on a gentoo install, I mistakenly had an extra ' on one line in my make.conf and emerge crapped out just like if portage was broken.

.: Just a little FYI
_________________
This message self destructed a long time ago.
Back to top
View user's profile Send private message
Scandium
Retired Dev
Retired Dev


Joined: 22 Apr 2002
Posts: 340
Location: Germany

PostPosted: Sun Jul 07, 2002 10:45 am    Post subject: Reply with quote

btw: 2.0.11 is ok here, too :)
Back to top
View user's profile Send private message
klieber
Bodhisattva
Bodhisattva


Joined: 17 Apr 2002
Posts: 3657
Location: San Francisco, CA

PostPosted: Mon Jul 08, 2002 5:09 pm    Post subject: Reply with quote

2.0.11 seems to have quieted down this thread, so I'm unsticking it.

--kurt
_________________
The problem with political jokes is that they get elected
Back to top
View user's profile Send private message
piraxter
n00b
n00b


Joined: 14 Jul 2002
Posts: 13
Location: Huajuapan de León, Oaxaca, México

PostPosted: Sun Jul 14, 2002 6:47 pm    Post subject: Sorry but i dont want a Portage as RPM.. Reply with quote

Opinion about Portage Dev.
Yes, ok. Portage 2.x its better than Portage 1.x but i dont like the RPM philosophy, bugs and failed installs, because the RPM tools always its diffent in a new release of RedHat or Mandrake :( And it works always equal.

Regards..
My 5 cents :D
_________________
Piraxter... Aka EliudHR
Because GNU/Linux is yours, although you do not buy it !!! - Porque GNU/Linux es tuyo, aunque no lo compres !!!
--
Being Gentoo.
piraxter at yahoo dot com, piraxter at linuxmail dot com
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Goto page Previous  1, 2, 3, 4, 5  Next
Page 4 of 5

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum