Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
ivman debug
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
classic2005
n00b
n00b


Joined: 11 Aug 2005
Posts: 26

PostPosted: Sun Sep 10, 2006 10:50 pm    Post subject: ivman debug Reply with quote

Old Today, 04:08 AM #1
classic
Newbie

Registered: Dec 2004
Posts: 23
Distribution:

ivman debug
hi,

i have ivman and it works ok but i see a debug message and i dont know what it is for and how i can disable it:


manager.c:1357 (do_startup_configure) Directory /etc/ivman/ will be used for configuration files.
9665: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 243.
This is normally a bug in some application using the D-BUS library.
9665: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 243.
This is normally a bug in some application using the D-BUS library.
9665: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 243.
This is normally a bug in some application using the D-BUS library.
9665: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 243.
This is normally a bug in some application using the D-BUS library.
9665: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 243.
This is normally a bug in some application using the D-BUS library.
libhal.c 373 : No property volume.mount_point on device with id
Back to top
View user's profile Send private message
dalek
Veteran
Veteran


Joined: 19 Sep 2003
Posts: 1336
Location: Mississippi USA

PostPosted: Fri Sep 22, 2006 1:10 am    Post subject: Reply with quote

Me gets same error after upgrading to ivman-0.6.12. Here is my emerge info:

Code:
root@smoker / # emerge --info
Portage 2.1.1 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.4-r3, 2.6.17-gentoo-r7 i686)
=================================================================
System uname: 2.6.17-gentoo-r7 i686 AMD Athlon(tm) XP 2500+
Gentoo Base System version 1.12.5
Last Sync: Fri, 22 Sep 2006 00:30:01 +0000
ccache version 2.3 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.2.11-r1
dev-lang/python:     2.3.4-r1, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O2 -momit-leaf-frame-pointer -fno-ident -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=athlon-xp -O2 -momit-leaf-frame-pointer -fno-ident -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig buildpkg ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="<<< SNIP OUT ONE LONG LIST >>> "
LDFLAGS="-Wl,-z,now"
LINGUAS="en"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow X acl acpi alsa amd arts artswrappersuid automount berkdb bitmap-fonts browserplugin bzip2 cairo cdr chroot cli crypt cups dbus dlloader doc dri dvd dvdr eds elibc_glibc emboss encode esd exif fam fdftk fortran gaim gcj gdbm gif gimp gimpprint gkrellm gphoto2 gpm gstreamer gtk hal hbci input_devices_keyboard input_devices_mouse ipv6 isdnlog java javascript jbig jpeg jpeg2k justify kde kernel_linux ldap libg++ linguas_en mad mikmod mmx mp3 mpeg ncurses nls nptl nptlonly nsplugin offensive ofx ogg opengl pam pcre perl png postgres ppds pppd python qt3 qt4 quicktime readline reflection samba scanner sdl seamonkey session spell spl sqlite sse ssl syslog tcltk tcpd tiff tk truetype truetype-fonts type1-fonts udev unicode usb userland_GNU video_cards_nvidia vorbis win32codecs wmf xml xmms xorg xprint xv yahoo zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

root@smoker / #


Anybody know of a fix or should we go back a version?? I see there are not many versions available here.

Code:
root@smoker / # equery list -p ivman
[ Searching for package 'ivman' in all categories among: ]
 * installed packages
[I--] [  ] sys-apps/ivman-0.6.12 (0)
 * Portage tree (/usr/portage)
[-P-] [  ] sys-apps/ivman-0.6.11 (0)
root@smoker / #


Thanks

:D :D :D :D
_________________
My rig: Gigabyte GA-770T-USB3 mobo AMD Phenom II X4 955 3.2GHz ZALMAN CNPS10X Performa CPU cooler
G.SKILL 16GB DDR3 PC3 12800 Memory Nvidia GT-220 video card LG W2253 Monitor
WD1600AAJS & WD2502ABYS hard drives
Cooler Master HAF-932 Case
Back to top
View user's profile Send private message
syntaxerrormmm
Guru
Guru


Joined: 17 Apr 2005
Posts: 449
Location: Romano di Lombardia - BG - ITALY

PostPosted: Sun Sep 24, 2006 5:27 pm    Post subject: Reply with quote

I have the same problem too. Some info:
Code:
# emerge -pv udev dbus hal ivman

These are the packages that would be merged, in order:

Calculating dependencies ... done!
[ebuild   R   ] sys-fs/udev-100-r2  USE="(-selinux)" 192 kB
[ebuild   R   ] sys-apps/dbus-0.62-r1  USE="X gtk python qt3 qt4 -debug -doc -mono (-selinux)" 1,696 kB
[ebuild   R   ] sys-apps/hal-0.5.7.1-r1  USE="acpi crypt pcmcia -debug -dmi -doc (-selinux)" 0 kB
[ebuild   R   ] sys-apps/ivman-0.6.12  USE="-debug" 304 kB

Total size of downloads: 2,194 kB

# emerge --info
Gentoo Base System version 1.12.5
Portage 2.1.2_pre1-r1 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.4-r3, 2.6.18-suspend2 i686)
=================================================================
System uname: 2.6.18-suspend2 i686 Mobile AMD Athlon(tm) XP 2600+
Last Sync: Sun, 24 Sep 2006 11:20:02 +0000
ccache version 2.4 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.3-r1, 2.0.30
dev-lang/python:     2.4.3-r3
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=athlon-xp -O3 -pipe -fomit-frame-pointer -funroll-loops"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=athlon-xp -O3 -pipe -fomit-frame-pointer -funroll-loops"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo ftp://mirror.switch.ch/mirror/gentoo/ ftp://ftp.solnet.ch/mirror/Gentoo ftp://pandemonium.tiscali.de/pub/gentoo/ ftp://ftp.unina.it/pub/linux/distributions/gentoo"
LANG="it_IT"
LC_ALL="it_IT.utf8"
LINGUAS="it en"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 3dnow 7zip X aac aalib acpi aim alsa apache2 audiofile berkdb bitmap-fonts bzip2 caps cdparanoia cdr cli crypt cups dba dbase dbus dga dio dlloader dri dts dvb dvd dvdr dvdread elibc_glibc emboss encode esd fam fbcon ffmpeg fftw firefox flac flatfile fortran ftp gcj gdbm geoip gif gnutls gpm gps gstreamer gtk hal iconv icq ieee1394 imagemagick imap imlib input_devices_keyboard input_devices_mouse input_devices_synaptics isdnlog jabber jack javascript jpeg jpeg2k kernel_linux lcms lesstif libcaca libg++ libgda linguas_en linguas_it mad matroska mbox md5sum mhash mikmod mime mmap mmx mng motif mp3 mpeg msn nas ncurses nis nls nptl nptlonly nsplugin odbc offensive ogg opengl oscar oss pam pcmcia pcre pdf perl php pic png posix postgres ppds pppd python qt3 qt4 quicktime readline reflection samba sdl session sharedmem sndfile soap sockets sox spell spl sse ssl svg sysvipc szip tcltk tcpd tetex theora threads tiff timidity truetype truetype-fonts type1-fonts udev unicode usb userland_GNU v4l vcd video_cards_fbdev video_cards_v4l video_cards_vesa video_cards_via vorbis win32codecs wmf wxwindows xinerama xml xml2 xmlrpc xorg xosd xpm xprint xsl xv xvid yahoo zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, MAKEOPTS,PORTAGE_RSYNC_EXTRA_OPTS


I'm thinking on opening a bugreport.

Thanks.
_________________
"Every rule can be broken, but no rule may be ignored."

Last.fm - Gentoo 2006.1 on:
Acer Aspire 1355LC - suspend2-sources-2.6.18-r3
IBM Thinkpad T30 - suspend2-sources-2.6.19-r3
Back to top
View user's profile Send private message
Scullder
Guru
Guru


Joined: 16 Mar 2006
Posts: 466
Location: France

PostPosted: Sun Sep 24, 2006 5:38 pm    Post subject: Reply with quote

Same problem. I've tried to downgrade to ivman 0.6.11, and then re-emerged udev dbus hal but the problem stay.

Code:

# emerge udev dbus hal ivman -pv

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] sys-fs/udev-100-r2  USE="(-selinux)" 0 kB
[ebuild   R   ] sys-apps/dbus-0.62-r1  USE="X python qt3 qt4 -debug -doc -gtk -mono (-selinux)" 0 kB
[ebuild   R   ] sys-apps/hal-0.5.7.1-r1  USE="crypt -acpi -debug -dmi -doc -pcmcia (-selinux)" 0 kB
[ebuild   R   ] sys-apps/ivman-0.6.11  USE="-debug" 0 kB


Code:

# /etc/init.d/hald restart
 * Service hald stopping
 * Service ivman stopping
 * Service ivman stopped
 * Service hald stopped
 * Service hald starting
 * Service hald started
 * Service ivman starting
15691: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 243.
This is normally a bug in some application using the D-BUS library.
15691: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 243.
This is normally a bug in some application using the D-BUS library.
15691: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 243.
This is normally a bug in some application using the D-BUS library.
15691: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 243.
This is normally a bug in some application using the D-BUS library.
15691: arguments to dbus_move_error() were incorrect, assertion "(dest) == NULL || !dbus_error_is_set ((dest))" failed in file dbus-errors.c line 243.
This is normally a bug in some application using the D-BUS library.
libhal.c 373 : No property  volume.mount_point  on device with id /org/freedesktop/Hal/devices/volume_uuid_211c1dda_5924_404b_823e_80db55f2ff43
 * Service ivman started

_________________
Linux gentoo 2.6.18-ck1-r2 #1 PREEMPT Fri Nov 17 01:37:56 CET 2006 x86_64 AMD Athlon(tm) 64 Processor 3000+ AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
SteelRage
Apprentice
Apprentice


Joined: 17 Nov 2003
Posts: 192

PostPosted: Mon Sep 25, 2006 4:23 pm    Post subject: Reply with quote

Same problem here.
I read in another forum thread that ivman is not needed with newest kde versions.
I'm using kde... Could the problem depend on that?
Do we have to uninstall ivman?

Are you kde users too?
_________________
In the end we only see to change light to dark dark to light light to dark dark to light.
Back to top
View user's profile Send private message
dalek
Veteran
Veteran


Joined: 19 Sep 2003
Posts: 1336
Location: Mississippi USA

PostPosted: Mon Sep 25, 2006 4:49 pm    Post subject: Reply with quote

I use KDE. I read that somewhere too.

:D :D :D :D :D
_________________
My rig: Gigabyte GA-770T-USB3 mobo AMD Phenom II X4 955 3.2GHz ZALMAN CNPS10X Performa CPU cooler
G.SKILL 16GB DDR3 PC3 12800 Memory Nvidia GT-220 video card LG W2253 Monitor
WD1600AAJS & WD2502ABYS hard drives
Cooler Master HAF-932 Case
Back to top
View user's profile Send private message
Scullder
Guru
Guru


Joined: 16 Mar 2006
Posts: 466
Location: France

PostPosted: Mon Sep 25, 2006 5:28 pm    Post subject: Reply with quote

Downgrading to dbus-0.62 solve my problem.

SteelRage wrote:
Are you kde users too?


Yes :)

dalek wrote:
I use KDE. I read that somewhere too.

:D :D :D :D :D


I can't find where so I keep ivman ^^
_________________
Linux gentoo 2.6.18-ck1-r2 #1 PREEMPT Fri Nov 17 01:37:56 CET 2006 x86_64 AMD Athlon(tm) 64 Processor 3000+ AuthenticAMD GNU/Linux
Back to top
View user's profile Send private message
syntaxerrormmm
Guru
Guru


Joined: 17 Apr 2005
Posts: 449
Location: Romano di Lombardia - BG - ITALY

PostPosted: Mon Sep 25, 2006 5:37 pm    Post subject: Reply with quote

Scullder wrote:
Downgrading to dbus-0.62 solve my problem.
Thanks for the tip, I will try it too.

[Edit]
Downgrading to dbus-0.62 worked for me.
[/Edit]

SteelRage wrote:
Are you kde users too?
No, I'm not.

Scullder wrote:
dalek wrote:
I use KDE. I read that somewhere too.

:D :D :D :D :D


I can't find where so I keep ivman ^^
In Bug 142004 they say automounting is supported by KDE without ivman, but with ivman mounting method varies.

Thanks again.
_________________
"Every rule can be broken, but no rule may be ignored."

Last.fm - Gentoo 2006.1 on:
Acer Aspire 1355LC - suspend2-sources-2.6.18-r3
IBM Thinkpad T30 - suspend2-sources-2.6.19-r3
Back to top
View user's profile Send private message
syntaxerrormmm
Guru
Guru


Joined: 17 Apr 2005
Posts: 449
Location: Romano di Lombardia - BG - ITALY

PostPosted: Tue Sep 26, 2006 1:22 pm    Post subject: Reply with quote

News. A bugreport was opened, please see Bug 149112.

Viewing dbus changelog, seems that from dbus-0.62 to dbus-0.62-r1 the developers switched from libxml2 to expat, maybe can be something related.

Cheers.
_________________
"Every rule can be broken, but no rule may be ignored."

Last.fm - Gentoo 2006.1 on:
Acer Aspire 1355LC - suspend2-sources-2.6.18-r3
IBM Thinkpad T30 - suspend2-sources-2.6.19-r3
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum