Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Problem with gtk+-2.8.19
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
fiore
n00b
n00b


Joined: 08 Aug 2006
Posts: 34

PostPosted: Sat Sep 02, 2006 6:27 pm    Post subject: Problem with gtk+-2.8.19 Reply with quote

Sorry for my first post, I've wrote a wrong argument......


I'm trying to install KDE on my system.

I typed the command: emerge kde.

At the start all goes right, but when the system starts to compile the pakage: x11-libs/gtk+-2-8.19 the installation crashes.
When the installation crashes print the follow error message: CAIRO NEEDS THE X FLAG SET.

What is the X Flag? How Can I set it? How can I install KDE?

Thanks for help!!!!!!!!
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Sat Sep 02, 2006 9:55 pm    Post subject: Reply with quote

Add X to your USE flags in /etc/make.conf. Then run `emerge --oneshot cairo`. You should now be able to continue your installation of KDE.
_________________
www.gentoo.org.au || #gentoo-au
Back to top
View user's profile Send private message
DcMaStEr
n00b
n00b


Joined: 19 Aug 2006
Posts: 4

PostPosted: Sat Sep 16, 2006 1:01 pm    Post subject: USE flags? Reply with quote

I've installed gentoo and everything went well I've got a runing x server, and I'm very happy with gentoo... Now there are still some small problems which I need to solve:
If I want to install gpsdrive (gpsd is already installed) I open a terminal an type in:
emerge gpsdrive
it calculates depencies and sees that I need x11-libs/gtk+-2.8.19 so it wants to emerge also that lib but it fails it says:

* Please re-emerge x11-libs/cairo with the X USE flag set

!!! ERROR: x11-libs/gtk+-2.8.19 failed.
Call stack:
ebuild.sh, line 1555: Called dyn_setup
ebuild.sh, line 668: Called pkg_setup
gtk+-2.8.19.ebuild, line 57: Called die

!!! cairo needs the X flag set

Now I have no idea how I can set my USE flag X for cairo...What do I have to do? Change make.conf? And what do I have to write in the make.conf? Please help me!
Back to top
View user's profile Send private message
gidoca
n00b
n00b


Joined: 27 May 2006
Posts: 9
Location: Thun

PostPosted: Sat Sep 16, 2006 1:07 pm    Post subject: Reply with quote

I suggest you to read http://www.gentoo.org/doc/en/handbook/handbook-x86.xml?part=2&chap=2 .
Back to top
View user's profile Send private message
wiz
Tux's lil' helper
Tux's lil' helper


Joined: 15 Sep 2005
Posts: 121
Location: {€urope}

PostPosted: Sat Sep 16, 2006 1:14 pm    Post subject: Reply with quote

type
Code:
emerge -pv cairo

p stands for --pretend (not actually emerging)
v stands for --verbose (to show required USE flags)

so you can either type
Code:
USE="X" emerge -pv cairo"

or in make.conf have USE="X" flag set

when you are going to emerge simply remove the pv
Back to top
View user's profile Send private message
nixnut
Administrator
Administrator


Joined: 09 Apr 2004
Posts: 10973
Location: the dutch mountains

PostPosted: Sat Sep 16, 2006 2:10 pm    Post subject: Reply with quote

merged above three posts here.
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
dave87
Tux's lil' helper
Tux's lil' helper


Joined: 15 Jun 2006
Posts: 106
Location: Germany

PostPosted: Sat Sep 16, 2006 4:54 pm    Post subject: Reply with quote

wiz wrote:

so you can either type
Code:
USE="X" emerge -pv cairo"

or in make.conf have USE="X" flag set

I think, if you don't want the USE-Flag X in your make.conf, but want it for cairo you should do this:
Code:
echo "x11-libs/cairo X" >> /etc/portage/package.use
, because if you merge with USE="X" emerge cairo portage doesn't afaik remeber the X Use-Flag, so after an Upgrade of cairo, or an emerge -uDN you have cairo again without the X Use-Flag
_________________
Error 404 - signature.html not found
Back to top
View user's profile Send private message
desultory
Administrator
Administrator


Joined: 04 Nov 2005
Posts: 7820

PostPosted: Mon May 21, 2007 7:02 am    Post subject: Reply with quote

Moved from Desktop Environments to Duplicate Threads, refer to topic "Please re-emerge [solved]".

As noted in the handbook USE flags specified via environment variables are not retained as persistent settings so, aside from when a given USE flag setting is itself transient in nature, use one of the persistent USE flag setting methods (/etc/make.conf, /etc/portage/package.use). Also, note that USE flags are case sensitive.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum