Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Linux RAID hanging?
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
mverrilli
n00b
n00b


Joined: 04 Jul 2002
Posts: 40
Location: Atlanta, GA

PostPosted: Wed Jul 03, 2002 6:02 pm    Post subject: Linux RAID hanging? Reply with quote

I'm posting from work, so I might not have all the details...

The setup:

Brand new 1.2 gentoo installation using the stage3 tarball.

Code:
Dual P3 450mhz
onboard ide:
  /dev/hda1 swap
  /dev/hda2 /boot ext2
fastrak/66 card:
  /dev/md0 / xfs raid0
    /dev/hde1 linux autoraid
    /dev/hdg1 linux autoraid


I am not using the fastrak raid, I have no disks set up in an fastrak array, I am using linux's built in software raid.

Everything boots up fine, everything runs fine under normal load. (Although I haven't added X yet...) Gentoo rocks. :D

The problem:

When I compile for long periods of time... eventually the compile freezes. It doesn't matter what I compile, just that it is usually a large compile. Any programs that are already running, like telnet, top, etc work fine. Anything that requires going to disk hangs.

How do I fix this? What can I do to get the information I need to track down the issue? Is there a known problem doing this?
Back to top
View user's profile Send private message
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1141
Location: Williamsburg Virginia

PostPosted: Wed Jul 03, 2002 7:03 pm    Post subject: Reply with quote

i think if it were my system i would redo the install...this time from stage1...and then choose the vanilla kernel...and you might as well forget xfs unless there is a very specific feature that you need that it offers that ext3 doesnt....i got terrible through put using xfs and lsr on an smp system...run hdparm -t /dev/md0 adn see what it gives you....i am not saying these things will solve you problem but i think the stage1 and vanilla kernel might help
Back to top
View user's profile Send private message
mverrilli
n00b
n00b


Joined: 04 Jul 2002
Posts: 40
Location: Atlanta, GA

PostPosted: Wed Jul 03, 2002 11:00 pm    Post subject: Reply with quote

Well, I haven't taken that advice just yet... but I might if this didn't fix it.
In the linux config, I had support for my promise card compiled in, but I didn't have the Special UDMA feature and Special Fastrak feature compiled in. I don't know exactly what these are, but I enabled them.
Started my long emerge kde, and it has been running for 3 hours almost... so the problem might be licked.
Back to top
View user's profile Send private message
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1141
Location: Williamsburg Virginia

PostPosted: Thu Jul 04, 2002 1:50 am    Post subject: Reply with quote

oh yeah absolutely enable those options...i ahd a fast track tx2 and enabled all that and had lsr 0 screaming...did you do the hdparm -t /dev/md0 before and after (you should ahve just to see the difference)
Back to top
View user's profile Send private message
mverrilli
n00b
n00b


Joined: 04 Jul 2002
Posts: 40
Location: Atlanta, GA

PostPosted: Thu Jul 04, 2002 2:04 am    Post subject: Reply with quote

I didn't do it before... although I still have the old kernel, I could do it just to test it out. :) It's still compiling, so I'll do it when it's done (tomorrow? hehe).

While compiling I get 34Mb/sec. I've done zero tweaks, though.

So... compiling many hours now without a freeze, I'm guessing those options fixed me. I'll post my before and after rates later.
Back to top
View user's profile Send private message
rommel
Veteran
Veteran


Joined: 19 Apr 2002
Posts: 1141
Location: Williamsburg Virginia

PostPosted: Thu Jul 04, 2002 2:09 am    Post subject: Reply with quote

cool....it will be interesting to see the difference anyway..but hopefully you will run smoothly now.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum