Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
~x86 for only several packages
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Duplicate Threads
View previous topic :: View next topic  
Author Message
eis
Apprentice
Apprentice


Joined: 05 Aug 2005
Posts: 161
Location: Stuttgart, Germany

PostPosted: Wed Aug 09, 2006 9:55 am    Post subject: ~x86 for only several packages Reply with quote

Hi there!

I have a little problem with portage. I usually do NOT use the ~x86 keyword. But for mz ati-drivers I need it because otherwise I will have such an old version... And without ~x86 I got a module- or kernel-error during compiling.

Now when I want to update some packages of my "world" they think they are missing ati-drivers... see the output.
Is there anzthing I can do, in order to solve this unbeautiful error?

thx, eis


---
inglese gentoo # emerge -upv world

These are the packages that would be merged, in order:

Calculating world dependencies \
!!! All ebuilds that could satisfy "x11-drivers/ati-drivers" have been masked.
!!! One of the following masked packages is required to complete your request:
- x11-drivers/ati-drivers-8.21.7 (masked by: package.mask, ~x86 keyword)
# habe alle versionen gemasked um die uni software zu behalten...

- x11-drivers/ati-drivers-8.21.7-r1 (masked by: package.mask)
- x11-drivers/ati-drivers-8.22.5 (masked by: package.mask, ~x86 keyword)
- x11-drivers/ati-drivers-8.20.8 (masked by: package.mask, ~x86 keyword)
- x11-drivers/ati-drivers-8.26.18-r1 (masked by: ~x86 keyword)
- x11-drivers/ati-drivers-8.19.10 (masked by: package.mask, ~x86 keyword)
- x11-drivers/ati-drivers-8.27.10 (masked by: ~x86 keyword)
- x11-drivers/ati-drivers-8.26.18 (masked by: ~x86 keyword)
- x11-drivers/ati-drivers-8.16.20 (masked by: package.mask, missing keyword)
- x11-drivers/ati-drivers-8.25.18 (masked by: package.mask, ~x86 keyword)
- x11-drivers/ati-drivers-8.18.6-r1 (masked by: package.mask, ~x86 keyword)
- x11-drivers/ati-drivers-8.24.8 (masked by: package.mask, ~x86 keyword)
- x11-drivers/ati-drivers-8.27.10-r1 (masked by: ~x86 keyword)
- x11-drivers/ati-drivers-8.23.7 (masked by: package.mask, ~x86 keyword)
- x11-drivers/ati-drivers-8.14.13-r4 (masked by: package.mask, ~x86 keyword)
- x11-drivers/ati-drivers-8.14.13-r5 (masked by: package.mask, ~x86 keyword)
- x11-drivers/ati-drivers-8.14.13-r2 (masked by: package.mask)
- x11-drivers/ati-drivers-8.14.13-r3 (masked by: package.mask)
- x11-drivers/ati-drivers-8.16.20-r1 (masked by: package.mask, missing keyword)
- x11-drivers/ati-drivers-8.18.6 (masked by: package.mask, ~x86 keyword)
- x11-drivers/ati-drivers-8.18.8 (masked by: package.mask, ~x86 keyword)
- x11-drivers/ati-drivers-8.18.8-r2 (masked by: package.mask, missing keyword)
- x11-drivers/ati-drivers-8.18.8-r1 (masked by: package.mask, ~x86 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "x11-libs/qt-4.1.4" [ebuild])



!!! Problem resolving dependencies for x11-libs/qt
!!! Depgraph creation failed.
inglese gentoo # emerge --search ati-driver
Searching...
[ Results for search key : ati-driver ]
[ Applications found : 2 ]

* x11-apps/ati-drivers-extra [ Masked ]
Latest version available: 8.27.10
Latest version installed: [ Not Installed ]
Size of files: 56,272 kB
Homepage: http://www.ati.com
Description: Ati precompiled drivers extra application
License: ATI GPL-2 QPL-1.0

* x11-drivers/ati-drivers [ Masked ]
Latest version available: 8.27.10-r1
Latest version installed: 8.26.18-r1
Size of files: 56,272 kB
Homepage: http://www.ati.com
Description: Ati precompiled drivers for r350, r300, r250 and r200 chipsets
License: ATI


inglese gentoo #
---
Back to top
View user's profile Send private message
wynn
Advocate
Advocate


Joined: 01 Apr 2005
Posts: 2416
Location: UK

PostPosted: Wed Aug 09, 2006 10:01 am    Post subject: Reply with quote

I think you just want to add
Code:
x11-drivers/ati-drivers
to /usr/portage/package.keywords. You can do it with an editor (e.g. nano) or
Code:
echo x11-drivers/ati-drivers >> /etc/portage/package.keywords
be careful to use '>>' or you will lose the contents of package.keywords.

You can do the same for x11-apps/ati-drivers-extra
_________________
The avatar is jorma, a "duck" from "Elephants Dream": the film and all the production materials have been made available under a Creative Commons Attribution 2.5 License, see orange.blender.org for details.
Back to top
View user's profile Send private message
mark_alec
Bodhisattva
Bodhisattva


Joined: 11 Sep 2004
Posts: 6066
Location: Melbourne, Australia

PostPosted: Wed Aug 09, 2006 10:22 am    Post subject: Reply with quote

Moved from Portage & Programming to Duplicate Threads.

See GF5: What are masked packages?
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Duplicate Threads All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum