Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
emerging kde (2006.0)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Desktop Environments
View previous topic :: View next topic  
Author Message
Ph0eniX
Guru
Guru


Joined: 24 Sep 2004
Posts: 495
Location: New York, U.S.

PostPosted: Sat Jul 15, 2006 5:41 pm    Post subject: emerging kde (2006.0) Reply with quote

I'm trying to emerge kde 3.5.2-r1 and i'm getting an error during sdl-config run saying that SDL version 1.2.0 or higher was not found (while compiling kdeaddons). When I run "sdl-config --version", it comes back with version 1.2.8. How can I emerge the latest version of SDL? ...I tried "emerge --search SDL" but nothing relevant was found. What do I do? Should I compile the latest source from sdl.org manually?

Thanks!
Back to top
View user's profile Send private message
Philantrop
Retired Dev
Retired Dev


Joined: 21 Dec 2004
Posts: 1129
Location: Germany

PostPosted: Sat Jul 15, 2006 5:45 pm    Post subject: Reply with quote

Please paste the complete contents of config.log at http://pastebin.ca and post a link to it here.
_________________
If you feel the issues discussed in this thread have been resolved, please add a "[Solved]" to the subject of your original posting.
Back to top
View user's profile Send private message
Ph0eniX
Guru
Guru


Joined: 24 Sep 2004
Posts: 495
Location: New York, U.S.

PostPosted: Mon Jul 17, 2006 4:01 pm    Post subject: Reply with quote

Here you go:

http://pastebin.ca/90328

Thanks!


Philantrop wrote:
Please paste the complete contents of config.log at http://pastebin.ca and post a link to it here.
Back to top
View user's profile Send private message
Philantrop
Retired Dev
Retired Dev


Joined: 21 Dec 2004
Posts: 1129
Location: Germany

PostPosted: Mon Jul 17, 2006 5:07 pm    Post subject: Reply with quote

Thanks, but I forgot to ask for your "emerge --info", sorry. Please post that here, too.
_________________
If you feel the issues discussed in this thread have been resolved, please add a "[Solved]" to the subject of your original posting.
Back to top
View user's profile Send private message
Ph0eniX
Guru
Guru


Joined: 24 Sep 2004
Posts: 495
Location: New York, U.S.

PostPosted: Mon Jul 17, 2006 5:35 pm    Post subject: Reply with quote

Here it is:

Code:


Portage 2.1-r1 (default-linux/x86/2006.0, gcc-3.3.6, glibc-2.3.6-r4, 2.6.13-gentoo-r1 i686)
=================================================================
System uname: 2.6.13-gentoo-r1 i686 Pentium Pro
Gentoo Base System version 1.6.15
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.3.5-r2, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i386-pc-linux-gnu"
CFLAGS="-O2 -mcpu=i686"
CHOST="i386-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -mcpu=i686"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="ftp://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://distro.ibiblio.org/pub/linux/distributions/gentoo/ http://gentoo.chem.wisc.edu/gentoo/ ftp://gentoo.chem.wisc.edu/gentoo/ http://gentoo.mirrors.easynews.com/linux/gentoo/"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.us.gentoo.org/gentoo-portage"
USE="x86 X alsa apache2 apm arts avi berkdb bitmap-fonts cli crypt cups directfb dlloader dri eds emboss encode esd fbcon foomaticdb fortran gd2 gdbm gif gnome gpm gstreamer gtk gtk2 imlib ipv6 isdnlog jpeg kde libg++ libwww mad mikmod motif mp3 mpeg mysql ncurses nls nptl ogg opengl oss pam pcre pdflib perl png pppd python qt qt3 qt4 quicktime readline reflection sdl session spell spl ssl svga tcpd truetype truetype-fonts type1-fonts udev vorbis xml xmms xorg xv zlib elibc_glibc input_devices_keyboard input_devices_mouse input_devices_evdev kernel_linux userland_GNU"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

Back to top
View user's profile Send private message
Philantrop
Retired Dev
Retired Dev


Joined: 21 Dec 2004
Posts: 1129
Location: Germany

PostPosted: Mon Jul 17, 2006 5:49 pm    Post subject: Reply with quote

Ok, thanks.

Please try re-emerging dev-libs/DirectFB.
_________________
If you feel the issues discussed in this thread have been resolved, please add a "[Solved]" to the subject of your original posting.
Back to top
View user's profile Send private message
Ph0eniX
Guru
Guru


Joined: 24 Sep 2004
Posts: 495
Location: New York, U.S.

PostPosted: Tue Jul 18, 2006 4:00 pm    Post subject: Reply with quote

I re-emerged FBDirect and at the end it gave me the following notice:

Code:

 * Each DirectFB update in the 0.9.xx series
 * breaks DirectFB related applications.
 * Please run "revdep-rebuild" which can be
 * found by emerging the package 'gentoolkit'.
 *
 * If you have an ALPS touchpad, then you might
 * get your mouse unexpectedly set in absolute
 * mode in all DirectFB applications.
 * This can be fixed by removing linuxinput from
 * INPUT_DEVICES.


I ran revdep-rebuild as instructed and it's currently in the process of emerging 84 packages. I'll report back as soon as it's finished.

Thank you!
Back to top
View user's profile Send private message
Ph0eniX
Guru
Guru


Joined: 24 Sep 2004
Posts: 495
Location: New York, U.S.

PostPosted: Tue Jul 18, 2006 7:05 pm    Post subject: Reply with quote

For some reason it's emerging KDE 3.4.3 now. I really don't want that.
Back to top
View user's profile Send private message
Philantrop
Retired Dev
Retired Dev


Joined: 21 Dec 2004
Posts: 1129
Location: Germany

PostPosted: Tue Jul 18, 2006 7:18 pm    Post subject: Reply with quote

Your "emerge --info" looks like you have KDE 3.4.x installed already and revdep-rebuild noticed it's broken. Consequently, revdep-rebuild will now do exactly that - rebuild it.

Why don't you want it rebuilt?
_________________
If you feel the issues discussed in this thread have been resolved, please add a "[Solved]" to the subject of your original posting.
Back to top
View user's profile Send private message
Ph0eniX
Guru
Guru


Joined: 24 Sep 2004
Posts: 495
Location: New York, U.S.

PostPosted: Tue Jul 18, 2006 8:14 pm    Post subject: Reply with quote

Because I want to emerge 3.5.2. What if stopped it and told it to unmerge 3.4.3, then install 3.5.2.
Back to top
View user's profile Send private message
Philantrop
Retired Dev
Retired Dev


Joined: 21 Dec 2004
Posts: 1129
Location: Germany

PostPosted: Tue Jul 18, 2006 8:22 pm    Post subject: Reply with quote

That's a good reason. :-)

And, yes, your idea should work.
_________________
If you feel the issues discussed in this thread have been resolved, please add a "[Solved]" to the subject of your original posting.
Back to top
View user's profile Send private message
Ph0eniX
Guru
Guru


Joined: 24 Sep 2004
Posts: 495
Location: New York, U.S.

PostPosted: Wed Jul 19, 2006 1:05 pm    Post subject: Reply with quote

I decided to let it finish and upgrade KDE later but it came back with the following:

Code:

/usr/lib/gcc-lib/i386-pc-linux-gnu/3.3.6/../../../../i386-pc-linux-gnu/bin/ld: cannot find -lXxf86dga
collect2: ld returned 1 exit status
make[4]: *** [libmpeg.la] Error 1
make[4]: Leaving directory `/var/tmp/portage/kdemultimedia-3.4.3/work/kdemultimedia-3.4.3/mpeglib/lib'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/kdemultimedia-3.4.3/work/kdemultimedia-3.4.3/mpeglib/lib'
make[2]: *** [all-recursive] Error 1
make[2]: Leaving directory `/var/tmp/portage/kdemultimedia-3.4.3/work/kdemultimedia-3.4.3/mpeglib'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/kdemultimedia-3.4.3/work/kdemultimedia-3.4.3'
make: *** [all] Error 2

!!! ERROR: kde-base/kdemultimedia-3.4.3 failed.
Call stack:
  ebuild.sh, line 1539:   Called dyn_compile
  ebuild.sh, line 939:   Called src_compile
  kdemultimedia-3.4.3.ebuild, line 62:   Called kde_src_compile
  kde.eclass, line 164:   Called kde_src_compile 'all'
  kde.eclass, line 306:   Called kde_src_compile 'myconf' 'configure' 'make'
  kde.eclass, line 302:   Called die

!!! died running emake, kde_src_compile:make
!!! If you need support, post the topmost build error, and the call stack if relevant.


revdep-rebuild failed to emerge all packages
you have the following choices:

- if emerge failed during the build, fix the problems and re-run revdep-rebuild
    or
- use -X or --package-names as first argument (trys to rebuild package, not exact
  ebuild)
    or
- set ACCEPT_KEYWORDS="~<your platform>" and/or /etc/portage/package.unmask
  (and remove /root/.revdep-rebuild.5_order to be evaluated again)
    or
- modify the above emerge command and run it manually
    or
- compile or unmerge unsatisfied packages manually, remove temporary files and
  try again (you can edit package/ebuild list first)

To remove temporary files, please run:
rm /root/.revdep-rebuild*.?_*


What do I do? I guess I could try unmerging kde-3.4.3 altogether.
Back to top
View user's profile Send private message
Philantrop
Retired Dev
Retired Dev


Joined: 21 Dec 2004
Posts: 1129
Location: Germany

PostPosted: Wed Jul 19, 2006 2:15 pm    Post subject: Reply with quote

I'm currently not at home and can't try it myself but try the following:

Code:
emerge gentoolkit


Code:
equery b libXxf86dga.so


Then emerge the package equery outputs.
_________________
If you feel the issues discussed in this thread have been resolved, please add a "[Solved]" to the subject of your original posting.
Back to top
View user's profile Send private message
Ph0eniX
Guru
Guru


Joined: 24 Sep 2004
Posts: 495
Location: New York, U.S.

PostPosted: Wed Jul 19, 2006 2:54 pm    Post subject: Reply with quote

Philantrop wrote:
I'm currently not at home and can't try it myself but try the following:

Code:
emerge gentoolkit


Code:
equery b libXxf86dga.so


Then emerge the package equery outputs.


I didn't find libXxf86dga.so - I'm trying to emerge it now.
Back to top
View user's profile Send private message
Ph0eniX
Guru
Guru


Joined: 24 Sep 2004
Posts: 495
Location: New York, U.S.

PostPosted: Wed Jul 19, 2006 4:29 pm    Post subject: Reply with quote

libXxf86dga installed fine. I unmerged KDE 3.4.3 but it wants to reinstall it when I run revdep-rebuild. How do I tell it to forget 3.4.3?

Thanks!
Back to top
View user's profile Send private message
i92guboj
Moderator
Moderator


Joined: 30 Nov 2004
Posts: 9752
Location: Córdoba (Spain)

PostPosted: Wed Jul 19, 2006 4:58 pm    Post subject: Reply with quote

Ph0eniX wrote:
libXxf86dga installed fine. I unmerged KDE 3.4.3 but it wants to reinstall it when I run revdep-rebuild. How do I tell it to forget 3.4.3?

Thanks!


You dont. It portage is pushind it is because you need it. So, you dont need to instruct portage to forget about it, but to find which package needs kde-3.4, and surely, there will be more than one.

To do so, try emerge -puDvNt world and look at the output, it can be helpful.

You could also try to mask some kde-3.4 pack and the error message will tell you that pack A requires pack B that is masked.

Another reason could be that 3.5 is masked or ~arch. Then revdep-rebuild would emerge the needed packages to fix any missing deps. If 3.5 is masked in one way or another, then it will emerge 3.4 or whatever there is available.
_________________
Gentoo Handbook | My website
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Desktop Environments All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum