Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
coldplug is blocking udev
View unanswered posts
View posts from last 24 hours

Goto page Previous  1, 2  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
kamracik
Apprentice
Apprentice


Joined: 01 Apr 2006
Posts: 219
Location: Poland->Lodz

PostPosted: Tue Apr 04, 2006 11:00 pm    Post subject: Reply with quote

Okey i dont have problem with boot but with that udev dont start everything that it should :/ i mean i dont have speaker on my hp nx6110 :/ it quite annoying cant heard when something happend in ither window :/
Back to top
View user's profile Send private message
pmn
n00b
n00b


Joined: 25 Mar 2005
Posts: 17
Location: Helsinki

PostPosted: Wed Apr 05, 2006 5:53 am    Post subject: Reply with quote

Okay, when I said don't remove hotplug I meant it... Now things are different, I managed boot without hotplug. The problem was back then that my network-card didn't function without hotplug. I just put line 'forcedeth' to /etc/modules.autoload/kernel-2.6 and my system works w/o hotplug installed.

I could ask why new udev doesn't load my forcedeth module by itself like hotplug did?
Back to top
View user's profile Send private message
klemi
Guru
Guru


Joined: 26 May 2004
Posts: 494
Location: Erbach b. Ulm

PostPosted: Thu Apr 06, 2006 8:57 am    Post subject: Reply with quote

I have a question:
In which runlevel must I installed hotplug?.

I dont`t update udev at this time - but I will do it.


Code:
tux ~ # rc-update -s
           alsasound | boot default
                apmd |
            bootmisc | boot
             checkfs | boot
           checkroot | boot
               clock | boot
            coldplug | boot
         consolefont | boot
         crypto-loop |
               cupsd |      default
                dbus |      default
             dleserv |
             dnsmasq |      default
          domainname |      default
              esound |
                famd |      default
                 gpm |
                hald |      default
              hdparm |
            hostname | boot
             hotplug |
               ivman |      default
             keymaps | boot
               lircd |
              lircmd |
                lisa |
               local |      default nonetwork
          localmount | boot
       mDNSResponder |      default
             modules | boot
            net.eth0 |      default
              net.lo | boot
            netmount |      default
            net.ppp0 |
                nifd |
                nscd |
             numlock |
             portmap |
             pwcheck |
             reslisa |
           rmnologin | boot
            rp-pppoe |
              rsyncd |
           saslauthd |
              serial | boot
               slapd |
              slurpd |
               spamd |
                sshd |
           syslog-ng |      default
             urandom | boot
                 vdr |
          vixie-cron |      default
  wakeup-reboot-halt |
                 xdm |      default
                 xfs |
              xprint |


Thanks
_________________
Gentoo 2.6.16-r12; AMD Athlon 3GHz; NVidia GeForce 5700; Hauppauge nexus-s
Back to top
View user's profile Send private message
PaulBredbury
Watchman
Watchman


Joined: 14 Jul 2005
Posts: 7310

PostPosted: Thu Apr 06, 2006 9:29 am    Post subject: Reply with quote

klemi wrote:
In which runlevel must I installed hotplug?.

None. Look inside the hotplug ebuild:
Quote:
ewarn "WARNING: The hotplug init script is now gone (dead and burried.)"
ewarn "WARNING: If you want to load modules for hardware that was already"
ewarn "WARNING: discovered at boot time, like the old hotplug init script"
ewarn "WARNING: did, then emerge the coldplug package, and add coldplug to"
ewarn "WARNING: a runlevel, e.g. # rc-update add coldplug boot"
Back to top
View user's profile Send private message
lmcogs
Guru
Guru


Joined: 03 Apr 2005
Posts: 340

PostPosted: Thu Apr 06, 2006 11:42 am    Post subject: Reply with quote

Hi all

Had the same message with emerge -uD world. I unmerged coldplug but kept hotplug and updated world. The system reboots but I have lost eth0 and can't access the net. Is there some issue here and can anyone help please, big time. It was working fine before. I believe eth0 may need hotplug to work or does it need coldplug, or is there a new udev rule that handles bringing up eth0?

This is my /etc/conf.d/net file

# This blank configuration will automatically use DHCP for any net.*
# scripts in /etc/init.d. To create a more complete configuration,
# please review /etc/conf.d/net.example and save your configuration
# in /etc/conf.d/net (this file :]!).
iface_eth0=("dhcp")
dhcpcd_eth0=("-R")

Appreciate any help

lmcogs
Back to top
View user's profile Send private message
lmcogs
Guru
Guru


Joined: 03 Apr 2005
Posts: 340

PostPosted: Thu Apr 06, 2006 4:59 pm    Post subject: Reply with quote

Hi all

Well I seemed to have got it going, with a bit of luck. I followed these links

https://forums.gentoo.org/viewtopic-t-375493-start-0-postdays-0-postorder-asc-highlight-init+fails+renamed+interfaces.html
and
http://www.reactivated.net/writing_udev_rules.html#example-iface

It seems you have to write a udev rule etc to get it going.

All the best

lmcogs


Oh by the way my /etc/conf.d/net file is now
config_lan=("dhcp")
dhcpcd_eth0="-R"
Back to top
View user's profile Send private message
l33tmmx
Tux's lil' helper
Tux's lil' helper


Joined: 12 Mar 2005
Posts: 91
Location: Pirkkala, Finland

PostPosted: Fri Apr 07, 2006 5:33 pm    Post subject: Reply with quote

An excerpt from udev changelog:
Quote:

*udev-089 (03 Apr 2006)

adds "coldplug" functionality to udev by default, use the module blacklist
option to prevent things from being loaded if you don't like this.

How does one disable this coldplug functionality in udev-089? Or does the lines above mean that you just don't have any option but to blacklist every module you don't like to being loaded?

I'm asking this because I have all kind of weird & wonderful hardware, and coldplug seems to mess up things totally (for example, coldplug thinks I have 2 network interfaces :? , though I have only one...). Because of that I normally load all the modules I need via /etc/modules.autoload.d/kernel-2.6.

I tried udev-089-r2, but after a reboot the network refused to work, and because I mount /usr/portage via nfs from my server, I wasn't even able to downgrade back to udev-087 :evil:. You bet I had a hell of a job to get things back to normal, reconfiguring network manually, bit by bit...
_________________
"Trust me, I know what I'm doing!"
- Sledge Hammer

Follow me on Twitter
Back to top
View user's profile Send private message
gemini91
Guru
Guru


Joined: 27 Nov 2003
Posts: 317
Location: Naples, Fl

PostPosted: Sat Apr 08, 2006 12:59 am    Post subject: Reply with quote

I'm running a 2.6.16 kernel and when I un-emerged coldplug and installed udev-089
my wireless stopped working, eth0 and eth1 got mixed up, and I could not connect. Backed
off udev and reinstalled coldplug, and things work again. I'll wait for a new udev before
trying again.
Back to top
View user's profile Send private message
Cthulhu666
Apprentice
Apprentice


Joined: 02 Apr 2004
Posts: 195

PostPosted: Tue Apr 11, 2006 1:08 pm    Post subject: Reply with quote

After unmerging coldplug and upgrading udev (to 089-r2), all available modules were loaded unconditionally.

Since that's not the way I play, I downgraded udev (087) and I'm back in business. I haven't even reemerged coldplug, go figure.
_________________
A certified Gentoo lover!
Got 4 Gentoo boxes (2 desktops, 1 laptop and a server/MythTV HTPC).

Bought a computer bundled with windows? Don't want to use windows? Demand a refund!
Back to top
View user's profile Send private message
gemini91
Guru
Guru


Joined: 27 Nov 2003
Posts: 317
Location: Naples, Fl

PostPosted: Tue Apr 11, 2006 3:22 pm    Post subject: Reply with quote

My wireless problem with udev-089-r2 is resolved. I re-emerged
it to see if it may have changed. I rebooted, and my wireless connected
using eth0 the way it always worked. I re-booted again and it failed,
wireless was set up for eth1. I have both a wireless and a hard wired connection.
I hardly ever use the hard wired one. I don't care which one (eth0 or eth1)
connects to my wireless, just so one does.
I resolved the problem by modifying /etc/conf.d/wireless
FROM:
# /etc/conf.d/wireless:
# Global wireless config file for net.* rc-scripts
essid_eth0="any"
key_miloulan="e9e61d5f99"
TO:
# /etc/conf.d/wireless:
# Global wireless config file for net.* rc-scripts
#essid_eth0="any"
key_miloulan="e9e61d5f99"
Now sometimes it connects using eth0, sometimes eth1 but it connects.

EDIT: I also removed net.eth0 from rc-update, it is not needed anylonger. udev trys to start both interfaces.
Back to top
View user's profile Send private message
LostControl
l33t
l33t


Joined: 02 Mar 2004
Posts: 885
Location: La Glane, Suisse

PostPosted: Tue Apr 11, 2006 6:08 pm    Post subject: Reply with quote

gemini91 wrote:
EDIT: I also removed net.eth0 from rc-update, it is not needed anylonger. udev trys to start both interfaces.

Same here but this is annoying :? My eth0 is started at boot and waits on dhcp :? My laptop is almost never connected to a wired network so this is annoying. Any hints to disable this behavior?

Thank you
_________________
http://www.jaqpot.net
http://www.fail2ban.org
Back to top
View user's profile Send private message
gemini91
Guru
Guru


Joined: 27 Nov 2003
Posts: 317
Location: Naples, Fl

PostPosted: Tue Apr 11, 2006 6:42 pm    Post subject: Reply with quote

LostControl, my laptop is also never connected to a wired network,
but my machine does not wait on that adapter coming up. I'll check
and see what dmesg says when my wireless connects to eth1.
Back to top
View user's profile Send private message
gemini91
Guru
Guru


Joined: 27 Nov 2003
Posts: 317
Location: Naples, Fl

PostPosted: Tue Apr 11, 2006 6:58 pm    Post subject: Reply with quote

Well nothing in dmesg, however on the console when machine is
coming up

Starting eth0
Starting netplug on eth0
Backgrounding

I have netplug installed and that seems to be what is taking care
of it.
Back to top
View user's profile Send private message
zxy
Veteran
Veteran


Joined: 06 Jan 2006
Posts: 1160
Location: in bed in front of the computer

PostPosted: Tue Apr 11, 2006 8:49 pm    Post subject: Reply with quote

@LostControl You can aslo use ifplugd. It works good for me. And yes, waiting for half a minute for a nonexisting network connection is just annoying.
Back to top
View user's profile Send private message
LostControl
l33t
l33t


Joined: 02 Mar 2004
Posts: 885
Location: La Glane, Suisse

PostPosted: Tue Apr 11, 2006 10:03 pm    Post subject: Reply with quote

Thank you :D

I installed netplug and now the daemon waits on the background until a cable is plugged :-)

A+
_________________
http://www.jaqpot.net
http://www.fail2ban.org
Back to top
View user's profile Send private message
_savage
Guru
Guru


Joined: 06 Jun 2004
Posts: 308
Location: Redmond, WA

PostPosted: Fri May 05, 2006 6:15 pm    Post subject: Reply with quote

Back from vacation and I ought to tend to my totally boned Gentoo box. The problem was that after a complete system update I had this failure during boot:
Code:
* Populating /dev with existing devices with udevstart ...
/lib/rcscripts/addons/udev-start.sh: line 58: /sbin/udevstart: No such file or directory

I assume the issue has been resolved by now.

However, to get me up and running again, could somebody please post that script (/sbin/udevstart) so that I can download it? That should unblock me, right?

Thanks!
_________________
Jens Troeger
http://savage.light-speed.de/
Back to top
View user's profile Send private message
Cthulhu666
Apprentice
Apprentice


Joined: 02 Apr 2004
Posts: 195

PostPosted: Mon May 08, 2006 11:01 am    Post subject: Reply with quote

_savage wrote:
Back from vacation and I ought to tend to my totally boned Gentoo box. The problem was that after a complete system update I had this failure during boot:
Code:
* Populating /dev with existing devices with udevstart ...
/lib/rcscripts/addons/udev-start.sh: line 58: /sbin/udevstart: No such file or directory

I assume the issue has been resolved by now.

However, to get me up and running again, could somebody please post that script (/sbin/udevstart) so that I can download it? That should unblock me, right?

Thanks!

You can download it here.

It may, however, not be from the same version of udev, as you currently have installed. Thus it may or may not work.

EDIT: The udevstart I have provided above is from sys-fs/udev-090
_________________
A certified Gentoo lover!
Got 4 Gentoo boxes (2 desktops, 1 laptop and a server/MythTV HTPC).

Bought a computer bundled with windows? Don't want to use windows? Demand a refund!
Back to top
View user's profile Send private message
_savage
Guru
Guru


Joined: 06 Jun 2004
Posts: 308
Location: Redmond, WA

PostPosted: Thu May 11, 2006 12:41 pm    Post subject: Reply with quote

Thanks Cthulhu666, I downloaded it.

Problem is that my TiBook is now four years old and it seems to have difficulties reading my boot CD. So that means I can't boot from my CD to copy the file back onto the Gentoo partition. OS-X doesn't have xfs drivers either, so I can't mount my Gentoo partition. I am locked out of my Gentoo, unless I find another way to boot the box. Does network boot work? Or from a USB/FireWire device?

Whoever submitted that "fix" a few weeks ago ought to be beaten; people shouldn't be allowed to check in without testing! Argh! :evil:
_________________
Jens Troeger
http://savage.light-speed.de/
Back to top
View user's profile Send private message
thepustule
Apprentice
Apprentice


Joined: 22 Feb 2004
Posts: 212
Location: Toronto, Canada

PostPosted: Fri May 12, 2006 9:52 pm    Post subject: Holy Cow! Reply with quote

Might I ask - is there any page anywhere that explains the reasoning behind combining the coldplug functionality into udev?

Udev is supposed to manage the /dev tree - not load modules!

I have 5 network adapters in my system. Various versions of Coldplug/hotplug would load them in all kinds of different orders, which would repeatedly hose my iptables rules and a bunch of other interface-specific services.

So I specified the network driver load order in /etc/modules/autoload.d and put coldplug in default runlevel. So my order-important modules load nicely before the auto stuff happens.

But now with this merge, udev will auto-load the pile before the autoload.d is processed, and I'm back to mayhem!

Why, oh why oh WHY!

Even the udev website doesn't mention anything about loading modules - is this a gentoo-only thing?

Maybe there's a good reason for this, but it would be nice to read it - all I see so far is pain and anquish, and a nice easy workaround totally killed.
Back to top
View user's profile Send private message
thepustule
Apprentice
Apprentice


Joined: 22 Feb 2004
Posts: 212
Location: Toronto, Canada

PostPosted: Fri May 12, 2006 10:06 pm    Post subject: For More Info Reply with quote

For more information about my above gripe, please read the following exerpt from the udev FAQ
Quote:
Q: But udev will not automatically load a driver if a /dev node is opened
when it is not present like devfs will do.
A: Right, but Linux is supposed to load a module when a device is discovered
not to load a module when it's accessed.

Q: Oh come on, pretty please. It can't be that hard to do.
A: Such a functionality isn't needed on a properly configured system. All
devices present on the system should generate hotplug events, loading
the appropriate driver, and udev will notice and create the
appropriate device node. If you don't want to keep all drivers for your
hardware in memory, then use something else to manage your modules
(scripts, modules.conf, etc.) This is not a task for udev.



Right on the udev FAQ it is explained that loading modules is not a task for udev. Why would gentoo be moving this way then?
Back to top
View user's profile Send private message
Cthulhu666
Apprentice
Apprentice


Joined: 02 Apr 2004
Posts: 195

PostPosted: Mon May 15, 2006 6:28 am    Post subject: Reply with quote

The coldplug behaviour in udev can now be controlled with a couple of options in /etc/conf.d/rc

Code:

# Dynamic /dev managers can trigger coldplug events which cause services to
# start before we are ready for them. If this happens, we can defer these
# services to start in the boot runlevel. Set RC_COLDPLUG="no" if you don't
# want this.
# NOTE: This does not affect anything coldplug/udev related, just the
# starting/stopping of the init.d service triggered by coldplug.

RC_COLDPLUG="no"

# Some people want a finer grain over hotplug/coldplug. RC_PLUG_SERVICES is a
# list of services that are matched in order, either allowing or not. By
# default we allow services through as RC_COLDPLUG/RC_HOTPLUG has to be yes
# anyway.
# Example - RC_PLUG_SERVICES="net.wlan !net.*"
# This allows net.wlan and any service not matching net.* to be plugged.

RC_PLUG_SERVICES=""

This seems to work just fine.

thepustule wrote:

I have 5 network adapters in my system. Various versions of Coldplug/hotplug would load them in all kinds of different orders, which would repeatedly hose my iptables rules and a bunch of other interface-specific services.

Another (and more elegant) workaround to this problem, would be to specify a couple of udev rules to give specific device names to each of your network adapters.
_________________
A certified Gentoo lover!
Got 4 Gentoo boxes (2 desktops, 1 laptop and a server/MythTV HTPC).

Bought a computer bundled with windows? Don't want to use windows? Demand a refund!
Back to top
View user's profile Send private message
thepustule
Apprentice
Apprentice


Joined: 22 Feb 2004
Posts: 212
Location: Toronto, Canada

PostPosted: Mon May 15, 2006 12:24 pm    Post subject: Reply with quote

Would it be possible to use the udev rules to specify which one is eth0, eth1, etc?

It would be quite the task to change all firewall rules, and all config files for services that bind to specific network interfaces, etc.
Back to top
View user's profile Send private message
Cthulhu666
Apprentice
Apprentice


Joined: 02 Apr 2004
Posts: 195

PostPosted: Mon May 15, 2006 12:45 pm    Post subject: Reply with quote

thepustule wrote:
Would it be possible to use the udev rules to specify which one is eth0, eth1, etc?

It would be quite the task to change all firewall rules, and all config files for services that bind to specific network interfaces, etc.

That should definately be possible.

Here are a few links to aid you in writing the rules:
Gentoo udev Guide
Writing udev rules

Have fun :wink:
_________________
A certified Gentoo lover!
Got 4 Gentoo boxes (2 desktops, 1 laptop and a server/MythTV HTPC).

Bought a computer bundled with windows? Don't want to use windows? Demand a refund!


Last edited by Cthulhu666 on Tue May 16, 2006 6:47 am; edited 2 times in total
Back to top
View user's profile Send private message
Cthulhu666
Apprentice
Apprentice


Joined: 02 Apr 2004
Posts: 195

PostPosted: Mon May 15, 2006 12:49 pm    Post subject: Reply with quote

Here's an example from my laptop, just to give you an idea about how to write rules:

Code:

abhoth ~ # cat /etc/udev/rules.d/10-udev.rules
# Sony CLIE palm
BUS="usb", SYSFS{product}="Palm Handheld", KERNEL="ttyUSB0", NAME="pilot", GROUP="usb", MODE="0660"

# USB Mouse
BUS="usb", SYSFS{product}="Optical USB Mouse", NAME="usbmouse", GROUP="usb", MODE="0660"

# Intel 2200BG WiFi miniPCI card
BUS="pci", DRIVER="ipw2200", NAME="wlan0"

_________________
A certified Gentoo lover!
Got 4 Gentoo boxes (2 desktops, 1 laptop and a server/MythTV HTPC).

Bought a computer bundled with windows? Don't want to use windows? Demand a refund!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page Previous  1, 2
Page 2 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum