Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
libexpat 2.0.0 ABI breakage
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3 ... 9, 10, 11  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
bdumitriu
n00b
n00b


Joined: 24 Apr 2004
Posts: 21

PostPosted: Thu Mar 30, 2006 2:20 pm    Post subject: libexpat 2.0.0 ABI breakage Reply with quote

I've had to recompile a number of programs after upgrading to expat-2.0.0, and they all worked just fine after recompilation. All except subversion, that is. I've recompiled it (twice!), and still I get this:

Code:
$ svn
svn: error while loading shared libraries: libexpat.so.0: cannot open shared object file: No such file or directory


The weird thing is that it seems that svn links both against libexpat.so.1 and libexpat.so.0, as shown below:

Code:
$ ldd /usr/bin/svn
        linux-gate.so.1 =>  (0xffffe000)
        libsvn_client-1.so.0 => /usr/lib/libsvn_client-1.so.0 (0xb7f31000)
        libsvn_wc-1.so.0 => /usr/lib/libsvn_wc-1.so.0 (0xb7f03000)
        libsvn_ra-1.so.0 => /usr/lib/libsvn_ra-1.so.0 (0xb7eff000)
        libsvn_diff-1.so.0 => /usr/lib/libsvn_diff-1.so.0 (0xb7ef9000)
        libsvn_ra_local-1.so.0 => /usr/lib/libsvn_ra_local-1.so.0 (0xb7ef2000)
        libsvn_repos-1.so.0 => /usr/lib/libsvn_repos-1.so.0 (0xb7ed1000)
        libsvn_fs-1.so.0 => /usr/lib/libsvn_fs-1.so.0 (0xb7ecb000)
        libsvn_fs_fs-1.so.0 => /usr/lib/libsvn_fs_fs-1.so.0 (0xb7ead000)
        libsvn_fs_base-1.so.0 => /usr/lib/libsvn_fs_base-1.so.0 (0xb7e84000)
        libsvn_ra_svn-1.so.0 => /usr/lib/libsvn_ra_svn-1.so.0 (0xb7e71000)
        libsvn_ra_dav-1.so.0 => /usr/lib/libsvn_ra_dav-1.so.0 (0xb7e57000)
        libsvn_delta-1.so.0 => /usr/lib/libsvn_delta-1.so.0 (0xb7e4e000)
        libsvn_subr-1.so.0 => /usr/lib/libsvn_subr-1.so.0 (0xb7e25000)
        libaprutil-0.so.0 => /usr/lib/libaprutil-0.so.0 (0xb7e0f000)
        libgdbm.so.3 => /usr/lib/libgdbm.so.3 (0xb7e09000)
        libdb-4.2.so => /usr/lib/libdb-4.2.so (0xb7d2e000)
        libapr-0.so.0 => /usr/lib/libapr-0.so.0 (0xb7d0b000)
        librt.so.1 => /lib/librt.so.1 (0xb7cdb000)
        libm.so.6 => /lib/libm.so.6 (0xb7cb7000)
        libcrypt.so.1 => /lib/libcrypt.so.1 (0xb7c8a000)
        libnsl.so.1 => /lib/libnsl.so.1 (0xb7c75000)
        libpthread.so.0 => /lib/libpthread.so.0 (0xb7c62000)
        libneon.so.25 => /usr/lib/libneon.so.25 (0xb7c46000)
        libssl.so.0.9.7 => /usr/lib/libssl.so.0.9.7 (0xb7c16000)
        libcrypto.so.0.9.7 => /usr/lib/libcrypto.so.0.9.7 (0xb7b12000)
        libdl.so.2 => /lib/libdl.so.2 (0xb7b0e000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0xb7ae2000)
        libz.so.1 => /lib/libz.so.1 (0xb7acf000)
        libc.so.6 => /lib/libc.so.6 (0xb79b5000)
        /lib/ld-linux.so.2 (0xb7f5b000)
        libexpat.so.0 => not found


I know I can create a symlink from libexpat.so.0 to libexpat.so.1.5.0, but I'd like to avoid doing that.

Any ideas how I can fix my svn (except by creating the symlink or downgrading back to my previous expat)?

mod edit:
Made sticky.
Also changed the title as it's a generic problem with libexpat 2.0.0
amne


Last edited by bdumitriu on Thu Mar 30, 2006 2:35 pm; edited 1 time in total
Back to top
View user's profile Send private message
bdumitriu
n00b
n00b


Joined: 24 Apr 2004
Posts: 21

PostPosted: Thu Mar 30, 2006 2:35 pm    Post subject: Reply with quote

Hmm... I got it working finally. I think reemerging net-misc/neon did the trick, but I'm not 100% sure. Confirmation would be nice (for others, at least).
Back to top
View user's profile Send private message
nixnut
Administrator
Administrator


Joined: 09 Apr 2004
Posts: 10973
Location: the dutch mountains

PostPosted: Thu Mar 30, 2006 5:21 pm    Post subject: Reply with quote

Some info here as well https://bugs.gentoo.org/show_bug.cgi?id=128108
_________________
Please add [solved] to the initial post's subject line if you feel your problem is resolved. Help answer the unanswered

talk is cheap. supply exceeds demand
Back to top
View user's profile Send private message
mariourk
l33t
l33t


Joined: 11 Jul 2003
Posts: 807
Location: Urk, Netherlands

PostPosted: Thu Mar 30, 2006 5:35 pm    Post subject: Reply with quote

I found a quick hack to fix this. I linked /usr/lib64/libexpat.so.1 to /usr/lib64/libexpat.so.0
Code:

ln -s /usr/lib64/libexpat.so.1 /usr/lib64/libexpat.so.0

I'm running an AMD64. Maybe it't related?? :?
_________________
If there is one thing to learn from history, it's that we usualy don't learn anything from it, at all.
Back to top
View user's profile Send private message
SirRichard
n00b
n00b


Joined: 10 Oct 2004
Posts: 13
Location: Stockelsdorf, Germany

PostPosted: Thu Mar 30, 2006 6:25 pm    Post subject: Reply with quote

No, making a softlink is really dirty. The solution is to run revdep-rebuild. Worked fine for me
Back to top
View user's profile Send private message
seemant
Retired Dev
Retired Dev


Joined: 16 Nov 2002
Posts: 61
Location: Oakland, CA

PostPosted: Thu Mar 30, 2006 6:31 pm    Post subject: Reply with quote

Yeah, at the very minimum, remerge neon and subversion, but run revdep-rebuild because you may have a lot more linking issues than you realise (with gnome and kde both installed I had 200 odd packages that needed rebuilding -- I'm saving my upgrade/rebuild for the weekend though).
Back to top
View user's profile Send private message
seemant
Retired Dev
Retired Dev


Joined: 16 Nov 2002
Posts: 61
Location: Oakland, CA

PostPosted: Thu Mar 30, 2006 6:32 pm    Post subject: Reply with quote

Oh yeah, as far as the softlink. I did try it this morning, but things like gconf-editor broke (while changing a setting). IOW, it lets you start applications, but no guarantees on how well they run. So, yeah, softlink = bad idea.
Back to top
View user's profile Send private message
amne
Bodhisattva
Bodhisattva


Joined: 17 Nov 2002
Posts: 6377
Location: Graz / EU

PostPosted: Thu Mar 30, 2006 6:34 pm    Post subject: Reply with quote

As already said, running
Code:
revdep-rebuild
should find all packages broken by this (and other) upgrade(s). If you want to rebuild only the packages broken by this update and don't care about others, you could also run
Code:
revdep-rebuild --library=libexpat.so.0

_________________
Dinosaur week! (Ok, this thread is so last week)
Back to top
View user's profile Send private message
mariourk
l33t
l33t


Joined: 11 Jul 2003
Posts: 807
Location: Urk, Netherlands

PostPosted: Thu Mar 30, 2006 6:55 pm    Post subject: Reply with quote

I know softlinks are dirty. But right now I'm running a loooooong emerge -uD world
and I needed it fixed fast ;)
_________________
If there is one thing to learn from history, it's that we usualy don't learn anything from it, at all.
Back to top
View user's profile Send private message
7seven7
n00b
n00b


Joined: 22 Jan 2005
Posts: 72

PostPosted: Thu Mar 30, 2006 11:02 pm    Post subject: Reply with quote

If i update to expat-2, i have to run revdep-rebuild because of the missing library error in same aplications.

Kde packages are one of many afected packges, but during the update of the packages, after udpdate kdelibs, i get the fowling error when emerging any kde aplication:

Code:
configure: error:
 you need to install kdelibs first.
 
 If you did install kdelibs, then the Qt version that is picked up by
 this configure is not the same version you used to compile kdelibs.
 The Qt Plugin installed by kdelibs is *ONLY* loadable if it is the
 _same Qt version_, compiled with the _same compiler_ and the same Qt
 configuration settings.


i have to downgrade to expat-1.95.8 and run revdep-rebuild to get all the programs rigth.

Any advices?
Back to top
View user's profile Send private message
darkphader
Veteran
Veteran


Joined: 09 May 2002
Posts: 1113
Location: Motown

PostPosted: Thu Mar 30, 2006 11:11 pm    Post subject: Reply with quote

Tip: use emwrap.sh to assist in the rebuilding (the remerge doesn't halt because of a failure).

emwrap thread:
https://forums.gentoo.org/viewtopic.php?t=282474&highlight=

Because of the ABI change in expat-2.0.0 there are many packages that need to be remerged and running directly from revdep-rebuild any emerge failure would result in a halt of the remerging. By using emwrap.sh one can allow the process to continue and get to the failed packages after.
For now it can be done manually, as root (assuming you've used emwrap.sh at least once, and after taking care of any outstanding emwrap failed builds, etc.):
Code:
revdep-rebuild -i -p
cp /root/.revdep-rebuild.4_ebuilds /tmp/emwrap/build
emwrap.sh -r
I usually do a
Code:
rm /tmp/emwrap/*
first but it's probably not necessary.

Chris
_________________
What I need is an exact list of specific unknown problems we might encounter.
Back to top
View user's profile Send private message
rhill
Developer
Developer


Joined: 22 Oct 2004
Posts: 1629
Location: sk.ca

PostPosted: Fri Mar 31, 2006 12:54 am    Post subject: Reply with quote

7seven7 wrote:
If i update to expat-2, i have to run revdep-rebuild because of the missing library error in same aplications.

Kde packages are one of many afected packges, but during the update of the packages, after udpdate kdelibs, i get the fowling error when emerging any kde aplication:

Code:
configure: error:
 you need to install kdelibs first.
 
 If you did install kdelibs, then the Qt version that is picked up by
 this configure is not the same version you used to compile kdelibs.
 The Qt Plugin installed by kdelibs is *ONLY* loadable if it is the
 _same Qt version_, compiled with the _same compiler_ and the same Qt
 configuration settings.


i have to downgrade to expat-1.95.8 and run revdep-rebuild to get all the programs rigth.

Any advices?


follow the information it gives you. it's telling you that qt and kdelibs have been compiled with different compilers or compile options. to set it straight, try 'emerge -av qt kdelibs'.
_________________
by design, by neglect
for a fact or just for effect
Back to top
View user's profile Send private message
StifflerStealth
l33t
l33t


Joined: 03 Jul 2002
Posts: 955

PostPosted: Fri Mar 31, 2006 2:20 am    Post subject: Reply with quote

Sometimes revdep-rebuild misses things, so with something like KDE, you can try:
Code:
emerge --oneshot `ls -d /var/db/pkg/kde-base/*-3.5* | sed -e "s/\/var\/db\/pkg\//\=/g"` -a
This will reinstall everything KDE, but you will know that nothing was missed. People have been saying that even after revdep-rebuild, kde is still broke, so this might be a good thing to try. Oh, if you get anything that wants to be downgraded, just change the -a to -pt and try emerge -uD {packagename}. I had to do that for lisa, because it never got updated in a world update to 3.5.2. :S Weird. Then re-run that script. :)

Cheers.
_________________
Nothing to read in this sig. Move along.
Back to top
View user's profile Send private message
eNTi
Veteran
Veteran


Joined: 20 Oct 2002
Posts: 1011
Location: Salzburg, Austria

PostPosted: Fri Mar 31, 2006 9:22 am    Post subject: Reply with quote

why is it possible to have such a static behavoir in a single libary? i do not even need to recompile as many packages when upgrading glibc!
_________________
If you fall off a cliff, you might as well try to fly. After all, you got nothing to lose.

-- John Sheridan - Babylon 5, Season 4
Back to top
View user's profile Send private message
Maedhros
Bodhisattva
Bodhisattva


Joined: 14 Apr 2004
Posts: 5511
Location: Durham, UK

PostPosted: Fri Mar 31, 2006 9:33 am    Post subject: Reply with quote

eNTi wrote:
why is it possible to have such a static behavoir in a single libary? i do not even need to recompile as many packages when upgrading glibc!

Because upgrading glibc doesn't often change the ABI. When it does, then you have to recompile a lot of things (think gcc-3.4 related libstdc++.so.6 chaos).
_________________
No-one's more important than the earthworm.
Back to top
View user's profile Send private message
mebrelith
Tux's lil' helper
Tux's lil' helper


Joined: 04 Apr 2005
Posts: 102
Location: Torreon, Coahuila, Mexico

PostPosted: Fri Mar 31, 2006 1:11 pm    Post subject: Reply with quote

What Id like to know is do I really need to update to expat 2? Cause then having to rebuild my KDE (and openoffice and others) would take me about 50 hours (this according to the logs on previous compilings of these packages) and I really don't have the time right now to spend that much time cooking.

I mean, is it really necessary? Are there any critical patches? Will keeping the previous expat version eat my box?

Cause unless its a critical thingie Id rather wait till I have time to waste and not have have as much to do with my box as I do these days.
_________________
Mebrelith Lord of Thingamajigs, Linux zealot, Gentoo advocate, KDE promoter. Linux user #373009
Omnia mutantur, nihil interit - Everything changes, nothing is truly lost.
Back to top
View user's profile Send private message
no4b
Bodhisattva
Bodhisattva


Joined: 18 Jan 2004
Posts: 774
Location: Tarnów, Poland

PostPosted: Fri Mar 31, 2006 4:14 pm    Post subject: Reply with quote

I have updated expat and I didn't need to recompile kde, only 10 small packages (the only one that can be called "big" was k3b).
_________________
GTK2/GNOME - The weakest link!
Back to top
View user's profile Send private message
Matteo Azzali
Retired Dev
Retired Dev


Joined: 23 Sep 2004
Posts: 1133

PostPosted: Fri Mar 31, 2006 4:22 pm    Post subject: Reply with quote

well, I had to recompile 149 packages and now I'm testing the rebuilded packages for errors/issues....
(found nothing, so far, except that kradio doesn't compile anymore, but can be caused by other factors)
_________________
Every day a new distro comes to birth. Every day a distro "eats" another.
If you're born distro, no matter what, start to run.
---- http://www.linuxprinting.org/ ---- http://tuxmobil.org/
Back to top
View user's profile Send private message
darkphader
Veteran
Veteran


Joined: 09 May 2002
Posts: 1113
Location: Motown

PostPosted: Fri Mar 31, 2006 5:46 pm    Post subject: Reply with quote

mebrelith wrote:
What Id like to know is do I really need to update to expat 2?
I mean, is it really necessary? Are there any critical patches?

I'm not an expert but my guess is that there is no critical reason to do so. I doubt you'll even see version 2 in upcoming binary distro releases, such as Dapper (the next ubuntu release scheduled for 6/06) due to code freeze.

Chris
_________________
What I need is an exact list of specific unknown problems we might encounter.
Back to top
View user's profile Send private message
kimchi_sg
Advocate
Advocate


Joined: 26 Nov 2004
Posts: 2915
Location: Singapore

PostPosted: Fri Mar 31, 2006 6:03 pm    Post subject: gdm broke... Reply with quote

For me the expat upgrade broke about 10 packages, all recompiled easily with revdep-rebuild - except gdm which complained about not finding glib (of all things). :(
_________________
Murphy's Law of Gentoo installation: If a compile can fail, it will.

MacGillicuddy's Corollary: At the most inopportune time.

Please search and read the FAQs before posting.
Back to top
View user's profile Send private message
paladin-zero
Guru
Guru


Joined: 19 May 2004
Posts: 322

PostPosted: Fri Mar 31, 2006 6:18 pm    Post subject: Reply with quote

revdep-rebuild is not being very helpful. I have already run revdep-rebuild --library=libexpat.so.0. Afterward, I ran revdep-rebuild -p. Look at this list of broken apps, and it doesnt know how to fix it:

Code:
Checking dynamic linking consistency...
  broken /usr/kde/3.5//lib64/kde3/kabc_groupdav.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/kabc_groupwise.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/kabc_kolab.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/kabc_newexchange.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/kabc_slox.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/kabc_xmlrpc.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/kcal_groupdav.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/kcal_groupwise.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/kcal_kabc.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/kcal_kolab.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/kcal_newexchange.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/kcal_remote.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/kcal_resourcefeatureplan.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/kcal_slox.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/kcal_xmlrpc.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/kcm_sdsummary.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/kio_groupwise.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/kio_imap4.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/kio_mbox.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/knotes_kolab.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/knotes_xmlrpc.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/libkaddrbk_geo_xxport.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/libkaddrbk_gmx_xxport.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/libkontact_specialdatesplugin.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/kde3/resourcecalendarexchange.so (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkabc_groupdav.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkabc_groupwise.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkabc_newexchange.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkabc_slox.so.0.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkabc_xmlrpc.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkabckolab.so.0.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkcal_groupdav.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkcal_groupwise.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkcal_newexchange.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkcal_resourcefeatureplan.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkcal_resourceremote.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkcal_slox.so.0.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkcal_xmlrpc.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkcalkolab.so.0.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkgroupwarebase.so.0.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkgroupwaredav.so.0.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkholidays.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkmime.so.2.2.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libknotes_xmlrpc.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libknoteskolab.so.0.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkpgp.so.2.2.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkpimexchange.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libksieve.so.0.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5//lib64/libkslox.so.0.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/kabc_groupdav.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/kabc_groupwise.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/kabc_kolab.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/kabc_newexchange.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/kabc_slox.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/kabc_xmlrpc.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/kcal_groupdav.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/kcal_groupwise.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/kcal_kabc.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/kcal_kolab.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/kcal_newexchange.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/kcal_remote.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/kcal_resourcefeatureplan.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/kcal_slox.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/kcal_xmlrpc.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/kcm_sdsummary.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/kio_groupwise.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/kio_imap4.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/kio_mbox.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/knotes_kolab.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/knotes_xmlrpc.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/libkaddrbk_geo_xxport.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/libkaddrbk_gmx_xxport.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/libkontact_specialdatesplugin.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/kde3/resourcecalendarexchange.so (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkabc_groupdav.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkabc_groupwise.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkabc_newexchange.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkabc_slox.so.0.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkabc_xmlrpc.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkabckolab.so.0.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkcal_groupdav.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkcal_groupwise.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkcal_newexchange.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkcal_resourcefeatureplan.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkcal_resourceremote.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkcal_slox.so.0.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkcal_xmlrpc.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkcalkolab.so.0.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkgroupwarebase.so.0.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkgroupwaredav.so.0.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkholidays.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkmime.so.2.2.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libknotes_xmlrpc.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libknoteskolab.so.0.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkpgp.so.2.2.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkpimexchange.so.1.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libksieve.so.0.0.0 (requires  libexpat.so.0)
  broken /usr/kde/3.5/lib/libkslox.so.0.0.0 (requires  libexpat.so.0)
  broken /usr/lib32/openoffice/program/gconfbe1.uno.so (requires  libORBit-2.so.0 libgconf-2.so.4)
  broken /usr/lib32/openoffice/program/gnome-set-default-application (requires  libORBit-2.so.0 libORBitCosNaming-2.so.0 libbonobo-2.so.0 libbonobo-activation.so.4 libgconf-2.so.4 libgnomevfs-2.so.0)
  broken /usr/lib32/openoffice/program/libkabdrv1.so.1.1 (requires  libkabc.so.1 libkdeui.so.4)
  broken /usr/lib32/openoffice/program/libofficebean.so.1.1 (requires  libjawt.so)
  broken /usr/lib32/openoffice/program/libvclplug_kde680li.so.1.1 (requires  libkdeui.so.4)
  broken /usr/lib32/openoffice/program/python-core-2.3.4/lib/lib-dynload/_bsddb.so (requires  libdb-3.1.so)
  broken /usr/lib32/openoffice/program/python-core-2.3.4/lib/lib-dynload/_ssl.so (requires  libcrypto.so.0.9.6 libssl.so.0.9.6)
  broken /usr/lib32/openoffice/program/python-core-2.3.4/lib/lib-dynload/dbm.so (requires  libgdbm.so.2)
  broken /usr/lib32/openoffice/program/python-core-2.3.4/lib/lib-dynload/gdbm.so (requires  libgdbm.so.2)
  broken /usr/lib32/openoffice/program/python-core-2.3.4/lib/lib-dynload/mpz.so (requires  libgmp.so.3)
  broken /usr/lib32/openoffice/program/ucpgvfs1.uno.so (requires  libgnomevfs-2.so.0)
 done.
  (/home/darren/.revdep-rebuild.3_rebuild)

Assigning files to ebuilds... done.
  (/home/darren/.revdep-rebuild.4_ebuilds)

Evaluating package order... done.
  (/home/darren/.revdep-rebuild.5_order)

All prepared. Starting rebuild...
emerge --oneshot -p =app-office/openoffice-bin-2.0.2

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] app-office/openoffice-bin-2.0.2  USE="-gnome*"
Now you can remove -p (or --pretend) from arguments and re-run revdep-rebuild.
Back to top
View user's profile Send private message
UncleOwen
Veteran
Veteran


Joined: 27 Feb 2003
Posts: 1493
Location: Germany, Hamburg

PostPosted: Fri Mar 31, 2006 6:57 pm    Post subject: Reply with quote

Okay, that's not right. What does
Code:
equery b /usr/kde/3.5//lib64/kde3/kabc_groupdav.so

say?
Back to top
View user's profile Send private message
paladin-zero
Guru
Guru


Joined: 19 May 2004
Posts: 322

PostPosted: Fri Mar 31, 2006 7:15 pm    Post subject: Reply with quote

UncleOwen wrote:
Okay, that's not right. What does
Code:
equery b /usr/kde/3.5//lib64/kde3/kabc_groupdav.so

say?


Code:

$ equery b /usr/kde/3.5//lib64/kde3/kabc_groupdav.so
[ Searching for file(s) /usr/kde/3.5//lib64/kde3/kabc_groupdav.so in *... ]

$   


Yikes, I dont know what to do about that.

edit: I should have noted, I'm using the ~amd64 branch with gcc-4.1


Last edited by paladin-zero on Fri Mar 31, 2006 7:18 pm; edited 1 time in total
Back to top
View user's profile Send private message
eNTi
Veteran
Veteran


Joined: 20 Oct 2002
Posts: 1011
Location: Salzburg, Austria

PostPosted: Fri Mar 31, 2006 7:18 pm    Post subject: Reply with quote

even though i've already emerged kdelibs-3.5.2 and i've upgraded most kde packages to 3.5.2 (all of them), revdep-rebuild wants to build 3.5.0 ones? it also fails at that, because configure states, that it can't find kdelibs!

also, revdep-rebuild wants to emerge avifile, which doesn't seem to be in portage in that form any longer... this expat thingy, really freaks me out.

Code:
All prepared. Starting rebuild...
emerge --oneshot -p =app-admin/klogview-0.6 =app-backup/konserve-0.10.3 =app-emu lation/emul-linux-x86-qtlibs-3.4.4 =app-emulation/emul-linux-x86-xlibs-7.0-r1 =a pp-portage/kentoo-0.4 =dev-util/kdesvn-0.7.4 =dev-util/subversion-1.3.0_rc4 =gno me-base/gconf-2.12.1-r1 =gnome-base/gnome-keyring-0.4.6 =gnome-base/libgnomeui-2 .12.1 =gnome-base/librsvg-2.12.7 =kde-base/kdeaddons-3.5.0 =kde-base/kdeadmin-3. 5.0 =kde-base/kdeedu-3.5.0 =kde-base/kdegames-3.5.0 =kde-base/kdelibs-3.5.2 =kde -base/kdenetwork-3.5.0 =kde-base/kdepim-3.5.0 =kde-base/kdetoys-3.5.2 =kde-base/ kdeutils-3.5.0 =kde-base/kdewebdev-3.5.0 =kde-base/kompare-3.5.1 =kde-misc/kdiff 3-0.9.88 =kde-misc/krename-3.0.9 =media-gfx/digikam-0.8.1-r1 =media-libs/libexif -gtk-0.3.5 =media-libs/libkexif-0.2.2 =media-libs/libkipi-0.1.2 =media-libs/libq uicktime-0.9.7-r1 =media-libs/musicbrainz-2.1.2 =media-libs/tunepimp-0.3.0-r1 =m edia-sound/easytag-1.99.11 =media-sound/grip-3.3.1 =media-sound/gstreamripper-0. 2 =media-video/avifile-0.7.43.20050224-r2 =media-video/mjpegtools-1.8.0-r1 =medi a-video/xine-ui-0.99.4-r4 =net-im/gaim-1.5.0 =net-misc/streamtuner-0.99.99-r1 =n et-www/apache-2.0.55-r1 =sys-apps/dbus-0.61-r1 =x11-libs/gtk+-2.8.13 =x11-libs/p ango-1.10.4 =x11-libs/vte-0.11.18 =x11-libs/wxGTK-2.6.2-r1 =x11-misc/electricshe ep-2.6.4

These are the packages that would be merged, in order:

Calculating dependencies \
emerge: there are no ebuilds to satisfy "=media-video/avifile-0.7.43.20050224-r2 ".


revdep-rebuild failed to emerge all packages
you have the following choices:

_________________
If you fall off a cliff, you might as well try to fly. After all, you got nothing to lose.

-- John Sheridan - Babylon 5, Season 4
Back to top
View user's profile Send private message
paladin-zero
Guru
Guru


Joined: 19 May 2004
Posts: 322

PostPosted: Fri Mar 31, 2006 7:22 pm    Post subject: Reply with quote

UncleOwen wrote:
Okay, that's not right. What does
Code:
equery b /usr/kde/3.5//lib64/kde3/kabc_groupdav.so

say?


Code:
$ equery b /usr/kde/3.5//lib64/kde3/kabc_groupdav.so
[ Searching for file(s) /usr/kde/3.5//lib64/kde3/kabc_groupdav.so in *... ]

$


Maybe that extra / is part of the problem?

Code:
$ equery b /usr/kde/3.5/lib64/kde3/kabc_groupdav.so
[ Searching for file(s) /usr/kde/3.5/lib64/kde3/kabc_groupdav.so in *... ]
kde-base/kdepim-kresources-3.5.2 (/usr/kde/3.5/lib64/kde3/kabc_groupdav.so)


edit: it looks like portage was not able to fix my expat problem because some of the offended packages were not in my world file. I recently recovered from a borked system, and it looks like I havent fully recovered yet. Sorry for noise.


Last edited by paladin-zero on Fri Mar 31, 2006 8:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2, 3 ... 9, 10, 11  Next
Page 1 of 11

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum