Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Printing and Scanning with Canon Pixma/Pixus Series
View unanswered posts
View posts from last 24 hours

Goto page 1, 2, 3 ... 15, 16, 17  Next  
Reply to topic    Gentoo Forums Forum Index Unsupported Software
View previous topic :: View next topic  
Author Message
ColinK
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2005
Posts: 142

PostPosted: Wed Mar 29, 2006 11:30 pm    Post subject: Printing and Scanning with Canon Pixma/Pixus Series Reply with quote

Hi

Inspired by HOWTO - Canon ... I began writing my first ebuild (two days ago).

I visited ftp://download.canon.jp and discovered the file "bfilter-common-2.50-2.src.rpm

Because I had a lot of trouble with my brand-new Canon Pixma MP 780 myself (after migrating from XP 4 month' ago), I was motivated to contribute something to the solution of this problem. I didn't believe to be successful actually - nor that fast. :)

Well that's why I'm proud to present my first ebuild (for ~x86 and ~amd64)

>> Visit Canon Pixma Series on gentoo-wiki.com <<

Or get the ebuilds directly:
> scanning: media-gfx/sane-pixma
> printing: net-print/bjfilter & net-print/cnijfilter
> + printing on amd64: app-emulation/emul-linux-x86-bjdeps


Last edited by ColinK on Thu Oct 26, 2006 5:34 pm; edited 15 times in total
Back to top
View user's profile Send private message
yabbadabbadont
Advocate
Advocate


Joined: 14 Mar 2003
Posts: 4791
Location: 2 exits past crazy

PostPosted: Thu Mar 30, 2006 12:24 am    Post subject: Reply with quote

Thanks for giving back. Now if I could only figure out if my i900D is compatible with any of the drivers provided... so far, the only thing I've found are commercial drivers from Germany. I would pony up the dough, but I have win2k running inside vmware when I need that printer. Oh well, at least my Brother HL-1440 works perfectly in linux.

Again, thanks and keep up the good work.
Back to top
View user's profile Send private message
ColinK
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2005
Posts: 142

PostPosted: Thu Mar 30, 2006 8:51 am    Post subject: Reply with quote

I searched for "canon printhead i900D". I discovered that the i900D, i905D, Pixma ip6000D printers use the same printhead. But it seems to be a different printhead as in any of the printers these drivers are designed for.
Back to top
View user's profile Send private message
yabbadabbadont
Advocate
Advocate


Joined: 14 Mar 2003
Posts: 4791
Location: 2 exits past crazy

PostPosted: Fri Mar 31, 2006 2:41 am    Post subject: Reply with quote

Thanks for the information. I never thought of including "printhead" in my searches.
Back to top
View user's profile Send private message
Eugene33
Apprentice
Apprentice


Joined: 14 Nov 2004
Posts: 167
Location: Lyon

PostPosted: Sat Apr 01, 2006 11:08 am    Post subject: Reply with quote

Hi Colink,
Many thanks for your effort, I'm desperatly trying to run my canon 560 on my AMD64 and still no result, so I gave a try to your ebuild, just copied and run...this is the result I get. I hope this will help you

Quote:
ebuild /usr/local/portage/net-print/bjfilter/bjfilter-2.50.ebuild digest
/usr/local/portage/net-print/bjfilter/bjfilter-2.50.ebuild: line 99: syntax error near unexpected token `||'
/usr/local/portage/net-print/bjfilter/bjfilter-2.50.ebuild: line 99: ` || die "Error: libs/autoconf.sh failed" '

!!! ERROR: net-print/bjfilter-2.50 failed.
!!! Function , Line 1765, Exitcode 1
!!! error sourcing ebuild
!!! If you need support, post the topmost build error, NOT this status message.


aux_get(): (0) Error in net-print/bjfilter-2.50 ebuild. (1)
Check for syntax error or corruption in the ebuild. (--debug)

/usr/local/portage/net-print/bjfilter/bjfilter-2.50.ebuild: line 99: syntax error near unexpected token `||'
/usr/local/portage/net-print/bjfilter/bjfilter-2.50.ebuild: line 99: ` || die "Error: libs/autoconf.sh failed" '

!!! ERROR: net-print/bjfilter-2.50 failed.
!!! Function , Line 1765, Exitcode 1
!!! error sourcing ebuild
!!! If you need support, post the topmost build error, NOT this status message.


aux_get(): (0) Error in net-print/bjfilter-2.50 ebuild. (1)
Check for syntax error or corruption in the ebuild. (--debug)

Traceback (most recent call last):
File "/usr/sbin/ebuild", line 71, in ?
a = portage.doebuild(ebuild, arg, portage.root, tmpsettings, debug=debug, cleanup=("noauto" not in portage.features), tree=mytree)
File "/usr/lib/portage/pym/portage.py", line 2435, in doebuild
eapi = db[root][tree].dbapi.aux_get(mycpv, ["EAPI"])[0]
File "/usr/lib/portage/pym/portage.py", line 5407, in aux_get
raise KeyError
KeyError

Sorry if I'm not of a wonderful help here. ;)
Back to top
View user's profile Send private message
bladus
Apprentice
Apprentice


Joined: 27 Jul 2005
Posts: 233

PostPosted: Sat Apr 01, 2006 12:04 pm    Post subject: Reply with quote

Thanks for the ebuild, i also tryed it with my amd64 and pixma4000 and get the following error:

Quote:
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.5/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/../lib64/libcnbpcmcm221.so when searching for -lcnbpcmcm221
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.5/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/libcnbpcmcm221.so when searching for -lcnbpcmcm221
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.5/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/libcnbpcmcm221.so when searching for -lcnbpcmcm221
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.5/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lcnbpcmcm221
collect2: ld returned 1 exit status
make[2]: *** [bjfilter] Error 1
make[2]: Leaving directory `/var/tmp/portage/bjfilter-2.50/work/bjfilter-2.50/pixusip4100/bjfilter/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/bjfilter-2.50/work/bjfilter-2.50/pixusip4100/bjfilter'
make: *** [all] Error 2

!!! ERROR: net-print/bjfilter-2.50 failed.
!!! Function src_compile_pr, Line 251, Exitcode 2
!!! (no error message)
!!! If you need support, post the topmost build error, NOT this status message.
Back to top
View user's profile Send private message
ColinK
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2005
Posts: 142

PostPosted: Sat Apr 01, 2006 11:26 pm    Post subject: Reply with quote

@Eugene33:

Eugene33 wrote:

/usr/local/portage/net-print/bjfilter/bjfilter-2.50.ebuild: line 99: syntax error near unexpected token `||'
/usr/local/portage/net-print/bjfilter/bjfilter-2.50.ebuild: line 99: ` || die "Error: libs/autoconf.sh failed" '


Line 98-99:
Code:
   ./autogen.sh --prefix=${_prefix} \
      || die "Error: libs/autoconf.sh failed"


hmm .. looks like your bash doesn't understand this.

Replace it with one line

Code:
   ./autogen.sh --prefix=${_prefix} || die "Error: libs/autoconf.sh failed"


Repeat this step with every sequence of "\"+newline+"||".

Please report if this solves your issue.

(But I guess you'll run into the same trouble as bladus after that.)


@bladus:

Those *.so files are precompiled 32-bit libraries from canon. They are closed source and the only binaries this ebuild doesn't compile.

I don't have any experience with AMD64. Does anyone know if it is possible to link against 32-bit libraries on AMD64? Does anyone (else) know how?

I'm sorry I can't help you better. :-/
Back to top
View user's profile Send private message
Eugene33
Apprentice
Apprentice


Joined: 14 Nov 2004
Posts: 167
Location: Lyon

PostPosted: Sun Apr 02, 2006 3:24 pm    Post subject: Reply with quote

Many thanks, it does the trick, so now I'm making the digest.... :wink:
I'll came back later to tell you if I have the same prob for AMD64

Ok here the result:
Quote:
* Applying bjfilter-2.50-pixusip4100-ppd.patch ...

* Failed Patch: bjfilter-2.50-pixusip4100-ppd.patch !
* ( /usr/local/portage/net-print/bjfilter/files/bjfilter-2.50-pixusip4100-ppd.patch )
*
* Include in your bugreport the contents of:
*
* /var/tmp/portage/bjfilter-2.50/temp/bjfilter-2.50-pixusip4100-ppd.patch-17513.out

Wel I don't understand as I was installing the pixusip3100 for the i560
Back to top
View user's profile Send private message
ColinK
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2005
Posts: 142

PostPosted: Sun Apr 02, 2006 3:52 pm    Post subject: Reply with quote

@Eugene33:

1. Please post /var/tmp/portage/bjfilter-2.50/temp/bjfilter-2.50-pixusip4100-ppd.patch-17513.out

2. Edit the ebuild and remove line 93: "epatch ..." -> So the patch won't be applied anymore if you retry. But that doesn't matter in your case anyway.

Please do 1 before 2. :)
Back to top
View user's profile Send private message
Eugene33
Apprentice
Apprentice


Joined: 14 Nov 2004
Posts: 167
Location: Lyon

PostPosted: Sun Apr 02, 2006 4:22 pm    Post subject: Reply with quote

Thanks ColinK for your precious help

Sorry I could not find the /var/tmp/portage/bjfilter-2.50/temp/bjfilter-2.50-pixusip4100-ppd.patch-27802.out
I tried many time to generate it but still nothing.

so I removed the patch line from the ebuild
Quote:
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.5/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/../lib64/libcnbpcmcm218.so when searching for -lcnbpcmcm218
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.5/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib64/libcnbpcmcm218.so when searching for -lcnbpcmcm218
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.5/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/libcnbpcmcm218.so when searching for -lcnbpcmcm218
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.5/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lcnbpcmcm218
collect2: ld returned 1 exit status
make[2]: *** [bjfilter] Error 1
make[2]: Leaving directory `/var/tmp/portage/bjfilter-2.50/work/bjfilter-2.50/pixusip3100/bjfilter/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/bjfilter-2.50/work/bjfilter-2.50/pixusip3100/bjfilter'
make: *** [all] Error 2

There is some kind of progress as with the other ebuilds I crashed on another library (libcnbpcnclui189.so)
Back to top
View user's profile Send private message
ColinK
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2005
Posts: 142

PostPosted: Sun Apr 02, 2006 4:55 pm    Post subject: Reply with quote

hmm .. I was already interested why that patch didn't work for you - while it worked for me and bladus, as I suppose.

Does anyone know if it is possible to mix 32/64-bit? (especially if it is possible to compile a 64-bit application against 32-bit libraries?). Because that's what this is about.
Back to top
View user's profile Send private message
ColinK
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2005
Posts: 142

PostPosted: Sun Apr 02, 2006 7:01 pm    Post subject: Reply with quote

@Eugene33/bladus:

Do you have 32bit-emulation enabled? Someone told me, that it should actually work in this case.
Back to top
View user's profile Send private message
Eugene33
Apprentice
Apprentice


Joined: 14 Nov 2004
Posts: 167
Location: Lyon

PostPosted: Sun Apr 02, 2006 7:08 pm    Post subject: Reply with quote

I have a 32-bit enabled, in the kernel and the emul-32.xxxxx packages
I was installed some ~x86 like ACX and the canon-560 ebuild https://bugs.gentoo.org/show_bug.cgi?id=61955 but always crashed with the bjfilter
Back to top
View user's profile Send private message
ColinK
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2005
Posts: 142

PostPosted: Sun Apr 02, 2006 8:38 pm    Post subject: Reply with quote

@Eugene33:

Please try the new ebuild. It should now compile in 32-bit mode on AMD64.

Good luck.

PS: did you previously place the patch in the correct folder? It has to be put in net-print/bjfilter/files/.
Back to top
View user's profile Send private message
Eugene33
Apprentice
Apprentice


Joined: 14 Nov 2004
Posts: 167
Location: Lyon

PostPosted: Sun Apr 02, 2006 8:58 pm    Post subject: Reply with quote

Hi ColinK
Can't wait to try it ;)
I started the x11 modular but I will give it a try just after.

Yes I put the patch in the bjfilter/files folder :cry:

Thanks again for all your efforts

Ok I'm back :lol:
There is a little error with the dependency for emul-x86-gtklibs which should be emul-linux-x86-gtklibs. Then it stopped again, telling me I should use the multilib with GCC. I checked and Multilib was in the USE.
Anyway I think this last problem come from my station as I have 289 upgrades to do. So when I will have finished with that (and checked again that gcc is multilib....weird) I 'll come back to you. :lol: hopefully with a Great Hourra and a bottle of beer.
Back to top
View user's profile Send private message
Eugene33
Apprentice
Apprentice


Joined: 14 Nov 2004
Posts: 167
Location: Lyon

PostPosted: Mon Apr 03, 2006 11:38 pm    Post subject: Reply with quote

Ok here is my feedback after re-emerging gcc with USE=multilib FEATURES=-sandbox as indicated
Quote:
# emerge bjfilter
Calculating dependencies... done!
>>> Emerging (1 of 1) net-print/bjfilter-2.50 to /
>>> checksums files ;-) bjfilter-2.4.ebuild
>>> checksums files ;-) bjfilter-2.4.0.ebuild
>>> checksums files ;-) bjfilter-2.50.ebuild
>>> checksums files ;-) files/bjfilter-2.4.patch
>>> checksums files ;-) files/digest-bjfilter-2.4
>>> checksums files ;-) files/digest-bjfilter-2.4.0
>>> checksums files ;-) files/bjfilter-2.4.0.patch
>>> checksums files ;-) files/bjfilter-2.50-pixusip4100-ppd.patch
>>> checksums files ;-) files/digest-bjfilter-2.50
>>> checksums src_uri ;-) bjfilter-common-2.50-2.src.rpm
/usr/local/portage/net-print/bjfilter/bjfilter-2.50.ebuild: line 75: has_m32: command not found
* Your compiler seems to be unable to compile 32bit code.
* Make sure you compile gcc with:

* USE=multilib FEATURES=-sandbox

!!! ERROR: net-print/bjfilter-2.50 failed.
Call stack:
ebuild.sh, line 1542: Called dyn_setup
ebuild.sh, line 654: Called pkg_setup
bjfilter-2.50.ebuild, line 80: Called die

!!! Cannot produce 32bit code
!!! If you need support, post the topmost build error, and the call stack if relevant.
Back to top
View user's profile Send private message
ColinK
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2005
Posts: 142

PostPosted: Tue Apr 04, 2006 4:06 pm    Post subject: Reply with quote

I fixed some bugs. The ebuild in fact didn't copy all neccessary files. Now it does. :roll:

@Eugene33:
I removed the "has_m32"-check. So your last problem is gone now, too.

And I don't know if you really need a "USE=multilib FEATURES=-sandbox"-compiled gcc. I just studied what other ebuilds did to support AMD64. It might be possible that I misunderstood something. So you might try to switch back to your normal gcc-configuration. But you might try the new ebuild first. :)
Back to top
View user's profile Send private message
Eugene33
Apprentice
Apprentice


Joined: 14 Nov 2004
Posts: 167
Location: Lyon

PostPosted: Tue Apr 04, 2006 5:25 pm    Post subject: Reply with quote

:( :( sorry still the same
Quote:
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.6/../../../../x86_64-pc-linux-gnu/bin/ld: skipping incompatible /usr/lib/libcnbpcmcm218.so when searching for -lcnbpcmcm218
/usr/lib/gcc/x86_64-pc-linux-gnu/3.4.6/../../../../x86_64-pc-linux-gnu/bin/ld: cannot find -lcnbpcmcm218
collect2: ld returned 1 exit status
make[2]: *** [bjfilter] Error 1
make[2]: Leaving directory `/var/tmp/portage/bjfilter-2.50/work/bjfilter-2.50/pixusip3100/bjfilter/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/bjfilter-2.50/work/bjfilter-2.50/pixusip3100/bjfilter'
make: *** [all] Error 2

!!! ERROR: net-print/bjfilter-2.50 failed.
Call stack:
ebuild.sh, line 1526: Called dyn_compile
ebuild.sh, line 923: Called src_compile
bjfilter-2.50.ebuild, line 130: Called src_compile_pr
bjfilter-2.50.ebuild, line 226: Called die


And I guess there is an error line 37 with
Code:
amd64? (app-emulation/emul-[b]linux[/b]-x86-gtklibs)"
Back to top
View user's profile Send private message
ColinK
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2005
Posts: 142

PostPosted: Tue Apr 04, 2006 6:22 pm    Post subject: Reply with quote

Ok - I fixed the dependency - but I don't know if that will help. I actually don't think so.


I guess I could need some help by someone experienced with AMD64 ebuilds - or just someone with any idea regarding this bug.

help :(
Back to top
View user's profile Send private message
Eugene33
Apprentice
Apprentice


Joined: 14 Nov 2004
Posts: 167
Location: Lyon

PostPosted: Tue Apr 04, 2006 6:25 pm    Post subject: Reply with quote

I join you too, I put all my hope in you........ :wink: I know what a burden
Back to top
View user's profile Send private message
Tlaloc
Guru
Guru


Joined: 21 Feb 2005
Posts: 451
Location: Europe - Alps - Tyrol

PostPosted: Tue Apr 04, 2006 8:20 pm    Post subject: Reply with quote

I am on x86 and also have problems with libraries not found when emerging the model specific parts selected with the use flags. Here is the output:
Code:

Now type `make' to compile the package.
make  all-recursive
make[1]: Entering directory `/var/tmp/portage/bjfilter-2.50/work/bjfilter-2.50/pixusip3100/bjfilter'
Making all in src
make[2]: Entering directory `/var/tmp/portage/bjfilter-2.50/work/bjfilter-2.50/pixusip3100/bjfilter/src'
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include/cncl -I../include/misc    -O2 -MT bjferror.o -MD -MP -MF ".deps/bjferror.Tpo" -c -o bjferror.o bjferror.c; \
then mv -f ".deps/bjferror.Tpo" ".deps/bjferror.Po"; else rm -f ".deps/bjferror.Tpo"; exit 1; fi
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include/cncl -I../include/misc    -O2 -MT bjfilter.o -MD -MP -MF ".deps/bjfilter.Tpo" -c -o bjfilter.o bjfilter.c; \
then mv -f ".deps/bjfilter.Tpo" ".deps/bjfilter.Po"; else rm -f ".deps/bjfilter.Tpo"; exit 1; fi
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include/cncl -I../include/misc    -O2 -MT bjfimage.o -MD -MP -MF ".deps/bjfimage.Tpo" -c -o bjfimage.o bjfimage.c; \
then mv -f ".deps/bjfimage.Tpo" ".deps/bjfimage.Po"; else rm -f ".deps/bjfimage.Tpo"; exit 1; fi
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include/cncl -I../include/misc    -O2 -MT bjfoption.o -MD -MP -MF ".deps/bjfoption.Tpo" -c -o bjfoption.o bjfoption.c; \
then mv -f ".deps/bjfoption.Tpo" ".deps/bjfoption.Po"; else rm -f ".deps/bjfoption.Tpo"; exit 1; fi
bjfoption.c: In function `SetCmdOption':
bjfoption.c:546: warning: passing arg 3 of `poptGetContext' from incompatible pointer type
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include/cncl -I../include/misc    -O2 -MT bjfpos.o -MD -MP -MF ".deps/bjfpos.Tpo" -c -o bjfpos.o bjfpos.c; \
then mv -f ".deps/bjfpos.Tpo" ".deps/bjfpos.Po"; else rm -f ".deps/bjfpos.Tpo"; exit 1; fi
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include/cncl -I../include/misc    -O2 -MT bjfrcaccess.o -MD -MP -MF ".deps/bjfrcaccess.Tpo" -c -o bjfrcaccess.o bjfrcaccess.c; \
then mv -f ".deps/bjfrcaccess.Tpo" ".deps/bjfrcaccess.Po"; else rm -f ".deps/bjfrcaccess.Tpo"; exit 1; fi
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include/cncl -I../include/misc    -O2 -MT getipc.o -MD -MP -MF ".deps/getipc.Tpo" -c -o getipc.o getipc.c; \
then mv -f ".deps/getipc.Tpo" ".deps/getipc.Po"; else rm -f ".deps/getipc.Tpo"; exit 1; fi
if gcc -DHAVE_CONFIG_H -I. -I. -I.. -I../include/cncl -I../include/misc    -O2 -MT bjflist.o -MD -MP -MF ".deps/bjflist.Tpo" -c -o bjflist.o bjflist.c; \
then mv -f ".deps/bjflist.Tpo" ".deps/bjflist.Po"; else rm -f ".deps/bjflist.Tpo"; exit 1; fi
gcc  -O2   -o bjfilter -L../../218/libs_bin bjferror.o bjfilter.o bjfimage.o bjfoption.o bjfpos.o bjfrcaccess.o getipc.o bjflist.o -lcnbpcmcm218 -lcnbpess218 -lm -ldl -ltiff -lpng -lcnbpcnclapi218 -lcnbpcnclbjcmd218 -lcnbpcnclui218 -lpopt
/usr/lib/gcc/i686-pc-linux-gnu/3.4.5/../../../../i686-pc-linux-gnu/bin/ld: cannot find -lcnbpcmcm218
collect2: ld returned 1 exit status
make[2]: *** [bjfilter] Error 1
make[2]: Leaving directory `/var/tmp/portage/bjfilter-2.50/work/bjfilter-2.50/pixusip3100/bjfilter/src'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/bjfilter-2.50/work/bjfilter-2.50/pixusip3100/bjfilter'
make: *** [all] Error 2

!!! ERROR: net-print/bjfilter-2.50 failed.
Call stack:
  ebuild.sh, line 1526:   Called dyn_compile
  ebuild.sh, line 923:   Called src_compile
  bjfilter-2.50.ebuild, line 130:   Called src_compile_pr
  bjfilter-2.50.ebuild, line 226:   Called die

!!! Couldn't make pixusip3100/bjfilter
!!! If you need support, post the topmost build error, and the call stack if relevant.


Then there is a small dependency issue, as I think the monitor app needs gtk-1.2. I had only gtk-2.x.x installed and it wouldn't compile therefore.

Bye, Val.
Back to top
View user's profile Send private message
brot
Guru
Guru


Joined: 06 Apr 2004
Posts: 320

PostPosted: Tue Apr 04, 2006 9:19 pm    Post subject: Reply with quote

If i can help, i would, but i dont know if the Canon Pixima MP500 works with this driver.

http://www.precisionroller.com/find/canon+pixma+mp500+printhead+print+head+mp-500+mp+500.htm

does this link mean that it is ip4200 compatible ?

edit: i found some files that have ip4200 in their names. Maybe I may help adding support for the mp500


Last edited by brot on Tue Apr 04, 2006 9:29 pm; edited 1 time in total
Back to top
View user's profile Send private message
ColinK
Tux's lil' helper
Tux's lil' helper


Joined: 30 Dec 2005
Posts: 142

PostPosted: Tue Apr 04, 2006 9:22 pm    Post subject: Reply with quote

Ok thats actually good news because I've possibly got an explanation. :roll:

It doesn't seem to be related to AMD64 or not.

Ok I am now able to reproduce this problem.

And I solved it - the problem disapeared on my box.

I hope it will work now.
Back to top
View user's profile Send private message
Tlaloc
Guru
Guru


Joined: 21 Feb 2005
Posts: 451
Location: Europe - Alps - Tyrol

PostPosted: Wed Apr 05, 2006 7:46 am    Post subject: Reply with quote

The last ebuild you posted on bugs.gentoo.org compiles for me too now. Now I have to wait for the print server to arrive to actually test printing as I am too lazy to drag the printer around twice. 8) But I will report if it works or not. Ah, did you fix the dependency for gtk+-1.2 in the ebuild?
Bye, Val.

EDIT: I remembered that I could also print to the printer when it is attached to the windows box through samba, and voila, after some setup work it worked well at first glance. I tried only simple documents now, but setting the paper size and paper source worked through the kprint dialogue. :D

Bye and thanks, Val.
Back to top
View user's profile Send private message
Eugene33
Apprentice
Apprentice


Joined: 14 Nov 2004
Posts: 167
Location: Lyon

PostPosted: Wed Apr 05, 2006 11:16 am    Post subject: Reply with quote

Glad to hear it Tlaloc ;)
Well, sadly i tried the last version and, for me, there is no change. Still crashing for the same library with the same error message.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Unsupported Software All times are GMT
Goto page 1, 2, 3 ... 15, 16, 17  Next
Page 1 of 17

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum