Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[RISOLTO] Grave errore libexpat!
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian)
View previous topic :: View next topic  
Author Message
pjphem
n00b
n00b


Joined: 09 Feb 2006
Posts: 64

PostPosted: Thu Mar 30, 2006 4:42 pm    Post subject: [RISOLTO] Grave errore libexpat! Reply with quote

Code:

emanuele@cartina ~ $ firefox
No running windows found
/usr/lib/mozilla-firefox/firefox-bin: error while loading shared libraries: libexpat.so.0: cannot open shared object file: No such file or directory
firefox-bin exited with non-zero status (127)
emanuele@cartina ~ $



e

Code:

cartina ~ # locate libexpat
/opt/vmware/workstation/lib/lib/libexpat.so.0
/opt/vmware/workstation/lib/lib/libexpat.so.0/libexpat.so.0
/usr/lib/libexpat.so.0
/usr/lib/libexpat.a
/usr/lib/libexpat.so.0.5.0
/usr/lib/libexpat.la
/usr/lib/libexpat.so
/usr/src/vmware-distrib/lib/lib/libexpat.so.0
/usr/src/vmware-distrib/lib/lib/libexpat.so.0/libexpat.so.0
cartina ~ #         


idee? :(


Last edited by pjphem on Thu Mar 30, 2006 5:56 pm; edited 2 times in total
Back to top
View user's profile Send private message
nick_spacca
l33t
l33t


Joined: 29 May 2004
Posts: 689
Location: Paris/France

PostPosted: Thu Mar 30, 2006 4:56 pm    Post subject: Reply with quote

Hai gia provato a dare un:
Code:
revdep-rebuild -p
per vedere se ci sono librerie/programmi che vanno ricompilati a causa di dipendenze "rotte"

(ovviamente dopo che hai visto che prog vuole ricompilare devi togliere il -p per compilarli effettivamente... :wink: )
_________________
I can resist anything but temptation.
(O. Wilde)
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Thu Mar 30, 2006 4:56 pm    Post subject: Reply with quote

Ci ho aperto un bug.

Si tratta solo di una stupida libreria che sale diversione.
Ma purtroppo stragtegica, perché forza un revdep-rebuild colossale, con la ricompilazione di tutta kde e mezzo gnome - quasi una reinstallazione ex-novo.

Se non fai il revdep potrebbe non partire nemmeno X.

Comunque, dev-libs/expat è stata messa masked proprio per questa ragione. Se non hai voglia o tempo di affrontare la mega reistallazione, fai il downgrade alla versione 1.9*
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
federico
Advocate
Advocate


Joined: 18 Feb 2003
Posts: 3272
Location: Italy, Milano

PostPosted: Thu Mar 30, 2006 4:59 pm    Post subject: Reply with quote

Particolare pero' perche' ho avuto anche io questo problema e ho risolto sistemando link simbolici :

Code:

*  dev-libs/expat
      Latest version available: 2.0.0
      Latest version installed: 2.0.0
      Size of files: 1,320 kB
      Homepage:      http://expat.sourceforge.net/
      Description:   XML parsing libraries
      License:       as-is


Code:

blackman@altair ~ $ ls /usr/lib/*expa* -l
-rw-r--r-- 1 root root 161276 Mar 30 16:34 /usr/lib/libexpat.a
-rw-r--r-- 1 root root    793 Mar 30 16:34 /usr/lib/libexpat.la
lrwxrwxrwx 1 root root     17 Mar 30 16:34 /usr/lib/libexpat.so -> libexpat.so.1.5.0
lrwxrwxrwx 1 root root     17 Mar 30 16:38 /usr/lib/libexpat.so.0 -> libexpat.so.1.5.0
lrwxrwxrwx 1 root root     17 Mar 30 16:34 /usr/lib/libexpat.so.1 -> libexpat.so.1.5.0
-rwxr-xr-x 1 root root 130708 Mar 30 16:34 /usr/lib/libexpat.so.1.5.0


Fede
_________________
Sideralis www.sideralis.org
Pic http://blackman.amicofigo.com/gallery
Arduino http://www.arduino.cc
Chi aveva potuto aveva spaccato
2000 pezzi buttati là
Molti saluti,qualche domanda
Semplice come musica punk
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Thu Mar 30, 2006 5:18 pm    Post subject: Reply with quote

federico wrote:
Particolare pero' perche' ho avuto anche io questo problema e ho risolto sistemando link simbolici :

Anch'io ho fatto lo stesso, per i primi due giorni, altrimenti non funzionava nulla.

Ma ritengo che sia una soluzione comoda nell'immediato, ma pericolosa in prospettiva.
Credo infatti che i programmi compilati da ora in avanti saranno linkati alla librearia vecchia, pur utilizzando, di fatto, quella nuova.

Non credo che sia una condizione di lavoro salutare per una distribuzione così rapidamente in evoluzione come gentoo.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
lavish
Bodhisattva
Bodhisattva


Joined: 13 Sep 2004
Posts: 4296

PostPosted: Thu Mar 30, 2006 5:44 pm    Post subject: Reply with quote

cloc3, no nè un bug.. come è stato detto "basta" un revdep-rebuild

Enorme in questo caso, sì.. però poi va tutto bene :)
_________________
minimalblue.com | secgroup.github.io/
Back to top
View user's profile Send private message
pjphem
n00b
n00b


Joined: 09 Feb 2006
Posts: 64

PostPosted: Thu Mar 30, 2006 5:55 pm    Post subject: Reply with quote

risolto!

precisi e veloci come al solito :)

grazie.
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Thu Mar 30, 2006 8:02 pm    Post subject: Reply with quote

lavish wrote:
cloc3, no nè un bug.. come è stato detto "basta" un revdep-rebuild

Enorme in questo caso, sì.. però poi va tutto bene :)

Lo so che non è un bug. Ma meritava che qualcuno ci facesse un bug.

Il problema è che aggiornando quell'unica libreria, si tagliano le gambe a metà della distribuzione appena compilata, magari con un misero PIII in sette giorni di compilazione.
Per di più, l'ebuild non segnala neppure all'utente la necessità di fare un revdep-rebuild.

Ancora. Gli effetti dell'aggiornamento sono disastrosi. Se tu in quel momento stai usando konqueror, improvvisamente scopri che i cookies non funzionano più. Se chiudi kde, scopri che non riparte e puoi capire il problema solo da una lettura attenta dell'ouput di startx. Se hai lanciato X con kdm, ti crescia sotto il naso e devi scoprire il (non?) baco nei log di sistema.

Non è un caso se immeditamente dopo la mia segnalazione il pacchetto è ritornato da ~ a mask. Credo che i developer dovranno fare molta attenzione a preparare gli utenti alla transizione verso la nuova versione.

Secondo me, quello di expat è un esempio emblematico dei pregi e dei difetti di gentoo.
Da un lato opportunità di aggiornamento esasperato, dall'altro esigenze di stabilità.
Quasi quasi, perché non ce ne facciamo sopra un flame?
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
kaosone
Guru
Guru


Joined: 01 Feb 2004
Posts: 446

PostPosted: Thu Mar 30, 2006 8:29 pm    Post subject: Reply with quote

guarda che e' cosi' per il 99% delle librerie, non e' assolutamente un bug
Back to top
View user's profile Send private message
SonOfTheStage
n00b
n00b


Joined: 02 Mar 2004
Posts: 39
Location: Taranto - Italy

PostPosted: Thu Mar 30, 2006 8:37 pm    Post subject: Reply with quote

Perché dovremmo farne un flame scusa?

Se utilizzi ~arch sei consapevole che vai incontro a questi "problemi"...
_________________
Proud Gentoo GNU/Linux user
There's no place like ~
Back to top
View user's profile Send private message
cloc3
Advocate
Advocate


Joined: 13 Jan 2004
Posts: 4670
Location: http://www.gentoo-users.org/user/cloc3/

PostPosted: Fri Mar 31, 2006 9:51 am    Post subject: Reply with quote

SonOfTheStage wrote:
Perché dovremmo farne un flame scusa?

Certe osservazioni che ho fatto sono oggettivamente un flame, perché riguardano il senso della misura e non il significato tecnico di un fatto che è definibile in modo univoco.
D'altra parte, penso che un flame consapevole e strettamente attinente a gentoo possa essere sviluppato in maniera moderata, senza necessariamente scatenarsi in una rissa di opinioni.

La questione è che il rebuild è veramente molto grande.
Penso maggiore di quello per una transizione di gcc.

Eppure expat è una libreria tanto piccola. Immaginate se ce fossero molte così?
Per colmo, e quasi per beffa, è uscito la settimana prima della nuova versione di kde-3.5.2 ...
Non so voi, ma io mi sono sentito a un tratto la Principessa sul Pisello.

Vero è come voi dite, che in fondo "basta" un revdep-rebuild, ma anche questo genera in me stupore nel mettere in luce ad un tempo tutta la potenza e la fragilità degli strumenti di portage.
_________________
vu vu vu
gentù
mi piaci tu
Back to top
View user's profile Send private message
skakz
Guru
Guru


Joined: 03 Jul 2004
Posts: 380
Location: Ischia/Napoli/Italia/Terra

PostPosted: Fri Mar 31, 2006 10:02 am    Post subject: Reply with quote

bastava guardare alla fine dell'upgrade di expat..

Quote:
* Please note that the soname of the library changed!
* If you are upgrading from a previous version you need
* to fix dynamic linking inconsistencies by executing:
* revdep-rebuild --library libexpat.so.0

_________________
Linux Registered User n.340423
Linux User Group Ischia
www.tush.it
Back to top
View user's profile Send private message
Cazzantonio
Bodhisattva
Bodhisattva


Joined: 20 Mar 2004
Posts: 4489
Location: Somewere around the world

PostPosted: Fri Mar 31, 2006 12:25 pm    Post subject: Reply with quote

E' una cosa normale che talvolta (raramente per fortuna) un aggiornamento ci costringa a grandi ricompilazioni a catena... consolati del fatto che avviene di rado.
Ma è un aggiornamento di sicurezza o un normale aggiornamento? Perché nel secondo caso nessuno ti obbliga ad aggiornare...
_________________
Any man's death diminishes me, because I am involved in mankind, and therefore never send to know for whom the bell tolls; it tolls for thee
-John Donne
Back to top
View user's profile Send private message
Luca89
Advocate
Advocate


Joined: 27 Apr 2005
Posts: 2107
Location: Agrigento (Italy)

PostPosted: Fri Mar 31, 2006 1:22 pm    Post subject: Reply with quote

A quanto ho capito stai lavorando su un sistema completamente ~, quindi credo che non sei nella condizioni di poterti lamentare per queste cose, se hai scelto di utilizzare sempre pacchetti ~ devi capire che problemi di queste ce ne sono ora e ce ne saranno sempre, hai scelto tu di utilizzare pacchetti in testing, se non ti piace puoi sempre utilizzare stabile e starai più tranquillo.
_________________
Running Fast!
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Forum italiano (Italian) All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum