Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
qmailadmin problem
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Networking & Security
View previous topic :: View next topic  
Author Message
flow666
n00b
n00b


Joined: 01 Jul 2003
Posts: 74
Location: Diepholz

PostPosted: Sat Sep 18, 2004 10:27 am    Post subject: qmailadmin problem Reply with quote

Hi,

Ive installed a new mailserver with te howto in Documentation, Tips and Tricks (https://forums.gentoo.org/viewtopic.php?t=171499)

I want to access the qmailadmin frontend now, but it always says "Invalid Login".

I looked into the Apache error_log and it states the following there:

[Sat Sep 18 11:32:01 2004] [error] [client 10.100.0.7] vmysql: can't read settings from /var/vpopmail/etc/vpopmail.mysql, referer: http://10.100.0.108/cgi-bin/qmailadmin

I thought, the problem could be a wrong permission of that file, so i changed that to world readable for testing, but it didn't help. I found out that this file was a symbolic link to /etc/vpopmail.conf so i set that file world readable too. It didn't help either.

Google & the forum search didn't know an answer either.

Has anybody an idea?

Thanks,
flow
_________________
Ringwald's Gesetz der Haushaltsgeometrie:
"Alle horizontalen Flächen werden in kurzer Zeit mit Gerümpel bedeckt."
Back to top
View user's profile Send private message
Jabbas
n00b
n00b


Joined: 23 Jun 2003
Posts: 22
Location: Poland, Cracow

PostPosted: Sun Oct 24, 2004 10:46 pm    Post subject: Reply with quote

Hi!

You have wrong rights for qmailadmin binary in cgi-bin...

reemerge it or change it to that:

Code:
limper cgi-bin # ls -l /var/www/localhost/cgi-bin/qmailadmin
-rwsr-sr-x  1 vpopmail vpopmail 149512 pa¼ 25 00:35 /var/www/localhost/cgi-bin/qmailadmin


Suids for user, group and chown to vpopmail user and group.
_________________
Half my life is in books' written pages
Live and learn from fools and from sages
You know it's true
All the things you do, come back to you

Greetings!
JaBBaS
Back to top
View user's profile Send private message
enek
n00b
n00b


Joined: 17 Jan 2003
Posts: 15
Location: Edmonton

PostPosted: Tue Jan 10, 2006 5:16 am    Post subject: same problem Reply with quote

I have the same problem:

Code:
vmysql: can't read settings from /var/vpopmail/etc/vpopmail.mysql, referer: http://10.100.0.108/cgi-bin/qmailadmin


/cgi-bin/qmailadmin
is owned by vpopmail:vpopmail and my permissions are correct.

I also tried to emerge but that didn't help either. Does anyone else know what the problem could be?
_________________
Tied up in Knots
Back to top
View user's profile Send private message
enek
n00b
n00b


Joined: 17 Jan 2003
Posts: 15
Location: Edmonton

PostPosted: Tue Jan 10, 2006 5:52 am    Post subject: Solution Reply with quote

Here is one possible solution that works:

Quote:
QUICK NOTE : In order to use vpopmail or qmailadmin Apache must run as user vpopmail:vpopmail. You will need to edit your /etc/apache2/conf/commonapache.conf file to read

> User vpopmail
> Group vpopmail

and then restart apache with the command /etc/init.d/apache2 restart. Now back to our regularly scheduled programming.

Note This is likely to remove other apache functionality which relies on apache:apache for user:group. You are warned!


Personally I don't think this is a very good solution and would like to figure out why it isn't working correctly in the first place. I tried making all files readable by apache user but still couldn't get it to work without making apache start as vpopmail:vpopmail.
_________________
Tied up in Knots
Back to top
View user's profile Send private message
drJeckyll
n00b
n00b


Joined: 12 Sep 2003
Posts: 2

PostPosted: Sun Mar 26, 2006 9:44 am    Post subject: Reply with quote

nano -w /etc/group

find vpopmail:x:89:
and change it to
vpopmail:x:89:vpopmail,apache

restart apache then ... and whoala ...
Back to top
View user's profile Send private message
mephcpp
n00b
n00b


Joined: 17 Jul 2006
Posts: 1

PostPosted: Mon Jul 17, 2006 5:56 pm    Post subject: Reply with quote

hi! same problem here, the above I tried and not working, permissions are fine and I set up apache to be in vpopmail group and still it's not letting me in!
Back to top
View user's profile Send private message
kreep69
n00b
n00b


Joined: 30 Jun 2004
Posts: 8

PostPosted: Mon Jul 24, 2006 11:05 am    Post subject: Reply with quote

Check the permissions and ownership of /etc/vpopmail.conf

The file should be --

chmod 640 /etc/vpopmail.conf
chown root:vpopmail /etc/vpopmail.conf

That should fix it for you, if it does not also check /var/vpopmail/bin/vchkpw as that program should be --

-rws--x--x root:vpopmail vchkpw
_________________
/.kR
Back to top
View user's profile Send private message
cowgod
n00b
n00b


Joined: 31 Oct 2002
Posts: 34
Location: tucson, az

PostPosted: Mon Jan 28, 2008 12:24 am    Post subject: Reply with quote

i am having this same problem. help please!

here's all my relevant settings:

Code:
# ls -l /var/www/localhost/cgi-bin
-rwx--x--x 1 vpopmail vpopmail 145752 Jan 27 14:25 qmailadmin

# ls -l /etc/vpopmail.conf
-rw-r----- 1 root vpopmail 635 Jan 31  2008 /etc/vpopmail.conf

# ls -l /var/vpopmail/bin/vchkpw
-rws--x--x 1 root vpopmail 83368 Jan 31  2008 /var/vpopmail/bin/vchkpw

# cat /etc/group | grep vpopmail
vpopmail:x:89:vpopmail,apache


apache vhost config:
Code:
<VirtualHost *:80>
  ServerName mydomain.com
  DocumentRoot "/var/www/localhost/htdocs"

  ScriptAlias /cgi-bin/ /var/www/localhost/cgi-bin/
  <Directory "/var/www/localhost/htdocs">
    Options Indexes FollowSymLinks
    AllowOverride All
    Order allow,deny
    Allow from all
  </Directory>
  <Directory "/var/www/localhost/cgi-bin">
    Options +ExecCGI
    AllowOverride All
    Order allow,deny
    Allow from all
  </Directory>
</VirtualHost>


when i try to login, i get the following in the apache error_log:
Code:
[Sun Jan 27 17:14:42 2008] [error] [client x.x.x.x] mod_mime_magic: can't read `/var/www/localhost/cgi-bin/qmailadmin'
[Sun Jan 27 17:14:51 2008] [error] [client x.x.x.x] mod_mime_magic: can't read `/var/www/localhost/cgi-bin/qmailadmin', referer: http://mydomain.com/cgi-bin/qmailadmin
Back to top
View user's profile Send private message
cowgod
n00b
n00b


Joined: 31 Oct 2002
Posts: 34
Location: tucson, az

PostPosted: Tue Jan 29, 2008 7:27 am    Post subject: Reply with quote

i cannot this thing to work right. i simply do not understand how qmailadmin could possibly work straight out of the box.

if i change the "User" to "vpopmail" in my httpd.conf, everything works properly. however, i certainly don't want to run my whole web server as the vpopmail user.

instead, i have installed suexec and created a different virtual host specifically for qmailadmin. i set that virtual host to run as user/group vpopmail. i changed the vpopmail uid/gid to 9999 so that it can run without giving an error about having too low of an id. after all of this, i'm back at square one with an "Invalid Login" whenever i try to login.

why isn't this working? am i totally missing something obvious?
Back to top
View user's profile Send private message
Crymson
Apprentice
Apprentice


Joined: 21 Mar 2004
Posts: 200
Location: Flagstaff, AZ

PostPosted: Sun Apr 20, 2008 7:16 pm    Post subject: Reply with quote

I just wanted to say thanks for this thread - somehow my permissions got all screwed on my qmailadmin. Changing the owner to vpopmail:vpopmail and chmod 4755 on the qmailadmin file fixed the problems.

So, thanks to the submitters above!
_________________
Knowledge is Power // Power Corrupts // Study Hard // Be Evil
Back to top
View user's profile Send private message
dmittner
n00b
n00b


Joined: 28 Apr 2010
Posts: 2

PostPosted: Mon Jun 27, 2011 8:26 am    Post subject: Reply with quote

Ressurrecting something of an old thread but THANK YOU.

I was tweaking permissions, resetting passwords a dozen times, restarting every service I could think might matter.... except Apache. Restarted that and now it's working. The insanity can finally end...
Back to top
View user's profile Send private message
hnaparst
Apprentice
Apprentice


Joined: 27 Jul 2005
Posts: 215
Location: Hertfordshire, UK

PostPosted: Fri Aug 30, 2013 2:00 pm    Post subject: Reply with quote

Honestly, this is just way too hard. There are no useful error messages and guidance about what could be wrong. By randomly making changes to my system, all of which are clearly wrong, I am just introducing tons of security holes.

All of the features of qmailadmin are available at the command line from the directory /var/vpopmail/bin. Just execute the relevant commands there.
_________________
Harold Naparst
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Networking & Security All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum