Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Hotplugprobleem met USB iAudio X5 mediaspeler
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
Guytaar
n00b
n00b


Joined: 25 Feb 2006
Posts: 2

PostPosted: Sat Feb 25, 2006 11:47 am    Post subject: Hotplugprobleem met USB iAudio X5 mediaspeler Reply with quote

Beste allemaal,

Mijn opstelling is ruwweg als volgt:

Toshiba Satellite S1410-604 met daarop Gentoo, Mandriva, SuSE, Ubuntu en XP
LaCie Hard Drive USB 250G
iAudio X5 multimediaspeler 20G

Mandriva herkent bij hotpluggen probleemloos beide toestellen (icoontjes op bureaublad, kopiëren van en naar, etc.), Gentoo niet. Omdat ik meestal met Gentoo werk had ik dat liever anders gezien. Ik heb de tutorials over udev en USB auto-mounting (D-bus, HAL en ivman) uit Linux Format (lxf66 en lxf 73) uitgeprobeerd maar zonder veel resultaat. D-bus en HAL worden bij het booten gestart maar er gaat iets mis met ivman, daar krijg ik namelijk volgende foutmelding :

ivman

libhal.c 644 : Error connecting to system bus: Failed to connect to socket /usr/local/var/run/dbus/system_bus_socket: No such file or directory

** (process:8751): WARNING **: manager.c/656: Failed to initialize HAL!


locate system_bus_socket geeft volgend resultaat :

/var/lib/dbus/system_bus_socket

Moet ik gewoon de juiste directory aanmaken en die system_bus_socket verhuizen of is het niet zo simpel? Heb ik misschien teveel van beide tutorials gemengd?
In elk geval geeft udevtest /block/sda/sda1 dit resultaat:

version 045
looking at '/block/sda/sda1'
configured rule in '/etc/udev/rules.d/10-udev.rules' at line 5 applied, added symlink 'usb/iAudio_X5'
configured rule in '/etc/udev/rules.d/10-udev.rules' at line 5 applied, 'sda1' becomes '%k'
creating device node '/dev/sda1', major = '8', minor = '1', mode = '060660', uid = '0', gid = '6'


Mijn /etc/udev/rules.d/10-udev.rules:

# externe harde schijf LaCie 250GB
BUS="usb",KERNEL="sd[a-z]1",SYSFS{product}="LaCie Hard Drive USB",NAME="%k",SYMLINK="usb/lacie"

# mp3-speler iAudio X5
BUS="usb",KERNEL="sd[a-z]1",SYSFS{product}="iAUDIO X5",NAME="%k",SYMLINK="usb/iAudio_X5"

Dat ziet er redelijk goed uit en ik heb nu ook een /dev/usb/iAudio_X5 met een link naar /dev/sda1 maar ik krijg die op geen enkele manier gemount of geopend, noch in Konqueror, noch in een Konsole.

Voor de volledigheid geef ik nog de output van dmesg nadat ik mijn iAudio ingeplugd heb:

usb 1-2: new full speed USB device using uhci_hcd and address 3
scsi0 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 3
usb-storage: waiting for device to settle before scanning
Vendor: TOSHIBA Model: MK2006GAL Rev: BY30
Type: Direct-Access ANSI SCSI revision: 00
SCSI device sda: 39063024 512-byte hdwr sectors (20000 MB)
sda: assuming drive cache: write through
SCSI device sda: 39063024 512-byte hdwr sectors (20000 MB)
sda: assuming drive cache: write through
sda: sda1
Attached scsi disk sda at scsi0, channel 0, id 0, lun 0
Attached scsi generic sg0 at scsi0, channel 0, id 0, lun 0, type 0
usb-storage: device scan complete

Kan iemand mij op weg helpen om dit probleem op te lossen? Alvast bedankt voor de moeite.
Back to top
View user's profile Send private message
Q-collective
Advocate
Advocate


Joined: 22 Mar 2004
Posts: 2056

PostPosted: Sat Feb 25, 2006 1:12 pm    Post subject: Reply with quote

Probeer voor de verandering eens gnome-volume-manager?
Back to top
View user's profile Send private message
Guytaar
n00b
n00b


Joined: 25 Feb 2006
Posts: 2

PostPosted: Sun Feb 26, 2006 5:43 pm    Post subject: Reply with quote

Bedankt voor de tip maar het is mij intussen gelukt om het systeem aan de praat te krijgen.Bij het herlezen van mijn post viel ineens mijn oude gedevalueerde frank: misschien lukt het wel met een link van /usr/local/var/run/dbus/system_bus_socket naar /var/lib/dbus/system_bus_socket ...

En ja hoor.

Toch bedankt voor de poging tot assistentie.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum