Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Sound problems continue (Was: AWE 64)
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware
View previous topic :: View next topic  
Author Message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16137
Location: Colorado

PostPosted: Tue May 07, 2002 8:29 pm    Post subject: Sound problems continue (Was: AWE 64) Reply with quote

Me again :D

I installed an AWE64 and now I get a hissing noise when I start Gnome (I'm assuming because it loads sound driver automatically).
The hissing goes away if I reboot, but I'd like to turn it "off" manually instead of rebooting, any ideas?


Last edited by pjp on Wed May 08, 2002 3:26 am; edited 1 time in total
Back to top
View user's profile Send private message
friedmud
Apprentice
Apprentice


Joined: 18 Apr 2002
Posts: 258
Location: Austin, TX USA

PostPosted: Tue May 07, 2002 8:31 pm    Post subject: Try.... Reply with quote

Try using "lsmod" to see what modules you have loaded.

Then you can use "rmmod" to remove a module from memory and "modprobe" to turn it back on again.

Derek
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16137
Location: Colorado

PostPosted: Tue May 07, 2002 9:06 pm    Post subject: Reply with quote

I get Device or resource busy errors. Guess I should just work on getting it configured properly.
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16137
Location: Colorado

PostPosted: Wed May 08, 2002 1:55 am    Post subject: Reply with quote

Code:
insmod sb io=0x220 irq=5 dma=3 dma16=6 mpu_io=0x330
Using /lib/modules/2.4.19-r1/kernel/drivers/sound/sb.o
/lib/modules/2.4.19-r1/kernel/drivers/sound/sb.o: unresolved symbol sb_dsp_detect_Rsmp_d8a2731c
/lib/modules/2.4.19-r1/kernel/drivers/sound/sb.o: unresolved symbol sb_dsp_init_Rsmp_e986438b
/lib/modules/2.4.19-r1/kernel/drivers/sound/sb.o: unresolved symbol sb_dsp_unload_Rsmp_c4884969
/lib/modules/2.4.19-r1/kernel/drivers/sound/sb.o: unresolved symbol unload_sbmpu_Rsmp_74afd69c
/lib/modules/2.4.19-r1/kernel/drivers/sound/sb.o: unresolved symbol smw_free_Rsmp_450f9aea
/lib/modules/2.4.19-r1/kernel/drivers/sound/sb.o: unresolved symbol probe_sbmpu_Rsmp_ddc8ad00


Does that mean anything to anyone?
Back to top
View user's profile Send private message
Mr. Atoz
Tux's lil' helper
Tux's lil' helper


Joined: 06 May 2002
Posts: 84
Location: Colorado

PostPosted: Wed May 08, 2002 2:35 pm    Post subject: Reply with quote

Unresolved Symbols _usually_ means (in my experience) some dependancie(s) didn't get compiled or compiled correctly. It appears you are using the Linux Kernel sound drivers. Can you switch to ALSA? Or are you using the Kernel drivers for a specific reason?

To use the current version of ALSA, 0.9x, all you need compiled in the kernel or as a module is sound support; you don't need to select ANY drivers,
_________________
---Atoz
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16137
Location: Colorado

PostPosted: Wed May 08, 2002 7:04 pm    Post subject: Reply with quote

Mr. Atoz wrote:
Unresolved Symbols _usually_ means (in my experience) some dependancie(s) didn't get compiled or compiled correctly. It appears you are using the Linux Kernel sound drivers. Can you switch to ALSA? Or are you using the Kernel drivers for a specific reason?

To use the current version of ALSA, 0.9x, all you need compiled in the kernel or as a module is sound support; you don't need to select ANY drivers,


I think I had already tried what you suggested, but I'm not positive, so I just did it. Under sound, this is the only option I selected: <*> Sound card support

Now, when I start Gnome, i see an error about not being able to open a device (or something similar). I am in the audio group.

I am totally lost and confused on setting up sound... I just don't get it.
Back to top
View user's profile Send private message
arkane
l33t
l33t


Joined: 30 Apr 2002
Posts: 918
Location: Phoenix, AZ

PostPosted: Wed May 08, 2002 7:12 pm    Post subject: Reply with quote

Did you select the AWE32 Synth in the module and read the install doc that the kernel help file told ya too? Just wondering.

--
Dan
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16137
Location: Colorado

PostPosted: Wed May 08, 2002 7:20 pm    Post subject: Reply with quote

arkane wrote:
Did you select the AWE32 Synth in the module and read the install doc that the kernel help file told ya too? Just wondering.

--
Dan


Is that not a kernel module that Mr. Atoz said to not use? I have done what you suggested without luck. My problem is I've just gotten confused with
everything I've read. I don't know which way is up :). Previously I had the following selected:
<*> Sound card support
<M> OSS sound modules
[*] Verbose initialization
[*] Persistant DMA buffers
<M> 100% Sound Blaster Compatibles
<M> AWE32 Synth

With that setup, I was able to get hissing noise but no sound. gmix would load and control volume of the hiss, but thats about it.
Back to top
View user's profile Send private message
arkane
l33t
l33t


Joined: 30 Apr 2002
Posts: 918
Location: Phoenix, AZ

PostPosted: Wed May 08, 2002 7:47 pm    Post subject: Reply with quote

kanuslupus wrote:
arkane wrote:
Did you select the AWE32 Synth in the module and read the install doc that the kernel help file told ya too? Just wondering.

--
Dan


Is that not a kernel module that Mr. Atoz said to not use? I have done what you suggested without luck. My problem is I've just gotten confused with
everything I've read. I don't know which way is up :). Previously I had the following selected:
<*> Sound card support
<M> OSS sound modules
[*] Verbose initialization
[*] Persistant DMA buffers
<M> 100% Sound Blaster Compatibles
<M> AWE32 Synth

With that setup, I was able to get hissing noise but no sound. gmix would load and control volume of the hiss, but thats about it.


Okay... hmm... I was just checking to see if that worked or not.. never hurts to try :)
Back to top
View user's profile Send private message
Mr. Atoz
Tux's lil' helper
Tux's lil' helper


Joined: 06 May 2002
Posts: 84
Location: Colorado

PostPosted: Thu May 09, 2002 10:30 pm    Post subject: Setting up ALSA Reply with quote

Yes, to use ALSA, you ONLY need to select sound support in the kernel. I always do it a a module so I can see it is loaded. You should review Section 3 of the Desktop Configuration Guide. The discuss setting up ALSA here. It is slightly out of date, since Gentoo moved to ALSA 0.9x. Basically don't setup the aliases in /etc/modules.d/aliases. The have moved to /etc/modules.d/alsa. Also drop the "card" out of the module names.

Also, read up on ALSA . Try this link first. http://www.alsa-project.org/~valentyn/Alsa-sound-mini-HOWTO-5.html#ss5.2

I believe the driver you're looking for is going to be "snd-sb16", which supports the AWE cards. So, to sum it all up, here is what I would try:

    1 - emerge rsync
    2 - emerge alsa-utils (This will get you ALSA, ALSA Libraries, and ALSA Utilities
    3 - Edit the /etc/modules.d/alsa to look similar to the folowing.
    Code:

    ##  ALSA portion
    alias char-major-116 snd
    alias snd-card-0 snd-sb16
    alias snd-card-1 snd-sb16
    alias snd-card-2 snd-sb16
    alias snd-card-3 snd-sb16
    alias snd-card-4 snd-sb16
    alias snd-card-5 snd-sb16
    alias snd-card-6 snd-sb16
    alias snd-card-7 snd-sb16

    ##  OSS/Free portion
    alias  char-major-14     soundcore
    alias sound-slot-0 snd-card-0

    # OSS/Free portion - card #1
    alias sound-service-0-0 snd-mixer-oss
    alias sound-service-0-1 snd-seq-oss
    alias sound-service-0-3 snd-pcm-oss
    alias sound-service-0-8 snd-seq-oss
    alias sound-service-0-12 snd-pcm-oss

    4 - Run rc-update add alsasound default
    5 - Reboot (and cross fingers for no errors when it starts ALSA. if you get errors be sure to post them here.)
    6 - Run alsamixer
    7 - Unmute Master, HeadPhones, PCM, and CD and crank the volume up on all of them
    8 - In another shell, use aplay to play a WAV or mp3 file. With any luck, you have sound!!
    9 - Adjust your volumes using alsamixer to your taste. Hit ESC to exit
    10 - Run /etc/init.d/alsasound stop & then /etc/init.d/alsasound start to save your volume settings. (Or just reboot)


Hope this helps....
_________________
---Atoz
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16137
Location: Colorado

PostPosted: Fri May 10, 2002 4:29 am    Post subject: Reply with quote

Naturally I tried your suggestion before reading the online documentation you referenced :).
I made it all the way to step 6 which is running alsamixer which reports:
Code:
amixer: Mixer attach default error: No such file or directory

While installing the alsa stuff, I noticed something refer to a documentation file for the alsa driver. After looking at it, I think I may need isapnptools.
I have yet to figure out how to configure that file. After reading the website you mentioned, I noticed some settings for IRQ & DMA... maybe I need that part.

Also, during boot I see this:
Code:
Starting sound driver: sb modprobe: Can't locate module sb [ok]
Starting sound driver: sb modprobe: Can't locate module sb [ok]
Starting sound driver: sb modprobe: Can't locate module sb [ok]
Starting sound driver: sb modprobe: Can't locate module sb [ok]
Starting sound driver: sb modprobe: Can't locate module sb [ok]
Starting sound driver: sb modprobe: Can't locate module sb [ok]
Starting sound driver: sb modprobe: Can't locate module sb [ok]
Starting sound driver: sb modprobe: Can't locate module sb [ok]

I'm assuming that comes from modules.conf, but when I try to modify the following lines, the changes don't save.
Code:
alias snd-card-0 sb
.
.
alias snd-card-7 sb

Naturally I still get the error about the sound device when starting Gnome. gmix does load though.
Back to top
View user's profile Send private message
jay
l33t
l33t


Joined: 08 May 2002
Posts: 980

PostPosted: Mon May 13, 2002 7:30 pm    Post subject: Reply with quote

you may want to check this out. had the same problem:

https://forums.gentoo.org/viewtopic.php?t=2297&highlight=alsa
_________________
Do you want your posessions identified? [ynq] (n)
Back to top
View user's profile Send private message
Lactic
n00b
n00b


Joined: 18 Jun 2002
Posts: 34
Location: Earth [Minneapolis]

PostPosted: Fri Jun 21, 2002 11:59 pm    Post subject: Re: Setting up ALSA Reply with quote

Mr. Atoz wrote:

...

## OSS/Free portion
alias char-major-14 soundcore
alias sound-slot-0 snd-card-0
Code:

# OSS/Free portion - card #1
alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

4 - Run rc-update add alsasound default
5 - Reboot (and cross fingers for no errors when it starts ALSA. if you get errors be sure to post them here.)


The first time I rebooted, my NVdriver & alsa modules did not load. When I tried to check it out or do a modprobe snd-cmipci or some-such, I got an error,
Code:
Invalid line in /etc/modules.conf
 **


It turned out that in my /etc/modules.d/alsa, I had a second line under "## OSS/Free portion", "** alias sound-slot-1 snd-card-1". Once I removed the stars, it was fine. (I assume I can remove the line altogether, as well). Just thought I'd post my error...and thanks for the instructions!
Back to top
View user's profile Send private message
Xamot
n00b
n00b


Joined: 20 May 2002
Posts: 29

PostPosted: Wed Jun 26, 2002 10:25 pm    Post subject: Reply with quote

kanuslupus wrote:

Code:
alias snd-card-0 sb
.
.
alias snd-card-7 sb

Naturally I still get the error about the sound device when starting Gnome. gmix does load though.


I think instead of sb you should be using snd-sbawe. That is the alsa driver instead of the kernel driver (sb). I just got mine setup that way (over ssh) so I'm heading home to test it out :) But "/etc/init.d/alsasound start" worked fine.

Thanks for all the great info guys.

Update: Everything worked great. Can we do anything about getting the Desktop guide updated with this information?


Last edited by Xamot on Thu Jun 27, 2002 1:58 pm; edited 1 time in total
Back to top
View user's profile Send private message
pjp
Administrator
Administrator


Joined: 16 Apr 2002
Posts: 16137
Location: Colorado

PostPosted: Wed Jun 26, 2002 11:24 pm    Post subject: Reply with quote

Thanks for the tip, but I gave up long ago... I found a PnP card that I got working.
_________________
lolgov. 'cause where we're going, you don't have civil liberties.

In Loving Memory
1787 - 2008
Back to top
View user's profile Send private message
klieber
Administrator
Administrator


Joined: 17 Apr 2002
Posts: 3657
Location: San Francisco, CA

PostPosted: Thu Jun 27, 2002 1:09 am    Post subject: Reply with quote

moving this to the hardware forum...

--kurt
_________________
The problem with political jokes is that they get elected
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Kernel & Hardware All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum