Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
problems with modprobing drivers
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo
View previous topic :: View next topic  
Author Message
TheCoop
Veteran
Veteran


Joined: 15 Jun 2002
Posts: 1814
Location: Where you least expect it

PostPosted: Wed Jun 26, 2002 2:52 pm    Post subject: problems with modprobing drivers Reply with quote

ok, so im trying to get the sound running on my box, so i follow the instructions on the desktop config guide

i compile the base sound module (soundcore) and the sound card specific module under that (snd-ens1371), and after saving it i run make dep, and reboot

when i try to modprobe the drivers in it says it can't find snd-ens1371 or snd-pcm-oss (soundcore modprobes ok), so i go back and check ive got the correct names etc etc, and then i again run make dep, then make modules and make modules_install just to make sure the modules are in the correct places and compiled.

Yet it still says it cant find the snd-ens1371 or snd-pcm-oss modules. What am I doing wrong?
Back to top
View user's profile Send private message
Utoxin
Guru
Guru


Joined: 19 Apr 2002
Posts: 411
Location: Springville, UT

PostPosted: Wed Jun 26, 2002 2:54 pm    Post subject: Reply with quote

Make /SURE/ they're going into the right kernel folder in /lib/modules/*. I've had this problem many times, and it was always because they were going to the wrong folder.
_________________
Gentoo:
1. A small fast penguin from Antarctica.
2. A small fast penguin on your computer.

Cool.
Back to top
View user's profile Send private message
TheCoop
Veteran
Veteran


Joined: 15 Jun 2002
Posts: 1814
Location: Where you least expect it

PostPosted: Wed Jun 26, 2002 3:21 pm    Post subject: Reply with quote

ive checked that, es1371.o is in /lib/modules/..../sound

however, snd-pcm-oss doesnt exist at all in /lib/modules/*, and now when i try to modprobe the module i get:

/lib/modules/..../sound/es1371.o: init_module: No such device
...
insmod es1371 failed

(i also get the same message when i try to load the rivafb module)

ive looked in /dev, and ive noticed that there are no directories in there, even though ive enabled the /dev/filesystem, and devfsd is loading ok at startup. What is going on?
Back to top
View user's profile Send private message
AutoBot
l33t
l33t


Joined: 22 Apr 2002
Posts: 968
Location: Usually Out

PostPosted: Wed Jul 10, 2002 4:08 am    Post subject: Reply with quote

TheCoop wrote:
ive checked that, es1371.o is in /lib/modules/..../sound

however, snd-pcm-oss doesnt exist at all in /lib/modules/*, and now when i try to modprobe the module i get:

/lib/modules/..../sound/es1371.o: init_module: No such device
...
insmod es1371 failed

(i also get the same message when i try to load the rivafb module)

ive looked in /dev, and ive noticed that there are no directories in there, even though ive enabled the /dev/filesystem, and devfsd is loading ok at startup. What is going on?


Try dmesg | grep rivafb and see if your getting some boot time issue.
_________________
This message self destructed a long time ago.
Back to top
View user's profile Send private message
BonezTheGoon
Bodhisattva
Bodhisattva


Joined: 14 Jun 2002
Posts: 1375
Location: Albuquerque, NM -- birthplace of Microsoft and Gentoo

PostPosted: Wed Jul 10, 2002 9:28 pm    Post subject: Reply with quote

I had a peculiar issue when I was trying to modpobe snd-pcm-oss that I had to overcome by modprobe(ing) some "pre-requisites" if you will -- Check out the thread that talks about it here -----> https://forums.gentoo.org/viewtopic.php?t=5453&highlight= Its currently the last post in the thread. I hope that helps!! Please be sure to post your results for others (and so I know if it was worthless to you so I will stop mentioning it to other people too).

Good luck!!!

Regards,
BonezTheGoon
_________________
mcgruff wrote:
I can't promise to be civil.


pjp wrote:
The greater evil is voting for the "lesser evil."
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Other Things Gentoo All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum