Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xpdf / poppler dependency problem
View unanswered posts
View posts from last 24 hours

Goto page 1, 2  Next  
Reply to topic    Gentoo Forums Forum Index Portage & Programming
View previous topic :: View next topic  
Author Message
asiobob
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1375
Location: Bamboo Creek

PostPosted: Wed Dec 28, 2005 8:47 am    Post subject: xpdf / poppler dependency problem Reply with quote

Greetings,

I've having a wierd dependancy issue...when i run emerge world -uvaD

Code:

Calculating world dependencies ...done!
[blocks B     ] <app-text/xpdf-3.01-r4 (is blocking app-text/poppler-0.4.3-r1)
[ebuild  N    ] app-text/xpdf-3.01-r3  +X +motif 0 kB


The issue is I do NOT have xpdf installed at all!

Code:

 emerge -C xpdf
>>> unmerge: No packages selected for removal.one!
[blocks B     ] <app-text/xpdf-3.01-r4 (is blocking app-text/poppler-0.4.3-r1)
[ebuild  N    ] app-text/xpdf-3.01-r3  +X +motif 0 kB


ideas?
Back to top
View user's profile Send private message
John-Boy
Guru
Guru


Joined: 23 Jun 2004
Posts: 442
Location: Desperately seeking moksha in all the wrong places

PostPosted: Wed Dec 28, 2005 8:53 am    Post subject: Reply with quote

I've got the same issue, I do have xpdf installed, a swift uninstall doesn't cure the prob either.
_________________
Like the Roman, I seem to see "the River Tiber foaming with much blood"
Back to top
View user's profile Send private message
apache2
n00b
n00b


Joined: 06 Jun 2005
Posts: 12

PostPosted: Wed Dec 28, 2005 8:57 am    Post subject: yeah Reply with quote

Hey guys, I have this problem too in a world update...... and I really need to get it fixed so I can continue....... anyone have an y ideas?
Back to top
View user's profile Send private message
asiobob
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1375
Location: Bamboo Creek

PostPosted: Wed Dec 28, 2005 9:13 am    Post subject: Reply with quote

bug posted: 116957

Last edited by asiobob on Wed Dec 28, 2005 9:23 am; edited 1 time in total
Back to top
View user's profile Send private message
apache2
n00b
n00b


Joined: 06 Jun 2005
Posts: 12

PostPosted: Wed Dec 28, 2005 9:16 am    Post subject: Reply with quote

good I was just about to check out bugzilla
Back to top
View user's profile Send private message
apache2
n00b
n00b


Joined: 06 Jun 2005
Posts: 12

PostPosted: Wed Dec 28, 2005 9:18 am    Post subject: solution Reply with quote

found a quick get around.........
just put 'app-text/xpdf' into package.keywords and you should be good to go
Back to top
View user's profile Send private message
asiobob
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1375
Location: Bamboo Creek

PostPosted: Wed Dec 28, 2005 9:22 am    Post subject: Reply with quote

Good catch, it makes since app-text/xpdf-3.01-r4 is still in ~arch!

EDIT: I'm making a mess of my self on the bugzilla report!!

The blocker is not on the entire package, just for versions below a certain version. Hence apache2's suggestion isn't a quick work around, it is the solution because the required version of xpdf to satisfy not being blocked is stll marked as ~arch. And in that sense only considering poppler and xpdf there is no requirement (yet) for xpdf to be marked stable since basically the lastest version of poppler mentioned in this post is also ~arch
Back to top
View user's profile Send private message
apache2
n00b
n00b


Joined: 06 Jun 2005
Posts: 12

PostPosted: Wed Dec 28, 2005 10:18 am    Post subject: Reply with quote

heheheh, least we found the problem, now I can finally update my world :D

have fun,
apache2
Back to top
View user's profile Send private message
_Seth_
Guru
Guru


Joined: 15 Sep 2004
Posts: 539
Location: encore paumé dans un labo ;)

PostPosted: Wed Dec 28, 2005 3:09 pm    Post subject: Reply with quote

hi !
I feel dumb but i'm in ~arch and i have the same "emerge --deep" problem. If i put :
Code:
echo "app-text/xpdf ~x86" >> /etc/portage/package.keywords

or
Code:
echo "app-text/xpdf x86" >> /etc/portage/package.keywords

nothing change, emerge ends with the same error.
I'm sorry but i don't understand the point of the apache2's solution :? Are you guys in arch and putting xpdf in ~arch fixes the problem ?
Thanx ;)
_________________
no tears to cry, no feelings left
the species has amused itself to death
amused itself to death
Back to top
View user's profile Send private message
jkressin
n00b
n00b


Joined: 23 Sep 2004
Posts: 8

PostPosted: Wed Dec 28, 2005 4:04 pm    Post subject: Reply with quote

I have this same problem. I read thru the bug log, and they seem to to imply that if you use both the ~x86 version of poppler and xpdf, it should all work. I think the whole logic of using '!<' for not less then a specific version number does not work the way the ebuild creator thinks it does.

I made an overlay copy of poppler where that dependency line is changed to >=app-text/xpdf-3.01-r4

Everything runs fine with this change.

Hopefully they make the correction in portage.

Thanks,
Jonathan
Back to top
View user's profile Send private message
yamakawa
Guru
Guru


Joined: 28 Jul 2003
Posts: 340

PostPosted: Wed Dec 28, 2005 4:46 pm    Post subject: Reply with quote

If modifying the ebuild file of poppler is not definitely discouraged, why not
Code:
# vim /usr/portage/app-text-poppler/poppler-0.4.3-r1
(Edit RDEPEND line: !<app-text/xpdf-3.01-r4  to >=app-text/xpdf-3.01-r4)
# emerge -u app-text/xpdf
# rm /usr/portage/app-text/poppler/files/digest-poppler-0.4.3-r1
# ebuild /usr/portage/app-text/poppler/poppler-0.4.3-r1.ebuild digest
# emerge -u app-text/poppler
and make yourself :D ?
The developpers will fix the file anyway. :)
Back to top
View user's profile Send private message
asiobob
Veteran
Veteran


Joined: 29 Oct 2003
Posts: 1375
Location: Bamboo Creek

PostPosted: Wed Dec 28, 2005 7:47 pm    Post subject: Reply with quote

I'm in ~arch for gnome 2.12 packages. Hence Poppler is also in ~arch. Untill the other day I was on stable for xpdf but since then a new poppler ebuild was placed into the tree and it had a xpdf version restriction. So anything BELOW app-text/xpdf-3.01-r4 should be blocked. BUT I'm running stable with selected packages as ~arch and xpdf-3.01-r4 is ~arch but I never had it it in packages.keywords (since I had no reason to, untill now).

By putting xpdf-3.01-r4 in packages.keywords we are allowing to be installed, and by doing this we satisfy the requirement of anything "less" than version xpdf-3.01-r4 blocked. Now since we are greater that the version to be blocked we are fine.

I hope that makes sense. If this version of poppler gets marked stable, xpdf would also have to get marked stable otherwise the entire gentoo "mob" would be posting a problem similiar to this.
Back to top
View user's profile Send private message
omp
Retired Dev
Retired Dev


Joined: 10 Sep 2005
Posts: 1018
Location: Glendale, California

PostPosted: Thu Dec 29, 2005 10:09 am    Post subject: Reply with quote

Hmm... I too have this problem.
_________________
meow.
Back to top
View user's profile Send private message
Naib
Watchman
Watchman


Joined: 21 May 2004
Posts: 5707
Location: Removed by Neddy

PostPosted: Thu Dec 29, 2005 11:20 am    Post subject: Reply with quote

same probe here,
un-arching XPDF works tho for me
_________________
The best argument against democracy is a five-minute conversation with the average voter
Great Britain is a republic, with a hereditary president, while the United States is a monarchy with an elective king
Back to top
View user's profile Send private message
TheDebugger
Apprentice
Apprentice


Joined: 30 Aug 2005
Posts: 159
Location: Germany

PostPosted: Thu Dec 29, 2005 11:56 am    Post subject: Reply with quote

Ok, who's insane now? Seems to be me ...

I got the same problem as everyone else, but the proposed solution doesn't work.

Adding "app-text/xpdf ~x86" to package.keywords results in the same blocker message as without:
Code:

$> grep xpdf /etc/portage/package.keywords
#  app-text/xpdf           ~x86
$> emerge --ask --verbose --update --deep --newuse world

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[blocks B     ] <app-text/xpdf-3.01-r4 (is blocking app-text/poppler-0.4.3-r1)
...
[ebuild     U ] app-text/poppler-0.4.3-r1 [0.4.3] -cairo +gtk +jpeg +qt +zlib 45 kB
...
!!! Error: The above package list contains packages which cannot be installed
!!!        on the same system.

Uncommenting that entry in package.keywords
Code:

$> grep xpdf /etc/portage/package.keywords
app-text/xpdf           ~x86
$> emerge --ask --verbose --update --deep --newuse world

These are the packages that I would merge, in order:

Calculating world dependencies ...done!
[blocks B     ] <app-text/xpdf-3.01-r4 (is blocking app-text/poppler-0.4.3-r1)
[ebuild     U ] app-text/poppler-0.4.3-r1 [0.4.3] -cairo +gtk +jpeg +qt +zlib 45 kB
...
!!! Error: The above package list contains packages which cannot be installed
!!!        on the same system.

Also nice, if only xpdf is unmasked, but poppler isn't ...
Code:

$> grep xpdf /etc/portage/package.keywords
app-text/xpdf           ~x86
$> grep poppler /etc/portage/package.keywords
# app-text/poppler         ~x86
$> emerge --ask --verbose --update --deep --newuse world

These are the packages that I would merge, in order:

Calculating world dependencies /
!!! All ebuilds that could satisfy ">=app-text/poppler-0.4.3-r1" have been masked.
!!! One of the following masked packages is required to complete your request:
- app-text/poppler-0.4.3-r1 (masked by: ~x86 keyword)

!!!    (dependency required by "app-text/xpdf-3.01-r4" [ebuild])


Any ideas?
Back to top
View user's profile Send private message
Peach
Advocate
Advocate


Joined: 08 Mar 2003
Posts: 3686
Location: London, UK

PostPosted: Thu Dec 29, 2005 1:19 pm    Post subject: Reply with quote

I've solved this way:
unmasked both poppler and xpdf as previously noticed before in this thread
then unmerged xpdf, and reemerged it

the problem is that poppler can't install if there's xpdf, and xpdf can't upgrade if there's old poppler. or something like this.
in other words a reverse dependencies problem..
_________________
Gentoo user since 2004.
"It's all fun and games, until someone loses an eye" - mom
Back to top
View user's profile Send private message
TheDebugger
Apprentice
Apprentice


Joined: 30 Aug 2005
Posts: 159
Location: Germany

PostPosted: Thu Dec 29, 2005 2:30 pm    Post subject: Reply with quote

Peach wrote:

unmasked both poppler and xpdf as previously noticed before in this thread
then unmerged xpdf, and reemerged it


I didn't dare to unmerge xpdf in the first place, but I found that `equery depends xpdf` was empty. Therefore, unmerging xpdf allows poppler as well as xpdf to upgrade (it is pulled in again, most likely a virtual dependance?!) -- seems to work now. Thanks.

Hint: xpdf doesn't have a motif-USE-flag any more, now it's USE=X ... if one diabled motif before (as I did), one now has to disable the X-flag ...
Back to top
View user's profile Send private message
Cintra
Advocate
Advocate


Joined: 03 Apr 2004
Posts: 2111
Location: Norway

PostPosted: Fri Dec 30, 2005 3:53 pm    Post subject: Reply with quote

ASIO_BOB wrote:
bug posted: 116957

doesn't look as though they are doing much with it.

In the meantime I've masked the poppler and cups updates with..
Code:
>app-text/poppler-0.4.3
>net-print/cups-1.1.23-r6


Edit: also followed yamakawa's solution and brought cups up to date
_________________
"I am not bound to please thee with my answers" W.S.


Last edited by Cintra on Fri Dec 30, 2005 8:57 pm; edited 2 times in total
Back to top
View user's profile Send private message
doalwa
Tux's lil' helper
Tux's lil' helper


Joined: 03 Mar 2003
Posts: 130
Location: Old Europe

PostPosted: Fri Dec 30, 2005 8:39 pm    Post subject: Reply with quote

Had the same problem and solved it by following yamakawa's tip...probably not the best solution, but it was quick and dirty, and it worked just fine :-)
_________________
Keepin' the Funk alive since 1983!
Back to top
View user's profile Send private message
mlybarger
Guru
Guru


Joined: 04 Sep 2002
Posts: 463

PostPosted: Wed Jan 04, 2006 11:58 am    Post subject: Reply with quote

i also updated the poppler ebuild. and it seems to be working. somebody with cvs access seems to have left some christmas presents for all to enjoy.
Back to top
View user's profile Send private message
kroenecker
n00b
n00b


Joined: 10 Aug 2005
Posts: 64

PostPosted: Fri Jan 13, 2006 8:11 pm    Post subject: Reply with quote

Yamakawas method worked. My question is why isn't !< equivalent to >=
Back to top
View user's profile Send private message
lion1977
n00b
n00b


Joined: 21 Nov 2005
Posts: 5
Location: Linz, Austria

PostPosted: Sat Jan 14, 2006 12:18 am    Post subject: Reply with quote

Hello,

I got around the problem by removing app-text/xpdf-3.01-r1 and installing the new version 3.01-r5. Poppler doesn't like xpdf below 3.01-r4 but even this version requires poppler to be installed. Portage can't handle this at the moment. It doesn't reconize that if both packages would be installed at one time the blocking package would be removed.

There is difference between !< and >= in portage. As logical operator they would be equivalent but this is bit related to set theory.
!< meens the a version below that one must not be installed
>= meens a version equal or greater must be installed
The !< is satified even if xpdf is not installed, the second condition not.

Bye
Back to top
View user's profile Send private message
WaTcHmE
n00b
n00b


Joined: 18 Aug 2004
Posts: 36

PostPosted: Sat Jan 14, 2006 11:26 am    Post subject: Reply with quote

I dont get it :D

where is the Problem?

I wanted to emerge world, but my machine showed me the known poppler <> xpdf dependency problem. I searched and found the new xpdf version in the tree. Then I just unmerged xpdf, and then emerged it again.
now I have the newest Version of poppler _and_ xpdf on my machine without much trouble :D

cya

WaTcHmE
_________________
It doesnt matter how to pronounce "Linux"....
If you use it!
Back to top
View user's profile Send private message
dbergst
Tux's lil' helper
Tux's lil' helper


Joined: 25 Mar 2003
Posts: 88

PostPosted: Sat Jan 14, 2006 2:06 pm    Post subject: Reply with quote

WaTcHmE wrote:
I dont get it :D

where is the Problem?

I wanted to emerge world, but my machine showed me the known poppler <> xpdf dependency problem. I searched and found the new xpdf version in the tree. Then I just unmerged xpdf, and then emerged it again.
now I have the newest Version of poppler _and_ xpdf on my machine without much trouble :D

cya

WaTcHmE


Same here . . . maybe someone should put this in the bugzilla report for this issue.
Back to top
View user's profile Send private message
mhoskins
n00b
n00b


Joined: 23 Jan 2004
Posts: 64
Location: Southern New Joisey

PostPosted: Sat Jan 14, 2006 5:54 pm    Post subject: xpdf and poppler conflict apparently resolved Reply with quote

The latest xpdf release -r5 appears to have resolved the conflict.

Life is good.
_________________
--
To know even one life has breathed easier because you have lived.
This is to have succeeded. -Bessie Stanely, 1905
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Portage & Programming All times are GMT
Goto page 1, 2  Next
Page 1 of 2

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum