Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
Portage nieuwe versie laten aanvaarden
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Dutch
View previous topic :: View next topic  
Author Message
Stuartje
Apprentice
Apprentice


Joined: 12 Dec 2002
Posts: 165

PostPosted: Mon Apr 21, 2003 3:12 pm    Post subject: Portage nieuwe versie laten aanvaarden Reply with quote

Hoe laat je de portage een nieuwe versie van een proggy dat je handmatig ( met ebuild package.ebuild merge ) hebt geinstalleerd aanvaarden?
Elke keer als ik emerge world doe wil ie persé de bewuste package downgraden terwijl ik dit niet wil!
Back to top
View user's profile Send private message
Yinchie
Apprentice
Apprentice


Joined: 05 Mar 2003
Posts: 179
Location: The Netherlands

PostPosted: Mon Apr 21, 2003 7:29 pm    Post subject: Reply with quote

de zelf gemaakte ebuild een hogere versie geven en dan nogmaals emergen.
Back to top
View user's profile Send private message
Stuartje
Apprentice
Apprentice


Joined: 12 Dec 2002
Posts: 165

PostPosted: Mon Apr 21, 2003 8:42 pm    Post subject: Reply with quote

Het is geen zelfgemaakte ebuild, het is gewoon een ebuild uit testing :)
Back to top
View user's profile Send private message
theBlackDragon
l33t
l33t


Joined: 23 Nov 2002
Posts: 759
Location: Gent (Belgium)

PostPosted: Tue Apr 22, 2003 7:43 am    Post subject: Reply with quote

Ik heb eens ergens in de forums gezien dat de 'inject' optie van emerge dit doet, nog nooit geprobeerd echter, dus ik heb geen idee of dit klopt...
'man emerge' zal hier wel uitsluitsel over geven :)
Back to top
View user's profile Send private message
water
Guru
Guru


Joined: 19 Jun 2002
Posts: 387
Location: Zierikzee, The Netherlands

PostPosted: Tue Apr 22, 2003 8:25 am    Post subject: Reply with quote

--inject forceert dependencies. Je kunt de optie gebruiken om te voorkomen dat bepaalde pakketten geinstalleerd worden. Waarschijnlijk werkt het ook wel voor het probleem van de topic-starter.
_________________
Groeten uit Holland
Back to top
View user's profile Send private message
blubber
Retired Dev
Retired Dev


Joined: 26 Apr 2002
Posts: 152
Location: Enschede, Netherlands

PostPosted: Tue Apr 22, 2003 8:38 am    Post subject: Reply with quote

Kheb hier hetzelfde probleem jah. Net samba 3.0 vanwege de recente problemen geinstalleerd, maar met emerge -u world wil portage hem downgraden naar 2.2.8a. Werkt het --inject? Iemand er ervaring mee?
Back to top
View user's profile Send private message
wdconinc
Tux's lil' helper
Tux's lil' helper


Joined: 17 Jan 2003
Posts: 80
Location: Ann Arbor, Michigan

PostPosted: Tue Apr 22, 2003 9:04 am    Post subject: Reply with quote

Hallo mensen (en andere),

Ik had ook een dergelijk probleem (ik heb orsa rc2 van het web geplukt en geinstalleerd met een eigen ebuild, maar emerge wil die ook altijd downgraden naar rc1). Ik heb dat met emerge inject een keer geprobeerd en dat lijkt te werken.

Code:
emerge inject app-sci/orsa-0.3.0-rc1


Vanaf nu kan ik weer met een gerust hart emerge world -u doen...

Ik vraag mij nu af wat hij zal doen als er een orsa-0.3.0 uitkomt. Zal hij dan niet willen orsa-0.3.0-rc1 unmergen, hoewel het eigenlijk niet geinstalleerd is?

Bedankt voor de tip,
Wouter
Back to top
View user's profile Send private message
blubber
Retired Dev
Retired Dev


Joined: 26 Apr 2002
Posts: 152
Location: Enschede, Netherlands

PostPosted: Tue Apr 22, 2003 9:42 am    Post subject: Reply with quote

alrighty :D inject werkt. Ik moest wel eerst samba 3.0 unmergen daarna injecten, daarna emergen. Met emerge -up world staat ie er nu niet meer tussen :)
Back to top
View user's profile Send private message
iKiddo
Guru
Guru


Joined: 27 Jun 2002
Posts: 329
Location: Europe?

PostPosted: Tue Apr 22, 2003 3:40 pm    Post subject: Reply with quote

water wrote:
--inject forceert dependencies. Je kunt de optie gebruiken om te voorkomen dat bepaalde pakketten geinstalleerd worden. Waarschijnlijk werkt het ook wel voor het probleem van de topic-starter.

Nee, dat doet --nodeps.
Bij inject (syntax: emerge inject cate-gory/pakket-naam-ver.sie) word het pakket dat je specifieert zonder het te installeren in alle logs als geinstalleerd opgeschreven.
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Dutch All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum