Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
[SOLVED][HARDWARE/USB]Nikon D70 i montowanie
View unanswered posts
View posts from last 24 hours
View posts from last 7 days

 
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt
View previous topic :: View next topic  
Author Message
Poe
Bodhisattva
Bodhisattva


Joined: 03 Apr 2004
Posts: 2158
Location: Mysłowice/Lublin, Poland

PostPosted: Sun Nov 13, 2005 5:29 pm    Post subject: [SOLVED][HARDWARE/USB]Nikon D70 i montowanie Reply with quote

Witam. zebralem sie w sobie i w koncu pokonfigurowalem kernel, pomegrowalem odpowiednie rzczy (hotplug), a wszystko po to, by moc sobie wreszcie bez problemow zgrywac zjecia z aparatu cyfrowego - Nikon D70. podpiąłem go na usb
Code:

root@failed> lsusb                                                    /home/poe
Duplicate product spec at line 2453 product 0846:4240 WG111 WiFi
Bus 004 Device 003: ID 04b0:0406 Nikon Corp.
Bus 004 Device 001: ID 0000:0000 
Bus 003 Device 001: ID 0000:0000 
Bus 002 Device 001: ID 0000:0000 
Bus 001 Device 001: ID 0000:0000 

wiec jak widac, wykrywa go. nie wiem tylko na jakim urzadzeniu to ma byc. z tego co udalo mi sie wygooglowac, to ma byc sdaX. sda1 i 2 nie dzialaja.. tak samo jak 3 i 4.
Code:

root@failed> mount /dev/sda3 /mnt/aparat                         /usr/src/linux
mount: /dev/sda3 is not a valid block device

dmesg pokazuje takie cos
Code:

usb 4-2: new full speed USB device using uhci_hcd and address 5

(rejestruje rowniez jak sie odlaczy. jak sie znow podlaczy to kolejno jest adress 6, 7 itd)

kernel
Code:

CONFIG_HOTPLUG=y

Code:

root@failed> emerge -p hotplug                                   /usr/src/linux

These are the packages that I would merge, in order:

Calculating dependencies ...done!
[ebuild   R   ] sys-apps/hotplug-20040923-r1 

nie wiem co jeszcze jest potrzebne... zapewne rozwiazanie jest jakies banalnie proste, ale nie mam pomyslow zadnych..
pozdrawiam
Marcin.
_________________
Hardware:HP Pavilion DV6875SE[C2DT5550@1.83GHz_3GB-DDR2_320GB-SATA_GF8400GS]
http://poe.art.pl/ - fotografia artystyczna
http://poe.art.pl/blog - III Rzeczywistość Polska
RLU#342333


Last edited by Poe on Sun Nov 13, 2005 6:32 pm; edited 1 time in total
Back to top
View user's profile Send private message
pwe
Guru
Guru


Joined: 12 Mar 2005
Posts: 445
Location: Polska aka Poland

PostPosted: Sun Nov 13, 2005 5:36 pm    Post subject: Reply with quote

w kernelu wszystkie SCSI i mass_storage itp masz?
_________________
there is no empty MHz :)
Back to top
View user's profile Send private message
Poe
Bodhisattva
Bodhisattva


Joined: 03 Apr 2004
Posts: 2158
Location: Mysłowice/Lublin, Poland

PostPosted: Sun Nov 13, 2005 5:42 pm    Post subject: Reply with quote

Code:

CONFIG_USB_STORAGE=y

CONFIG_SCSI=y

np. moj odtwarzacz mp3 (na pamieci flash) montuje bez zadnych problemow poprzez
Code:

mount /dev/sda1 /mnt/mp3

_________________
Hardware:HP Pavilion DV6875SE[C2DT5550@1.83GHz_3GB-DDR2_320GB-SATA_GF8400GS]
http://poe.art.pl/ - fotografia artystyczna
http://poe.art.pl/blog - III Rzeczywistość Polska
RLU#342333
Back to top
View user's profile Send private message
mziab
l33t
l33t


Joined: 01 Oct 2004
Posts: 637

PostPosted: Sun Nov 13, 2005 6:22 pm    Post subject: Reply with quote

Zdaje się, że musisz przestawić cyfrówkę tryb USB Mass Storage. Bez tego nie wykryje ci na pewno aparatu jako dysk. W każdym razie, tak było z moim aparatem - Nikon CoolPix SQ. Był fabrycznie ustawiony na tryb PTP. Jeśli nie masz możliwości przełączenia, próbuj się pobawić gphoto2.
_________________
Gentoo Linux 13.0 | 3.8.0 | glibc 2.15 | gcc 4.7.3

mteam | mziab's blog | roslin
Back to top
View user's profile Send private message
Poe
Bodhisattva
Bodhisattva


Joined: 03 Apr 2004
Posts: 2158
Location: Mysłowice/Lublin, Poland

PostPosted: Sun Nov 13, 2005 6:32 pm    Post subject: Reply with quote

o, dzięki. o to chodziło. byl na PTP. teraz juz normalnie zamontowac poprzez
Code:

mount /dev/sda1 /mnt/aparat


pozdrawiam
_________________
Hardware:HP Pavilion DV6875SE[C2DT5550@1.83GHz_3GB-DDR2_320GB-SATA_GF8400GS]
http://poe.art.pl/ - fotografia artystyczna
http://poe.art.pl/blog - III Rzeczywistość Polska
RLU#342333
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Polskie forum (Polish) Instalacja i sprzęt All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum