Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
CPU 1 illegal instruction
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc
View previous topic :: View next topic  
Author Message
petersen
n00b
n00b


Joined: 28 Apr 2005
Posts: 46
Location: Germany

PostPosted: Wed Nov 02, 2005 3:43 pm    Post subject: CPU 1 illegal instruction Reply with quote

On my Ultra2 Enterprise appears the error message "Starting CPU1... illegal instruction" on first boot. Silo, kernel compiling and so on without any errors. Can anybody help me?
(Gentoo 2005.1, gentoo-sources 2.4.31)
Back to top
View user's profile Send private message
Toady
Apprentice
Apprentice


Joined: 21 Dec 2004
Posts: 161
Location: South Wales, UK

PostPosted: Mon Nov 07, 2005 8:24 am    Post subject: Reply with quote

Are both the processors the same - what are they ?
Did you compile for SMP ?
Do you really have 2 processors ?
_________________
Toady

Gentoo Laptop
3.1.10-gentoo-r1, Intel Core 2 Duo (32bit)
Gnome on the desk, Intel in the box, on-board everything, but it all works!
Back to top
View user's profile Send private message
petersen
n00b
n00b


Joined: 28 Apr 2005
Posts: 46
Location: Germany

PostPosted: Mon Nov 07, 2005 11:04 am    Post subject: Reply with quote

2 x UltraSparc II 300 MHz. Compiled for SMP
Back to top
View user's profile Send private message
gust4voz
Retired Dev
Retired Dev


Joined: 09 Sep 2003
Posts: 373
Location: Buenos Aires, Argentina

PostPosted: Mon Nov 07, 2005 1:01 pm    Post subject: Reply with quote

gentoo-sources-2.4.31? That's completely untested for sparc.
Or do you mean sparc-sources?
_________________
Gustavo Zacarias
Gentoo/SPARC monkey
Back to top
View user's profile Send private message
petersen
n00b
n00b


Joined: 28 Apr 2005
Posts: 46
Location: Germany

PostPosted: Tue Nov 08, 2005 11:33 am    Post subject: Reply with quote

Sorry, I mean sparc-sources 2.4.31
Back to top
View user's profile Send private message
gust4voz
Retired Dev
Retired Dev


Joined: 09 Sep 2003
Posts: 373
Location: Buenos Aires, Argentina

PostPosted: Tue Nov 08, 2005 12:31 pm    Post subject: Reply with quote

Try upgrading the OBP to the latest.
_________________
Gustavo Zacarias
Gentoo/SPARC monkey
Back to top
View user's profile Send private message
petersen
n00b
n00b


Joined: 28 Apr 2005
Posts: 46
Location: Germany

PostPosted: Wed Nov 09, 2005 8:29 am    Post subject: Reply with quote

Thanks, will try it in a few days once more.
Back to top
View user's profile Send private message
jondlm
n00b
n00b


Joined: 17 Feb 2006
Posts: 11
Location: Oregon

PostPosted: Sat Feb 18, 2006 5:30 pm    Post subject: Update Reply with quote

I have an enterprise server 420R with OBP 3.23. I was having this exact problem after installing Gentoo on my system.

I have found the solution to my problem and probably yours also. I found that the SILO Boot Loader in its current version is not compatible with some Sun Systems. The version that emerge loads is 1.4.9. The version that I found to be compatible with my server was 1.3.2. I couldn't figure out have to downgrade though, I will explain how to do this:

First you want to make sure that you backup your /etc/silo.conf
Once you are booted into the cd and have mounted and chrooted back up the /etc/silo.conf with "cp /etc/silo.conf /etc/silo.conf.bk
Then run the command: "emerge --unemerge silo"
After that has finished goto http://www.sparc-boot.org/pub/silo/old/ and download silo-1.3.2.tar.gz
Gunzip and tar -xvf that file then cd into the directory you unpacked it to.
Then run "make" then "make install"
Once you are done with that run "mv /etc/silo.conf.bk /etc/silo.conf"
Then run "cp /etc/silo.conf /boot/"
Then umount everything and reboot.

This fixed my problem and I'm fairly confident it should help yours also!

Good luck from the linux noob :)

Jon
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Gentoo on Sparc All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum