Gentoo Forums
Gentoo Forums
Gentoo Forums
Quick Search: in
xine update breaks DVD playback
View unanswered posts
View posts from last 24 hours

 
Reply to topic    Gentoo Forums Forum Index Multimedia
View previous topic :: View next topic  
Author Message
mellofone
Apprentice
Apprentice


Joined: 13 Apr 2002
Posts: 286

PostPosted: Tue Jun 18, 2002 9:48 pm    Post subject: xine update breaks DVD playback Reply with quote

Since I upgraded to xine-0.9.10, I notice that I cannot use the d5d DVD playback.

I also noticed that the package is masked... Ayone have any ideas what's up?
Back to top
View user's profile Send private message
delta407
Bodhisattva
Bodhisattva


Joined: 23 Apr 2002
Posts: 2876
Location: Chicago, IL

PostPosted: Tue Jun 18, 2002 9:53 pm    Post subject: Reply with quote

If the package is masked, why are you using it? Masking a package is generally a way to signify that you're not supposed to be using it unless you know what you're doing...
Back to top
View user's profile Send private message
mellofone
Apprentice
Apprentice


Joined: 13 Apr 2002
Posts: 286

PostPosted: Tue Jun 18, 2002 9:59 pm    Post subject: Reply with quote

delta407 wrote:
If the package is masked, why are you using it? Masking a package is generally a way to signify that you're not supposed to be using it unless you know what you're doing...


I previously had it installed, and it worked with the old version of xine...

I just wondered if there was a reason why it was masked. The documentation on the mask file is confusing, since it states that the d5d package should work, but it is masked...
Back to top
View user's profile Send private message
delta407
Bodhisattva
Bodhisattva


Joined: 23 Apr 2002
Posts: 2876
Location: Chicago, IL

PostPosted: Tue Jun 18, 2002 10:04 pm    Post subject: Reply with quote

Wow, definitely does look like an oops. Filed bug #3865.
Back to top
View user's profile Send private message
ElCondor
Guru
Guru


Joined: 10 Apr 2002
Posts: 520
Location: Vienna, Austria, Europe

PostPosted: Wed Jun 19, 2002 9:30 am    Post subject: Reply with quote

Since xine didn't start after upgrading to 0.9.10 I removed the masked packages d4d and d5d, but xine does not start at all, complaining about
Code:
load_plugins: video output plugin /usr/lib/xine/plugins/xineplug_vo_out_xshm.so failed to link:
libxineutils-0.9.9.so.0: cannot open shared object file: file not found
why is it still looking for 0.9.9 libs?

* ElCondor pasa *
_________________
Here I am the victim of my own choices and I'm just starting!
Back to top
View user's profile Send private message
BinaryAlchemy
n00b
n00b


Joined: 31 May 2002
Posts: 42
Location: Ca, US

PostPosted: Wed Jun 19, 2002 11:46 am    Post subject: Reply with quote

You need to unmerge the old xine-libs before you emerge the new xine, or it links to the wrong libs. To fix:
Code:

emerge unmerge xine-ui
emerge -c xine-lib
emerge xine-ui
Back to top
View user's profile Send private message
mellofone
Apprentice
Apprentice


Joined: 13 Apr 2002
Posts: 286

PostPosted: Wed Jun 19, 2002 12:00 pm    Post subject: Reply with quote

BinaryAlchemy wrote:
You need to unmerge the old xine-libs before you emerge the new xine, or it links to the wrong libs. To fix:
Code:

emerge unmerge xine-ui
emerge -c xine-lib
emerge xine-ui


It works, but we have to wait until the new d5d and d4d plugin ebuilds are updated. The new version of xine has a new API....
Back to top
View user's profile Send private message
BinaryAlchemy
n00b
n00b


Joined: 31 May 2002
Posts: 42
Location: Ca, US

PostPosted: Wed Jun 19, 2002 2:03 pm    Post subject: Reply with quote

Well it's a one line patch (just change the version requested in the plugin) so hopefully it will happen soon. If you want to patch it your self you could have a look in xine-devel around the time 9.10 came out. Apparently the api didn't change enough to break the plugin, just confuse it.
Back to top
View user's profile Send private message
mellofone
Apprentice
Apprentice


Joined: 13 Apr 2002
Posts: 286

PostPosted: Wed Jun 19, 2002 3:03 pm    Post subject: Reply with quote

BinaryAlchemy wrote:
Well it's a one line patch (just change the version requested in the plugin) so hopefully it will happen soon. If you want to patch it your self you could have a look in xine-devel around the time 9.10 came out. Apparently the api didn't change enough to break the plugin, just confuse it.


Heh. Figures :)
Back to top
View user's profile Send private message
Display posts from previous:   
Reply to topic    Gentoo Forums Forum Index Multimedia All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum